Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Can't get Qemu? qemu-softmmu fails.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Dheath
Tux's lil' helper
Tux's lil' helper


Joined: 06 Aug 2006
Posts: 131

PostPosted: Mon Sep 24, 2007 5:10 pm    Post subject: Can't get Qemu? qemu-softmmu fails. Reply with quote

I'm trying to install Qemu but it requires qemu-softmmu and it fails to build:
Code:

i686-pc-linux-gnu-gcc -Wall -O2 -g -fno-strict-aliasing -mpreferred-stack-boundary=2 -fomit-frame-pointer -falign-functions=0 -fno-gcse -fno-reorder-blocks -fno-optimize-sibling-calls  -I. -I.. -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0/work/qemu-0.9.0/target-i386 -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0/work/qemu-0.9.0 -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0/work/qemu-0.9.0/fpu -DHAS_AUDIO -I/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0/work/qemu-0.9.0/slirp -c -o op.o /var/tmp/portage/app-emulation/qemu-softmmu-0.9.0/work/qemu-0.9.0/target-i386/op.c
/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0/work/qemu-0.9.0/target-i386/ops_sse.h: In function `op_psrlq_mmx':
/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0/work/qemu-0.9.0/target-i386/ops_sse.h:213: error: unable to find a register to spill in class `GENERAL_REGS'
/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0/work/qemu-0.9.0/target-i386/ops_sse.h:213: error: this is the insn:
(insn:HI 36 35 37 3 /var/tmp/portage/app-emulation/qemu-softmmu-0.9.0/work/qemu-0.9.0/target-i386/ops_sse.h:207 (parallel [
            (set (reg:DI 63 [ <variable>.q ])
                (lshiftrt:DI (reg:DI 63 [ <variable>.q ])
                    (subreg:QI (reg/v:SI 60 [ shift ]) 0)))
            (clobber (scratch:SI))
            (clobber (reg:CC 17 flags))
        ]) 309 {lshrdi3_1} (insn_list 33 (insn_list 35 (nil)))
    (expr_list:REG_DEAD (reg/v:SI 60 [ shift ])
        (expr_list:REG_UNUSED (reg:CC 17 flags)
            (expr_list:REG_UNUSED (scratch:SI)
                (nil)))))
/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0/work/qemu-0.9.0/target-i386/ops_sse.h:213: confused by earlier errors, bailing out
make[1]: *** [op.o] Error 1
make[1]: Leaving directory `/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0/work/qemu-0.9.0/i386-softmmu'
make: *** [subdir-i386-softmmu] Error 2
 *
 * ERROR: app-emulation/qemu-softmmu-0.9.0 failed.
 * Call stack:
 *   ebuild.sh, line 1654:   Called dyn_compile
 *   ebuild.sh, line 990:   Called qa_call 'src_compile'
 *   ebuild.sh, line 44:   Called src_compile
 *   qemu-softmmu-0.9.0.ebuild, line 98:   Called die
 *
 * make failed
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0/temp/build.log'.
 *

 * Messages for package app-emulation/qemu-softmmu-0.9.0:

 *
 * ERROR: app-emulation/qemu-softmmu-0.9.0 failed.
 * Call stack:
 *   ebuild.sh, line 1654:   Called dyn_compile
 *   ebuild.sh, line 990:   Called qa_call 'src_compile'
 *   ebuild.sh, line 44:   Called src_compile
 *   qemu-softmmu-0.9.0.ebuild, line 98:   Called die
 *
 * make failed
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/app-emulation/qemu-softmmu-0.9.0/temp/build.log'.
 *

I tried many things but now I'm out of ideas.
Does any one have any idea where to start solving this?
Back to top
View user's profile Send private message
loki_val
Retired Dev
Retired Dev


Joined: 13 Nov 2006
Posts: 401
Location: Denmark

PostPosted: Mon Sep 24, 2007 5:30 pm    Post subject: Reply with quote

Did you build it with gcc -3.4.6?
Back to top
View user's profile Send private message
Dheath
Tux's lil' helper
Tux's lil' helper


Joined: 06 Aug 2006
Posts: 131

PostPosted: Tue Sep 25, 2007 10:29 am    Post subject: Reply with quote

peteralf wrote:
Did you build it with gcc -3.4.6?


Yeap.

It doesn't complain about that.

...

Or maybe that error was on 4.x.x with some keywords but I got exactly the same error on gcc 3.4.6.
Back to top
View user's profile Send private message
tr3
n00b
n00b


Joined: 06 Aug 2007
Posts: 4
Location: Italy

PostPosted: Tue Sep 25, 2007 11:18 am    Post subject: Reply with quote

try to build it with gcc 3.3.6
_________________
void quickexit() { int *p=NULL; *p=0; }
Back to top
View user's profile Send private message
sundialsvc4
Guru
Guru


Joined: 10 Nov 2005
Posts: 433

PostPosted: Thu Sep 27, 2007 3:06 am    Post subject: Reply with quote

Umm... with the hardware-virtualization support that is now possible in the Linux kernel, qemu and its ilk are rather out-of-date and out-of-touch ...
Back to top
View user's profile Send private message
Dheath
Tux's lil' helper
Tux's lil' helper


Joined: 06 Aug 2006
Posts: 131

PostPosted: Sat Sep 29, 2007 6:55 pm    Post subject: Reply with quote

sundialsvc4 wrote:
Umm... with the hardware-virtualization support that is now possible in the Linux kernel, qemu and its ilk are rather out-of-date and out-of-touch ...

Then you could just tell me how I could emulate the Open Moko on my system.
edit:
tr3 wrote:
try to build it with gcc 3.3.6

Successful! :D
Thanks!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum