Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Fusion-Java] Probleme
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
SiOu
Apprentice
Apprentice


Joined: 08 Apr 2005
Posts: 271

PostPosted: Fri Sep 21, 2007 9:31 am    Post subject: [Fusion-Java] Probleme Reply with quote

Voila depuis peux je suis sous fusion-compiz et j'avais fait la petite manip recommandé pour faire fonctionné java sous fusion :

Quote:
sed -i 's/XINERAMA/FAKEEXTN/g' /opt/sun-jdk-1.6.0.02/jre/lib/amd64/xawt/libmawt.so


Donc tout fonctionnait pour le mieux dans le meilleur des mondes , sauf que depuis que jai mit a jour ma machine ( plus de 200 paquets ) plus aucune de mes application java ne fonctionne , voici les erreurs :

Azureus :

Quote:
siou@localhost ~ $ azureus
using /home/siou/.azureus/gentoo.config
$UI not set defaulting to swt
java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at org.gudy.azureus2.ui.common.Main.directLaunch(Main.java:228)
at org.gudy.azureus2.ui.common.Main.main(Main.java:131)
Caused by: java.lang.UnsatisfiedLinkError: no swt-gtk-3346 or swt-gtk in swt.library.path, java.library.path or the jar file
at org.eclipse.swt.internal.Library.loadLibrary(Unknown Source)
at org.eclipse.swt.internal.Library.loadLibrary(Unknown Source)
at org.eclipse.swt.internal.C.<clinit>(Unknown Source)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Unknown Source)
at org.eclipse.swt.internal.Converter.wcsToMbcs(Unknown Source)
at org.eclipse.swt.widgets.Display.<clinit>(Unknown Source)
at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.<init>(SWTThread.java:89)
at org.gudy.azureus2.ui.swt.mainwindow.SWTThread.createInstance(SWTThread.java:68)
at org.gudy.azureus2.ui.swt.mainwindow.Initializer.<init>(Initializer.java:106)
at org.gudy.azureus2.ui.swt.Main.<init>(Main.java:80)
at org.gudy.azureus2.ui.swt.Main.main(Main.java:180)
... 6 more
StartSocket: passing startup args to already-running process.
[alert] Alert:3:Failed to access torrent file '--ui=swt'. Ensure sufficient temporary file space available (check browser cache usage).


J'ai pourtant viré le .azureus qui traine dans mon home ( pour quil suprime le peu de torrent quil avait en liste ) , mais cela change rien .

Mercury :


Quote:
siou@localhost ~ $ sh /home/siou/Mercury/mercury-bin-1.9_rc7c/startup/startup_linux.sh
21.09.2007 11:26:56 Mercury/1.9RC7c [20070821]
21.09.2007 11:26:56 Resource Type > General
21.09.2007 11:26:56 Locations > Loading...
21.09.2007 11:26:56 Locations > Loaded OK.
21.09.2007 11:26:56 Main > Loading Global Settings...
21.09.2007 11:26:57 Main > Loading Splash Screen...
#
# An unexpected error has been detected by HotSpot Virtual Machine:
#
# SIGSEGV (0xb) at pc=0xcc040369, pid=26068, tid=4158297792
#
# Java VM: Java HotSpot(TM) Server VM (1.5.0_12-b04 mixed mode)
# Problematic frame:
# C [libmawt.so+0x217369]
#
# An error report file with more information is saved as hs_err_pid26068.log
#
# If you would like to submit a bug report, please visit:
# http://java.sun.com/webapps/bugreport/crash.jsp
#
/home/siou/Mercury/mercury-bin-1.9_rc7c/startup/startup_linux.sh: line 43: 26068 Abandon java -Djava.library.path=jni:jni/jmf -Xmx512m -classpath $classpath com.dMSN.Main $*


Dès lors , jai essayé tout les java que javais :

Quote:
localhost siou # java-config -L
The following VMs are available for generation-2:
1) Blackdown JDK 1.4.2.03 [blackdown-jdk-1.4.2]
2) Sun 32bit JRE 1.5.0.12 [emul-linux-x86-java-1.5]
*) Sun 32bit JRE 1.6.0.02 [emul-linux-x86-java-1.6]
4) Sun JDK 1.5.0.12 [sun-jdk-1.5]
5) Sun JDK 1.6.0.02 [sun-jdk-1.6]
6) Sun JRE 1.6.0.02 [sun-jre-bin-1.6]


Mais aucun des 6 ne fonctionnent ...

Voici mon emerge info , et je suis sous gnome 2.20 si cela peut aider :

Quote:
localhost siou # emerge --info
Portage 2.1.3.9 (default-linux/amd64/2006.1/desktop, gcc-4.2.0, glibc-2.6.1-r0, 2.6.22-gentoo-r6 x86_64)
=================================================================
System uname: 2.6.22-gentoo-r6 x86_64 Intel(R) Core(TM)2 CPU 6400 @ 2.13GHz
Timestamp of tree: Fri, 21 Sep 2007 08:00:01 +0000
ccache version 2.4 [disabled]
app-shells/bash: 3.2_p17-r1
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python: 2.4.4-r4, 2.5.1-r2
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache: 2.4-r7
sys-apps/baselayout: 1.12.10-r4
sys-apps/sandbox: 1.2.18.1
sys-devel/autoconf: 2.13, 2.61-r1
sys-devel/automake: 1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils: 2.18
sys-devel/gcc-config: 1.4.0-r2
sys-devel/libtool: 1.5.24
virtual/os-headers: 2.6.22-r2
ACCEPT_KEYWORDS="amd64 ~amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=nocona -msse3 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /opt/glftpd/etc /opt/glftpd/ftp-data /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=nocona -msse3 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS=" http://mirror.ovh.net/gentoo-distfiles/ "
LANG="fr_FR.UTF-8"
LC_ALL="fr_FR.UTF-8"
LINGUAS="fr"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/gnome-experimental /usr/portage/local/layman/sunrise /usr/portage/local/layman/xeffects /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acc alsa alsancurses amd64 avi berkdb bitmap-fonts browserplugin cairo cdr cli cracklib crypt cups dbus dlloader dri dvd dvdr dvdread eds emboss encode esd fam firefox fortran gdbm gif gnome gpm gstreamer gtk gtk2 hal iconv ipv6 isdnlog jpeg ldap libg++ mad mastroka midi mikmod mono mp3 mpeg mudflap ncurses nls nptl nptlonly nsplugin ogg oggvorbis opengl openmp oss pam pcre pdf pdflib perl png ppds pppd python qt4 quicktime readline reflection samba sdl session spell spl ssl tcpd tiff tk truetype truetype-fonts type1-fonts udev unicode usb v4l vorbis xml xorg xv xvid zlib" ALSA_CARDS="hda_intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset: CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Par ailleur jai un autre probleme , vlc n'a jamais voulu ce lancer chez moi je ne sais pas si cela est lié ou pas :

Quote:
siou@localhost ~ $ vlc
VLC media player 0.8.6c Janus
/home/siou/.themes/Alphacube GTK 0.5/gtk-2.0/gtkrc:63: Clearlooks configuration option "menuitemstyle" is not supported and will be ignored.
/home/siou/.themes/Alphacube GTK 0.5/gtk-2.0/gtkrc:64: Clearlooks configuration option "listviewitemstyle" is not supported and will be ignored.
/home/siou/.themes/Alphacube GTK 0.5/gtk-2.0/gtkrc:65: Clearlooks configuration option "progressbarstyle" is not supported and will be ignored.


Voila merci d'avance .
Back to top
View user's profile Send private message
SiOu
Apprentice
Apprentice


Joined: 08 Apr 2005
Posts: 271

PostPosted: Mon Sep 24, 2007 10:15 am    Post subject: Reply with quote

UP :cry:
Back to top
View user's profile Send private message
GentooUser@Clubic
l33t
l33t


Joined: 01 Nov 2004
Posts: 829

PostPosted: Mon Sep 24, 2007 11:23 am    Post subject: Reply with quote

Essai de re-emerger Java, et de lancer une appli Java sans compiz-fusion, si ça marche utiliser plutôt cet ebuild https://bugs.gentoo.org/show_bug.cgi?id=176839#c1 pour corriger le problème de Java avec xcb.
Back to top
View user's profile Send private message
SiOu
Apprentice
Apprentice


Joined: 08 Apr 2005
Posts: 271

PostPosted: Mon Sep 24, 2007 12:06 pm    Post subject: Reply with quote

j'ai reémerger java , désactivé fusion et pour autant jai toujours les meme problemes ... :cry:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum