Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[tap] virtualbox
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
zyprexa
Apprentice
Apprentice


Joined: 26 Dec 2004
Posts: 180

PostPosted: Sat Sep 22, 2007 12:57 am    Post subject: Reply with quote

sd44 wrote:
bon je revient a la charge !

ça marche sur ma machine perso et du premier coup en plus ...
j'ai simplement lancé ce script (récup sur la doc ubuntu :oops: ):
Code:

brctl addbr br0
brctl addif br0 eth0
tunctl -t tap1 -u toto
chmod 0666 /dev/net/tun
ifconfig tap1 up
brctl addif br0 tap1
ifconfig tap1 0.0.0.0 promisc up
ifconfig eth0 0.0.0.0 promisc up
ifconfig br0 192.168.11.2 netmask 255.255.255.0 broadcast 192.168.11.255
route add default gw 192.168.11.254


conclusion :
=> je comprend rien car la config est bien sur la meme que guilc a premiere vue
=> le ip_forward est inutile
=> je vais tester par curiositer avec la config de guilc (mais a priori pas de probleme)
=> de plus faut aussi que ca marche sur mon srv ... :roll:

a suivre ... :D


Enfin !
Personnellement, je ne suis jamais passé par l'es scripts gentoo pour bridger : je me suis fait un petit script comme celui-là et qui me charge les règles iptables qui vont bien, ça me permet de revenir à la normale sans tout désactiver.
Pour iptables, sans règles il n'y a effectivement rien à changer, mais avec, si je laisse tel quel rien ne passe ... il faut alors que je change eth0 en br0 dans le script et ça roule.
Quant à l'ipforward ça ... j'ai comme un gros doute, je ne sais plus si j'avais déjà bridgé l'interface ou pas.
_________________
enjoy
Back to top
View user's profile Send private message
sd44
Apprentice
Apprentice


Joined: 21 Jul 2007
Posts: 277
Location: Nantes 44

PostPosted: Sat Sep 22, 2007 1:11 am    Post subject: Reply with quote

en effet, j'ai essayé la conf a guilc dans tout les sens et d'autre et rien n'y fait ! il y a quelque chose qui doit m'échapper car les confs qui en résulte semble identique et pourtant ca marche pas :roll:

guilc tu as zappé quelque chose ou je devient fou et bazarde le pc par la fenetre :twisted:

j'ai pourtant cherché un peu partout, revue la doc gentoo (pas tres genéreuse sur cette partie du reseau (tap)) , rien a faire :!:

a suivre ...
_________________
Pourquoi faire simple quand on peut faire compliqué ?
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Sat Sep 22, 2007 8:00 am    Post subject: Reply with quote

AHAH ! t'ain mais faut vraiment que j'aille me jeter ! encore un dernier oubli !
La différence ?
le script ubuntu fait un chmod 666 /dev/net/tun...

Et de mon coté, j'avais fait moins violent, une regle udev qui change le groupe du périphérique...
Code:
# cat /etc/udev/rules.d/01-tuntap.rules
# le vboxuser doit pouvoir upper les interfaces tap
KERNEL=="tun",            NAME="net/%k",  GROUP="vboxusers" MODE="0660", OPTIONS+="ignore_remove"


[EDIT]
Effectivement, après un nouveau test, le forward n'est pas nécessaire...
Il a du arrivé là lorsque j'ai mis en place tout ça et que j'ai bien ramé :lol:
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
sd44
Apprentice
Apprentice


Joined: 21 Jul 2007
Posts: 277
Location: Nantes 44

PostPosted: Sat Sep 22, 2007 9:34 am    Post subject: Reply with quote

oui mais je pense pas que le probleme vienne de la car j'avais deja fait ta manip / ou le chmod et ca changeait rien => d'autant plus que j'ai tout fait en root pour eviter ce genre de probleme :wink:

il y a autre chose ! un autre truc :lol: ?
_________________
Pourquoi faire simple quand on peut faire compliqué ?
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Sat Sep 22, 2007 11:25 am    Post subject: Reply with quote

guilc wrote:

[EDIT]
Effectivement, après un nouveau test, le forward n'est pas nécessaire...
Il a du arrivé là lorsque j'ai mis en place tout ça et que j'ai bien ramé :lol:

aah me disais bien! 8)

l'honneur est sauf, je suis pas gateux! pas encore...
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Sat Oct 27, 2007 10:35 am    Post subject: Reply with quote

Bon, ben cette histoire du forward, c'est BIZARRE.
pendant un moment, ça a marché sans. Mais la, ça faisait un petit moment que mes virtualbox n'avaient pas tourné (premier redémarrage depuis la MAJ en vbox 1.5.2 en fait), plus moyen de sortir de ma machine.
Par hasard, je rerentre "iptables -A FORWARD -o br0 -i br0 -j ACCEPT" et PAF, ça résoud le problème.
Alors utile ? pas utile ?
En tous cas, il me débloque la situation dans ce cas :D
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
sd44
Apprentice
Apprentice


Joined: 21 Jul 2007
Posts: 277
Location: Nantes 44

PostPosted: Sat Oct 27, 2007 1:46 pm    Post subject: Reply with quote

moi j'ai pas besoin de faire ça,

d'un autre coté :

-> j'arrive toujours pas a utiliser les script net de gentoo pour ça (et j'ai fais 1 millions de test)
-> j'utilise donc la procedure ci dessus
-> j'ai pas de firewall sur le pc en question
-> j'avais pas le ip_forward d'activé et ca marchait

j'aimerai bien comprendre guilc comment utiliser le meme script que toi car les bidouilles reseau ...
_________________
Pourquoi faire simple quand on peut faire compliqué ?
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Sat Oct 27, 2007 3:31 pm    Post subject: Reply with quote

sd44 wrote:
j'aimerai bien comprendre guilc comment utiliser le meme script que toi car les bidouilles reseau ...

Bah je comprends (toujours) pas pourquoi ça ne tourne pas chez toi !
J'ai beau en refaire le tour, tout est dit dans le topic... Je n'ai absolument rien d'autre pour faire tourner les bridges. Juste cette bizarrerie du forward...
C'est depuis migré en baselayout 2, mais ça ne change rien sur le fond...
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
sd44
Apprentice
Apprentice


Joined: 21 Jul 2007
Posts: 277
Location: Nantes 44

PostPosted: Sat Oct 27, 2007 3:50 pm    Post subject: Reply with quote

si ça peux aider

Code:

~ # brctl showmacs br0
port no mac addr                is local?       ageing timer
  1     00:07:cb:0d:b8:c2       no                 0.00                 => freebox
  1     00:14:38:b6:8e:2e       no               263.28                => imprimante reseau
  1     00:17:31:87:6c:40       yes                0.00                 => br0 et eth0
  2     00:ff:1c:de:7c:74       yes                0.00                  => vbox
  2     08:00:27:17:4a:df       no                12.44                 => xp sous virtualbox



Code:

~ # ifconfig
br0       Lien encap:Ethernet  HWaddr 00:17:31:87:6C:40
          inet adr:192.168.11.2  Bcast:192.168.11.255  Masque:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6947618 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7376792 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:5084901338 (4849.3 Mb)  TX bytes:3638307483 (3469.7 Mb)

eth0      Lien encap:Ethernet  HWaddr 00:17:31:87:6C:40
          UP BROADCAST RUNNING PROMISC MULTICAST  MTU:1500  Metric:1
          RX packets:6947755 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7376781 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          RX bytes:5187079793 (4946.7 Mb)  TX bytes:3684828927 (3514.1 Mb)
          Interruption:23 Adresse de base:0xe000

lo        Lien encap:Boucle locale
          inet adr:127.0.0.1  Masque:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:57 errors:0 dropped:0 overruns:0 frame:0
          TX packets:57 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:5563 (5.4 Kb)  TX bytes:5563 (5.4 Kb)

tun0      Lien encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
          inet adr:192.168.100.50  P-t-P:192.168.100.49  Masque:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:7946 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12402 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:100
          RX bytes:1519570 (1.4 Mb)  TX bytes:845398 (825.5 Kb)

vbox0     Lien encap:Ethernet  HWaddr 00:FF:1C:DE:7C:74
          UP BROADCAST RUNNING PROMISC MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:4319 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)



c'est quoi ce dropped : 4319 ?
_________________
Pourquoi faire simple quand on peut faire compliqué ?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum