Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200709-03 ] Streamripper: Buffer overflow
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1471

PostPosted: Thu Sep 13, 2007 9:26 pm    Post subject: [ GLSA 200709-03 ] Streamripper: Buffer overflow Reply with quote

Gentoo Linux Security Advisory

Title: Streamripper: Buffer overflow (GLSA 200709-03)
Severity: normal
Exploitable: remote
Date: September 13, 2007
Bug(s): #188698
ID: 200709-03

Synopsis

A buffer overflow vulnerability has been discovered in Streamripper, allowing for user-assisted execution of arbitrary code.

Background

Streamripper is a tool for extracting and recording mp3 files from a Shoutcast stream.

Affected Packages

Package: media-sound/streamripper
Vulnerable: < 1.62.2
Unaffected: >= 1.62.2
Architectures: All supported architectures


Description

Chris Rohlf discovered several boundary errors in the httplib_parse_sc_header() function when processing HTTP headers.

Impact

A remote attacker could entice a user to connect to a malicious streaming server, resulting in the execution of arbitrary code with the privileges of the user running Streamripper.

Workaround

There is no known workaround at this time.

Resolution

All Streamripper users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=media-sound/streamripper-1.62.2"


References

CVE-2007-4337
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum