Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] - Audio non si avvia dopo aggiornamento kernel
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Thu Sep 13, 2007 3:23 pm    Post subject: [RISOLTO] - Audio non si avvia dopo aggiornamento kernel Reply with quote

Salve, dopo l'ultio aggiornamento del kernel non si avvia la mia interfaccia audio
Ottengo un messaggio d'errore appena entro in kde, vi lascio un link all'immagine
http://www.bernaparkhotel.it/uploads/linux/err_audio.jpg
ao chip triumph quan lot khe dung cu tap an ao so mi cong so ban buon quan ao cac loai do boi tre em do lot nu sieu mong khan ta so sinh cho be ban buon ban buon trang phuc ca mua kich
Accetto suggerimenti, links, guide da leggere..........


Last edited by lsegalla on Fri May 03, 2013 3:10 pm; edited 4 times in total
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Thu Sep 13, 2007 3:34 pm    Post subject: Reply with quote

dalla cara vecchia linea di comando lanci
Code:
dmesg | less

digiti "/ALSA"+invio e vedi che errore riporta il kernel per incominciare.
un lspci per vedere la scheda audio che bestia è potrebbe essere un buon seguito, un cat /proc/asound/cards è opzionale, leggere la guida meglio.

a naso: cerca "alsa" e "blacklisted" sul forum :wink:
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Tigerwalk
Guru
Guru


Joined: 15 May 2007
Posts: 475
Location: Napoli

PostPosted: Thu Sep 13, 2007 7:45 pm    Post subject: Re: Audio non si avvia dopo aggiornamento kernel Reply with quote

lsegalla wrote:
Salve, dopo l'ultio aggiornamento del kernel non si avvia la mia interfaccia audio
Ottengo un messaggio d'errore appena entro in kde, vi lascio un link all'immagine
http://www.bernaparkhotel.it/uploads/linux/err_audio.jpg

Accetto suggerimenti, links, guide da leggere..........

Anche a me è successo passando dal kernel 2.6.21 al 2.6.22.
La mia scheda è una Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller
Ho risolto con:
Code:
alsaconfig

dopo il riconoscimento della scheda:
Code:
alsamixer

per impostare i volumi ma si sentiva appena il suono, allora ho dato:
Code:
 lsof /dev/snd/*

che mi ha elencato tutti i programmi che usavano il suono, poi con
kill -9 xxxxx
ho killato i suddetti programmi
Code:
rmmod snd-hda-intel

per rimuovere il modulo attuale, a questo punto devi andare a questa pagina
[EDIT]: questo link http://bulletproof.servebeer.com/alsa/configs/hda_intel_models
non è più funzionante e quindi aggiungo l'elenco dei moduli snd-hda-intel
Code:
Module snd-hda-intel
  --------------------

    Module for Intel HD Audio (ICH6, ICH6M, ESB2, ICH7, ICH8),
      ATI SB450, SB600, RS600,
      VIA VT8251/VT8237A,
      SIS966, ULI M5461

    model   - force the model name
    position_fix - Fix DMA pointer (0 = auto, 1 = none, 2 = POSBUF, 3 = FIFO size)
    single_cmd  - Use single immediate commands to communicate with
      codecs (for debugging only)
    enable_msi   - Enable Message Signaled Interrupt (MSI) (default = off)

    This module supports one card and autoprobe.

    Each codec may have a model table for different configurations.
    If your machine isn't listed there, the default (usually minimal)
    configuration is set up.  You can pass "model=<name>" option to
    specify a certain model in such a case.  There are different
    models depending on the codec chip.

     Model name   Description
     ----------    -----------
   ALC880
     3stack   3-jack in back and a headphone out
     3stack-digout   3-jack in back, a HP out and a SPDIF out
     5stack   5-jack in back, 2-jack in front
     5stack-digout   5-jack in back, 2-jack in front, a SPDIF out
     6stack   6-jack in back, 2-jack in front
     6stack-digout   6-jack with a SPDIF out
     w810      3-jack
     z71v      3-jack (HP shared SPDIF)
     asus      3-jack (ASUS Mobo)
     asus-w1v   ASUS W1V
     asus-dig   ASUS with SPDIF out
     asus-dig2   ASUS with SPDIF out (using GPIO2)
     uniwill   3-jack
     fujitsu   Fujitsu Laptops (Pi1536)
     F1734      2-jack
     lg      LG laptop (m1 express dual)
     lg-lw      LG LW20/LW25 laptop
     tcl      TCL S700
     clevo      Clevo laptops (m520G, m665n)
     test      for testing/debugging purpose, almost all controls can be
         adjusted.  Appearing only when compiled with
         $CONFIG_SND_DEBUG=y
     auto      auto-config reading BIOS (default)

   ALC260
     hp      HP machines
     hp-3013   HP machines (3013-variant)
     fujitsu   Fujitsu S7020
     acer      Acer TravelMate
     basic      fixed pin assignment (old default model)
     auto      auto-config reading BIOS (default)

   ALC262
     fujitsu   Fujitsu Laptop
     hp-bpc   HP xw4400/6400/8400/9400 laptops
     hp-bpc-d7000   HP BPC D7000
     benq      Benq ED8
     hippo      Hippo (ATI) with jack detection, Sony UX-90s
     hippo_1   Hippo (Benq) with jack detection
     basic      fixed pin assignment w/o SPDIF
     auto      auto-config reading BIOS (default)

   ALC882/885
     3stack-dig   3-jack with SPDIF I/O
     6stack-dig   6-jack digital with SPDIF I/O
     arima      Arima W820Di1
     macpro   MacPro support
     auto      auto-config reading BIOS (default)

   ALC883/888
     3stack-dig   3-jack with SPDIF I/O
     6stack-dig   6-jack digital with SPDIF I/O
     3stack-6ch    3-jack 6-channel
     3stack-6ch-dig 3-jack 6-channel with SPDIF I/O
     6stack-dig-demo  6-jack digital for Intel demo board
     acer      Acer laptops (Travelmate 3012WTMi, Aspire 5600, etc)
     medion   Medion Laptops
     targa-dig   Targa/MSI
     targa-2ch-dig   Targs/MSI with 2-channel
     laptop-eapd   3-jack with SPDIF I/O and EAPD (Clevo M540JE, M550JE)
     auto      auto-config reading BIOS (default)

   ALC861/660
     3stack   3-jack
     3stack-dig   3-jack with SPDIF I/O
     6stack-dig   6-jack with SPDIF I/O
     3stack-660   3-jack (for ALC660)
     uniwill-m31   Uniwill M31 laptop
     toshiba   Toshiba laptop support
     asus      Asus laptop support
     asus-laptop   ASUS F2/F3 laptops
     auto      auto-config reading BIOS (default)

   ALC861VD/660VD
     3stack   3-jack
     3stack-dig   3-jack with SPDIF OUT
     6stack-dig   6-jack with SPDIF OUT
     3stack-660   3-jack (for ALC660VD)
     auto      auto-config reading BIOS (default)

   CMI9880
     minimal   3-jack in back
     min_fp   3-jack in back, 2-jack in front
     full      6-jack in back, 2-jack in front
     full_dig   6-jack in back, 2-jack in front, SPDIF I/O
     allout   5-jack in back, 2-jack in front, SPDIF out
     auto      auto-config reading BIOS (default)

   AD1981
     basic      3-jack (default)
     hp      HP nx6320
     thinkpad   Lenovo Thinkpad T60/X60/Z60

   AD1986A
     6stack   6-jack, separate surrounds (default)
     3stack   3-stack, shared surrounds
     laptop   2-channel only (FSC V2060, Samsung M50)
     laptop-eapd   2-channel with EAPD (Samsung R65, ASUS A6J)
     ultra      2-channel with EAPD (Samsung Ultra tablet PC)

   AD1988
     6stack   6-jack
     6stack-dig   ditto with SPDIF
     3stack   3-jack
     3stack-dig   ditto with SPDIF
     laptop   3-jack with hp-jack automute
     laptop-dig   ditto with SPDIF
     auto      auto-config reading BIOS (default)
   
   Conexant 5045
     laptop   Laptop config
     test      for testing/debugging purpose, almost all controls
         can be adjusted.  Appearing only when compiled with
         $CONFIG_SND_DEBUG=y

   Conexant 5047
     laptop   Basic Laptop config
     laptop-hp   Laptop config for some HP models (subdevice 30A5)
     laptop-eapd   Laptop config with EAPD support
     test      for testing/debugging purpose, almost all controls
         can be adjusted.  Appearing only when compiled with
         $CONFIG_SND_DEBUG=y

   STAC9200/9205/9254
     ref      Reference board

   STAC9220/9221
     ref      Reference board
     3stack   D945 3stack
     5stack   D945 5stack + SPDIF
     macmini   Intel Mac Mini
     macbook   Intel Mac Book
     macbook-pro   Intel Mac Book Pro

   STAC9202/9250/9251
     ref      Reference board, base config
     m2-2      Some Gateway MX series laptops
     m6      Some Gateway NX series laptops

   STAC9227/9228/9229/927x
     ref      Reference board
     3stack   D965 3stack
     5stack   D965 5stack + SPDIF

   STAC9872
     vaio      Setup for VAIO FE550G/SZ110
     vaio-ar Setup for VAIO AR

    If the default configuration doesn't work and one of the above
    matches with your device, report it together with the PCI
    subsystem ID (output of "lspci -nv") to ALSA BTS or alsa-devel
    ML (see the section "Links and Addresses").

    Note 2: If you get click noises on output, try the module option
       position_fix=1 or 2.  position_fix=1 will use the SD_LPIB
       register value without FIFO size correction as the current
       DMA pointer.  position_fix=2 will make the driver to use
       the position buffer instead of reading SD_LPIB register.
       (Usually SD_LPLIB register is more accurate than the
       position buffer.)

    NB: If you get many "azx_get_response timeout" messages at
    loading, it's likely a problem of interrupts (e.g. ACPI irq
    routing).  Try to boot with options like "pci=noacpi".  Also, you
    can try "single_cmd=1" module option.  This will switch the
    communication method between HDA controller and codecs to the
    single immediate commands instead of CORB/RIRB.  Basically, the
    single command mode is provided only for BIOS, and you won't get
    unsolicited events, too.  But, at least, this works independently
    from the irq.  Remember this is a last resort, and should be
    avoided as much as possible...
   
    The power-management is supported.

e cercare il codec che corrisponde alla tua scheda audio e una volta trovato dare questo comando che abilita il modulo per la tua scheda:
Code:
modprobe snd-hda-intel model=<opzione corrispondente>

A questo punto con alsamixer, alzi i volumi che sono tutti azzerati e provi a sentire un suono
Spesso il codec della scheda non va bene, prova tutti quelli della sezione corrispondente per trovare quello giusto.
Trovato il codec adatto,
Code:
echo "options snd-hda-intel model=<modello corretto>" >> /etc/modules.d/alsa

e
Code:
modules-update

n.b.: valido per le schede INTEL


Last edited by Tigerwalk on Tue Oct 02, 2007 7:35 am; edited 1 time in total
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Fri Sep 14, 2007 10:46 am    Post subject: Reply with quote

Ringrazio tutti mi è stato tuto utile, cominciando dalla guida che ho seguito scrupolosamente.
Ora da console riesco ad ascoltare, però dal kde ancora no.
Avevo già installato vlc precedentemente, ma dopo la configurazione ho dovuto attivare la USE alsa (che forse non serviva ma per scrupolo l'ho fatto).
Attualmente quando lancio VLC non succede niente, nemmeno parte l'applicazione....
do boi tre em dep do ngu nam may hut sua cho me truoc va sau sinh chan vay cong so nu thoi trang cong so nu quan lot khe do boi nam ca tinh xe day loai khac chan vay cong so nu thoi trang cong so nu cho thue trang phuc bieu dien
Immagino di essere vicino alla soluzione....


Last edited by lsegalla on Fri May 03, 2013 3:04 pm; edited 1 time in total
Back to top
View user's profile Send private message
Tigerwalk
Guru
Guru


Joined: 15 May 2007
Posts: 475
Location: Napoli

PostPosted: Sat Sep 22, 2007 1:16 pm    Post subject: Reply with quote

lsegalla wrote:
Ringrazio tutti mi è stato tuto utile, cominciando dalla guida che ho seguito scrupolosamente.
Ora da console riesco ad ascoltare, però dal kde ancora no.
Avevo già installato vlc precedentemente, ma dopo la configurazione ho dovuto attivare la USE alsa (che forse non serviva ma per scrupolo l'ho fatto).
Attualmente quando lancio VLC non succede niente, nemmeno parte l'applicazione....

Immagino di essere vicino alla soluzione....


nella compilazione di vlc, hai incluso le USE flag X e wxwindows? Eventualmente, ricompilalo con quelle USE!
Back to top
View user's profile Send private message
pinopineta
n00b
n00b


Joined: 07 Jun 2006
Posts: 29
Location: Torino

PostPosted: Fri Sep 28, 2007 2:36 pm    Post subject: Reply with quote

Salve a tutti.
Ho installato gentoo qualche giorno fà sul portatile Dell Precision M4300.
Il kernel in origine era il .22 r5.
Ho messo ieri l'r8 e l'audio non mi và piu'...
Ne ho provate di tutti i colori.

Ho una HDA Intel con chip Conexant, e ho provato a seguire cosa scritto in questo thread, ma niente da fare.
alsaconf me la configura, ma mi dice che non riesce a caricare il modulo, e lo stesso all'avvio ( anche se il modulo effettivamente me lo carica).

dmesg dopo il caricamento del modulo, che avviene comunuqe.
Code:
ACPI: PCI Interrupt 0000:00:1b.0[A] -> GSI 21 (level, low) -> IRQ 21
PCI: Setting latency timer of device 0000:00:1b.0 to 64
hda_intel: azx_get_response timeout, switching to polling mode...
hda_intel: azx_get_response timeout, switching to single_cmd mode...
hda-intel: no codecs initialized
ACPI: PCI interrupt for device 0000:00:1b.0 disabled


alsamixer
invece mi riporta, dopo aver caricato il modulo:
Code:
alsamixer: function snd_ctl_open failed for default: No such device



Non sò piu' che fare..
e non mi va di mettere gli alsa-driver dal portage in quanto prima coi driver presenti nel kernel funzionava.
_________________
pinopineta@hotmail.com

'cause nothin' lasts forever
Back to top
View user's profile Send private message
CarloJekko
Veteran
Veteran


Joined: 31 Mar 2005
Posts: 1315
Location: Baia Domizia :-)

PostPosted: Fri Sep 28, 2007 4:41 pm    Post subject: Reply with quote

forse l'ultima spiaggia è compilare alsa-driver...
_________________
C.
Back to top
View user's profile Send private message
pinopineta
n00b
n00b


Joined: 07 Jun 2006
Posts: 29
Location: Torino

PostPosted: Sat Sep 29, 2007 10:20 am    Post subject: Reply with quote

nah..
Sono tornato all'r5 e mi funziona l'audio con alsa nel kernel...
Dovevo assolutamente vedermi un film ieri sera.. I pirati di Silicon Valley.... non mi è piaciuto.. potevo lasciare tranquillamente l'r8 senza audio eheh ;)

Aspetterò il .23 =)
_________________
pinopineta@hotmail.com

'cause nothin' lasts forever
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Tue Oct 02, 2007 12:16 pm    Post subject: Reply with quote

Tigerwalk wrote:
lsegalla wrote:
Ringrazio tutti mi è stato tuto utile, cominciando dalla guida che ho seguito scrupolosamente.
Ora da console riesco ad ascoltare, però dal kde ancora no.
Avevo già installato vlc precedentemente, ma dopo la configurazione ho dovuto attivare la USE alsa (che forse non serviva ma per scrupolo l'ho fatto).
Attualmente quando lancio VLC non succede niente, nemmeno parte l'applicazione....

Immagino di essere vicino alla soluzione....


nella compilazione di vlc, hai incluso le USE flag X e wxwindows? Eventualmente, ricompilalo con quelle USE!

quan chip bon bon do lot nu sieu mong bao chan cho be thoi trang cong so gia re vay lien cong so nu quan ao nu quan lot khe binh sua cho be vay cong so nu chan vay cong so nu album anh
Fatto, ora funziona
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum