Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] KDE Automount Problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
joefish
Guru
Guru


Joined: 27 Jan 2004
Posts: 316
Location: New Zealand

PostPosted: Thu Sep 13, 2007 8:28 am    Post subject: [SOLVED] KDE Automount Problem Reply with quote

Fresh install of absolutely everything, cannot get auto mounting to work in KDE. I've read through quite a few threads to try and find a solution, but so far nothing works.

Using the following software versions:
KDE 3.5.7
dbus 1.0.2-r2
hal 0.5.9-r1
udev 114

When I put in a CD, nothing happens in KDE. When I put in a USB drive, KDE pops up a box asking me what to do, but upon attempting to mount, I get the following message:

Quote:
A security policy in place prevents this sender from sending this message to this recipient, see message bus configuration file (rejected message had interface "org.freedesktop.Hal.Device.Volume" member "Mount" error name "(unset)" destination "org.freedesktop.Hal")


kdebase-kioslaves is compiled with hal support (the option in the control center is greyed out, although enabled).

I'm added to the plugdev group (also tried adding myself to the haldaemon and messagebus groups, as other threads have suggested).

Any ideas would be appreciated. Thanks.


Last edited by joefish on Sat Sep 15, 2007 6:11 am; edited 1 time in total
Back to top
View user's profile Send private message
Staren
n00b
n00b


Joined: 08 Sep 2003
Posts: 27
Location: Riviere-du-Loup, Canada

PostPosted: Thu Sep 13, 2007 6:02 pm    Post subject: Reply with quote

Maybe this link can help you:

http://jefferyfernandez.id.au/2007/07/26/a-security-policy-in-place-prevents-mounting-of-volumes/

You can have a look at this file: /etc/dbus-1/system.d/hal.conf, see if you got all necessary accesses. Can't comment much on this as I'm a simple noob and never got serious problems with automount.

You can also post your hal.conf and dmesg here for everyone to check up. It can improve your chances for a quick answer.
Back to top
View user's profile Send private message
joefish
Guru
Guru


Joined: 27 Jan 2004
Posts: 316
Location: New Zealand

PostPosted: Thu Sep 13, 2007 7:40 pm    Post subject: Reply with quote

Thanks,

I can now mount USB drives; I added the section as recommended by that post you linked to.

I am now left with the problem of nothing showing up in kde when I insert a cd. I have made sure that there is nothing listed in my fstab about removable drives.
Back to top
View user's profile Send private message
joefish
Guru
Guru


Joined: 27 Jan 2004
Posts: 316
Location: New Zealand

PostPosted: Sat Sep 15, 2007 5:57 am    Post subject: Reply with quote

Does anyone know what I might need to do to get KDE to recognise when I insert a CD?

UPDATE: Apparently my system isn't currently recognising my cdrom at all... I'll get that fixed then come back to this thread if need be...
Back to top
View user's profile Send private message
padoor
Advocate
Advocate


Joined: 30 Dec 2005
Posts: 4185
Location: india

PostPosted: Sat Sep 15, 2007 6:03 am    Post subject: Reply with quote

your fstab has cdrom mount line?
autostart has to be enabled for playing cd to play automatically

what is mentioned in fstab only you can mount.
if the joilet filesystem not enabled i kernel also can give trouble fiding cd inserted
_________________
reach out a little bit more to catch it (DON'T BELIEVE the advocate part under my user name)
Back to top
View user's profile Send private message
joefish
Guru
Guru


Joined: 27 Jan 2004
Posts: 316
Location: New Zealand

PostPosted: Sat Sep 15, 2007 6:11 am    Post subject: Reply with quote

It looks like I forgot to enable scsi cdrom support in the kernel (I'm using a sata drive).
Back to top
View user's profile Send private message
urcindalo
l33t
l33t


Joined: 08 Feb 2005
Posts: 601
Location: Almeria, Spain

PostPosted: Thu Oct 04, 2007 11:12 am    Post subject: Reply with quote

I have the same problem in KDE 3.5.7. I can only mount CD's manually, since they do NOT show up in my kicker panel when inserted. No dialog box popping up asking me what to do, like when I insert a USB pendrive, for instance (no problems whatsoever to mount/umount them as a regular user from the kicker panel).

How did you manage to solve it?

These are the active lines in my /etc/fstab, which, by the way, has been this way for ages and was working in the past. As you can see, no references are made to /dev/hdc nor /dev/hdd to let udev do its work
Code:
/dev/hda2               /               reiserfs        noatime,user_xattr      0 1
/dev/hda6               /home/myname    reiserfs        noatime,user_xattr      0 2
/dev/hda5               swap            swap            sw                      0 0

none                    /proc           proc            defaults                0 0

none                    /dev/shm        tmpfs           nodev,nosuid,noexec             0 0

/dev/hda1 /mnt/hda1 auto noauto,users,exec 0 0
/dev/hda3 /mnt/hda3 auto noauto,users,exec 0 0
/dev/hda7 /mnt/hda7 auto user_xattr,noauto,users,exec,noatime,notail 0 2
/dev/hda8 /mnt/hda8 reiserfs user_xattr,noauto,users,exec,noatime,notail 0 2
/dev/hda9 /mnt/hda9 auto user_xattr,noauto,users,exec,noatime,notail 0 2
/dev/hda10 /mnt/hda10 auto user_xattr,noauto,users,exec 0 2
/dev/hda11 /mnt/hda11 reiserfs user_xattr,noauto,users,exec,noatime,notail 0 2
/dev/hda12 /mnt/hda12 auto noauto,users,exec 0 0
/dev/hdb1 /mnt/hdb1 auto user_xattr,noauto,users,exec 0 2

/dev/floppy/0           /mnt/floppy     auto    user,exec,noauto,managed 0 0


This is dmesg recognizing my CD drives:
Code:
$ dmesg | grep DVD
hdc: HL-DT-ST DVDRAM GSA-4081B, ATAPI CD/DVD-ROM drive
hdd: HL-DT-STDVD-ROM GDR8163B, ATAPI CD/DVD-ROM drive
hdc: ATAPI 32X DVD-ROM DVD-R-RAM CD-R/RW drive, 2048kB Cache, UDMA(33)
hdd: ATAPI 52X DVD-ROM drive, 256kB Cache, UDMA(33)


And this is the SCSI config in my running kernel:
Code:
/usr/src/linux $ cat .config | grep SCSI
CONFIG_BLK_DEV_IDESCSI=y
# SCSI device support
CONFIG_SCSI=y
CONFIG_SCSI_TGT=m
# CONFIG_SCSI_NETLINK is not set
CONFIG_SCSI_PROC_FS=y
# SCSI support type (disk, tape, CD-ROM)
# Some SCSI devices (e.g. CD jukebox) support multiple LUNs
CONFIG_SCSI_MULTI_LUN=y
# CONFIG_SCSI_CONSTANTS is not set
# CONFIG_SCSI_LOGGING is not set
CONFIG_SCSI_SCAN_ASYNC=y
CONFIG_SCSI_WAIT_SCAN=m
# SCSI Transports
CONFIG_SCSI_SPI_ATTRS=y
# CONFIG_SCSI_FC_ATTRS is not set
# CONFIG_SCSI_ISCSI_ATTRS is not set
CONFIG_SCSI_SAS_ATTRS=m
# CONFIG_SCSI_SAS_LIBSAS is not set
# SCSI low-level drivers
# CONFIG_ISCSI_TCP is not set
# CONFIG_SCSI_3W_9XXX is not set
# CONFIG_SCSI_ACARD is not set
# CONFIG_SCSI_AACRAID is not set
# CONFIG_SCSI_AIC7XXX is not set
# CONFIG_SCSI_AIC7XXX_OLD is not set
# CONFIG_SCSI_AIC79XX is not set
# CONFIG_SCSI_AIC94XX is not set
# CONFIG_SCSI_ARCMSR is not set
# CONFIG_SCSI_HPTIOP is not set
# CONFIG_SCSI_BUSLOGIC is not set
# CONFIG_SCSI_DMX3191D is not set
# CONFIG_SCSI_EATA is not set
# CONFIG_SCSI_FUTURE_DOMAIN is not set
# CONFIG_SCSI_GDTH is not set
# CONFIG_SCSI_IPS is not set
# CONFIG_SCSI_INITIO is not set
# CONFIG_SCSI_INIA100 is not set
CONFIG_SCSI_PPA=m
CONFIG_SCSI_IMM=m
CONFIG_SCSI_IZIP_EPP16=y
# CONFIG_SCSI_IZIP_SLOW_CTR is not set
# CONFIG_SCSI_STEX is not set
# CONFIG_SCSI_SYM53C8XX_2 is not set
# CONFIG_SCSI_IPR is not set
# CONFIG_SCSI_QLOGIC_1280 is not set
# CONFIG_SCSI_QLA_FC is not set
# CONFIG_SCSI_QLA_ISCSI is not set
# CONFIG_SCSI_LPFC is not set
# CONFIG_SCSI_DC390T is not set
# CONFIG_SCSI_DEBUG is not set
CONFIG_SCSI_SRP=m
CONFIG_I2O_SCSI=m
# NOTE: USB_STORAGE enables SCSI, and 'SCSI disk support'


Any help is greatly appreciated.
Back to top
View user's profile Send private message
urcindalo
l33t
l33t


Joined: 08 Feb 2005
Posts: 601
Location: Almeria, Spain

PostPosted: Thu Oct 04, 2007 11:32 am    Post subject: Reply with quote

I re-emerged the packages below and rebooted with a CD inserted. Now... well, I think where the problem might lie (see my problem in the post just above this one):
Code:
These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild   R   ] kde-base/kdebase-kioslaves-3.5.7-r1  USE="arts hal kdeenablefinal ldap openexr samba -debug -kdehiddenvisibility -xinerama" 0 kB
[ebuild   R   ] dev-libs/dbus-glib-0.73  USE="-debug -doc (-selinux)" 0 kB
[ebuild   R   ] dev-libs/dbus-qt3-old-0.70  USE="-debug" 0 kB
[ebuild   R   ] x11-misc/notification-daemon-0.3.7  USE="-debug" 0 kB
[ebuild   R   ] sys-apps/dbus-1.0.2-r2  USE="X -debug -doc (-selinux)" 0 kB
[ebuild   R   ] app-misc/hal-info-20070618  0 kB
[ebuild   R   ] sys-apps/hal-0.5.9-r1  USE="acpi crypt disk-partition -debug -dell -doc -pcmcia (-selinux)" 0 kB
[ebuild   R   ] sys-fs/udev-114  USE="(-selinux)" 0 kB

Total: 8 packages (8 reinstalls), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No]


After login into my account, I saw a regular hard drive icon in my kicker panel representing the CD. If I'm not wrong, months ago there was a similar problem regarding USB drives: they were treated as regular hard drives instead of removable media, even though, when mounted, the mount point was /media/something.

So, why is my system treating a CD like a hard drive? Because it is a /dev/hdX drive at boot time? Is it a bug? Is there anyone NOT having this problem? In the past (KDE 3.5.5 time), this wasn't an issue.

Any help is much appreciated.

PS: I forgot to mention I use a stable AMD64 box with a 2.6.22-gentoo-r8 kernel.
Back to top
View user's profile Send private message
SuperDindon
Tux's lil' helper
Tux's lil' helper


Joined: 01 Sep 2005
Posts: 125

PostPosted: Tue Oct 23, 2007 8:19 am    Post subject: Reply with quote

I'm getting the same problem with an USB disk and an USB card reader. They do not (and they shouldn't) have an entry in fstab and so they do not even appear in KDE volumes ( and same for GNOME IIRC, I'll check this evening ). In order to get the volume icon in KDE media manager, I have to use pmount (which works flawlessly) to mount the device, and then re-login.
I'm not 100% sure, but I think the problem started when I switched to libata PATA and removed completely old IDE support from my 2.6.22 kernel. They should not be related to each other, but well.. I still have my old config so I'll be able someday to check too if this assessment is right.
Back to top
View user's profile Send private message
joefish
Guru
Guru


Joined: 27 Jan 2004
Posts: 316
Location: New Zealand

PostPosted: Tue Oct 23, 2007 8:31 am    Post subject: Reply with quote

Sorry I don't have enough experience to offer you any more suggestion beyond my own problem.
Back to top
View user's profile Send private message
SuperDindon
Tux's lil' helper
Tux's lil' helper


Joined: 01 Sep 2005
Posts: 125

PostPosted: Tue Oct 23, 2007 8:41 am    Post subject: Reply with quote

JUST FOUND THE SOLUTION! : http://gentoo-wiki.com/HOWTO_D-BUS,_HAL,_KDE_media:/#KDE.2FGNOME_hal_stops_working_with_usb_devices :)
Finally! It's amazing to think that I've been really pissed off by this problem during a month..
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Tue Oct 23, 2007 9:55 am    Post subject: Reply with quote

SuperDindon wrote:
JUST FOUND THE SOLUTION! : http://gentoo-wiki.com/HOWTO_D-BUS,_HAL,_KDE_media:/#KDE.2FGNOME_hal_stops_working_with_usb_devices :)
Finally! It's amazing to think that I've been really pissed off by this problem during a month..

Thank you, Automounting with gnome 2.20 works for me again, now.
Back to top
View user's profile Send private message
urcindalo
l33t
l33t


Joined: 08 Feb 2005
Posts: 601
Location: Almeria, Spain

PostPosted: Tue Oct 23, 2007 2:16 pm    Post subject: Reply with quote

SuperDindon wrote:
JUST FOUND THE SOLUTION! : http://gentoo-wiki.com/HOWTO_D-BUS,_HAL,_KDE_media:/#KDE.2FGNOME_hal_stops_working_with_usb_devices :)
Finally! It's amazing to think that I've been really pissed off by this problem during a month..


I'm glad you solved your problem.

However, the CD/DVD-not-automounting problem persists. If I pop-in a CD or DVD in any drive, I'm forced to mount it manually (command line or double-clicking an icon).
Back to top
View user's profile Send private message
tgurr
Retired Dev
Retired Dev


Joined: 27 Jan 2004
Posts: 571
Location: germany

PostPosted: Tue Oct 23, 2007 2:55 pm    Post subject: Reply with quote

urcindalo wrote:
However, the CD/DVD-not-automounting problem persists. If I pop-in a CD or DVD in any drive, I'm forced to mount it manually (command line or double-clicking an icon).

If you have an ATA/IDE CD/DVD-ROM also check that you have enabled "legacy /proc/ide/ support" in your Kernel.
Back to top
View user's profile Send private message
urcindalo
l33t
l33t


Joined: 08 Feb 2005
Posts: 601
Location: Almeria, Spain

PostPosted: Tue Oct 23, 2007 4:52 pm    Post subject: Reply with quote

tgurr wrote:
urcindalo wrote:
However, the CD/DVD-not-automounting problem persists. If I pop-in a CD or DVD in any drive, I'm forced to mount it manually (command line or double-clicking an icon).

If you have an ATA/IDE CD/DVD-ROM also check that you have enabled "legacy /proc/ide/ support" in your Kernel.


YES, YES, YES!!! You're the man!!! Thank you!!! :D

I've been struggling with this problem for a long time. It occurred to me may be this was a kernel issue, but I never found the related entry :(

Thanks again.
Back to top
View user's profile Send private message
urcindalo
l33t
l33t


Joined: 08 Feb 2005
Posts: 601
Location: Almeria, Spain

PostPosted: Thu Nov 22, 2007 6:18 pm    Post subject: Reply with quote

Well, here am I again.

Today I just noticed my USB pen drives (and probably other USB devices) just didn't automount anymore. No entry was created in /media, but however hal detected them:
Code:
$ sudo lshal -m

Start monitoring devicelist:
-------------------------------------------------
18:50:40.790: usb_device_204_1976_1207000206010001 added
18:50:40.847: usb_device_204_1976_1207000206010001_if0 added
18:50:45.827: usb_device_204_1976_1207000206010001_if0_scsi_host added
18:50:45.827: usb_device_204_1976_1207000206010001_if0_scsi_host_scsi_device_lun0 added
18:50:45.860: usb_device_204_1976_1207000206010001_if0_scsi_host_scsi_device_lun0_scsi_generic added
18:50:45.905: storage_serial_CHIPSBNK_Flash_Disk_1207000206010001_0_0 added
18:50:45.947: volume_uuid_0021_AACF added

Up until last monday, at least, everything was OK. I tried the solution suggested in the gentoo-wiki, to no avail.

However, after re-emerging kdebase-kioslaves, logging out of my account, restarting the X server and logging in again, everything is back in business.

Hope this info helps.
Back to top
View user's profile Send private message
Kimmei
Tux's lil' helper
Tux's lil' helper


Joined: 17 Oct 2005
Posts: 102

PostPosted: Wed May 07, 2008 6:45 pm    Post subject: Reply with quote

Got the same auto mount problem as above and tryed to fix it with adding section... but it worsened things. Not only the automount doen't even start but when I try accessing my cdrom i receive an arrore message say that i ned hal to do it.

Here is my /etc/dbus-1/system.d/hal.conf http://rafb.net/p/NHwEFU46.html

How many horrors did I put in it?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum