Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Skype e caratteri accentati [Risolto]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
axettone
n00b
n00b


Joined: 22 Feb 2006
Posts: 16

PostPosted: Fri Sep 07, 2007 7:24 am    Post subject: Skype e caratteri accentati [Risolto] Reply with quote

Salve a tutti!
Ho notato che skype (installato tramite portage, of course) non accetta i caratteri accentati. Se invece i caratteri provengono dall'utente con cui sto chattando, non ci sono problemi.
Qualcuno ha avuto lo stesso problema?
Sono su piattaforma amd64 e se può servire nel mio make.conf ho opportunamente inserito LINGUAS=it, e in tutte le applicazioni kde non ho alcun problema del genere. La versione di skype è la 1.4.0.99, ma anche con le versioni precedenti accadeva la stessa cosa.
Grazie a tutti in anticipo e buon lavoro!


Last edited by axettone on Fri Sep 07, 2007 12:22 pm; edited 1 time in total
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Fri Sep 07, 2007 10:35 am    Post subject: Reply with quote

Oltre al linguas=it hai configurato locale.gen?
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
IlGab
Guru
Guru


Joined: 26 Nov 2004
Posts: 486

PostPosted: Fri Sep 07, 2007 11:24 am    Post subject: Reply with quote

Succede anche a me e non so come fare...
Back to top
View user's profile Send private message
axettone
n00b
n00b


Joined: 22 Feb 2006
Posts: 16

PostPosted: Fri Sep 07, 2007 12:03 pm    Post subject: Reply with quote

Risolto! Grazie djinnZ!
Il file locales.gen era a posto (e cmq lo posto qua):
Code:

$ cat /etc/locale.gen
en_US ISO-8859-1
en_US.UTF-8 UTF-8
it_IT ISO-8859-1
it_IT@euro ISO-8859-15

poi ho creato questo file /etc/env.d/02locale e ci ho messo dentro questo:
Code:

LC_ALL="it_IT@euro"
LANG="it_IT@euro"

successivamente ho chiamato env-update e source /etc/profile e ho riavviato il PC.
Adesso funziona perfettamente.
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Fri Sep 07, 2007 12:06 pm    Post subject: Reply with quote

ti consiglierei di aggiungere comunque
it_IT.UTF8 UTF8
e ricompilare la libc etc. (come da guida per utf8, anche se non la abiliti per ora)
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
axettone
n00b
n00b


Joined: 22 Feb 2006
Posts: 16

PostPosted: Fri Sep 07, 2007 12:08 pm    Post subject: Reply with quote

Uhm... l'ho fatto ma mi è capitato questo:
Code:
# locale-gen
 * Generating 5 locales (this might take a while) with 1 jobs
 *  (1/5) Generating en_US.ISO-8859-1 ...                                 [ ok ]
 *  (2/5) Generating en_US.UTF-8 ...                                      [ ok ]
 *  (3/5) Generating it_IT.ISO-8859-1 ...                                 [ ok ]
 *  (4/5) Generating it_IT.ISO-8859-15@euro ...                           [ ok ]
 *  (5/5) Generating it_IT.UTF8 ...
character map file `UTF8' not found: No such file or directory
/usr/share/i18n/locales/it_IT:24: LC_IDENTIFICATION: unknown character in field `address'                                                                 [ !! ]
 * Generation complete

A proposito, mi ero dimenticato di dire sopra che bisogna lanciare locale-gen se si modifica il locale.gen.
Back to top
View user's profile Send private message
axettone
n00b
n00b


Joined: 22 Feb 2006
Posts: 16

PostPosted: Fri Sep 07, 2007 12:15 pm    Post subject: Reply with quote

Ok ho risolto! Basta mettere un trattino in UTF-8!
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Fri Sep 07, 2007 1:45 pm    Post subject: Reply with quote

:oops: anche chi è perfetto può sbagliare :lol: 8)
Lo aggiungerei alla firma ma ci sono solo 255 caratteri a disposizione.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum