Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[app-office/dia] Core dump au lancement de dia 0.95.1
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
F!nTcH
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2007
Posts: 149

PostPosted: Thu Sep 06, 2007 9:54 am    Post subject: [app-office/dia] Core dump au lancement de dia 0.95.1 Reply with quote

Plop le monde

J'ai un ch'tit souci avec Dia :
Code:

*** glibc detected *** dia: free(): invalid pointer: 0xb70220c0 ***
======= Backtrace: =========
/lib/libc.so.6[0xb7493126]
/lib/libc.so.6(__libc_free+0x89)[0xb7494dd9]
/usr/lib/dia/libpython_plugin.so[0xb70cb79d]
...

"et caétéra" comme on dit ...

Pensez-vous que c'est un truc à destination du bugzilla ? Ou bien c'est moi qui ai une simple rupture de dépendance quelquepart ?
Je viens de l'emerger, donc il vient de compiler avec des dépendances toutes fraîches, emerge aurait râlé si y'avait pas la bonne version de la glibc nan ?

Merci pour votre aide
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 510

PostPosted: Thu Sep 06, 2007 11:12 am    Post subject: Reply with quote

Salut, peux tu mettre ton emerge --info.
Back to top
View user's profile Send private message
F!nTcH
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2007
Posts: 149

PostPosted: Thu Sep 06, 2007 12:04 pm    Post subject: Reply with quote

Code:

Portage 2.1.3.7 (default-linux/x86/2007.0, gcc-4.2.0, glibc-2.6.1-r0, 2.6.22-gentoo-r1 i686)
=================================================================
System uname: 2.6.22-gentoo-r1 i686 Intel(R) Pentium(R) 4 CPU 3.00GHz
Gentoo Base System release 1.12.10
Timestamp of tree: Thu, 06 Sep 2007 08:50:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4, 2.5.1-r2
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.10-r4
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18
sys-devel/gcc-config: 1.4.0-r2
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--ask"
FEATURES="ccache confcache distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://mirror.ovh.net/gentoo-distfiles/ ftp://ftp.free.fr/mirrors/ftp.gentoo.org/"
LINGUAS="fr"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow X aac acl acpi alsa apache2 apm bash-completion berkdb bitmap-fonts bluetooth bzip2 cairo calendar canna cddb cdparanoia cdr cli cracklib crypt cups dbase dbus dga dri dvd dvdr dvdread emacs encode exif expat fastcgi ffmpeg firefox flac fortran ftp gd gdbm gif gpm hal iconv imap imlib ipv6 isdnlog jabber javascript jpeg kde libwww mad midi mime mmx mp3 mpeg msn mudflap mysql ncurses nls nntp nptl nptlonly ogg opengl openmp pam pcre pdf perl php png pppd python qt3 qt4 readline reflection samba session spl sse sse2 ssl svg tcpd truetype truetype-fonts type1-fonts unicode usb v4l vcd vhosts vorbis wmf x86 xinerama xml xorg xsl xv xvid yahoo zlib"
ALSA_CARDS="hda-intel"
ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol"
ELIBC="glibc"
INPUT_DEVICES="keyboard mouse"
KERNEL="linux"
LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text"
LINGUAS="fr"
USERLAND="GNU"
VIDEO_CARDS="apm ark chips cirrus cyrix dummy fbdev glint i128 i740 i810 imstt mach64 mga neomagic nsc nv r128 radeon rendition s3 s3virge savage siliconmotion sis sisusb tdfx tga trident tseng v4l vesa vga via vmware voodoo"
Unset:  CTARGET, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

[/code]
Y'a deux ou trois USE qui doivent être inutile, je crois que j'ai foutu 3dnow mais que ça sert à rien sur mon architecture, enfin bon ... ça importe peu a priori, et je constate qu'il m'a rajouté plein de saloperies dans VIDEO_CARDS, je pense que ça vient du profil Portage ...
Mais je touche pas !! je me suis battu avec le DRI, maintenant je le lache plus xD
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Thu Sep 06, 2007 12:12 pm    Post subject: Reply with quote

Tu as fais ton python-updater à la mise à jour de python ?

EDIT : parceque :
Code:
dep -Ln python |grep -i dia
   app-office/dia-0.95.1                python? >=dev-lang/python-1.5.2
   app-office/dia-0.96.1                python? >=dev-lang/python-1.5.2


et que
Code:
/usr/lib/dia/libpython_plugin.so[0xb70cb79d]

et requeque :
Code:
dev-lang/python:     2.4.4-r4, 2.5.1-r2


Trouve un dieux et met toi à prier le totem de python :
The "glibc detected" List.
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
F!nTcH
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2007
Posts: 149

PostPosted: Thu Sep 06, 2007 12:50 pm    Post subject: Reply with quote

Quote:
Prier le totem de Python


Après avoir réémergé python-updater, puisqu'il le trouvait pas dans le PATH, malgré son installation d'après Portage, j'obtiens ça :

Code:

host ~ # python-updater
 * Starting Python Updater from 2.4 to 2.5 :
 * Searching for packages with files in /usr/lib/python2.4 /usr/lib32/python2.4 /usr/lib64/python2.4 ..
 * Adding to list: =net-fs/samba-3.0.24-r3
 * Adding to list: =sys-libs/cracklib-2.8.10
 * Adding to list: =dev-python/numeric-24.2-r4
 * Adding to list: =dev-python/pycrypto-2.0.1-r6
 * Adding to list: =dev-python/pygobject-2.12.3
 * Adding to list: =dev-python/pyopengl-2.0.1.09-r1
 * Adding to list: =dev-python/python-fchksum-1.7.1
 * Adding to list: =dev-python/pycairo-1.4.0
 * Adding to list: =dev-python/pygtk-2.10.6
 * Adding to list: =sys-apps/file-4.21-r1
 * Adding to list: =dev-libs/libxml2-2.6.29
 * Adding to list: =app-admin/webapp-config-1.50.16-r1
 * Adding to list: =dev-java/java-config-2.0.33-r1
 * Adding to list: =dev-java/java-config-1.3.7
 * Adding to list: =dev-java/antlr-2.7.7
 * Adding to list: =media-libs/lcms-1.17
 * Adding to list: =dev-tcltk/snack-2.2.10-r1
 * Adding to list: =app-pda/libopensync-0.22

These are the packages that would be merged, in order:

Calculating dependencies |
emerge: there are no ebuilds to satisfy "=dev-python/numeric-24.2-r4".


J'trouve ça fun ... j'espère ne pas avoir à me battre pendant des heures avec ça, j'ai besoin de Dia d'ici ce soir, et j'ai pas mal de choses à préparer pour demain ... :s

Enfin merci ! Je sais déjà d'où ça peut venir ...

Heu, python-updater, il a pas l'intention de me recompiler tout ça quand même ? :s

PS (avant validation du post :P ) :
Code:

user@host ~ $ MALLOC_CHECK_=1 dia
malloc: using debugging hooks
*** glibc detected *** dia: free(): invalid pointer: 0xb70e20c0 ***
*** glibc detected *** dia: free(): invalid pointer: 0xb70e20a0 ***
*** glibc detected *** dia: free(): invalid pointer: 0xb70e20b0 ***
*** glibc detected *** dia: free(): invalid pointer: 0xb70e20d0 ***
*** glibc detected *** dia: free(): invalid pointer: 0xb70e20e0 ***
could not import gtkcons.py

Et effectivement Dia se lance, m'enfin c'est quand même moche comme méthode ... j'ai jamais eu de prob avec Dia (sauf sous Kro$oft) ...
Bon, merci les gars, je clôture pas le thread parce que ça m'intrigue quand même cette histoire de python-updater, mais au moins je vais pouvoir avancer un peu ;)
Back to top
View user's profile Send private message
F!nTcH
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2007
Posts: 149

PostPosted: Thu Sep 06, 2007 12:56 pm    Post subject: Reply with quote

Bon numeric, je lui ai balancé un emerge dans la poire et c'est passé B-)

Reste plus que l'histoire originale pour Dia, rapport de bug ou connerie de ma part ?
Je finis le python-updater et je reviens vous dire ...
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Thu Sep 06, 2007 1:16 pm    Post subject: Reply with quote

Mais au fait, c'est quelle version de DIA. Ces infos tu aurais du nous les filées au début.
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
F!nTcH
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2007
Posts: 149

PostPosted: Thu Sep 06, 2007 1:45 pm    Post subject: Reply with quote

Heu ... vrai

Je suis en ~x86, donc normalement j'ai les dernières versions testing, c'est pour ça que je parlais de rapport de bogue

Code:

*  app-office/dia
      Latest version available: 0.95.1
      Latest version installed: 0.95.1
      Size of files: 4,104 kB
      Homepage:      http://www.gnome.org/projects/dia/
      Description:   Diagram/flowchart creation program
      License:       GPL-2

*  dev-lang/python
      Latest version available: 2.5.1-r2
      Latest version installed: 2.5.1-r2
      Size of files: 9,169 kB
      Homepage:      http://www.python.org/
      Description:   Python is an interpreted, interactive, object-oriented programming language.
      License:       PSF-2.2

*  sys-libs/glibc
      Latest version available: 2.6.1
      Latest version installed: 2.6.1
      Size of files: 16,005 kB
      Homepage:      http://www.gnu.org/software/libc/libc.html
      Description:   GNU libc6 (also called glibc2) C library
      License:       LGPL-2

*  dev-libs/glib
      Latest version available: 2.12.13
      Latest version installed: 2.12.13
      Size of files: 2,869 kB
      Homepage:      http://www.gtk.org/
      Description:   The GLib library of C routines
      License:       LGPL-2


Ceci suffira ??

Ah et python-updater m'a mis à jour plein de trucs, portage s'est fait plaisir, et Dia se plante toujours ...
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Thu Sep 06, 2007 1:46 pm    Post subject: Reply with quote

Installe de nouveau DIA maintenant que python est à jour.

Attends , je vois pas cette ligne dans ton emerge --info :
Code:
MAKEOPTS="-j3"
fait voir ton make.conf stp.
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
F!nTcH
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2007
Posts: 149

PostPosted: Thu Sep 06, 2007 1:52 pm    Post subject: Reply with quote

MAKEOPTS="-j3"

C'est bien ça, j'ai un HyperThread, donc 2CPU vu par le système, et finalement on se rends compte qu'il ne lance jamais 2 compils à la fois ... alors que 2 vmware qui travaillent vont bien travailler sur l'une des deux, et monter tout le CPU au plafond. C'est jamais le cas de Portage, malgré le -j3 il ne semble faire qu'un "-j2"

Code:

CHOST="i686-pc-linux-gnu"

ACCEPT_KEYWORDS="~x86"

GENTOO_MIRRORS="http://mirror.ovh.net/gentoo-distfiles/ ftp://ftp.free.fr/mirrors/ftp.gentoo.org/"

EMERGE_DEFAULT_OPTS="--ask"

MAKE_OPTS="-j3"

AUTOCLEAN="yes"

PORTAGE_NICENESS="3"

FEATURES="parallel-fetch ccache confcache userfetch userpriv sandbox usersandbox"

CCACHE_SIZE="1G"

PORTAGE_ELOG_CLASSES="warn error log"

LINGUAS="fr"

INPUT_DEVICES="keyboard mouse"

VIDEO_CARD="fglrx radeon"

SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"

USE="3dnow X aac acpi alsa apache2 apm bash-completion bluetooth bzip2 cairo calendar canna cddb cdparanoia cdr dbase dbus dga dri dvd dvdr dvdread emacs encode exif expat fastcgi ffmpeg firefox flac ftp gd gif -gnome -gtk hal imap imlib jabber javascript jpeg kde libwww mad mime mmx mp3 mpeg msn mysql ncurses nntp ogg opengl pcre pdf perl php png qt3 qt4 samba sse sse2 ssl svg truetype usb v4l vcd vhosts vorbis wmf xinerama xml xsl xv xvid yahoo zlib"

ALSA_CARDS="hda-intel"
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Thu Sep 06, 2007 2:02 pm    Post subject: Reply with quote

Alors je crois qu'il y a une faute de frappe dans make.conf : MAKE_OPTS="-j3" != MAKEOPTS="-j3"
Une fois rectifiée, tente une installation de DIA comme ceci : MAKEOPTS="-j1" emerge -pv dia
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
F!nTcH
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2007
Posts: 149

PostPosted: Thu Sep 06, 2007 2:03 pm    Post subject: Reply with quote

Dia recompilé, problème persiste :s

Bah, j'ai fait ce que j'avais à faire avec, c'est plus urgent, mais bon, d'autres pourraient avoir le même souci ...

Merci beaucoup tout de même (je le redirai jamais assez ...)
Back to top
View user's profile Send private message
F!nTcH
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2007
Posts: 149

PostPosted: Thu Sep 06, 2007 2:06 pm    Post subject: Reply with quote

Atta, emerge -pv, c'est une simulation nan ?

Et puis effectivement, si je faisais gaffe à mes variables ... ça irait beaucoup mieux :s

Code:

host ~ # MAKEOPTS="-j1" emerge -pv dia
>>> --pretend disables --ask... removing --ask from options.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] app-office/dia-0.95.1  USE="png python zlib -debug -gnome" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Thu Sep 06, 2007 2:07 pm    Post subject: Reply with quote

enlève le -p :)
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
F!nTcH
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jul 2007
Posts: 149

PostPosted: Thu Sep 06, 2007 2:10 pm    Post subject: Reply with quote

lol m'en serais douté xD

mais bon ...
en quoi avoir "undef MAKEOPTS" et MAKEOPTS=-j1 pourrait-ce changer quelquechose ??
je viens de réémerger Dia, il s'est recompilé tout seul sans dépendances ...
je vais lui péter un coup de remerge comme tu le suggères, mais je suis pas convaincu ...
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Thu Sep 06, 2007 2:12 pm    Post subject: Reply with quote

Le parallélisme c'est bien quand le code du programme est fait pour, dans le cas contraire, ça bug. D'où le -j1 pour une compilation sure.
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum