Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
rpc: timeout in modo silente?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
MajinJoko
l33t
l33t


Joined: 20 Sep 2005
Posts: 639
Location: Bergamo / Verona

PostPosted: Sat Sep 01, 2007 9:44 pm    Post subject: rpc: timeout in modo silente? Reply with quote

'sera a tutti.

A casa possiedo un portatile, un desktop e un fisso che mi fa da server.

Sul server sono presenti due condivisioni che esporto con nfs.

Nell'fstab del portatile ho:
Code:
192.168.2.207:/samba/storage /home/storage   nfs   rw,async,users,auto,tcp      0 0
192.168.2.207:/samba/mtv /home/mtv   nfs   rw,async,auto,users,tcp     0 0


Tutto funziona alla perfezione. In pratica al boot, poco prima che si avvii xdm, ottengo:
Code:
 * Service hald started
 * WARNING:  net.wlan0 has started but is inactive
 * WARNING:  sshd is scheduled to start when net.wlan0 has started.
 * WARNING:  ntp-client is scheduled to start when net.wlan0 has started.
 * Service vixie-cron started
 * Service portmap started
 * WARNING:  netmount is scheduled to start when net.wlan0 has started.
 * Service xdm started
 * Service alsasound started
 * Service local started

e, se trova il server acceso, monta correttamente le condivisioni, altrimenti, se il server è spento o irraggiungibile, non monta nulla. Però la procedura di boot termina senza alcun errore, arrivando correttamente al login.


Qualche giorno fa ho travasato brutalmente :) la mia gentoo che ho sul portatile, sul desktop.
Sistemate le cose ovvie, ho anche modificato il boot affinché avvii la eth0 anziché la wireless.

Ora, il desktop se non trova acceso il server, si blocca finché va in timeout, allorché restituisce
Code:
mount: RPC: Remote system error - No route to host
e finisce di completare l'avvio.

Una soluzione abbastanza ovvia è modificare l'fstab mettendo il noauto alle due righe incriminate.

Mi piacerebbe però capire se è possibile ottenere anche sul desktop lo stesso comportamento del portatile.
È possibile fare in modo che portmap vada in timeout senza bloccare il caricamento del sistema?

Grazie a tutti!
_________________
[(.. watashi wa Urumi Kanzaki ga suki da ..)]
Back to top
View user's profile Send private message
Ic3M4n
Advocate
Advocate


Joined: 02 Nov 2004
Posts: 3489
Location: Bergamo.

PostPosted: Sat Sep 01, 2007 10:48 pm    Post subject: Reply with quote

sei sicuro di non ricevere nessun errore? non è che compaiono dopo che ti si è avviato l'ambiente grafico?
Back to top
View user's profile Send private message
MajinJoko
l33t
l33t


Joined: 20 Sep 2005
Posts: 639
Location: Bergamo / Verona

PostPosted: Sun Sep 02, 2007 8:17 am    Post subject: Reply with quote

io non trovo traccia di errori né in dmesg né in /var/log/messages.

Così, dopo il pezzo già citato:
Quote:
* Service hald started
* WARNING: net.wlan0 has started but is inactive
* WARNING: sshd is scheduled to start when net.wlan0 has started.
* WARNING: ntp-client is scheduled to start when net.wlan0 has started.
* Service vixie-cron started
* Service portmap started
* WARNING: netmount is scheduled to start when net.wlan0 has started.
* Service xdm started
* Service alsasound started
* Service local started

ho direttamente il login, non errore di sorta..
_________________
[(.. watashi wa Urumi Kanzaki ga suki da ..)]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum