Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Audio driver for Dell Inspiron 8200 laptop
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Toby Jones
n00b
n00b


Joined: 21 Apr 2002
Posts: 2

PostPosted: Sun Apr 21, 2002 1:36 am    Post subject: Audio driver for Dell Inspiron 8200 laptop Reply with quote

I'm running Gentoo Linux on a Dell Inspiron 8200 laptop. I'm having difficulty getting the audio up and running. I've tried most of the kernel audio modules and most of the ALSA modules, but nothing seems to work.

The dell website says this about the I8200 sound:
-Foster's Audio sound system
-Optional External: Midnight gray Harmon/Kardon 195 Speakers
-Crystal CS 4205 AC '97 software based audio

I assume I'm looking for a driver for the CS 4205. Nothing in the kernel docs reference the 4205 and the ALSA website doesn't mention the CS4205.

Has anyone gotten the audio working on an I8200 or am I out of luck right now?
_________________
Toby Jones
Programmer
Human Head Studios
Back to top
View user's profile Send private message
klieber
Administrator
Administrator


Joined: 17 Apr 2002
Posts: 3657
Location: San Francisco, CA

PostPosted: Sun Apr 21, 2002 1:29 pm    Post subject: Re: Audio driver for Dell Inspiron 8200 laptop Reply with quote

Toby Jones wrote:
I assume I'm looking for a driver for the CS 4205. Nothing in the kernel docs reference the 4205 and the ALSA website doesn't mention the CS4205.


Try using the Intel ICH (i8xx) driver. Not very intuitive, I know, but it seems to work.

--kurt
_________________
The problem with political jokes is that they get elected
Back to top
View user's profile Send private message
Toby Jones
n00b
n00b


Joined: 21 Apr 2002
Posts: 2

PostPosted: Sun Apr 21, 2002 4:07 pm    Post subject: Reply with quote

Worked like a charm. Thanks!
_________________
Toby Jones
Programmer
Human Head Studios
Back to top
View user's profile Send private message
Stalione
Guru
Guru


Joined: 21 Apr 2002
Posts: 335

PostPosted: Sun Apr 21, 2002 9:08 pm    Post subject: IBM laptop with same soundcard...didnt' work Reply with quote

Hi,
I have the same crystal sound card using ac97 codec and I used snd-card-intel8x0 but it didnt' work for me. this is what i have currently loaded (from lsmod command):

snd-card-intel8x0 8672 0
snd-pcm 29760 0 [snd-card-intel8x0]
snd-timer 8704 0 [snd-pcm]
snd-ac97-codec 23072 0 [snd-card-intel8x0]
snd-mixer 26568 0 [snd-ac97-codec]
snd 32512 1 [snd-card-intel8x0 snd-pcm snd-timer snd-ac97-codec snd-mixer]

Am i missing something?
Back to top
View user's profile Send private message
Tester
Developer
Developer


Joined: 10 Jun 2002
Posts: 37
Location: Montreal, Canada

PostPosted: Mon Jun 10, 2002 3:24 am    Post subject: Reply with quote

Instead of ALSA, try the standard OSS driver from the standard kernel tree..
_________________
Tester
tester@gentoo.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum