Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[PAM] impossible de devenir "root" via su (resolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
gaga
Apprentice
Apprentice


Joined: 27 Apr 2005
Posts: 288

PostPosted: Wed Aug 29, 2007 8:03 pm    Post subject: [PAM] impossible de devenir "root" via su (resolu) Reply with quote

Bonjour

je comprends pas mon problème. Je viens de réinstallé une gentoo tt fraîche (obligé du à un pb de rangement niveau partitions)

je précise de suite que mes utilisateurs sont dans le groupe "wheel"

tout se passe (presque) parfaitement bien sauf que si je suis dans n'importe quelle console, je ne peux pas devenir superutilisateur (autre que dans les consoles framebuffer en se loggant directement en root)

je précise que j'ai déjà essayé de réinstallé pam (et en supprimant le dossier complet /etc/pam.d) mais rien n'a changé (enfin si c'était pire, je ne pouvais même plus me logguer du tout, j'ai alors remis les fichiers de conf que j'avais sauvegardé)

quelqu'un a -til la moindre idée du problème ? c'est vraiment agaçant !

merci d'avance

ps : j'ai repris certains fichiers de conf de mon ancienne gentoo, mais rien à voir avec pam (du moins il me semble). Tt mes récup' sont situé dans /etc/conf.d/, /etc/samba et /etc/nut + encore mon répertoire /home (mais j'ai aussi essayé avec un nouveau répertoire vide, change rien)


Quote:
Aug 29 21:27:37 schlopa su[8440]: + tty1 root:root
Aug 29 21:27:37 schlopa su[8440]: pam_unix(su:session): session opened for user root by root(uid=0)
Aug 29 21:27:41 schlopa su[8446]: Successful su for lagaffe by root
Aug 29 21:27:41 schlopa su[8446]: + tty1 root:lagaffe
Aug 29 21:27:41 schlopa su[8446]: pam_unix(su:session): session opened for user lagaffe by root(uid=0)
Aug 29 21:27:44 schlopa su[8452]: pam_unix(su:auth): authentication failure; logname=root uid=1000 euid=1000 tty=tty1 ruser=lagaffe rhost= user=root
Aug 29 21:27:46 schlopa su[8452]: pam_authenticate: Échec d'authentification
Aug 29 21:27:46 schlopa su[8452]: FAILED su for root by lagaffe
Aug 29 21:27:46 schlopa su[8452]: - tty1 lagaffe:root
Aug 29 21:27:48 schlopa su[8455]: pam_unix(su:auth): authentication failure; logname=root uid=1000 euid=1000 tty=tty1 ruser=lagaffe rhost= user=root
Aug 29 21:27:50 schlopa su[8455]: pam_authenticate: Échec d'authentification
Aug 29 21:27:50 schlopa su[8455]: FAILED su for root by lagaffe
Aug 29 21:27:50 schlopa su[8455]: - tty1 lagaffe:root
Aug 29 21:27:51 schlopa su[8446]: pam_unix(su:session): session closed for user lagaffe
Aug 29 21:29:17 schlopa login[8357]: PAM _pam_init_handlers: could not open /etc/pam.conf
Aug 29 21:29:17 schlopa login[8357]: PAM pam_start: failed to initialize handlers
Aug 29 21:29:17 schlopa login[8357]: Couldn't initialize PAM: Critical error - immediate abort
Aug 29 21:30:01 schlopa cron[8916]: PAM _pam_init_handlers: could not open /etc/pam.conf
Aug 29 21:30:01 schlopa cron[8916]: PAM pam_start: failed to initialize handlers
Aug 29 21:36:21 schlopa login[9058]: FAILED LOGIN (1) on 'tty2' FOR `root', Authentication failure
Aug 29 21:36:24 schlopa login[9058]: FAILED LOGIN (2) on 'tty2' FOR `UNKNOWN', Authentication failure
Aug 29 21:36:27 schlopa login[9058]: TOO MANY LOGIN TRIES (3) on 'tty2' FOR `UNKNOWN'
Aug 29 21:36:34 schlopa login[19596]: FAILED LOGIN (1) on 'tty2' FOR `root', Authentication failure
Aug 29 21:36:37 schlopa login[19596]: FAILED LOGIN (2) on 'tty2' FOR `UNKNOWN', Authentication failure
Aug 29 21:36:39 schlopa login[19596]: TOO MANY LOGIN TRIES (3) on 'tty2' FOR `UNKNOWN'
Aug 29 21:36:53 schlopa login[19607]: FAILED LOGIN (1) on 'tty2' FOR `lagaffe', Authentication failure
Aug 29 21:36:56 schlopa login[19607]: FAILED LOGIN (2) on 'tty2' FOR `UNKNOWN', Authentication failure
Aug 29 21:36:58 schlopa login[19607]: TOO MANY LOGIN TRIES (3) on 'tty2' FOR `UNKNOWN'
Aug 29 21:42:51 schlopa su[8440]: pam_unix(su:session): session closed for user root
Aug 29 21:42:54 schlopa sshd[8038]: Received signal 15; terminating.
Aug 29 21:44:09 schlopa sshd[8032]: Server listening on :: port 22.
Aug 29 21:44:09 schlopa sshd[8032]: error: Bind to port 22 on 0.0.0.0 failed: Address already in use.
Aug 29 21:44:43 schlopa login[8350]: FAILED LOGIN (1) on 'tty1' FOR `root', Authentication failure
Aug 29 21:52:23 schlopa sshd[8154]: Server listening on :: port 22.
Aug 29 21:52:23 schlopa sshd[8154]: error: Bind to port 22 on 0.0.0.0 failed: Address already in use.
Aug 29 21:52:36 schlopa kdm: :0[8519]: pam_unix(kde-np:session): session opened for user lagaffe by (uid=0)
Aug 29 21:53:37 schlopa su[8713]: pam_unix(su:auth): authentication failure; logname= uid=1000 euid=1000 tty=pts/1 ruser=lagaffe rhost= user=root
Aug 29 21:53:38 schlopa su[8713]: pam_authenticate: Échec d'authentification
Aug 29 21:53:38 schlopa su[8713]: FAILED su for root by lagaffe
Aug 29 21:53:38 schlopa su[8713]: - pts/1 lagaffe:root
Aug 29 21:54:16 schlopa login[8472]: pam_tally(login:auth): unknown option: no_magic_root
Aug 29 21:54:17 schlopa login[8472]: pam_tally(login:account): option deny=0 allowed in auth phase only
Aug 29 21:54:17 schlopa login[8472]: pam_tally(login:account): unknown option: no_magic_root
Aug 29 21:54:17 schlopa login[8472]: pam_tally(login:setcred): unknown option: no_magic_root
Aug 29 21:54:17 schlopa login[8472]: pam_unix(login:session): session opened for user root by LOGIN(uid=0)
Aug 29 21:54:17 schlopa login[8759]: ROOT LOGIN on 'tty1'


Last edited by gaga on Thu Aug 30, 2007 9:06 pm; edited 1 time in total
Back to top
View user's profile Send private message
gaga
Apprentice
Apprentice


Joined: 27 Apr 2005
Posts: 288

PostPosted: Wed Aug 29, 2007 9:50 pm    Post subject: Reply with quote

après quelques recherches, j'ai quelques "pistes" qui pourrait être à l'origine du problème

j'ai essayé d'enlever carrement le mots de passe root pour voir ( patapäy :oops: )

dans une console framebuffer si je tape 'root' comme login j'ai directement le shell donc ok
mais toujours pas possible de me retrouver superutilisateur via su

maintenant il me sort ceci :

Quote:
su : Le service d'authentification n'a pas pu récupérer les infos d'authentification



une meilleur idée ?

je vois pas où chercher ! HELP please ! dans les log y a rien !
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 512

PostPosted: Wed Aug 29, 2007 11:52 pm    Post subject: Reply with quote

A priori, la gestion de tout ce qui est lié à pam (su, login, login via ssh) est scindé dans différents fichiers.

Le fait que login fonctionne mais pas su me fait penser que tu as un problème dans ton
Code:
/etc/pam.d/su
. (soit un problème de droits sur le fichiers, soit un fichier mal recopié et/ou édité)

Plusieurs solutions :
- soit tu postes ton /etc/pam.d/su
- soit tu t'inspire du mien (qui n'a pas été touché), il a les droits : -rw-r--r-- est appartient à root root
- soit tu fais un :
Code:
emerge -C pam && emerge pam && etc-update
le tout sans te délogguer si tu veux pas avoir à passer par la cause chroot ...
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8541
Location: ~Brussels - Belgique

PostPosted: Thu Aug 30, 2007 6:39 am    Post subject: Reply with quote

sinon, as-tu bien fait un etc-update (ou dispatch-conf) après la mise à jour de pam/shadow ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
gaga
Apprentice
Apprentice


Joined: 27 Apr 2005
Posts: 288

PostPosted: Thu Aug 30, 2007 10:17 am    Post subject: Reply with quote

ppfff je commence a en avoir marre, déjà 3 heures ce matin là dessus et j'ai pas avancé d'un pouce !

Quote:
A priori, la gestion de tout ce qui est lié à pam (su, login, login via ssh) est scindé dans différents fichiers.

Le fait que login fonctionne mais pas su me fait penser que tu as un problème dans ton

Quote:

/etc/pam.d/su
. (soit un problème de droits sur le fichiers, soit un fichier mal recopié et/ou édité)

Plusieurs solutions :
- soit tu postes ton /etc/pam.d/su
- soit tu t'inspire du mien (qui n'a pas été touché), il a les droits : -rw-r--r-- est appartient à root root
- soit tu fais un :
Code:
emerge -C pam && emerge pam && etc-update
le tout sans te délogguer si tu veux pas avoir à passer par la cause chroot ...


j'ai tout essayé ! niet ! je reviens au point de départ

Quote:
sinon, as-tu bien fait un etc-update (ou dispatch-conf) après la mise à jour de pam/shadow ?


j'ai vérifié et j'ai même fait les 2 commandes, tout est à jour !


j'ai également essayé en virant tout les fichiers en rapport avec pam. Mais alors j'arrive même plus à me logguer (chroot obligatoire pour résoudre le pb ) et j'ai remis les anciens fichiers....




une autre please ?? je vais finir par craqué


Last edited by gaga on Thu Aug 30, 2007 11:38 am; edited 1 time in total
Back to top
View user's profile Send private message
Bapt
Veteran
Veteran


Joined: 14 Apr 2003
Posts: 1152
Location: Paris

PostPosted: Thu Aug 30, 2007 10:23 am    Post subject: Reply with quote

Question peut être très conne, mais on ne sait jamais, dans quels groupes est le user qui veux faire le su ?
Back to top
View user's profile Send private message
gaga
Apprentice
Apprentice


Joined: 27 Apr 2005
Posts: 288

PostPosted: Thu Aug 30, 2007 10:52 am    Post subject: Reply with quote

Quote:

$ cat /etc/pam.d/su
#%PAM-1.0

auth sufficient pam_rootok.so

# If you want to restrict users begin allowed to su even more,
# create /etc/security/suauth.allow (or to that matter) that is only
# writable by root, and add users that are allowed to su to that
# file, one per line.
#auth required pam_listfile.so item=ruser sense=allow onerr=fail file=/etc/security/suauth.allow

# Uncomment this to allow users in the wheel group to su without
# entering a passwd.
#auth sufficient pam_wheel.so use_uid trust

# Alternatively to above, you can implement a list of users that do
# not need to supply a passwd with a list.
#auth sufficient pam_listfile.so item=ruser sense=allow onerr=fail file=/etc/security/suauth.nopass

# Comment this to allow any user, even those not in the 'wheel'
# group to su
auth required pam_wheel.so use_uid

auth include system-auth

account include system-auth

password include system-auth

session include system-auth
session required pam_env.so
session optional pam_xauth.so




Quote:
$ cat /etc/group
root::0:root
bin::1:root,bin,daemon
daemon::2:root,bin,daemon
sys::3:root,bin,adm
adm::4:root,adm,daemon
tty::5:
disk::6:root,adm,haldaemon
lp::7:lp
mem::8:
kmem::9:
wheel::10:root,lagaffe,temp
floppy::11:root,haldaemon,lagaffe
mail::12:mail
news::13:news
uucp:!:14:uucp,nut
man::15:man
console::17:
audio::18:lagaffe
cdrom::19:haldaemon,lagaffe
dialout::20:root
tape::26:root
video::27:root,lagaffe
cdrw::80:haldaemon
usb::85:haldaemon,lagaffe
users::100:games,lagaffe
nofiles:x:200:
smmsp:x:209:smmsp
portage::250:portage,lagaffe
utmp:x:406:
nogroup::65533:
nobody::65534:
ldap:x:439:
sshd:x:22:
messagebus:x:440:
mysql:x:60:
lpadmin:x:106:
cron:x:16:
postgres:x:70:
crontab:x:441:
netdev:x:442:
avahi:x:443:
avahi-autoipd:x:444:
haldaemon:x:445:haldaemon
plugdev:x:446:haldaemon,lagaffe
apache:x:81:
xfs:x:33:
gkrellmd:x:447:
beagleindex:x:448:
nut:!:84:nut
games:x:35:lagaffe
locate:x:245:
lagaffe:x:1000:
p2p:x:1001:
tcpdump:x:1002:
vmware:x:1003:
qemu:x:1004:
eclipse:x:1005:
temp:x:1006:
schlopa:x:1007:


je précise que lagaffe est mon utilisateur "définitif ! temp et schlopa sont des essais ....
Back to top
View user's profile Send private message
gaga
Apprentice
Apprentice


Joined: 27 Apr 2005
Posts: 288

PostPosted: Thu Aug 30, 2007 11:13 am    Post subject: Reply with quote

je crois que ça sent de moins en moins bon......... réinstall oblige ? j'ai l'impression que tout le système est pourri
( ça me fait sacrement ch*** après tt ces heures de compilations )


Last edited by gaga on Thu Aug 30, 2007 11:36 am; edited 1 time in total
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8541
Location: ~Brussels - Belgique

PostPosted: Thu Aug 30, 2007 11:29 am    Post subject: Reply with quote

salut,

as-tu bien monté /dev et proc dans ton répertoire chrooté ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
gaga
Apprentice
Apprentice


Joined: 27 Apr 2005
Posts: 288

PostPosted: Thu Aug 30, 2007 11:35 am    Post subject: Reply with quote

( ooops je crois que je fatigue, effectivement je n'avais pas monté /dev sur cet essai donc ça n'a rien à voir avec le pb je suppose )

PS : posts précédents EDITE

on est donc au même point qu'au départ
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8541
Location: ~Brussels - Belgique

PostPosted: Thu Aug 30, 2007 12:56 pm    Post subject: Reply with quote

solution: arrête, va te balader 15 minutes (te chercher un cornet de frites, boire un pot, acheter une pizza surgelée), ça te changera les idées 8)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
shakya
n00b
n00b


Joined: 04 Dec 2006
Posts: 40
Location: Somewhere

PostPosted: Thu Aug 30, 2007 2:04 pm    Post subject: Reply with quote

pourrais tu voir du coté de ton /etc/security/access.conf et nous en donner un aperçu s'il te plait ?
Back to top
View user's profile Send private message
gaga
Apprentice
Apprentice


Joined: 27 Apr 2005
Posts: 288

PostPosted: Thu Aug 30, 2007 3:26 pm    Post subject: Reply with quote

Quote:
solution: arrête, va te balader 15 minutes (te chercher un cornet de frites, boire un pot, acheter une pizza surgelée), ça te changera les idées


8) oui chef ! avec plaisir :D


Quote:
pourrais tu voir du coté de ton /etc/security/access.conf et nous en donner un aperçu s'il te plait ?


tout est en commentaires !

Quote:
# cat /etc/security/access.conf
# Login access control table.
#
# When someone logs in, the table is scanned for the first entry that
# matches the (user, host) combination, or, in case of non-networked
# logins, the first entry that matches the (user, tty) combination. The
# permissions field of that table entry determines whether the login will
# be accepted or refused.
#
# Format of the login access control table is three fields separated by a
# ":" character:
#
# [Note, if you supply a 'fieldsep=|' argument to the pam_access.so
# module, you can change the field separation character to be
# '|'. This is useful for configurations where you are trying to use
# pam_access with X applications that provide PAM_TTY values that are
# the display variable like "host:0".]
#
# permission : users : origins
#
# The first field should be a "+" (access granted) or "-" (access denied)
# character.
#
# The second field should be a list of one or more login names, group
# names, or ALL (always matches). A pattern of the form user@host is
# matched when the login name matches the "user" part, and when the
# "host" part matches the local machine name.
#
# The third field should be a list of one or more tty names (for
# non-networked logins), host names, domain names (begin with "."), host
# addresses, internet network numbers (end with "."), ALL (always
# matches) or LOCAL (matches any string that does not contain a "."
# character).
#
# If you run NIS you can use @netgroupname in host or user patterns; this
# even works for @usergroup@@hostgroup patterns. Weird.
#
# The EXCEPT operator makes it possible to write very compact rules.
#
# The group file is searched only when a name does not match that of the
# logged-in user. Both the user's primary group is matched, as well as
# groups in which users are explicitly listed.
#
# TTY NAMES: Must be in the form returned by ttyname(3) less the initial
# "/dev" (e.g. tty1 or vc/1)
#
##############################################################################
#
# Disallow non-root logins on tty1
#
#-:ALL EXCEPT root:tty1
#
# Disallow console logins to all but a few accounts.
#
#-:ALL EXCEPT wheel shutdown sync:LOCAL
#
# Disallow non-local logins to privileged accounts (group wheel).
#
#-:wheel:ALL EXCEPT LOCAL .win.tue.nl
#
# Some accounts are not allowed to login from anywhere:
#
#-:wsbscaro wsbsecr wsbspac wsbsym wscosor wstaiwde:ALL
#
# All other accounts are allowed to login from anywhere.
#


c'est normal ?

merci pour votre soutien !
Back to top
View user's profile Send private message
gaga
Apprentice
Apprentice


Joined: 27 Apr 2005
Posts: 288

PostPosted: Thu Aug 30, 2007 9:05 pm    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic-t-11126.html


pffffffffffff faut vraiment que j'apprenne à rechercher comme il faut ! la solution était la dedans


pour ceux qui vont suivre, mon pb se situait dans /etc/fstab !!! j'avais ajouté par mégarde les options de montages exec,users pour la partition racine ! et ça casse des choses ! (faut le savoir quand même)

voilà c'est résolu

merci pour votre soutien

gaga
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum