Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[hostapd] IOCTL erreur avec un bridge (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
BuBuaBu
l33t
l33t


Joined: 09 Jul 2005
Posts: 912
Location: France

PostPosted: Tue Aug 28, 2007 5:29 pm    Post subject: [hostapd] IOCTL erreur avec un bridge (résolu) Reply with quote

Voila, j'essai de faire une ap sur un serveur.

Je dispose d'une carte ATHEROS : ath0
et d'une carte wired : eth0

le tout dans un bridgo br0

Lorsque que je casse mon bridge et commentent la ligne (bridge=br0) dans /etc/hostapd/hostapd.conf, mon wifi marche a la perfection.

Si je refais le bridge, impossible de s'authentifier en WPA (normal selon la doc madwifi)

et avec le bridge et la config du bridge dans hostapd, voila ce que ça me fait :

Code:

# hostapd -dd /etc/hostapd/hostapd.conf
Configuration file: /etc/hostapd/hostapd.conf
Configure bridge br0     # Enable for EAPOL traffic.
ioctl[SIOCGIFINDEX]: No such device
madwifi driver initialization failed.



Last edited by BuBuaBu on Tue Aug 28, 2007 6:55 pm; edited 1 time in total
Back to top
View user's profile Send private message
widan
Veteran
Veteran


Joined: 07 Jun 2005
Posts: 1512
Location: Paris, France

PostPosted: Tue Aug 28, 2007 6:19 pm    Post subject: Re: [hostapd] IOCTL erreur avec un bridge Reply with quote

Code:
Configure bridge br0     # Enable for EAPOL traffic.
ioctl[SIOCGIFINDEX]: No such device

Le "# Enable ...", qu'est-ce qu'il vient faire là ? Un commentaire dans le fichier de config ? Essaye de le mettre sur une autre ligne, j'ai l'impression que hostapd considère "br0 # Enable ..." comme un nom d'interface, et bien sûr il la trouve pas.
Back to top
View user's profile Send private message
BuBuaBu
l33t
l33t


Joined: 09 Jul 2005
Posts: 912
Location: France

PostPosted: Tue Aug 28, 2007 6:55 pm    Post subject: Reply with quote

C'est vraiment con comme erreur ....

Mon fichier de config avant :
Code:

bridge=br0    # Enable this for standard bridging, leave disabled for netfilter firewalls



en ajoutant un retour a la ligne ça marche.

Je pense que hostapd a quelque problème a ce niveau (enfin en général ça dérange pas les commentaire en fin de ligne)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum