Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
errore emerge glibc-2.6.1 dopo revdep-rebuild[solved]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
flaaa
n00b
n00b


Joined: 24 Aug 2007
Posts: 5

PostPosted: Sun Aug 26, 2007 6:47 pm    Post subject: errore emerge glibc-2.6.1 dopo revdep-rebuild[solved] Reply with quote

dopo aver dato revdep-rebuild nel momento in cui mi compila le glibc ecco qua la sorpresa

Code:
/var/tmp/portage/sys-libs/glibc-2.6.1/work/build-x86-x86_64-pc-linux-gnu-nptl/li
bc_pic.os: In function `__nscd_get_map_ref':
(.text+0xdb99e): undefined reference to `__sync_val_compare_and_swap_4'
/var/tmp/portage/sys-libs/glibc-2.6.1/work/build-x86-x86_64-pc-linux-gnu-nptl/li
bc_pic.os: In function `__GI___libc_freeres':
(__libc_freeres_fn+0x89e): undefined reference to `__sync_bool_compare_and_swap_
4'
collect2: ld returned 1 exit status
make[1]: *** [/var/tmp/portage/sys-libs/glibc-2.6.1/work/build-x86-x86_64-pc-lin
ux-gnu-nptl/libc.so] Error 1
make[1]: Leaving directory `/var/tmp/portage/sys-libs/glibc-2.6.1/work/glibc-2.6
.1'
make: *** [all] Error 2
 *
 * ERROR: sys-libs/glibc-2.6.1 failed.
 * Call stack:
 *   ebuild.sh, line 1654:   Called dyn_compile
 *   ebuild.sh, line 990:   Called qa_call 'src_compile'
 *   ebuild.sh, line 44:   Called src_compile
 *   glibc-2.6.1.ebuild, line 147:   Called eblit-run 'src_compile'
 *   glibc-2.6.1.ebuild, line 143:   Called eblit-glibc-src_compile
 *   src_compile.eblit, line 168:   Called src_compile
 *   glibc-2.6.1.ebuild, line 147:   Called eblit-run 'src_compile'
 *   glibc-2.6.1.ebuild, line 143:   Called eblit-glibc-src_compile
 *   src_compile.eblit, line 179:   Called toolchain-glibc_src_compile
 *   src_compile.eblit, line 122:   Called die
 *
 * make for x86 failed
 * If you need support, post the topmost build error, and the call stack if rele
vant.
 * A complete build log is located at '/var/tmp/portage/sys-libs/glibc-2.6.1/tem
p/build.log'.
 *


ho letto per forum che il problema si potrebbe risolvere usando lo script
Code:
fix_libtool_files.sh
solo che con gcc 4.x sembra non funzionare, quindi tra poco proverò a downgradare gcc, intanto datemi le vostre impressioni
grazie in anticipo


Last edited by flaaa on Sun Aug 26, 2007 8:17 pm; edited 1 time in total
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sun Aug 26, 2007 6:52 pm    Post subject: Re: errore emerge glibc-2.6.1 dopo revdep-rebuild Reply with quote

flaaa wrote:
dopo aver dato revdep-rebuild nel momento in cui mi compila le glibc

:?: come mai revdep-rebuild ha chiamato una ricompilazione delle glibc?

fix_libtool_files.sh dovrebbe servire per il passaggio da gcc-3.* a gcc-4.*. ma dubito che tu sia partito da un sistema tanto vecchio. a quale post del forum ti riferisci?

stai usando CFLAGS particolari? prova a postare un emerge --info
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
flaaa
n00b
n00b


Joined: 24 Aug 2007
Posts: 5

PostPosted: Sun Aug 26, 2007 7:28 pm    Post subject: Reply with quote

a dirti la verità mi è parso strano anche a me cmq essendo un po newbie ho fatto finta di niente...
cmq ecco emerge --info:
Code:
Portage 2.1.3.6 (default-linux/amd64/2007.0, gcc-4.1.1, glibc-2.5-r0, 2.6.22-gentoo-r5 x86_64)
=================================================================
System uname: 2.6.22-gentoo-r5 x86_64 AMD Athlon(tm) 64 Processor 3500+
Gentoo Base System release 1.12.9
Timestamp of tree: Fri, 24 Aug 2007 14:30:01 +0000
ccache version 2.4 [enabled]
dev-lang/python:     2.4.3-r4, 2.5.1-r2
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17.50.0.18
sys-devel/gcc-config: 1.4.0
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
ABI="amd64"
ACCEPT_KEYWORDS="amd64 ~amd64"
ALSA_CARDS="...removed by randomaze..."
ALSA_PCM_PLUGINS="...removed by randomaze..."
ARCH="amd64"
ASFLAGS_x86="--32"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CCACHE_SIZE="2G"
CDEFINE_amd64="__x86_64__"
CDEFINE_x86="__i386__"
CFLAGS="-mtune=k8 -O2 -pipe"
CFLAGS_x86="-m32 -L/emul/linux/x86/lib -L/emul/linux/x86/usr/lib"
CHOST="x86_64-pc-linux-gnu"
CHOST_amd64="x86_64-pc-linux-gnu"
CHOST_x86="i686-pc-linux-gnu"
CLEAN_DELAY="5"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CVS_RSH="ssh"
CXXFLAGS="-mtune=k8 -O2 -pipe"
DEFAULT_ABI="amd64"
DISPLAY=":0.0"
DISTDIR="/usr/portage/distfiles"
EDITOR="/bin/nano"
ELIBC="glibc"
EMERGE_DEFAULT_OPTS="--ask --verbose"
EMERGE_WARNING_DELAY="10"
FEATURES="ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
FETCHCOMMAND="/usr/bin/wget -t 5 -T 60 --passive-ftp -O ${DISTDIR}/${FILE} ${URI}"
GCC_SPECS=""
GDK_USE_XFT="1"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
G_BROKEN_FILENAMES="1"
G_FILENAME_ENCODING="UTF-8"
HOME="/root"
HUSHLOGIN="FALSE"
INFOPATH="...removed by randomaze..."
INPUT_DEVICES="evdev keyboard mouse"
KDEDIRS="/usr:/usr/local:/usr/kde/3.5"
KERNEL="linux"
LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text"
LDFLAGS_x86="-m elf_i386 -L/emul/linux/x86/lib -L/emul/linux/x86/usr/lib"
LESS="-R -M --shift 5"
LESSOPEN="|lesspipe.sh %s"
LIBDIR_amd64="lib64"
LIBDIR_x86="lib32"
LIBGL_DRIVERS_PATH="/usr/lib64/dri:/usr/lib32/dri"
LINGUA="it"
LOGNAME="root"
LS_COLORS="...removed by randomaze..."
MAKEOPTS="-j2"
MANPATH="...removed by randomaze..."
MULTILIB_ABIS="amd64 x86"
MULTILIB_STRICT_DENY="64-bit.*shared object"
MULTILIB_STRICT_DIRS="/lib /usr/lib /usr/kde/*/lib /usr/qt/*/lib /usr/X11R6/lib"
MULTILIB_STRICT_EXEMPT="(perl5|gcc|gcc-lib|binutils|eclipse-3|debug|portage)"
OPENGL_PROFILE="ati"
PAGER="/usr/bin/less"
PATH="...removed by randomaze..."
PKGDIR="/usr/portage/packages"
PKG_CONFIG_PATH="/usr/qt/3/lib64/pkgconfig"
PORTAGE_ARCHLIST="ppc s390 amd64 x86 ppc64 x86-fbsd m68k arm sparc sh mips ia64 alpha ppc-macos hppa sparc-fbsd"
PORTAGE_BINHOST_CHUNKSIZE="3000"
PORTAGE_BIN_PATH="/usr/lib64/portage/bin"
PORTAGE_CONFIGROOT="/"
PORTAGE_DEBUG="0"
PORTAGE_DEPCACHEDIR="/var/cache/edb/dep"
PORTAGE_ELOG_CLASSES="log warn error"
PORTAGE_ELOG_MAILFROM="portage"
PORTAGE_ELOG_MAILSUBJECT="[portage] ebuild log for ${PACKAGE} on ${HOST}"
PORTAGE_ELOG_MAILURI="root"
PORTAGE_ELOG_SYSTEM="save_summary echo"
PORTAGE_GID="250"
PORTAGE_INST_GID="0"
PORTAGE_INST_UID="0"
PORTAGE_PYM_PATH="/usr/lib64/portage/pym"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force                                        --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_RSYNC_RETRIES="3"
PORTAGE_TMPDIR="/var/tmp"
PORTAGE_WORKDIR_MODE="0700"
PORTDIR="/usr/portage"
PWD="/home/fla"
PYTHONPATH="/usr/lib64/portage/pym"
QMAKESPEC="linux-g++"
QTDIR="/usr/qt/3"
RESUMECOMMAND="/usr/bin/wget -c -t 5 -T 60 --passive-ftp -O ${DISTDIR}/${FILE} ${URI}"
ROOT="/"
ROOTPATH="/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/4.1.1: /usr/kde/3.5/sbin:/usr/kde/3.5/bin:/usr/qt/3/bin"
RPMDIR="/usr/portage/rpm"
SHELL="/bin/bash"
SHLVL="5"
STAGE1_USE="nptl nptlonly unicode"
SYMLINK_LIB="yes"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
TERM="xterm"
USE="X aalib acl alsa amd64 apache2 at4 audacious berkdb bitmap-fonts cairo cdr cli cracklib crypt cups curl dri dvd dvdread ffmpeg fortran ftp gdbm gpm gtk iconv ipv6 isdnlog jpeg jpeg2k lcms midi mmx mmx2 mpeg mudflap mysql ncurses nls nptl nptlonly opengl openmp oss pam pcre pdf perl php png pppd python qt3 readline reflection session spl sse sse2 ssl ssl2 tcpd tiff truetype truetype-fonts type1-fonts unicode xorg xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="fglrx"
USER="root"
USERLAND="GNU"
USE_EXPAND="ALSA_CARDS ALSA_PCM_PLUGINS CAMERAS CROSSCOMPILE_OPTS DVB_CARDS ELIBC FCDSL_CARDS FOO2ZJS_DEVICES FRITZCAPI_CARDS INPUT_DEVICES KERNEL LCD_DEVICES LINGUAS LIRC_DEVICES MISDN_CARDS USERLAND VIDEO_CARDS"
USE_EXPAND_HIDDEN="CROSSCOMPILE_OPTS ELIBC KERNEL USERLAND"
USE_ORDER="env:pkg:conf:defaults:pkginternal:env.d"
VIDEO_CARDS="fglrx"
WINDOWID="23068685"
WINDOWPATH="7"
XARGS="xargs -r"
XAUTHORITY="/root/.xautheZX3gd"
XDG_DATA_DIRS="/usr/share:/usr/kde/3.5/share:/usr/local/share"
XTERM_LOCALE="C"
XTERM_SHELL="/bin/bash"
XTERM_VERSION="XTerm(229)"
_="/usr/bin/emerge"


edit by randomaze: ho reso un poco più leggibile il post rimuovendo alcune voci dall'emerge info
_________________
Amd64 k8 | asus A8N32-SLI | ati radeon x800gto2
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sun Aug 26, 2007 7:46 pm    Post subject: Reply with quote

flaaa wrote:
a dirti la verità mi è parso strano anche a me cmq essendo un po newbie ho fatto finta di niente...
cmq ecco emerge --info:

va bene. facciamo finta di niente.
le info sembrano a posto.

dopo avere ricompilato gcc (perchè mi pare di capire che il tuo sia nuovo), hai ricompilato per prima cosa sys-devel/libtool ?

inoltre, ho visto che hai la ccache attiva.
non so cosa accada se il compilatore nuovo utilizza una ccache generata da quello vecchio. forse nulla, ma io farei un clear.

magari prova prima a ricompilare libtool e glibc con la cache disabilitata nelle features e fai sapere.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
zolar czakl
Apprentice
Apprentice


Joined: 25 Sep 2004
Posts: 162
Location: UMRK

PostPosted: Sun Aug 26, 2007 7:48 pm    Post subject: Reply with quote

Code:
-march=k8


https://forums.gentoo.org/viewtopic-p-4199685.html?sid=1b64979ea7b962b03244446e15644495
Back to top
View user's profile Send private message
flaaa
n00b
n00b


Joined: 24 Aug 2007
Posts: 5

PostPosted: Sun Aug 26, 2007 8:07 pm    Post subject: Reply with quote

figura da pollo xD,
Quote:
-march=k8


grazie mille
_________________
Amd64 k8 | asus A8N32-SLI | ati radeon x800gto2
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sun Aug 26, 2007 8:13 pm    Post subject: Reply with quote

flaaa wrote:
figura da pollo xD

neanche troppo. sembra un problema serio
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
.:chrome:.
Advocate
Advocate


Joined: 19 Feb 2005
Posts: 4588
Location: Brescia, Italy

PostPosted: Sun Aug 26, 2007 9:19 pm    Post subject: Reply with quote

@flaaa:
potresti gentilmente editare il tuo post?
la variabile LS_COLORS non interessa a nessuno ed è ininfluente per il tuo problema. pubblicarla in quel modo rende solo illeggibile il forum

grazie
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Mon Aug 27, 2007 6:24 am    Post subject: Reply with quote

.:chrome:. wrote:
@flaaa:
potresti gentilmente editare il tuo post?

grazie

purtroppo è colpa mia, che ho chiesto un emerge --info e non ho nemmeno saputo usarlo :oops: .
flaaa è al suo quinto messaggio e ha fatto solo fatto un taglia incolla.

per di più il post è marcato risolto.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
nillkheope
Tux's lil' helper
Tux's lil' helper


Joined: 21 Mar 2005
Posts: 92

PostPosted: Fri Oct 26, 2007 1:08 pm    Post subject: Reply with quote

Code:
emerge glibc

ottengo questo.
Code:
* Messages for package sys-libs/glibc-2.6.1:

 *
 * ERROR: sys-libs/glibc-2.6.1 failed.
 * Call stack:
 *   ebuild.sh, line 1654:   Called dyn_compile
 *   ebuild.sh, line 990:   Called qa_call 'src_compile'
 *   ebuild.sh, line 44:   Called src_compile
 *   glibc-2.6.1.ebuild, line 147:   Called eblit-run 'src_compile'
 *   glibc-2.6.1.ebuild, line 143:   Called eblit-glibc-src_compile
 *   src_compile.eblit, line 179:   Called toolchain-glibc_src_compile
 *   src_compile.eblit, line 122:   Called die
 *
 * make for default failed
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/sys-libs/glibc-2.6.1/temp/build.log'.
 *


Io sinceramente non ho capito come risolvere.

vi psto in anticipo anche le miei configurazioni.

Code:

simba ~ # emerge --info
Portage 2.1.3.9 (default-linux/x86/2006.1, gcc-4.1.2, glibc-2.5-r0, 2.6.20-gentoo-r8 i686)
=================================================================
System uname: 2.6.20-gentoo-r8 i686 Intel(R) Pentium(R) 4 CPU 3.20GHz
Timestamp of tree: Fri, 26 Oct 2007 09:50:01 +0000
app-shells/bash:     3.2_p15-r1
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r6
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.9-r2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.17-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT=""
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ ftp://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ "
LANG="it_IT"
LC_ALL="it_IT@euro"
LINGUAS="it"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acpi alsa asd berkdb bitmap-fonts bzip2 cli cracklib crypt cups dri dvd dvdread encode fortran ftp gdbm gnome gpm gstreamer gtk iconv icq ipv6 isdnlog java jpeg libg++ midi mp3 mpeg msn mudflap ncurses nls nptl nptlonl nptlonly opengl openmp oss pam pcre perl ppds pppd python readline reflection samba session spl ssl tcpd truetype-fonts type1-fonts unicode usb win32codecs x86 xine xorg xvid zlib" ALSA_CARDS="ali5451" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="kbd mouse keyboard" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" USERLAND="GNU" VIDEO_CARDS="nvidia"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, MAKEOPTS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY


Code:
simba ~ # uname -r
2.6.20-gentoo-r8


Se mi potete spiegare...please.
Back to top
View user's profile Send private message
randomaze
Bodhisattva
Bodhisattva


Joined: 21 Oct 2003
Posts: 9985

PostPosted: Fri Oct 26, 2007 1:29 pm    Post subject: Reply with quote

nillkheope wrote:
Code:
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/sys-libs/glibc-2.6.1/temp/build.log'.
 *


Che, tradotto, significa più o meno: "Se hai bisogno di aiuto posta il primo errore e, il call stack se rilevante".

Ora, dovresti quindi postare più linee di output della compilazione che ha dato errore perché l'unica cosa che vedo é che non sei riuscito a compilare il toolchain ma il motivo non si sa.


OT: randomconcorso per developer: una birra a chi implementa l'emerge --info con output formattato a 80 colonne :roll:
_________________
Ciao da me!
Back to top
View user's profile Send private message
nillkheope
Tux's lil' helper
Tux's lil' helper


Joined: 21 Mar 2005
Posts: 92

PostPosted: Fri Oct 26, 2007 3:01 pm    Post subject: Reply with quote

ecco la parte mancante degli errori.

Code:

../sysdeps/unix/sysv/linux/init-first.c:95: internal compiler error: Aborted
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
make[2]: *** [/var/tmp/portage/sys-libs/glibc-2.6.1/work/build-default-i686-pc-linux-gnu-nptl/csu/init-first.os] Error 1
make[2]: Leaving directory `/var/tmp/portage/sys-libs/glibc-2.6.1/work/glibc-2.6.1/csu'
make[1]: *** [csu/subdir_lib] Error 2
make[1]: Leaving directory `/var/tmp/portage/sys-libs/glibc-2.6.1/work/glibc-2.6.1'
make: *** [all] Error 2



Grazie
Back to top
View user's profile Send private message
randomaze
Bodhisattva
Bodhisattva


Joined: 21 Oct 2003
Posts: 9985

PostPosted: Fri Oct 26, 2007 3:40 pm    Post subject: Reply with quote

nillkheope wrote:
ecco la parte mancante degli errori.

[code]
../sysdeps/unix/sysv/linux/init-first.c:95: internal compiler error: Aborted
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.


Non bello: in generale potrebbe essere un tuo problema hardware (processore overcloccato, banco di memoria difettoso, raffreddamento non funzionante...) oltre che, ovviamente, un problema del processore.
Le CFLAGS che vedo nell'emerge info sono le stesse che hai usato quando hai compilato il gcc?
_________________
Ciao da me!
Back to top
View user's profile Send private message
nillkheope
Tux's lil' helper
Tux's lil' helper


Joined: 21 Mar 2005
Posts: 92

PostPosted: Fri Oct 26, 2007 4:24 pm    Post subject: Reply with quote

si non le ho mai cambiate da quando ho installato gentoo (3 anni fa).
ma un difetto hardware non si dovrebbe riscontrare costantemente?
Durante la compilazione di ogni programma per esempio dovrebbe esserci una marea di errori.
La RAM l'ho controllata un po' di tempo fa, magari provo a ricontrollarla.

Grazie
Back to top
View user's profile Send private message
randomaze
Bodhisattva
Bodhisattva


Joined: 21 Oct 2003
Posts: 9985

PostPosted: Fri Oct 26, 2007 4:34 pm    Post subject: Reply with quote

nillkheope wrote:
ma un difetto hardware non si dovrebbe riscontrare costantemente?
Durante la compilazione di ogni programma per esempio dovrebbe esserci una marea di errori.


Non per ogni programma ma solo per quelli particolarmente onerosi... comuqnue non é detto. Quello del problema hw é un caso frequente quando appare il messaggio, ma potrebbe essere veramente un bug del compilatore.

E' da molto che non fai il sync?
Un'altra prova che potresti fare (oltre a memtest) é riemergere il gcc...
_________________
Ciao da me!
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Fri Oct 26, 2007 4:42 pm    Post subject: Reply with quote

randomaze wrote:
Un'altra prova che potresti fare (oltre a memtest) é riemergere il gcc...

dopo aver fatto un pacchetto binario con quickpkg... :wink:
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
nillkheope
Tux's lil' helper
Tux's lil' helper


Joined: 21 Mar 2005
Posts: 92

PostPosted: Fri Oct 26, 2007 4:44 pm    Post subject: Reply with quote

il sync l'ho fatto 4 ore fa.
di solito aggiorno ogni tanto, non costantemente, ma quando aggiorno, aggiorno tutto.

dopo provo a ricompilare gcc.
Back to top
View user's profile Send private message
nillkheope
Tux's lil' helper
Tux's lil' helper


Joined: 21 Mar 2005
Posts: 92

PostPosted: Fri Oct 26, 2007 7:52 pm    Post subject: Reply with quote

mah, ho ricompilato il kernel, ho ricompilato gcc, binutils, lidstdc++-v3 e ho rispovato con glibc...niente.
sempre solito errore.
ho provato a togliere la flag USE nptl ma non cambia niente.

ho dato un'occhiata ai bug di glibc, ma sinceramente non ci ho capito niente.
da che cosa può dipendere un errore del genere? sole le glibc-2.6.1 non riesco a compilare.

secondo me è un problema di qualche link...
adesso controllo per benino!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum