Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problemi dopo emerge world
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Chetto
Apprentice
Apprentice


Joined: 28 Nov 2006
Posts: 188
Location: Arco

PostPosted: Thu Aug 23, 2007 4:05 pm    Post subject: Problemi dopo emerge world Reply with quote

Dopo che ho fatto un
Code:
emerge --update --newuse --deep world
che mi ha aggiornato il sistema a gnome 2.18 credo e aggiornato vari altri pacchetti al riavvio accedo a gnome ma poi non funziona più praticamente nessuna applicazione, mi si apre la finestra ma all'interno resta tutto bianco e sono costretto a chiuderla forzatamente. Revdep-rebuild non funziona nemmeno con il -X e mi si blocca sull'emergsione di ekiga per quel problema con pwlib di cui ho chiesto nel topic apposito visto che c'era già una discussione su questo problema. Avete qualche altro consiglio da darmi?
Back to top
View user's profile Send private message
Ic3M4n
Advocate
Advocate


Joined: 02 Nov 2004
Posts: 3489
Location: Bergamo.

PostPosted: Fri Aug 24, 2007 12:59 am    Post subject: Reply with quote

prova una volta che hai il sistema X avviato a far partire le applicazioni da terminale. Puoi anche dal framebuffer specificando il display da utilizzare.
Code:
DISPLAY=:0 gnome-terminal&

se esce qualcosa riferito ad expat il problema è in sticky nei vari upgrade. altrimenti sarebbe bello sapere cosa effettivamente non va. Direi che l'output dell'applicazione è determinante per questo.
Back to top
View user's profile Send private message
Apetrini
Veteran
Veteran


Joined: 09 Feb 2005
Posts: 1158

PostPosted: Fri Aug 24, 2007 1:57 am    Post subject: Reply with quote

A volte non riesco a capire come fa la gente ad avere problemi cosi disastrosi dopo un
Code:
emerge -uND world

ma dopo aver visto un sacco di castronerie potrei autorispondermi in questi pochi punti:

-Hanno tutto il sistema in ~arch; cosa che sconsiglio a tutti, piuttosto tiratevi su un sistema stabile e poi solo i pacchetti che vi interessano smascherate.

-Ancora qualcuno usa ACCPET_KEYWORDS="~arch"; potrei stare qui fino a domani a stilare la lista dei possibili side-effects(effetti collaterali) che possono sorgere usando questo deprecatissimo comando.Quindi fidatevi e non usatelo MAI, esistono package.keywords e package.unmask.

-Avete "sporcato" il sistema con installazioni selvagge effettuate fuori dal portage; Mai!!! la gentoo vi durerà la vita utile dell hard-disk se imparate a rispettarla e non lasciare immondizia in giro. è fondamentale che ogni operazione/installazione nel sistema avvenga tramite emerge, poiche è in quest'ultimo strumento che sta la magia. Se per caso vi serve del software che non si trova in portage, potete cercare nei overlay ufficiali e non, se anche qui non trovate quello che vi serve, scaricatevi il sorgente e createvi un EBUILD(non è difficile);questo vi permetterà di tenere d'occhio i file che lascia in giro il software e potete decidere un giorno di eliminarlo senza lasciare schifezze. Vi ricordo che gentoo è versionless anche per questo.
P.s. Quindi miraccomando se non riuscite ad emergere un pacchetto, non fate la cazzata di scaricarvi il sorgente ed installarlo in modo selvaggio.

-Non avete controllato l'output di
Code:
emerge -uNDp world
prima di dare l'emerge definitivo; Fatelo sempre, il -p vi segnala sempre le operazioni che farà, non è detto che siano sempre giuste(per un motivo o per un altro), dovete avere la pazienza di controllare che non ci siano strani downgrade, dipendenze circolari strane e un sacco di altre cose. Ne va della vita del vostro sistema. Se ci dovessero essere problemi evidenti con il -p, fidatevi che si risolvono tutti con un paio di righe in portage.mask,portage.unmask,portage.keywords.

-Vi siete dimenticati di dare
Code:
etc-update
dopo l'emerge world. Il 90% dei file che vi propone potete tranquillamente scartare e usare i vostri originali, ma ci sono dei pacchetti( mi sembra alcune versioni di hal o udev per es.) che non funzionano se non sovrascrivete i nuovi file di configurazione. Occhio.


Ora, riprendendo fiato, vorrei spiegare che questo post non l'ho messo per accusare qualcuno di incompetenza o altro. Ho scritto questo post in buona fede pensando che potesse essere utile a qualcuno, che magari adotta delle pratiche scorrette e poi non riesce a venirne fuori nel momento in cui aggiorna il sistema.

@Chetto: magari hai fatto qualche passo falso tra i miei citati sopra...
_________________
Linux ape 2.6.31-vanilla. Paludis since 0.28.0.
Back to top
View user's profile Send private message
Chetto
Apprentice
Apprentice


Joined: 28 Nov 2006
Posts: 188
Location: Arco

PostPosted: Fri Aug 24, 2007 8:47 am    Post subject: Reply with quote

Grazie al consiglio di Ic3M4n ho lanciato gnome terminal e ho scoperto che mi veniva restituito un errore da xlib. Così ho reinstallato emul-linux-x86-xlib (ho gentoo amd64) e ora qualcosa funziona, il problema è che adesso spesso gnome si blocca magari semplicemente perchè schiaccio un bottone, per esempio indietro in nautilus esplorando i file. Vorrei mettere e a posto il sistema perchè ora come ora è inusabile, si blocca continuamente e mi costringe a riavviare il server X con CTRL-ALT-BACKSPACE per poi non funzionare proprio più definitivamente fino al successivo riavvio. Mi rendo conto che senza ulteriori informazioni è complicato risolvere il problema ma non so come darvele perchè mi si blocca proprio gnome!



@Apetrini:

Grazie dei consigli che mi hai dato che terrò buoni per il futuro ma ho installato gentoo da un mese e mi ritrovo ancora con un sistema praticamente inusabile anche se tuttavia non mi arrendo e non rischierei mai di fare casino con pacchetti che non sono presenti nell'albero di portage nè di smascherare pacchetti instabili visto che vorrei un sistema il più stabile possibile.
Per quanto riguarda l'output di emerge lo guardo sempre e quando mi da dei consigli li seguo, quando mi dice che dei file in etc devono essere aggiornati eseguo sempre un bel: etc-update e con -3 gli dico di sostituire tutti i file visto che per la maggior parte di questi non ne capisco il significato a meno che non siano per dire xorg.conf :) . Faccio male ad essere così brutale a sostituire i file? Non saprei fare altrimenti. :lol:
Back to top
View user's profile Send private message
Ic3M4n
Advocate
Advocate


Joined: 02 Nov 2004
Posts: 3489
Location: Bergamo.

PostPosted: Fri Aug 24, 2007 10:08 am    Post subject: Reply with quote

il consiglio: un'applicazione crasha? eseguila da terminale è sempre valido. fallo pure con nautilus se da problemi. Controlla anche il file ~/.xsession-errors per vedere se anche da li esce qualche informazione in più.

per quanto riguarda i file di conf:
1) controllare che file vuole sovrascrivere etc-update
2) un file è stato modificato da me? lo aggiorno a manina
3) il cervello è collegato?
4) riparti dal numero 1
5) dai un -5 e sovrascrivi quelli che non hai mai toccato. se preferisci puoi usare anche un -3
Back to top
View user's profile Send private message
Chetto
Apprentice
Apprentice


Joined: 28 Nov 2006
Posts: 188
Location: Arco

PostPosted: Sat Aug 25, 2007 11:58 am    Post subject: Reply with quote

Quote:
3) il cervello è collegato?
Quello è sempre collegato altrimenti mi sa che non ne verrei più fuori! A parte questo non mi sto facendo prendere da particolari ansie visto che come ho detto ho il notebook inutilizzabile da 1 mese circa, solo se non riuscirò a sistemare gentoo entro ottobre diciamo mi vedrò costretto ad installare qualche altra distribuzione e mi dispiacerebbe non poco. Grazie comunque dei consigli.

Venendo al problema io avvio le applicazioni da terminale ad es. nautilus ma poi si bloccano e non mi restituiscono errori nessun output, nel file ~/.xsession_errors c'è questo:
Code:


/etc/X11/gdm/PreSession/Default: Registering your session with wtmp and utmp
/etc/X11/gdm/PreSession/Default: running: /usr/X11R6/bin/sessreg -a -w /var/log/wtmp -u /var/run/utmp -x "/var/gdm/:0.Xservers" -h "" -l ":0" "marco"
/etc/X11/gdm/Xsession: Beginning session setup...
/etc/X11/gdm/Xsession: Setup done, will execute: /usr/bin/ssh-agent -- gnome-session
SESSION_MANAGER=local/localhost:/tmp/.ICE-unix/4115
Initializing gnome-mount extension

(gnome-panel:4155): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -9 and height 24
** Message: drive = 0
** Message: volume = 0
** Message: drive = 0
** Message: volume = 0
** Message: drive = 0
** Message: volume = 0
** Message: drive = 0
** Message: volume = 0
** Message: drive = 0
** Message: volume = 0
** Message: drive = 0
** Message: volume = 0
** Message: drive = 0
** Message: volume = 0
** Message: drive = 0
** Message: volume = 0
** Message: drive = 0
** Message: volume = 0
** Message: drive = 0
** Message: volume = 0
** Message: drive = 0
** Message: volume = 0


posto anche il risultato di emerge --info se può esservi utile (scusandomi per la lunghezza)

Code:
marco@localhost ~ $ emerge --info
Portage 2.1.2.12 (default-linux/amd64/2007.0/desktop, gcc-4.1.2, glibc-2.5-r4, 2.6.20-gentoo-r8 x86_64)
=================================================================
System uname: 2.6.20-gentoo-r8 x86_64 Intel(R) Core(TM)2 CPU T7400 @ 2.16GHz
Gentoo Base System release 1.12.9
Timestamp of tree: Fri, 24 Aug 2007 10:00:01 +0000
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.21
ABI="amd64"
ACCEPT_KEYWORDS="amd64"
ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci"
ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol"
ANT_HOME="/usr/share/ant"
ARCH="amd64"
ASFLAGS_x86="--32"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CDEFINE_amd64="__x86_64__"
CDEFINE_x86="__i386__"
CFLAGS="-march=nocona -O2 -pipe"
CFLAGS_x86="-m32 -L/emul/linux/x86/lib -L/emul/linux/x86/usr/lib"
CHOST="x86_64-pc-linux-gnu"
CHOST_amd64="x86_64-pc-linux-gnu"
CHOST_x86="i686-pc-linux-gnu"
CLASSPATH="."
CLEAN_DELAY="5"
COLORTERM="gnome-terminal"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CVS_RSH="ssh"
CXXFLAGS="-march=nocona -O2 -pipe"
DBUS_SESSION_BUS_ADDRESS="unix:abstract=/tmp/dbus-EtFDR0QQQM,guid=39e3f7097cd9a32f699c710046d019e0"
DEFAULT_ABI="amd64"
DESKTOP_SESSION="gnome"
DISPLAY=":0.0"
DISTDIR="/usr/portage/distfiles"
EDITOR="/bin/nano"
ELIBC="glibc"
EMERGE_DEFAULT_OPTS="--ask --verbose --tree"
EMERGE_WARNING_DELAY="10"
FEATURES="distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
FETCHCOMMAND="/usr/bin/wget -t 5 -T 60 --passive-ftp -O ${DISTDIR}/${FILE} ${URI}"
GCC_PATH="/usr/x86_64-pc-linux-gnu/gcc-bin/4.1.2"
GCC_SPECS=""
GDK_USE_XFT="1"
GDMSESSION="gnome"
GDM_XSERVER_LOCATION="local"
GENERATION="2"
GENTOO_MIRRORS="http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ ftp://pandemonium.tiscali.de/pub/gentoo/ http://www.die.unipd.it/pub/Linux/distributions/gentoo-sources/ ftp://ftp.unina.it/pub/linux/distributions/gentoo http://mirror.ing.unibo.it/gentoo/ ftp://mirror.ing.unibo.it/gentoo/ "
GNOME_DESKTOP_SESSION_ID="Default"
GNOME_KEYRING_SOCKET="/tmp/keyring-gsZ1NS/socket"
GTK_RC_FILES="/etc/gtk/gtkrc:/home/marco/.gtkrc-1.2-gnome2"
GUILE_LOAD_PATH="/usr/share/guile/1.6"
G_BROKEN_FILENAMES="1"
G_FILENAME_ENCODING="UTF-8"
HOME="/home/marco"
INFOPATH="/usr/share/info:/usr/share/binutils-data/x86_64-pc-linux-gnu/2.17/info:/usr/share/gcc-data/x86_64-pc-linux-gnu/4.1.2/info:/usr/share/info/emacs-21"
INPUT_DEVICES="keyboard mouse"
JAVAC="/etc/java-config-2/current-system-vm/bin/javac"
JAVA_HOME="/etc/java-config-2/current-system-vm"
JDK_HOME="/etc/java-config-2/current-system-vm"
KDEDIRS="/usr/kde/3.5:/usr:/usr/local"
KERNEL="linux"
LANG="it_IT@euro"
LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text"
LC_ALL="it_IT@euro"
LDFLAGS_x86="-m elf_i386 -L/emul/linux/x86/lib -L/emul/linux/x86/usr/lib"
LESS="-R -M --shift 5"
LESSOPEN="|lesspipe.sh %s"
LIBDIR_amd64="lib64"
LIBDIR_x86="lib32"
LINGUAS="en it"
LOGNAME="marco"
LS_COLORS="no=00:fi=00:di=01;34:ln=01;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=01;05;37;41:mi=01;05;37;41:su=37;41:sg=30;43:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.gz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.pdf=00;32:*.ps=00;32:*.txt=00;32:*.patch=00;32:*.diff=00;32:*.log=00;32:*.tex=00;32:*.doc=00;32:*.aac=00;36:*.au=00;36:*.flac=00;36:*.mid=00;36:*.midi=00;36:*.mka=00;36:*.mp3=00;36:*.mpc=00;36:*.ogg=00;36:*.ra=00;36:*.wav=00;36:"
MAKEOPTS="-j3"
MANPATH="/etc/java-config-2/current-system-vm/man:/usr/local/share/man:/usr/share/man:/usr/share/binutils-data/x86_64-pc-linux-gnu/2.17/man:/usr/share/gcc-data/x86_64-pc-linux-gnu/4.1.2/man:/opt/blackdown-jdk-1.4.2.03/man:/etc/java-config/system-vm/man/:/usr/lib64/php5/man/:/usr/qt/3/doc/man"
MULTILIB_ABIS="amd64 x86"
MULTILIB_STRICT_DENY="64-bit.*shared object"
MULTILIB_STRICT_DIRS="/lib /usr/lib /usr/kde/*/lib /usr/qt/*/lib /usr/X11R6/lib"
MULTILIB_STRICT_EXEMPT="(perl5|gcc|gcc-lib|binutils|eclipse-3|debug|portage)"
OPENGL_PROFILE="xorg-x11"
PAGER="/usr/bin/less"
PATH="/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/4.1.2:/opt/blackdown-jdk-1.4.2.03/bin:/opt/blackdown-jdk-1.4.2.03/jre/bin:/usr/kde/3.5/bin:/usr/qt/3/bin"
PKGDIR="/usr/portage/packages"
PKG_CONFIG_PATH="/usr/qt/3/lib64/pkgconfig:/usr/qt/3/lib32/pkgconfig"
PORTAGE_ARCHLIST="ppc s390 amd64 x86 ppc64 x86-fbsd m68k arm sparc sh mips ia64 alpha ppc-macos hppa sparc-fbsd"
PORTAGE_BINHOST_CHUNKSIZE="3000"
PORTAGE_BIN_PATH="/usr/lib64/portage/bin"
PORTAGE_CONFIGROOT="/"
PORTAGE_DEBUG="0"
PORTAGE_DEPCACHEDIR="/var/cache/edb/dep"
PORTAGE_ELOG_CLASSES="log warn error"
PORTAGE_ELOG_MAILFROM="portage"
PORTAGE_ELOG_MAILSUBJECT="[portage] ebuild log for ${PACKAGE} on ${HOST}"
PORTAGE_ELOG_MAILURI="root"
PORTAGE_GID="250"
PORTAGE_INST_GID="0"
PORTAGE_INST_UID="0"
PORTAGE_PYM_PATH="/usr/lib64/portage/pym"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_RSYNC_RETRIES="3"
PORTAGE_TMPDIR="/var/portage_tmp"
PORTAGE_WORKDIR_MODE="0700"
PORTDIR="/usr/portage"
PRELINK_PATH_MASK="/usr/lib/gstreamer-0.10"
PWD="/home/marco"
PYTHONDOCS="/usr/share/doc/python-docs-2.4.4/html/lib"
PYTHONPATH="/usr/lib64/portage/pym"
QMAKESPEC="linux-g++"
QTDIR="/usr/qt/3"
RESUMECOMMAND="/usr/bin/wget -c -t 5 -T 60 --passive-ftp -O ${DISTDIR}/${FILE} ${URI}"
ROOT="/"
ROOTPATH="/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/4.1.2:/opt/blackdown-jdk-1.4.2.03/bin:/opt/blackdown-jdk-1.4.2.03/jre/bin:/usr/kde/3.5/sbin:/usr/kde/3.5/bin:/usr/qt/3/bin"
RPMDIR="/usr/portage/rpm"
SESSION_MANAGER="local/localhost:/tmp/.ICE-unix/4115"
SHELL="/bin/bash"
SHLVL="1"
SSH_AGENT_PID="4136"
SSH_AUTH_SOCK="/tmp/ssh-alMaxt4115/agent.4115"
STAGE1_USE="nptl nptlonly unicode"
SYMLINK_LIB="yes"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
TERM="xterm"
USE="X acl acpi alsa amd64 arts berkdb bitmap-fonts bluetooth cairo cdr cli cracklib crypt cups dbus dri dvd dvdr dvdread eds emboss encode esd evo fam firefox fortran gdbm gif gnome gpm gstreamer gtk hal iconv ipv6 isdnlog jpeg kerberos ldap mad midi mikmod mmx mp3 mpeg mudflap ncurses nls nptl nptlonly ogg opengl openmp oss pam pcre pdf perl png pppd python qt3support quicktime readline reflection sdl session spell spl sse sse2 ssl svg tcpd tiff truetype truetype-fonts type1-fonts unicode vim vorbis xml xorg xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en it" USERLAND="GNU" VIDEO_CARDS="nvidia vesa"
USER="marco"
USERLAND="GNU"
USERNAME="marco"
USE_EXPAND="ALSA_CARDS ALSA_PCM_PLUGINS CAMERAS CROSSCOMPILE_OPTS DVB_CARDS ELIBC FCDSL_CARDS FOO2ZJS_DEVICES FRITZCAPI_CARDS INPUT_DEVICES KERNEL LCD_DEVICES LINGUAS LIRC_DEVICES MISDN_CARDS USERLAND VIDEO_CARDS"
USE_EXPAND_HIDDEN="CROSSCOMPILE_OPTS ELIBC KERNEL USERLAND"
USE_ORDER="env:pkg:conf:defaults:pkginternal:env.d"
VIDEO_CARDS="nvidia vesa"
VMHANDLE="blackdown-jdk-1.4.2"
WINDOWID="23068725"
XARGS="xargs -r"
XAUTHORITY="/home/marco/.Xauthority"
_="/usr/bin/emerge"




p.s: ho provato anche a riemergere le gtk+ ma non è cambiato nulla. :cry:
Back to top
View user's profile Send private message
Chetto
Apprentice
Apprentice


Joined: 28 Nov 2006
Posts: 188
Location: Arco

PostPosted: Mon Aug 27, 2007 2:02 pm    Post subject: Reply with quote

Non so, a questo punto forse mi conviene reinstallare tutto.... :cry:
Back to top
View user's profile Send private message
MeMyselfAndI
l33t
l33t


Joined: 15 Nov 2005
Posts: 784
Location: Between the monitor and the chair

PostPosted: Mon Aug 27, 2007 2:48 pm    Post subject: Re: Problemi dopo emerge world Reply with quote

Chetto wrote:
Dopo che ho fatto un
Code:
emerge --update --newuse --deep world
che mi ha aggiornato il sistema a gnome 2.18 credo e aggiornato vari altri pacchetti al riavvio accedo a gnome ma poi non funziona più praticamente nessuna applicazione, mi si apre la finestra ma all'interno resta tutto bianco e sono costretto a chiuderla forzatamente. Revdep-rebuild non funziona nemmeno con il -X e mi si blocca sull'emergsione di ekiga per quel problema con pwlib di cui ho chiesto nel topic apposito visto che c'era già una discussione su questo problema. Avete qualche altro consiglio da darmi?


Se una lista di pacchetti viene interrotta per un qualche motivo c'e' pur sempre l'ottima e comoda opzione --resume --skipfisrt da passare a emerge per recuperare l'ultima coda di installazione saltando il pacchetto incriminato.... hai per caso provato ?
Back to top
View user's profile Send private message
Chetto
Apprentice
Apprentice


Joined: 28 Nov 2006
Posts: 188
Location: Arco

PostPosted: Mon Aug 27, 2007 3:05 pm    Post subject: Reply with quote

Non ho provato perchè ho letto nel il forum che --skipfirst non sarebbe un'opzione da dare, cioè è un modo un po' di aggirare il problema che poi magar ti si ripresenta anche peggio, ho letto ripeto, non è un'esperienza personale.

Più che altro non mi funzia
Code:
revdep-rebuild
, è quello che mi spaventa perchè ho molti link "broken", la gran parte riguardano expat (nel topic sull'argomento non sembra rispondere nessuno). Resta comunque il fatto che praticamente qualsiasi applicazione che viene aperta in gnome si blocca cioè si apre e disegna solo i bordi finestra mentre all'interno rimane bianco, credo sia un problema di gnome e delle gtk. :lol:
Back to top
View user's profile Send private message
!equilibrium
Bodhisattva
Bodhisattva


Joined: 06 Jun 2004
Posts: 2109
Location: MI/BG/LC

PostPosted: Mon Aug 27, 2007 4:14 pm    Post subject: Reply with quote

Chetto wrote:
è quello che mi spaventa perchè ho molti link "broken", la gran parte riguardano expat (nel topic sull'argomento non sembra rispondere nessuno)


sei incappato nel fatidico problema di expat, concludi la sessione di "revdep-rebuild" e vedrai che le cose torneranno a posto da sole.

siccome i problemi di expat vengono discussi nell'apposito thread: problemi durante l'upgrade di expat
chiudo il seguente thread e casomai avessi ancora problemi con expat ti invito a continuare la discussione nell'altro. :wink:
_________________
Arch Tester for Gentoo/FreeBSD
Equilibrium's Universe

all my contents are released under the Creative Commons Licence by-nc-nd 2.5
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum