Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto] - Boot Gentoo 2007.0
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Yugi
n00b
n00b


Joined: 29 Nov 2005
Posts: 54
Location: Milan, Italy

PostPosted: Sun Aug 12, 2007 10:57 am    Post subject: [Risolto] - Boot Gentoo 2007.0 Reply with quote

Salve ho installato Gentoo 2007.0, il sistema parte senza problemi, pero' quando e' in fase di boot da il seguente errore :

mknod : /newroot/dev/tty1 Read-only file system

ho fatto gia' tutti gli aggiornamenti e compilato il nuovo kernel 2.6.21-r4 (pensando fosse qualcosa riferito al vecchio kernel o a qualche aggiornamento) ma il messaggio lo da lo stesso come posso risolverlo ?


Last edited by Yugi on Thu Aug 23, 2007 7:55 pm; edited 1 time in total
Back to top
View user's profile Send private message
Cazzantonio
Bodhisattva
Bodhisattva


Joined: 20 Mar 2004
Posts: 4489
Location: Somewere around the world

PostPosted: Sun Aug 12, 2007 11:03 am    Post subject: Reply with quote

potresti postarci il tuo fstab e il tuo grub.conf?
_________________
Any man's death diminishes me, because I am involved in mankind, and therefore never send to know for whom the bell tolls; it tolls for thee
-John Donne
Back to top
View user's profile Send private message
Yugi
n00b
n00b


Joined: 29 Nov 2005
Posts: 54
Location: Milan, Italy

PostPosted: Sun Aug 12, 2007 12:16 pm    Post subject: Reply with quote

si eccoli

fstab :

Code:
/dev/hda1        /boot   ext2    defaults,noatime                1 2
/dev/hda2        none            swap            sw              0 0
/dev/hda3        /       ext3    noatime                 0 1
none        /proc     proc    defaults          0 0
none        /dev/shm  tmpfs   defaults          0 0


grub :
Code:
default 0
timeout 30
splashimage=(hd0,0)/grub/splash.xpm.gz
title=Gentoo Linux (2.6.21-gentoo-r4)
root (hd0,0)
kernel /kernel-genkernel-x86-2.6.21-gentoo-r4 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/hda3
initrd /initramfs-genkernel-x86-2.6.21-gentoo-r4
title=Gentoo Linux
root (hd0,0)
kernel /kernel-genkernel-x86-2.6.19-gentoo-r5 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/hda3
initrd /initramfs-genkernel-x86-2.6.19-gentoo-r5
Back to top
View user's profile Send private message
Ic3M4n
Advocate
Advocate


Joined: 02 Nov 2004
Posts: 3489
Location: Bergamo.

PostPosted: Sun Aug 12, 2007 1:17 pm    Post subject: Reply with quote

credo che sia un'errore di genkernel. Purtroppo non utilizzandolo non so dirti come risolverlo. Io mi compilo a manina il kernel, mi trovo meglio.
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Mon Aug 13, 2007 5:41 pm    Post subject: Reply with quote

Guarda che con un partizionamento così semplice l'initrd non ti serve praticamente a nulla (si usa se hai raid o root su lvm) puoi anche usare solo genkernel per gestirti moduli e kernel senza initrd (ovviamente devi avere i driver del disco builtin quindi genkernel --menunconfig kernel etc.)

credo che il problema sia nel parametro init=/linuxrc comunque
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Yugi
n00b
n00b


Joined: 29 Nov 2005
Posts: 54
Location: Milan, Italy

PostPosted: Tue Aug 14, 2007 8:20 am    Post subject: Reply with quote

djinnZ wrote:
Guarda che con un partizionamento così semplice l'initrd non ti serve praticamente a nulla (si usa se hai raid o root su lvm) puoi anche usare solo genkernel per gestirti moduli e kernel senza initrd (ovviamente devi avere i driver del disco builtin quindi genkernel --menunconfig kernel etc.)

credo che il problema sia nel parametro init=/linuxrc comunque


ciao con l'occasione del kernel 2.6.22-r2 sto provando a compilarlo passando a genkernel invece dell'opzione all l'opzione kernel. vi faccio sapere appena finisce.

ciao
Back to top
View user's profile Send private message
Yugi
n00b
n00b


Joined: 29 Nov 2005
Posts: 54
Location: Milan, Italy

PostPosted: Thu Aug 23, 2007 7:59 pm    Post subject: Reply with quote

ho risolto il problema installando invece che dalla copia di livecd + installer grafico usando il livecd minimale. quindi deduco che :

1) era un problema della mia copia.
2) l'installer della 2007.0 ha qualche problema.
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4669
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Thu Aug 23, 2007 8:35 pm    Post subject: Reply with quote

Yugi wrote:
uindi deduco che :

no. il tipo di errore che hai incontrato non dovrebbe essere attribuibile al cd-rom, sia pure live.
scommetto che, ripartendo con il cd della prima volta, l'errore non si ripete.

in ogni caso, è bene ciò che finisce bene, e la strada che hai seguito è la migliore.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum