Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
amule and wxGTK 2.8 it's posible? [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
DarkMind
Guru
Guru


Joined: 18 Dec 2003
Posts: 525
Location: Santiago, Chile

PostPosted: Tue Aug 21, 2007 2:26 am    Post subject: amule and wxGTK 2.8 it's posible? [SOLVED] Reply with quote

i install wxGTK 2.8 ans when i tried to compile amule says:


Code:
[ebuild   R   ] net-p2p/amule-2.2.0_pre20070422  USE="gtk nls unicode -amuled -debug -remote -stats" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No]
>>> Verifying ebuild Manifests...

>>> Emerging (1 of 1) net-p2p/amule-2.2.0_pre20070422 to /
 * aMule-CVS-20070422.tar.bz2 MD5 ;-) ...                                                                                                                                                                   [ ok ]
 * aMule-CVS-20070422.tar.bz2 RMD160 ;-) ...                                                                                                                                                                [ ok ]
 * aMule-CVS-20070422.tar.bz2 SHA1 ;-) ...                                                                                                                                                                  [ ok ]
 * aMule-CVS-20070422.tar.bz2 SHA256 ;-) ...                                                                                                                                                                [ ok ]
 * aMule-CVS-20070422.tar.bz2 size ;-) ...                                                                                                                                                                  [ ok ]
 * checking ebuild checksums ;-) ...                                                                                                                                                                        [ ok ]
 * checking auxfile checksums ;-) ...                                                                                                                                                                       [ ok ]
 * checking miscfile checksums ;-) ...                                                                                                                                                                      [ ok ]
 * checking aMule-CVS-20070422.tar.bz2 ;-) ...                                                                                                                                                              [ ok ]
 * wxGTK with gtk2 and unicode support will be used
!!! set-wxconfig: Error:  Can't find normal or debug version:
!!! set-wxconfig:         /usr/bin/wxgtk2u-2.4-config not found
!!! set-wxconfig:         /usr/bin/wxgtk2ud-2.4-config not found
!!! You need to emerge wxGTK with unicode in your USE



but wxGTK have unicode support:

Code:
 emerge -av wxGTK

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] x11-libs/wxGTK-2.8.4.0  USE="X gif gnome joystick opengl unicode -debug -doc -odbc -sdl -stl" 0 kB [1]

Total: 1 package (1 reinstall), Size of downloads: 0 kB
Portage overlays:
 [1] /usr/local/portage


Last edited by DarkMind on Wed Aug 22, 2007 2:25 am; edited 1 time in total
Back to top
View user's profile Send private message
didymos
Advocate
Advocate


Joined: 10 Oct 2005
Posts: 4798
Location: California

PostPosted: Tue Aug 21, 2007 2:48 am    Post subject: Reply with quote

Check if the files are in /usr/lib/wx/config. If they do, as a workaround you could make symlinks to them in /usr/bin/.

[edit]
Ignore the above. Instead, see this bug:

emerge amule fails

which is a duplicate of this bug:

wxGTK SLOT issues

which is a duplicate of this bug:

x11-libs/wxGTK-2.6 - many file collision with wxGTK in another slot

which is so far not a duplicate of yet another bug.
_________________
Thomas S. Howard
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Tue Aug 21, 2007 4:13 am    Post subject: Re: amule and wxGTK 2.8 it's posible? Reply with quote

DarkMind wrote:
i install wxGTK 2.8 ans when i tried to compile amule says:


Code:
[ebuild   R   ]
 * wxGTK with gtk2 and unicode support will be used
!!! set-wxconfig: Error:  Can't find normal or debug version:
!!! set-wxconfig:         /usr/bin/wxgtk2u-2.4-config not found
!!! set-wxconfig:         /usr/bin/wxgtk2ud-2.4-config not found
!!! You need to emerge wxGTK with unicode in your USE


I think you need a new wxwidget.eclass. You must put this file into your overlay:
/usr/local/portage/eclass/
You can get this file from sabayon overlay or look at my codeblocks ebuild pack which includes wxGTK-2.8.4.0. It has the wxwidgets.eclass file from sabayon overlay.
I've just emerged net-p2p/amule-2.2.0_pre20070820, successfully.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
DarkMind
Guru
Guru


Joined: 18 Dec 2003
Posts: 525
Location: Santiago, Chile

PostPosted: Tue Aug 21, 2007 3:59 pm    Post subject: Re: amule and wxGTK 2.8 it's posible? Reply with quote

keenblade wrote:
DarkMind wrote:
i install wxGTK 2.8 ans when i tried to compile amule says:


Code:
[ebuild   R   ]
 * wxGTK with gtk2 and unicode support will be used
!!! set-wxconfig: Error:  Can't find normal or debug version:
!!! set-wxconfig:         /usr/bin/wxgtk2u-2.4-config not found
!!! set-wxconfig:         /usr/bin/wxgtk2ud-2.4-config not found
!!! You need to emerge wxGTK with unicode in your USE


I think you need a new wxwidget.eclass. You must put this file into your overlay:
/usr/local/portage/eclass/
You can get this file from sabayon overlay or look at my codeblocks ebuild pack which includes wxGTK-2.8.4.0. It has the wxwidgets.eclass file from sabayon overlay.
I've just emerged net-p2p/amule-2.2.0_pre20070820, successfully.


thank you! :D Amule is compiling with wxGTK 2.8 now . :D
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Tue Aug 21, 2007 7:37 pm    Post subject: Reply with quote

You're welcome.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum