Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge -uD world gives dbus error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
spankmygentoo
n00b
n00b


Joined: 20 Jun 2005
Posts: 39
Location: Utah

PostPosted: Fri Aug 17, 2007 11:03 am    Post subject: emerge -uD world gives dbus error Reply with quote

/usr/bin/dbus-binding-tool: error while loading shared libraries: libexpat.so.0: cannot open shared object file: No such file or directory
make[2]: *** [stamp-ephy-dbus-server-bindings.h] Error 127
make[2]: *** Waiting for unfinished jobs....
/usr/bin/dbus-binding-tool: error while loading shared libraries: libexpat.so.0: cannot open shared object file: No such file or directory
make[2]: *** [stamp-ephy-dbus-client-bindings.h] Error 127
make[2]: Leaving directory `/var/tmp/portage/www-client/epiphany-2.18.2/work/epiphany-2.18.2/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/www-client/epiphany-2.18.2/work/epiphany-2.18.2'
make: *** [all] Error 2

!!! ERROR: www-client/epiphany-2.18.2 failed.
Call stack:
ebuild.sh, line 1632: Called dyn_compile
ebuild.sh, line 983: Called qa_call 'src_compile'
ebuild.sh, line 44: Called src_compile
epiphany-2.18.2.ebuild, line 84: Called gnome2_src_compile
gnome2.eclass, line 71: Called die

!!! compile failure
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/www-client/epiphany-2.18.2/temp/build.log'.

--------------
My box is kinda behaving odd. I've ssh'd into it with my iBook because last time I tried, it wouldn't let me login via GDM. Anyhow, any help would be appreciated. It's been doing this ever since the gnome update. It was working fine before.
_________________
--Time moves forward, whether or not you do.
Back to top
View user's profile Send private message
Rob1n
l33t
l33t


Joined: 29 Nov 2003
Posts: 714
Location: Cambridge, UK

PostPosted: Fri Aug 17, 2007 11:11 am    Post subject: Reply with quote

You need to do a revdep-rebuild. See https://forums.gentoo.org/viewtopic-t-575655.html
Back to top
View user's profile Send private message
mistersnorfles
n00b
n00b


Joined: 03 Aug 2007
Posts: 32

PostPosted: Fri Aug 17, 2007 11:12 am    Post subject: Is expat installed? Reply with quote

EDITED: The above seems more likely...
Back to top
View user's profile Send private message
spankmygentoo
n00b
n00b


Joined: 20 Jun 2005
Posts: 39
Location: Utah

PostPosted: Fri Aug 17, 2007 11:15 am    Post subject: Reply with quote

I re-emerged dbus and now it seems to be compiling Nautilis instead, and it seems to be doing fine. We'll see if it continues on it's merry old way now. If not, I'll post a reply here.
_________________
--Time moves forward, whether or not you do.
Back to top
View user's profile Send private message
spankmygentoo
n00b
n00b


Joined: 20 Jun 2005
Posts: 39
Location: Utah

PostPosted: Fri Aug 17, 2007 1:33 pm    Post subject: Reply with quote

Rob1n wrote:
You need to do a revdep-rebuild. See https://forums.gentoo.org/viewtopic-t-575655.html


Thanks! I'm doing that as I type this. Luckily, I have an iBook and was able to ssh into it. The partial update from when the problem first started made it so I couldn't login with GDM. I never saw the error it gave me before. I can't remember the error but if said something about not having permission to start some process or program. Oh well, this should fix it. Stuff is actually compiling.
_________________
--Time moves forward, whether or not you do.
Back to top
View user's profile Send private message
spankmygentoo
n00b
n00b


Joined: 20 Jun 2005
Posts: 39
Location: Utah

PostPosted: Fri Aug 17, 2007 1:36 pm    Post subject: Re: Is expat installed? Reply with quote

mistersnorfles wrote:
EDITED: The above seems more likely...


Thanks for your reply too. Thank goodness for the forums!
_________________
--Time moves forward, whether or not you do.
Back to top
View user's profile Send private message
tomk
Administrator
Administrator


Joined: 23 Sep 2003
Posts: 7219
Location: Sat in front of my computer

PostPosted: Fri Aug 17, 2007 2:27 pm    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads, please follow up to the post mentioned by Rob1n.
_________________
Search | Read | Answer | Report | Strip
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum