Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Error emerging ruby-gettext
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
||AvataR||
n00b
n00b


Joined: 11 Jun 2003
Posts: 18

PostPosted: Thu Aug 16, 2007 3:00 pm    Post subject: Error emerging ruby-gettext Reply with quote

I have an error when i try to emerge ruby-gettext.

this is what i get:

Code:
>>> Install ruby-gettext-1.10.0 into /var/tmp/portage/dev-ruby/ruby-gettext-1.10.0/image/ category dev-ruby
make: /bin/install: Command not found
make: *** [/var/tmp/portage/dev-ruby/ruby-gettext-1.10.0/image/usr/lib/ruby/gems/1.8/gems/gettext-1.10.0/lib/locale_system.so] Error 127
ERROR:  Error installing gem /var/tmp/portage/dev-ruby/ruby-gettext-1.10.0/distdir/gettext-1.10.0[.gem]: ERROR: Failed to build gem native extension.
Gem files will remain installed in /var/tmp/portage/dev-ruby/ruby-gettext-1.10.0/image/usr/lib/ruby/gems/1.8/gems/gettext-1.10.0 for inspection.
  ruby extconf.rb install /var/tmp/portage/dev-ruby/ruby-gettext-1.10.0/distdir/gettext-1.10.0 -v 1.10.0 --no-ri --no-rdoc -l -i /var/tmp/portage/dev-ruby/ruby-gettext-1.10.0/image///usr/lib/ruby/gems/1.8\nchecking for setlocale()... yes
checking for nl_langinfo()... yes
creating Makefile
\nmake\ni686-pc-linux-gnu-gcc -I. -I. -I/usr/lib/ruby/1.8/i686-linux -I. -DHAVE_SETLOCALE -DHAVE_NL_LANGINFO  -fPIC -O2 -march=athlon-xp -pipe  -fPIC  -c locale_system.c
i686-pc-linux-gnu-gcc -shared  -L'/usr/lib' -Wl,-R'/usr/lib' -o locale_system.so locale_system.o  -Wl,-R -Wl,/usr/lib -L/usr/lib -L. -lruby18  -ldl -lcrypt -lm   -lc
\nmake install\n/bin/install -c -m 0755 locale_system.so /var/tmp/portage/dev-ruby/ruby-gettext-1.10.0/image/usr/lib/ruby/gems/1.8/gems/gettext-1.10.0/lib


Results logged to /var/tmp/portage/dev-ruby/ruby-gettext-1.10.0/image/usr/lib/ruby/gems/1.8/gems/gettext-1.10.0/ext/gettext/gem_make.out
Building native extensions.  This could take a while...
ruby extconf.rb install /var/tmp/portage/dev-ruby/ruby-gettext-1.10.0/distdir/gettext-1.10.0 -v 1.10.0 --no-ri --no-rdoc -l -i /var/tmp/portage/dev-ruby/ruby-gettext-1.10.0/image///usr/lib/ruby/gems/1.8
checking for setlocale()... yes
checking for nl_langinfo()... yes
creating Makefile

make
i686-pc-linux-gnu-gcc -I. -I. -I/usr/lib/ruby/1.8/i686-linux -I. -DHAVE_SETLOCALE -DHAVE_NL_LANGINFO  -fPIC -O2 -march=athlon-xp -pipe  -fPIC  -c locale_system.c
i686-pc-linux-gnu-gcc -shared  -L'/usr/lib' -Wl,-R'/usr/lib' -o locale_system.so locale_system.o  -Wl,-R -Wl,/usr/lib -L/usr/lib -L. -lruby18  -ldl -lcrypt -lm   -lc

make install
/bin/install -c -m 0755 locale_system.so /var/tmp/portage/dev-ruby/ruby-gettext-1.10.0/image/usr/lib/ruby/gems/1.8/gems/gettext-1.10.0/lib

!!! ERROR: dev-ruby/ruby-gettext-1.10.0 failed.
Call stack:
  ebuild.sh, line 1632:   Called dyn_install
  ebuild.sh, line 1077:   Called qa_call 'src_install'
  ebuild.sh, line 44:   Called src_install
  ebuild.sh, line 1322:   Called gems_src_install
  gems.eclass, line 78:   Called die

!!! gem install failed (spec file /var/tmp/portage/dev-ruby/ruby-gettext-1.10.0/image///usr/lib/ruby/gems/1.8/specifications/gettext-1.10.0.gemspec missing)
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/dev-ruby/ruby-gettext-1.10.0/temp/build.log'.


Does anyone has an idea how to fix this?

Thanks
Back to top
View user's profile Send private message
didymos
Advocate
Advocate


Joined: 10 Oct 2005
Posts: 4798
Location: California

PostPosted: Fri Aug 17, 2007 1:08 am    Post subject: Reply with quote

Yeah, a fairly recent coreutils change moved /bin/install to /usr/bin/install. A quick workaround is to do:
Code:

ln -s /usr/bin/install /bin/install


Check bugzilla for a better solution.
_________________
Thomas S. Howard
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7820

PostPosted: Fri Aug 17, 2007 4:33 am    Post subject: Reply with quote

Reinstall dev-lang/ruby, the locations of certain utilities are cached by the build process and the cached locations are reused without verification by various software dependent upon the build infrastructure provided by that package.

Moved from Portage & Programming to Duplicate Threads, as this is the same problem as that discussed in topic "dev-ruby/sqlite3-ruby-1.1.0 failed".
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum