Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ATI-DRIVERS] Unable to make
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
bouyafa
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2006
Posts: 126

PostPosted: Thu Aug 16, 2007 1:30 pm    Post subject: [ATI-DRIVERS] Unable to make Reply with quote

Bonjour ce matin j'ai voulu mettre à jour, dans la liste y étaient les ati-drivers-8.40.4.

Quote:
make[2]: *** [/var/tmp/portage/x11-drivers/ati-drivers-8.40.4/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o] Erreur 1
make[1]: *** [_module_/var/tmp/portage/x11-drivers/ati-drivers-8.40.4/work/common/lib/modules/fglrx/build_mod/2.6.x] Erreur 2
make[1]: quittant le répertoire « /usr/src/linux-2.6.17-cj1 »
make: *** [kmod_build] Erreur 2

!!! ERROR: x11-drivers/ati-drivers-8.40.4 failed.
Call stack:
ebuild.sh, line 1632: Called dyn_compile
ebuild.sh, line 983: Called qa_call 'src_compile'
ebuild.sh, line 44: Called src_compile
ati-drivers-8.40.4.ebuild, line 177: Called linux-mod_src_compile
linux-mod.eclass, line 516: Called die

!!! Unable to make GCC_VER_MAJ=3 KVER=2.6.17-cj1 KDIR=/usr/src/linux kmod_build.


Je suppose que mon kernel ainsi que mon bon vieux GCC sont un peu vieux, j'attends juste une confirmation claire et nette avant d'entreprendre de tout mettre à jour !

Merci :)
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Thu Aug 16, 2007 2:03 pm    Post subject: Reply with quote

Et on la devine ou la version de GCC?
_________________
Full Gentoo powered.
Back to top
View user's profile Send private message
bouyafa
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2006
Posts: 126

PostPosted: Thu Aug 16, 2007 2:08 pm    Post subject: Reply with quote

Ici :

Quote:
... GCC_VER_MAJ=3 ...



sinon en effet pour etre plus précis : [I] sys-devel/gcc (3.4.6-r2)
Back to top
View user's profile Send private message
Temet
Advocate
Advocate


Joined: 14 Mar 2006
Posts: 2586
Location: 92

PostPosted: Thu Aug 16, 2007 7:38 pm    Post subject: Reply with quote

o_O'''

Euh... t'es au courant que Gentoo a migré vers GCC 4 en stable y a environ un an??? 8O

Sinon, ça peut aussi être la version de noyau.

Le plus simple est bien sûr d'update du noyau... sinon, bah bonne migration de GCC :lol:
_________________
Full Gentoo powered.
Back to top
View user's profile Send private message
bouyafa
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2006
Posts: 126

PostPosted: Fri Aug 17, 2007 6:12 am    Post subject: Reply with quote

Héhé oui tout à fait au courant, mais je ne l'ai pas fait sur toutes mes machines, en l'occurence pas le portable. Bien donc je vais commencer ma migration avec ... enthousiasme ^^


Merci
Back to top
View user's profile Send private message
nykos
Guru
Guru


Joined: 08 Jun 2005
Posts: 488
Location: Strasbourg

PostPosted: Fri Aug 17, 2007 5:18 pm    Post subject: Reply with quote

sinon tu peux toujours rester aux versions précédentes d'ati-drivers !
_________________
-=Nykos=-
TARGA Traveller 826T - AMD Turion 64 MT 32 1,8GHz - ATI Radeon X700 Mobility (ati-drivers)
Back to top
View user's profile Send private message
avendesora
Veteran
Veteran


Joined: 16 Aug 2002
Posts: 1739
Location: Betelgeuse vicinity

PostPosted: Fri Aug 17, 2007 6:50 pm    Post subject: Reply with quote

Ou éventuellement poster l'erreur que tu as. Ce que tu nous a collé ne montre pas l'erreur de compil.
Ce qu'on voit sur ton poste, c'est make qui dit:
"Oh là! Y'a GCC qu'es pas content!"
puis emerge qui dit:
"bah merde, make n'a planté!"
Ce qui manque c'est ce que GCC a cherché à te dire.

(Pas dit que ca avance la chose, mais on sait jamais.)
Back to top
View user's profile Send private message
bouyafa
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2006
Posts: 126

PostPosted: Tue Aug 28, 2007 3:44 pm    Post subject: Reply with quote

Bien, j'ai donc fais ma migration sur GCC4 et avant de changer de kernel, j'ai mon disque dur qui part en cacahuètes ... bref, je n'ai pas pu aller jusqu'au bout de la chose. Pourtant aujourd'hui sur IRC je voie qu'une autre personne a le meme soucis que moi. A la différence qu'il est plus à jour que moi, un GCC4 et un kernel en 2.6.22. Je quote son build.log en espérant arriver à builder ce driver un jour ou l'autre.

Quote:
* Determining the location of the kernel source code
* Found kernel source directory:
* /usr/src/linux
* Found kernel object directory:
* /lib/modules/2.6.22.1-rt9/build
* Found sources for kernel version:
* 2.6.22.1-rt9
>>> Unpacking source...
* Converting 2.6.x/Makefile to use M= instead of SUBDIRS= ...
 [ ok ]
>>> Unpacking ./../common/usr/src/ati/fglrx_sample_source.tgz to /var/tmp/portage/x11-drivers/ati-drivers-8.39.4/work/extra
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/x11-drivers/ati-drivers-8.39.4/work ...
* Preparing fglrx module
make -C /usr/src/linux M=/var/tmp/portage/x11-drivers/ati-drivers-8.39.4/work/common/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: Entering directory `/usr/src/linux-2.6.22.1-rt9'
CC [M] /var/tmp/portage/x11-drivers/ati-drivers-8.39.4/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
In file included from /var/tmp/portage/x11-drivers/ati-drivers-8.39.4/work/common/lib/modules/fglrx/build_mod/2.6.x/drm_proc.h:41,
from /var/tmp/portage/x11-drivers/ati-drivers-8.39.4/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:366:
/var/tmp/portage/x11-drivers/ati-drivers-8.39.4/work/common/lib/modules/fglrx/build_mod/2.6.x/drmP.h:126:1: warning: "DRM_DEBUG_CODE" redefined
/var/tmp/portage/x11-drivers/ati-drivers-8.39.4/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:179:1: warning: this is the location of the previous definition
/var/tmp/portage/x11-drivers/ati-drivers-8.39.4/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:484: warning: initialization from incompatible pointer type
/var/tmp/portage/x11-drivers/ati-drivers-8.39.4/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function 'firegl_stub_open':
/var/tmp/portage/x11-drivers/ati-drivers-8.39.4/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:607: warning: assignment discards qualifiers from pointer target type
/var/tmp/portage/x11-drivers/ati-drivers-8.39.4/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function '__ke_pci_find_device':
/var/tmp/portage/x11-drivers/ati-drivers-8.39.4/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1863: warning: 'pci_find_device' is deprecated (declared at include/linux/pci.h:477)
/var/tmp/portage/x11-drivers/ati-drivers-8.39.4/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function '__ke_do_mmap':
/var/tmp/portage/x11-drivers/ati-drivers-8.39.4/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1968: warning: assignment makes pointer from integer without a cast
/var/tmp/portage/x11-drivers/ati-drivers-8.39.4/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function '__ke_request_irq':
/var/tmp/portage/x11-drivers/ati-drivers-8.39.4/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2806: warning: 'deprecated_irq_flag' is deprecated (declared at include/linux/interrupt.h:68)
/var/tmp/portage/x11-drivers/ati-drivers-8.39.4/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2806: warning: passing argument 2 of 'request_irq' from incompatible pointer type
/var/tmp/portage/x11-drivers/ati-drivers-8.39.4/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function 'KCL_has_pat':
/var/tmp/portage/x11-drivers/ati-drivers-8.39.4/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4512: warning: passing argument 2 of 'constant_test_bit' from incompatible pointer type
/var/tmp/portage/x11-drivers/ati-drivers-8.39.4/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4512: warning: passing argument 2 of 'variable_test_bit' from incompatible pointer type
/var/tmp/portage/x11-drivers/ati-drivers-8.39.4/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: At top level:
/var/tmp/portage/x11-drivers/ati-drivers-8.39.4/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:5280: warning: 'kmem_cache_t' is deprecated
LD [M] /var/tmp/portage/x11-drivers/ati-drivers-8.39.4/work/common/lib/modules/fglrx/build_mod/2.6.x/fglrx.o
Building modules, stage 2.
MODPOST 1 modules
WARNING: could not find /var/tmp/portage/x11-drivers/ati-drivers-8.39.4/work/common/lib/modules/fglrx/build_mod/2.6.x/.libfglrx_ip.a.GCC4.cmd for /var/tmp/portage/x11-drivers/ati-drivers-8.39.4/work/common/lib/modules/fglrx/build_mod/2.6.x/libfglrx_ip.a.GCC4
FATAL: modpost: GPL-incompatible module fglrx.ko uses GPL-only symbol '__rcu_read_unlock'
make[2]: *** [__modpost] Error 1
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.22.1-rt9'
make: *** [kmod_build] Error 2

!!! ERROR: x11-drivers/ati-drivers-8.39.4 failed.
Call stack:
ebuild.sh, line 1638: Called dyn_compile
ebuild.sh, line 985: Called qa_call 'src_compile'
ebuild.sh, line 44: Called src_compile
ati-drivers-8.39.4.ebuild, line 176: Called linux-mod_src_compile
linux-mod.eclass, line 516: Called die

!!! Unable to make GCC_VER_MAJ=4 KVER=2.6.22.1-rt9 KDIR=/usr/src/linux kmod_build.
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/x11-drivers/ati-drivers-8.39.4/temp/build.log'.


On observe aussi que lui ça ne build pas meme avec une version antérieure du driver. De mon coté les 8.40 ne build pas, du sien ce sont les 8.39 ...

Donc chez moi ça me fera pareil pas la peine que je change de kernel apperement, du moins pas pour le moment.

Merci
Back to top
View user's profile Send private message
bouyafa
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2006
Posts: 126

PostPosted: Thu Aug 30, 2007 8:13 am    Post subject: Reply with quote

Et bien ... Rebonjour, le post n'a pas l'air d'interesser grand monde mais de mon coté le soucis persiste.

Quote:
>>> Verifying ebuild Manifests...

>>> Emerging (1 of 1) x11-drivers/ati-drivers-8.40.4 to /
* ati-driver-installer-8.40.4-x86.x86_64.run RMD160 ;-) ... [ ok ]
* ati-driver-installer-8.40.4-x86.x86_64.run SHA1 ;-) ... [ ok ]
* ati-driver-installer-8.40.4-x86.x86_64.run SHA256 ;-) ... [ ok ]
* ati-driver-installer-8.40.4-x86.x86_64.run size ;-) ... [ ok ]
* checking ebuild checksums ;-) ... [ ok ]
* checking auxfile checksums ;-) ... [ ok ]
* checking miscfile checksums ;-) ... [ ok ]
* checking ati-driver-installer-8.40.4-x86.x86_64.run ;-) ... [ ok ]
ld_mod/2.6.x/firegl_public.c:2830: attention : passing argument 2 of 'request_irq
' from incompatible pointer type
make[2]: *** [/var/tmp/portage/x11-drivers/ati-drivers-8.40.4/work/common/lib/mod
ules/fglrx/build_mod/2.6.x/firegl_public.o] Erreur 1
make[1]: *** [_module_/var/tmp/portage/x11-drivers/ati-drivers-8.40.4/work/common
/lib/modules/fglrx/build_mod/2.6.x] Erreur 2
make[1]: quittant le répertoire « /usr/src/linux-2.6.17-cj3 »
make: *** [kmod_build] Erreur 2

!!! ERROR: x11-drivers/ati-drivers-8.40.4 failed.
Call stack:
ebuild.sh, line 1638: Called dyn_compile
ebuild.sh, line 985: Called qa_call 'src_compile'
ebuild.sh, line 44: Called src_compile
ati-drivers-8.40.4.ebuild, line 177: Called linux-mod_src_compile
linux-mod.eclass, line 516: Called die

!!! Unable to make GCC_VER_MAJ=4 KVER=2.6.17-cj3 KDIR=/usr/src/linux kmod_build.
!!! If you need support, post the topmost build error, and the call stack if rele
vant.
!!! A complete build log is located at '/var/tmp/portage/x11-drivers/ati-drivers-
8.40.4/temp/build.log'.


Personne n'a de retour comme ça ?
Back to top
View user's profile Send private message
bouyafa
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2006
Posts: 126

PostPosted: Thu Aug 30, 2007 3:05 pm    Post subject: Reply with quote

Y a quelqu'un ?? :)))
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Thu Aug 30, 2007 3:08 pm    Post subject: Reply with quote

bouyafa wrote:
Y a quelqu'un ?? :)))

retournes toi

ok c'est hyper nul...
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
Bapt
Veteran
Veteran


Joined: 14 Apr 2003
Posts: 1152
Location: Paris

PostPosted: Thu Aug 30, 2007 3:17 pm    Post subject: Reply with quote

dit moi ? si j'ai bien suivit ton noyau il est compilé avec un GCC 3 et là tu essayes de compiler le driver ati (donc un module noyau entre autre) avec gcc 4

Les modules noyau doivent être compilés avec le même compilateur que le noyau lui-même, donc ça ne rique pas de marcher.

Maintenant je pense que ça n'a rien à voir avec ton problème actuel, mais certainement avec ton futur problème une fois celui-ci corrigé.
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 510

PostPosted: Thu Aug 30, 2007 3:32 pm    Post subject: Reply with quote

kwenspc wrote:
retournes toi


[crackage]/me se prépare à criéer : BOUH!! [/crackage]

Plus sérieurieusement, tu sembles utiliser un kernel bien particulier quand même (des cj-sources en 2.6.17 ...).

Y a t-il une raison particulière? Peut être qu'un des patchs associés à ce noyau te joue des tours.

Si ce n'est tout simplement qu'il me semble que depuis les 8.33.6 (ça date quand même ...), les drivers ATI demandaient un kernel >= 2.6.18. Cette info reste à vérifier (je n'ai ni le temps ni l'envie de le faire, je suis en 2.6.22 ... et ça marche très bien.

Si il n'y a pas de raisons particulière à utiliser de telles sources, pourquoi ne pas utiliser les gentoo-sources? (sinon, et si ça viens bien de ça, t'as plus qu'à patcher un vanilla ...)
Back to top
View user's profile Send private message
bouyafa
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2006
Posts: 126

PostPosted: Thu Aug 30, 2007 3:54 pm    Post subject: Reply with quote

J'ai un GCC4 oui, et un kernel un peu vieux mais j'ai vu ailleurs que meme 'à jour' ça ne build pas. Concerant la remarque de Bapt on peut build n'importe quel module proche du kernel avec des versions différentes de GCC, mais ils ne fonctionneront pas (version mismatch). Pour la remarque de YetiBarBar, j'ai actuellement les drivers x11-drivers/ati-drivers-8.39.4, ils ont toujours bien build meme avec mon vieux kernel.

Le soucis, récurant, arrive donc bien depuis peu, je cherche un user qui possède et utilise une carte ATI avec les drivers proprios. Il m'arrive donc la meme chose sur une autre box, avec un kernel plus récent.
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 3110
Location: Paris

PostPosted: Thu Aug 30, 2007 4:50 pm    Post subject: Reply with quote

+1 pour prendre un kernel "normal", parce qu'un cj ou un 2.6.22.1-rt9 (cékoidon?), c'est pas du classique-classique ^^
_________________
-FreeNAS: µ-serv Gen8 G1610T, 16Go ECC & µ-serv N40L, 8Go ECC
-FreeBSD 11/Vimage/Jails: DS61, i3 2100T, 16Go
-Réseau: ERL-3 + ESL-24 + GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
RickyLoad
Tux's lil' helper
Tux's lil' helper


Joined: 29 Dec 2006
Posts: 148
Location: Rennes

PostPosted: Thu Aug 30, 2007 5:29 pm    Post subject: Reply with quote

salut
Je sais pas si çà va t'aider , mais je suis pas le seul sans doute à avoir çà :
Code:

uname -a
Linux Gentoo 2.6.22-gentoo-r5 #1 SMP Sat Aug 25 17:03:51 CEST 2007 i686 Intel(R) Pentium(R) 4 CPU 2.93GHz GenuineIntel GNU/Linux
06:00.1 Display controller: ATI Technologies Inc RV370 [Radeon X300SE]
x11-drivers/ati-drivers
      Latest version available: 8.40.4
      Latest version installed: 8.40.4
sys-devel/gcc
      Latest version available: 4.2.0
      Latest version installed: 4.2.0

Le tout avec ==> Xgl
Et le compiz fusion marche nickel :)
Mais bon , a part la carte qui date un peu , je suis ds le traditionnel , notamment au niveau du kernel ;))
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 510

PostPosted: Thu Aug 30, 2007 6:07 pm    Post subject: Reply with quote

tu pourrais poster ton :

emerge --info

(je viens de reéssayer, chez moi il build correctement en amd64 sans tout ces warning, en gentoo source avec USE=acpi kernel_libux -multilib )
Back to top
View user's profile Send private message
bouyafa
Tux's lil' helper
Tux's lil' helper


Joined: 23 Apr 2006
Posts: 126

PostPosted: Fri Aug 31, 2007 9:52 am    Post subject: Reply with quote

Quote:
Portage 2.1.2.12 (default-linux/x86/2007.0, gcc-4.1.2, glibc-2.5-r4, 2.6.17-cj1 i686)
=================================================================
System uname: 2.6.17-cj1 i686 Intel(R) Pentium(R) 4 CPU 3.40GHz
Gentoo Base System release 1.12.9
Timestamp of tree: Mon, 27 Aug 2007 05:50:01 +0000
app-shells/bash: 3.2_p17
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python: 2.3.5-r3, 2.4.4-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.9-r2
sys-apps/sandbox: 1.2.17
sys-devel/autoconf: 2.13, 2.61-r1
sys-devel/automake: 1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils: 2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool: 1.5.24
virtual/os-headers: 2.6.21
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -march=pentium4 -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="ftp://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ http://mir.zyrianes.net/gentoo/"
LANG="fr_FR@euro"
LC_ALL="fr_FR@euro"
LINGUAS="fr fr_FR"
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/enlightenment /usr/portage/local/layman/custom-kernels /usr/local/portage"
SYNC="rsync://rsync.fr.gentoo.org/gentoo-portage"
USE="X acl alsa avi bash-completion berkdb bitmap-fonts bluetooth browserplugin cdparanoia cdr cli cracklib crypt cups dri dv dvd dvdr dvdread eds encore esd ethereal fortran gdbm gif gimp gimpprint gpm gtk2 hal iconv imlib ipv6 isdnlog java jpeg kde kdeenablefinal midi mmx motif mpeg mudflap ncurses nls nptl nptlonly opengl openmp pam pcre perl pic png ppds pppd python qt readline reflection scanner sdl session slang spl sse ssl svg svga tcpd threads tiff truetype truetype-fonts type1-fonts unicode usb userlocales v4l vcd vorbis wifi win32codecs x86 xine xorg xv zlib" ALSA_CARDS="atiixp" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr fr_FR" USERLAND="GNU" VIDEO_CARDS="radeon fglrx vesa fbdev"
Unset: CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS



Voila pour mon emerge --info
Sinon pour le kernel je ne voie pas en quoi un patch ou deux peuvent altérer ce genre de choses, surtout que j'ai toujours utilisé un cj sur mon portable, un ck sur mon desktop, et dans un post précédent on voie un build.log avec un 2.6.22 'normal'.

Merci
Back to top
View user's profile Send private message
_Seth_
Guru
Guru


Joined: 15 Sep 2004
Posts: 539
Location: encore paumé dans un labo ;)

PostPosted: Fri Aug 31, 2007 11:23 am    Post subject: Reply with quote

bouyafa wrote:
[...] Pourtant aujourd'hui sur IRC je voie qu'une autre personne a le meme soucis que moi. A la différence qu'il est plus à jour que moi, un GCC4 et un kernel en 2.6.22. Je quote son build.log en espérant arriver à builder ce driver un jour ou l'autre.

Quote:
[...]
FATAL: modpost: GPL-incompatible module fglrx.ko uses GPL-only symbol '__rcu_read_unlock'

[...]


J'espère que ça pourra te servir, mais je viens de rencontrer un problème qui me semble similaire. J'ai l'impression que la cause de l'erreur est la même mais les conditions sont différentes : c'est avec les drivers nvidia sous debian et un kernel 2.6.20 ou 2.6.21.

M'enfin, l'erreur GPL-incompatible module uses GPL-only symbol est dû à la politique de gestion des erreurs des mainteneurs du noyau (Linus et ses amis quoi) et c'est expliqué un peu plus en détail ici. Grosso modo quand on installe un module proprio dans le noyau, c'est enregistré et le noyau est marqué comme "entâché" (tainted) et les devs refusent de fournir de l'aide pour résoudre les bugs éventuels (c'est bien normal puisqu'ils n'ont pas accès aux sources du module proprio). Mais ils ont aussi étendu cette politique à certaines parties du code sur lesquels les devs veulent éviter une mauvaise utilisation par des modules propriétaires, elles sont donc déclarées GPL-only et refusent de compiler avec un module propriétaire.

Je ne peux pas t'en dire plus sur ton problème mais j'espère que cela te facilitera les recherches ;)

EDIT : apparement c'est un problème déjà connu sur les rt-sources.
_________________
no tears to cry, no feelings left
the species has amused itself to death
amused itself to death
Back to top
View user's profile Send private message
Danfocus
n00b
n00b


Joined: 06 Dec 2007
Posts: 1

PostPosted: Thu Dec 06, 2007 5:31 am    Post subject: Reply with quote

bouyafa wrote:

Quote:

FATAL: modpost: GPL-incompatible module fglrx.ko uses GPL-only symbol '__rcu_read_unlock'
make[2]: *** [__modpost] Error 1



Read this solution
http://gentoo-wiki.com/HOWTO_ATI_Drivers#Build_ati-drivers_on_rt-kernels_failed
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum