Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[carte tv] pas de son avec tvtime [résolu]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
saphis
n00b
n00b


Joined: 15 Aug 2007
Posts: 3

PostPosted: Wed Aug 15, 2007 2:18 pm    Post subject: [carte tv] pas de son avec tvtime [résolu] Reply with quote

Bonjour a tous ceux qui passent sur ce sujet :D

Depuis plusieurs années que j'utilise un OS gnu/linux, c'est bien la premiere fois que j'arrive pas a trouver une solution dans un forum ou sur google, d'ou ce premier message de demande d'aide ici.

Voila mon probléme, je n'arrive pas a avoir du son avec tvtime alors que l'image est clair, ce qui est un peu bete :lol:

La carte tv est une pinnacle pctv 310i dont la sortie son est relié a ma carte mére, une p5b deluxe.

Pour la configuration, j'ai suivi ce wiki: http://gentoo-wiki.com/HARDWARE_saa7134 sur un noyau 2.6.22-gentoo-rc2 compilé par mes soins :D

Pour trouver le probléme, voici quelques infos:

/etc/modules.autoload.d/kernel-2.6 wrote:
dvb-core
saa7134
saa7134-alsa
saa7134-dvb


/etc/modules.d/saa7134 wrote:
options saa7134 i2c_scan=1 tuner=54 secam=l alsa=1


dmesg wrote:
Linux video capture interface: v2.00
saa7130/34: v4l2 driver version 0.2.14 loaded
ACPI: PCI Interrupt 0000:04:01.0[A] -> GSI 22 (level, low) -> IRQ 22
saa7133[0]: found at 0000:04:01.0, rev: 208, irq: 22, latency: 64, mmio: 0xfeaff800
saa7133[0]: subsystem: 11bd:002f, board: Pinnacle PCTV 310i [card=101,autodetected]
saa7133[0]: board init: gpio is 600e000
input: Pinnacle PCTV as /class/input/input3
ir-kbd-i2c: Pinnacle PCTV detected at i2c-1/1-0047/ir0 [saa7133[0]]
saa7133[0]: i2c eeprom 00: bd 11 2f 00 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
saa7133[0]: i2c eeprom 10: ff e0 60 06 ff 20 ff ff 00 30 8d 2d 6c 6e ff ff
saa7133[0]: i2c eeprom 20: 01 2c 01 02 02 01 04 30 98 ff 00 a5 ff 21 00 c2
saa7133[0]: i2c eeprom 30: 96 10 03 32 15 20 ff ff 0c 22 17 88 03 4a 9f 5d
saa7133[0]: i2c eeprom 40: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 50: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 60: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 70: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c scan: found device @ 0x10 [???]
saa7133[0]: i2c scan: found device @ 0x8e [???]
saa7133[0]: i2c scan: found device @ 0x96 [???]
saa7133[0]: i2c scan: found device @ 0xa0 [eeprom]
tuner 1-004b: chip found @ 0x96 (saa7133[0])
tuner 1-004b: setting tuner address to 61
tuner 1-004b: type set to tda8290+75a
tuner 1-004b: setting tuner address to 61
tuner 1-004b: type set to tda8290+75a
saa7133[0]: registered device video0 [v4l2]
saa7133[0]: registered device vbi0
saa7133[0]: registered device radio0
saa7134 ALSA driver for DMA sound loaded
saa7133[0]/alsa: saa7133[0] at 0xfeaff800 irq 22 registered as card -1
DVB: registering new adapter (saa7133[0]).
DVB: registering frontend 0 (Philips TDA10046H DVB-T)...
tda1004x: setting up plls for 48MHz sampling clock
tda1004x: found firmware revision 20 -- ok


j'ai bien vérifié que rien ne soit sur "muet" dans le controleur de volume et le resultat c'est que je n'ai pas de son en sorti


Je remerci tous ceux qui ont lu ce sujet, meme si vous ne participez pas ;)


Last edited by saphis on Thu Aug 16, 2007 7:44 pm; edited 1 time in total
Back to top
View user's profile Send private message
saphis
n00b
n00b


Joined: 15 Aug 2007
Posts: 3

PostPosted: Wed Aug 15, 2007 4:32 pm    Post subject: Reply with quote

Je commence a sécher, car je ne vois pas ou peut être le probléme :?

Voici d'autres fichiers de conf., si ça peut vous donner une idée dans quelle direction cherher.

/etc/modules.d/alsa wrote:
alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel


grep SND /usr/src/linux/.config | grep =m wrote:
CONFIG_SND=m
CONFIG_SND_TIMER=m
CONFIG_SND_PCM=m
CONFIG_SND_HWDEP=m
CONFIG_SND_RAWMIDI=m
CONFIG_SND_SEQUENCER=m
CONFIG_SND_MIXER_OSS=m
CONFIG_SND_PCM_OSS=m
CONFIG_SND_RTCTIMER=m
CONFIG_SND_MPU401_UART=m
CONFIG_SND_AC97_CODEC=m
CONFIG_SND_MPU401=m
CONFIG_SND_BT87X=m
CONFIG_SND_ENS1370=m
CONFIG_SND_ENS1371=m
CONFIG_SND_HDA_INTEL=m
CONFIG_SND_HDSP=m
CONFIG_SND_HDSPM=m
CONFIG_SND_INTEL8X0=m
CONFIG_SND_INTEL8X0M=m
CONFIG_SND_USB_AUDIO=m
CONFIG_SND_USB_USX2Y=m


grep SND /usr/src/linux/.config | grep =y wrote:
CONFIG_SND_OSSEMUL=y
CONFIG_SND_PCM_OSS_PLUGINS=y
CONFIG_SND_SEQUENCER_OSS=y
CONFIG_SND_SEQ_RTCTIMER_DEFAULT=y
CONFIG_SND_SUPPORT_OLD_API=y


/etc/modules.autoload.d/kernel-2.6 wrote:
snd_hda_intel
snd_hda_codec
snd_pcm
snd_timer
snd
snd_page_alloc
dvb-core
saa7134
saa7134-alsa
saa7134-dvb


Si vous avez besoin d'autres infos, dites le moi :D
Back to top
View user's profile Send private message
dapsaille
Advocate
Advocate


Joined: 02 Aug 2004
Posts: 2366
Location: Paris

PostPosted: Thu Aug 16, 2007 8:06 am    Post subject: Reply with quote

Cette carte tévé utilise le dma pour le son fait une recherche sur oss=1 saa7134 et tu trouveras ton bonheur
(désolé j'ai cette carte mais pas de réception chez moi donc je ne sais plus comment je l'avait fait fonctionner)

EDIT = http://gentoo-wiki.com/HARDWARE_saa7134
Back to top
View user's profile Send private message
saphis
n00b
n00b


Joined: 15 Aug 2007
Posts: 3

PostPosted: Thu Aug 16, 2007 7:44 pm    Post subject: Reply with quote

Je te remerci de m'avoir mis dans le bon chemin, car ça marche :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum