Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
multicast [risolto]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
masterbrian
Guru
Guru


Joined: 13 Feb 2004
Posts: 461

PostPosted: Tue Aug 14, 2007 10:21 am    Post subject: multicast [risolto] Reply with quote

Ciao ragazzi,

ho un problema semplice, che mi sta facendo impazzire, forse qualcuno di voi, con approccio e mente fresca (se possibile d'estate! :)) potrebbe aiutarmi.

Sto cercando di ricevere un flusso multicast da una sk dvb.

Ho configurato la scheda di rete dvb e l'ho messa in PROMISC UP con un ip a caso

dopo aver cancellato tutte le regole di routing riguardanti il multicast ho dato il comando:

Code:
route add -net 224.0.0.0/4 dev dvb0_0


ora l'output di route -n mi restituisce:

Code:
# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
10.0.0.0        0.0.0.0         255.0.0.0       U     0      0        0 dvb0_0
127.0.0.0       0.0.0.0         255.0.0.0       U     0      0        0 lo
224.0.0.0       0.0.0.0         240.0.0.0       U     0      0        0 dvb0_0


se faccio un tcpdump di dvb0_0 vedo i pacchetti dello stream che mi interessano.

A questo punto provo ad aprirli con mplayer o con vlc ma ottengo sempre lo stesso risultato

Code:
$ mplayer udp://239.13.13.2:4006
MPlayer dev-SVN-rUNKNOWN-4.1.1 (C) 2000-2007 MPlayer Team
CPU: Intel(R) Pentium(R) 4 CPU 2.80GHz (Family: 15, Model: 2, Stepping: 9)
CPUflags:  MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
Compilato con riconoscimento CPU in esecuzione.
mplayer: could not connect to socket
mplayer: No such file or directory
Apertura del supporto per LIRC fallita. Non potrai usare il tuo telecomando.

Riproduco udp://239.13.13.2:4006.
STREAM_UDP, URL: udp://239.13.13.2:4006
Timeout! No data from host 239.13.13.2
udp_streaming_start failed
No stream found to handle url udp://239.12.147.22:4106


In uscita... (Fine del file)


Come se non gli arrivassero dati.

per sicurezza ho tolto le regole di firewall:

Code:
# iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination


Qualche idea?
Grazie
_________________
[img:f6b0c3bcba]http://www.danasoft.com/sig/MasterBrian.jpg[/img:f6b0c3bcba]


Last edited by masterbrian on Thu Aug 16, 2007 9:47 am; edited 1 time in total
Back to top
View user's profile Send private message
IlGab
Guru
Guru


Joined: 26 Nov 2004
Posts: 486

PostPosted: Tue Aug 14, 2007 11:18 am    Post subject: Reply with quote

Che scheda è :?:

A... per aprire i flussi multicast io uso
Code:
mplayer -vo gl udp://@239.192.251.136:49408.
Magari ti manca solo la @
Back to top
View user's profile Send private message
masterbrian
Guru
Guru


Joined: 13 Feb 2004
Posts: 461

PostPosted: Tue Aug 14, 2007 11:34 am    Post subject: Reply with quote

Ciao,

ho provato anche con mplayer -vo gl udp://@ip:port ma il risultato non cambia :(

la mia scheda e' una avermedia.
Ciao
_________________
[img:f6b0c3bcba]http://www.danasoft.com/sig/MasterBrian.jpg[/img:f6b0c3bcba]
Back to top
View user's profile Send private message
gutter
Bodhisattva
Bodhisattva


Joined: 13 Mar 2004
Posts: 7162
Location: Aarau, Aargau, Switzerland

PostPosted: Tue Aug 14, 2007 12:49 pm    Post subject: Reply with quote

Hai abilitato la USE dvb?

In caso di risposta affermativa hai provato con qualcosa del tipo:

Code:
mplayer dvb://ip:port

_________________
Registered as User #281564 and Machines #163761
Back to top
View user's profile Send private message
masterbrian
Guru
Guru


Joined: 13 Feb 2004
Posts: 461

PostPosted: Tue Aug 14, 2007 3:20 pm    Post subject: Reply with quote

Si la flag dvb e' abilitata, il problema, e' che mplayer non riceve proprio lo stream
Anche se lo vedo sull'interfaccia gia' messa in promiscuo :(
_________________
[img:f6b0c3bcba]http://www.danasoft.com/sig/MasterBrian.jpg[/img:f6b0c3bcba]
Back to top
View user's profile Send private message
gutter
Bodhisattva
Bodhisattva


Joined: 13 Mar 2004
Posts: 7162
Location: Aarau, Aargau, Switzerland

PostPosted: Tue Aug 14, 2007 3:44 pm    Post subject: Reply with quote

Suppongo che questa opzione del kernel sia abilitata:

Code:
CONFIG_IP_MULTICAST=y

_________________
Registered as User #281564 and Machines #163761
Back to top
View user's profile Send private message
masterbrian
Guru
Guru


Joined: 13 Feb 2004
Posts: 461

PostPosted: Tue Aug 14, 2007 5:11 pm    Post subject: Reply with quote

Si è abilitata. Considera che uso regolarmente il multicast per applicazioni di streaming, e in genere funziona tutto... :(
_________________
[img:f6b0c3bcba]http://www.danasoft.com/sig/MasterBrian.jpg[/img:f6b0c3bcba]
Back to top
View user's profile Send private message
gutter
Bodhisattva
Bodhisattva


Joined: 13 Mar 2004
Posts: 7162
Location: Aarau, Aargau, Switzerland

PostPosted: Thu Aug 16, 2007 7:30 am    Post subject: Reply with quote

masterbrian wrote:
Si è abilitata. Considera che uso regolarmente il multicast per applicazioni di streaming, e in genere funziona tutto... :(


Ma il flusso è RTP? In questo caso hai abilitato la flag live:

Code:
gutter@giskard ~ $ euse -i live
global use flags (searching: live)
************************************************************
no matching entries found

local use flags (searching: live)
************************************************************
[+ C  ] live (media-video/mplayer):
Enables live.com streaming media support

[+ C  ] live (media-video/vlc):
Enables LIVE.com support.


:?:
_________________
Registered as User #281564 and Machines #163761
Back to top
View user's profile Send private message
masterbrian
Guru
Guru


Joined: 13 Feb 2004
Posts: 461

PostPosted: Thu Aug 16, 2007 7:51 am    Post subject: Reply with quote

Ho trovato la soluzione!!!

Code:
for i in /proc/sys/net/ipv4/conf/*/rp_filter ; do echo 1 > $i ; done


Il filtro del kernel per la sorgente dei pacchetti rp_filter blocca a livello di kernel i pacchetti lo ho impostato a zero e ora tutto funziona correttamente :)
_________________
[img:f6b0c3bcba]http://www.danasoft.com/sig/MasterBrian.jpg[/img:f6b0c3bcba]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum