Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problemi durante l'upgrade di expat [risolto con pezza]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2, 3, 4, 5, 6  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
MajinJoko
l33t
l33t


Joined: 20 Sep 2005
Posts: 639
Location: Bergamo / Verona

PostPosted: Sat Aug 11, 2007 11:46 am    Post subject: problemi durante l'upgrade di expat [risolto con pezza] Reply with quote

Ciao a tutti,

sono su amd64 stabile, e stamattina ho trovato stabilizzato gnome 2.18 e relativi pacchetti.

Il primo "emerge -uDN world" si è fermato su un pacchetto con errore sul parser xml. Poco male, cerco e trovo sul forum internazionale la soluzione: emergo il parser xml e riparto con l'aggiornamento del world. Il pacchetto che ha dato l'errore si compila correttamente e la procedura è andata avanti per un pò.

Poi un'altra interruzione, su un altro pacchetto X che si fermava per un errore "while loading shared libraries". In questo caso preferisco un "emerge resume skipfirst", vado avanti.. ma, qualche pacchetto dopo, un altro stop. Riparto di nuovo con il resume skipfirst, ma un altro blocco ancora.


Ora, chiedo scusa per il post confuso. Ovviamente non vi sto chiedendo di prendere in mano la vostra fida sfera di cristallo e risolvere tutti i miei problemi :D

Vorrei però chiedervi un consiglio.

Si tratta di un aggiornamento abbastanza grande, 70 e rotti pacchetti. Come posso procedere, per avanzare in maniera quanto più possibile sicura e corretta?
Termino l'aggiornamento con (chissà quanti :() skipfirst? Lancio un revdep rebuild? Spengo il portatile e vado a tirare due calci al pallone? :lol:

Ringrazio fin d'ora chiunque abbia voglia di mostrarmi la retta via,

Ciao!
_________________
[(.. watashi wa Urumi Kanzaki ga suki da ..)]


Last edited by MajinJoko on Sun Aug 12, 2007 9:04 am; edited 2 times in total
Back to top
View user's profile Send private message
Ic3M4n
Advocate
Advocate


Joined: 02 Nov 2004
Posts: 3489
Location: Bergamo.

PostPosted: Sat Aug 11, 2007 12:54 pm    Post subject: Reply with quote

solitamente il --resume --skipfirst non è una grande idea per pacchetti che hanno molti aggiornamenti. se il problema te lo da per delle librerie corrotte potrebbe essere che uno dei pacchetti che hai aggiornato abbia rotto delle librerie. sarebbe meglio trovare il pacchetto incriminato e ricompilarlo. Un po' di output potrebbe rendere il tutto più chiaro ai tuoi lettori e magari darti una mano nel sistemare. purtroppo io utilizzo gnome 2.18 da quando era hard masked e quindi non ricordo cosa ho fatto quando ho fatto l'aggiornamento. era qualche mese fa. Potrei indirizzarti con un po' di fortuna su dbus e hal che solitamente sono i due pacchetti che danno rogne mentre si aggiorna.
Back to top
View user's profile Send private message
MajinJoko
l33t
l33t


Joined: 20 Sep 2005
Posts: 639
Location: Bergamo / Verona

PostPosted: Sat Aug 11, 2007 1:04 pm    Post subject: Reply with quote

Grazie.

Allora la prossima volta mi segno di dare un bel revdep-rebuild prima di aggiornamenti così grossi. Il fatto è che negli ultimi tempi (in pratica, "mesi") non ho mai riscontrato problemi o errori, e quasi quotidianamente tenevo aggiornato il sistema. Non pensavo di trovarmi un tale casino sepolto 8O

Comunque, la prima libreria su cui è spuntato l'errore era libexpat.so (che noto con sommo piacere appartenere a emul-linux). Le altre non le ricordo.
Ora, giusto per impastarsi con maggior gusto, ho interrotto l'aggiornamento, e ho dato un revdep-rebuild. 45 pacchetti, di cui molti falliscono.

Il piano adesso è di arrivare in fondo al revdep, rieseguirlo nuovamente e poi procedere all'aggiornamento.


Quote:
Un po' di output potrebbe rendere il tutto più chiaro ai tuoi lettori e magari darti una mano nel sistemare.

Perfettamente corretto. Ma visto che non ho tenuto traccia degli errori (pensando/sperando) fosse roba da poco, ho pensato di aprire un thread per raccogliere suggerimenti diciamo più generali per quando ci si trova in situazioni così impantanate :?
_________________
[(.. watashi wa Urumi Kanzaki ga suki da ..)]
Back to top
View user's profile Send private message
Ic3M4n
Advocate
Advocate


Joined: 02 Nov 2004
Posts: 3489
Location: Bergamo.

PostPosted: Sat Aug 11, 2007 1:17 pm    Post subject: Reply with quote

secondo me non serve fare un revdep-rebuild adesso
hai mezzo gnome nuovo e mezzo vecchio. logico che qualcosa non vada. io procederei nel capire che errori di compilazione hai e risolverli man mano
Back to top
View user's profile Send private message
MajinJoko
l33t
l33t


Joined: 20 Sep 2005
Posts: 639
Location: Bergamo / Verona

PostPosted: Sat Aug 11, 2007 3:30 pm    Post subject: Reply with quote

forse la nebbia si dirada..

credo di essere incappato in questo https://forums.gentoo.org/viewtopic-t-575289-highlight-pango.html
che spiegherebbe quasi tutti gli errori in cui cado..

intanto ho downgradato expat, lanciato revdep rebuild su libexpat, vediamo che succede :x
_________________
[(.. watashi wa Urumi Kanzaki ga suki da ..)]
Back to top
View user's profile Send private message
MajinJoko
l33t
l33t


Joined: 20 Sep 2005
Posts: 639
Location: Bergamo / Verona

PostPosted: Sun Aug 12, 2007 8:36 am    Post subject: Reply with quote

downgradato expat alla 1.95, mascherata la >2, revdep-rebuild e finalmente sono stato in grado di installare gnome 2.18.


Terrò d'occhio il thread del forum internazionale segnalato poco sopra, per vedere sviluppi sulla questione expat-2 ed errori di compilazione..
_________________
[(.. watashi wa Urumi Kanzaki ga suki da ..)]
Back to top
View user's profile Send private message
lavish
Bodhisattva
Bodhisattva


Joined: 13 Sep 2004
Posts: 4296

PostPosted: Sun Aug 12, 2007 8:54 am    Post subject: Reply with quote

libexpat 2.0.0 ABI breakage Dite che puo' bastare questo thread da 10 pagine per risolvere il problema dell'aggiornamento di expat? :P

Ad ogni modo, per l'upgrade di gnome c'e' questa guida: http://www.gentoo.org/proj/en/desktop/gnome/howtos/gnome-2.18-upgrade.xml
Per expat:
Code:
revdep-rebuild -X


Il tag [RISOLTO] non lo userei quando si fixa temporaneamente il problema con una "pezza", quale mascherare un pacchetto stable ;)
_________________
minimalblue.com | secgroup.github.io/
Back to top
View user's profile Send private message
MajinJoko
l33t
l33t


Joined: 20 Sep 2005
Posts: 639
Location: Bergamo / Verona

PostPosted: Sun Aug 12, 2007 9:02 am    Post subject: Reply with quote

Vedi, come lamentano un paio di utenti nel thread che ho segnalato, il revdep fallisce in più punti, lasciandomi con un sistema quasi inutilizzabile.

Non sarà il massimo, ma intanto downgradare expat mi ha permesso di risolvere il mio problema.



Se poi per aggiornare un pacchetto (che mi sembra stia dando problemi anche ad altri) mi devo leggere 10 pagine di topic 8O, per il momento mi accontento di questa soluzione tampone.

Credo che comunque questo thread possa in qualche modo essere utile a chi incappa nello stesso problema :wink:


Ciao
_________________
[(.. watashi wa Urumi Kanzaki ga suki da ..)]
Back to top
View user's profile Send private message
lavish
Bodhisattva
Bodhisattva


Joined: 13 Sep 2004
Posts: 4296

PostPosted: Sun Aug 12, 2007 9:22 am    Post subject: Reply with quote

MajinJoko wrote:
Vedi, come lamentano un paio di utenti nel thread che ho segnalato, il revdep fallisce in più punti, lasciandomi con un sistema quasi inutilizzabile.

Hai provato
Code:
revdep-rebuild -X --library=libexpat.so.0
?
MajinJoko wrote:
Non sarà il massimo, ma intanto downgradare expat mi ha permesso di risolvere il mio problema.

Ovvio che facendo un downgrade ti funziona. E' legittimo: questo pero' non si chiama risolvere, ma raggirare. Il mio appunto era solo per il tag nel topic ;)
MajinJoko wrote:
Se poi per aggiornare un pacchetto (che mi sembra stia dando problemi anche ad altri) mi devo leggere 10 pagine di topic 8O, per il momento mi accontento di questa soluzione tampone.

expat e' il piu' grande PITA* che esista su gentoo :cry:
Io stesso ieri ho dovuto reemergere un bel numero di pacchetti...


*Pain In The Ass
_________________
minimalblue.com | secgroup.github.io/
Back to top
View user's profile Send private message
MajinJoko
l33t
l33t


Joined: 20 Sep 2005
Posts: 639
Location: Bergamo / Verona

PostPosted: Sun Aug 12, 2007 9:27 am    Post subject: Reply with quote

lavish wrote:
Hai provato
Code:
revdep-rebuild -X --library=libexpat.so.0
?


è proprio a quel punto che muore.. alcuni dei pacchetti (non ci metterei la mano sul fuoco, ma uno di essi mi sembra essere Pango) non mi si compilano dando errore sulla libreria mancante..
Devo anche essere sincero.. ormai stremato e stressato, ho cercato di arrivare a riavere un sistema up&running in qualsiasi modo.. domani, o dopodomani, riprovo la trafila.. però questa volta prima faccio un bel quickpkg..


lavish wrote:
Ovvio che facendo un downgrade ti funziona. E' legittimo: questo pero' non si chiama risolvere, ma raggirare. Il mio appunto era solo per il tag nel topic ;)

Hai pienamente ragione. Spero che il tag ora renda l'idea.


lavish wrote:
expat e' il piu' grande PITA* che esista su gentoo :cry:
Io stesso ieri ho dovuto reemergere un bel numero di pacchetti...

L'ho intuito quando ho visto che il thread che hai segnalato tu inizia nel 2006, e l'ultimo post è dell'11 agosto 2007..
_________________
[(.. watashi wa Urumi Kanzaki ga suki da ..)]
Back to top
View user's profile Send private message
lavish
Bodhisattva
Bodhisattva


Joined: 13 Sep 2004
Posts: 4296

PostPosted: Sun Aug 12, 2007 9:32 am    Post subject: Reply with quote

MajinJoko wrote:
lavish wrote:
expat e' il piu' grande PITA* che esista su gentoo :cry:
Io stesso ieri ho dovuto reemergere un bel numero di pacchetti...

L'ho intuito quando ho visto che il thread che hai segnalato tu inizia nel 2006, e l'ultimo post è dell'11 agosto 2007..

Eheh, inizia nel 2006 perche' expat-2 era entrato in testing l'anno scorso ;)
_________________
minimalblue.com | secgroup.github.io/
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Sun Aug 12, 2007 12:18 pm    Post subject: Reply with quote

lavish wrote:
Ad ogni modo, per l'upgrade di gnome c'e' questa guida: http://www.gentoo.org/proj/en/desktop/gnome/howtos/gnome-2.18-upgrade.xml

http://www.gentoo.org/proj/it/desktop/gnome/howtos/gnome-2.18-upgrade.xml :evil: :P
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
lavish
Bodhisattva
Bodhisattva


Joined: 13 Sep 2004
Posts: 4296

PostPosted: Sun Aug 12, 2007 12:50 pm    Post subject: Reply with quote

Scen wrote:
lavish wrote:
Ad ogni modo, per l'upgrade di gnome c'e' questa guida: http://www.gentoo.org/proj/en/desktop/gnome/howtos/gnome-2.18-upgrade.xml

http://www.gentoo.org/proj/it/desktop/gnome/howtos/gnome-2.18-upgrade.xml :evil: :P

en: Updated August 11, 2007
it: Aggiornato il 27 luglio 2007

Avevo controllato prima di postare ;)
_________________
minimalblue.com | secgroup.github.io/
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Sun Aug 12, 2007 2:24 pm    Post subject: Reply with quote

Damn, hanno fatto ben DUE revision bump proprio IERI :P

Tzè, stavolta ti è andata bene :wink:
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
Ic3M4n
Advocate
Advocate


Joined: 02 Nov 2004
Posts: 3489
Location: Bergamo.

PostPosted: Sun Aug 12, 2007 11:55 pm    Post subject: Reply with quote

io avevo già gnome-2.18.
oggi ho emerso expat con un
Code:
emerge -1 expat

e successivamente ho dato il revdep-rebuild come segnalato da emerge. Mi ha ricompilato 22 pacchetti e tutto è a posto.
probabilmente il tuo problema deriva dal fatto che alcuni pacchetti che hai ricompilato erano linkati alla vecchia expat e quindi faceva un gran casino durante l'aggiornamento oppure al fatto che io sono più fortunato di te. :lol:
Back to top
View user's profile Send private message
MajinJoko
l33t
l33t


Joined: 20 Sep 2005
Posts: 639
Location: Bergamo / Verona

PostPosted: Mon Aug 13, 2007 10:48 am    Post subject: Reply with quote

È ufficiale: non ci sto capendo più niente. 8O

Allora, smaschero expat-2.0.1.
Lo emerge.
Lancio il revdep sul famoso libexpat.so.0.
Mi prepara 67 pacchetti da compilare.
Parte con le QT.


FALLISCE!

Code:
x86_64-pc-linux-gnu-g++ -fno-exceptions -o ../../../bin/uic .obj/release-shared-mt/main.o .obj/release-shared-mt/uic.o .obj/release-shared-mt/form.o .obj/release-shared-mt/object.o .obj/release-shared-mt/subclassing.o .obj/release-shared-mt/embed.o .obj/release-shared-mt/widgetdatabase.o .obj/release-shared-mt/domtool.o .obj/release-shared-mt/parser.o    -L/usr/lib64 -L/var/tmp/portage/x11-libs/qt-3.3.8-r3/work/qt-x11-free-3.3.8/lib -L/usr/X11R6/lib64 -lqt-mt -lmng -ljpeg -lpng -lz -lXi -lXrender -lXrandr -lXcursor -lXft -lfreetype -lfontconfig -lXext -lX11 -lm -lSM -lICE -ldl -lpthread
/usr/lib/gcc/x86_64-pc-linux-gnu/4.1.2/../../../../x86_64-pc-linux-gnu/bin/ld: warning: libexpat.so.0, needed by /usr/lib64/libfontconfig.so, not found (try using -rpath or -rpath-link)
/usr/lib64/libfontconfig.so: undefined reference to `XML_SetElementHandler'
/usr/lib64/libfontconfig.so: undefined reference to `XML_SetDoctypeDeclHandler'
/usr/lib64/libfontconfig.so: undefined reference to `XML_ParserFree'
/usr/lib64/libfontconfig.so: undefined reference to `XML_SetCharacterDataHandler'
/usr/lib64/libfontconfig.so: undefined reference to `XML_ErrorString'
/usr/lib64/libfontconfig.so: undefined reference to `XML_ParseBuffer'
/usr/lib64/libfontconfig.so: undefined reference to `XML_ParserCreate'
/usr/lib64/libfontconfig.so: undefined reference to `XML_SetUserData'
/usr/lib64/libfontconfig.so: undefined reference to `XML_GetErrorCode'
/usr/lib64/libfontconfig.so: undefined reference to `XML_GetBuffer'
/usr/lib64/libfontconfig.so: undefined reference to `XML_GetCurrentLineNumber'
collect2: ld returned 1 exit status
make[3]: *** [../../../bin/uic] Error 1
make[3]: Leaving directory `/var/tmp/portage/x11-libs/qt-3.3.8-r3/work/qt-x11-free-3.3.8/tools/designer/uic'
make[2]: *** [sub-uic] Error 2
make[2]: Leaving directory `/var/tmp/portage/x11-libs/qt-3.3.8-r3/work/qt-x11-free-3.3.8/tools/designer'
make[1]: *** [sub-designer] Error 2
make[1]: Leaving directory `/var/tmp/portage/x11-libs/qt-3.3.8-r3/work/qt-x11-free-3.3.8/tools'
make: *** [sub-tools] Error 2

!!! ERROR: x11-libs/qt-3.3.8-r3 failed.
Call stack:
  ebuild.sh, line 1632:   Called dyn_compile
  ebuild.sh, line 983:   Called qa_call 'src_compile'
  ebuild.sh, line 44:   Called src_compile
  qt-3.3.8-r3.ebuild, line 214:   Called die

!!! (no error message)



Adesso, non posso non credervi se mi dite che vi va tutto senza problemi.. ma io come posso risolvere?! 8O




Vi ringrazio..


edit: questa è la lista dei pacchetti che revdep vuole emergere:
Code:
 =sys-devel/gettext-0.16.1 =media-libs/musicbrainz-2.1.4 =app-emulation/emul-linux-x86-xlibs-10.0 =app-emulation/emul-linux-x86-gtklibs-10.0-r1 =app-emulatio
n/emul-linux-x86-qtlibs-10.0 =x11-libs/gtk+-2.10.13 =app-text/aiksaurus-1.2.1 =gnome-extra/gtkhtml-2.6.3 =gnome-base/gconf-2.18.0.1 =gnome-base/libgnomeui-2
.18.1 =sys-devel/gdb-6.6-r2 =www-client/elinks-0.11.2-r1 =dev-libs/apr-util-1.2.8 =www-servers/apache-2.0.58-r2 =dev-util/subversion-1.4.4-r3 =games-emulati
on/gxmame-0.35_beta2 =gnome-extra/gconf-editor-2.18.0 [b]=media-libs/fontconfig-2.4.2[/b] =app-text/poppler-0.5.4-r1 =media-gfx/graphviz-2.12 =media-gfx/imagemagic
k-6.3.4-r1 =x11-libs/pango-1.16.4 =gnome-extra/gucharmap-1.10.0 =gnome-base/libbonoboui-2.18.0 =gnome-base/gnome-desktop-2.18.2 =dev-util/glade-2.12.1 =x11-
libs/vte-0.16.6-r1 =gnome-base/librsvg-2.16.1-r2 =dev-python/gnome-python-extras-2.14.2-r1 =x11-terms/gnome-terminal-2.18.1 =dev-libs/dbus-glib-0.73 =gnome-
base/gnome-panel-2.18.3 =gnome-extra/yelp-2.18.1 =www-client/epiphany-2.18.2 =app-i18n/uim-1.4.1 =gnome-base/gdm-2.18.4 =net-analyzer/gnome-netstatus-2.12.1
 =sys-apps/dbus-1.0.2-r2 =app-i18n/scim-1.4.5-r1 =gnome-base/nautilus-2.18.1-r1 =gnome-extra/gnome-keyring-manager-2.18.0 =gnome-extra/gnome-screensaver-2.1
8.2-r1 =x11-libs/libgksu-2.0.4 =media-libs/libquicktime-0.9.10 =sys-apps/hal-0.5.9-r1 =gnome-base/gnome-mount-0.6 =media-video/totem-2.18.2 =gnome-base/cont
rol-center-2.18.1 =gnome-extra/gnome-power-manager-2.18.3 =gnome-extra/nautilus-cd-burner-2.18.2 =gnome-base/gnome-session-2.18.3 =media-sound/sound-juicer-
2.16.4 =net-print/gtklp-1.2.2 =kde-base/kdelibs-3.5.7-r2 =app-admin/gnome-system-tools-2.14.0 =app-text/evince-0.8.3 =media-libs/xine-lib-1.1.4-r2 =app-cdr/
k3b-0.12.17 =kde-base/quanta-3.5.7 =net-wireless/gnome-bluetooth-0.7.0-r1 =mail-client/evolution-2.10.2 =app-office/lyx-1.4.2 =gnome-extra/gnome-utils-2.18.
1 =x11-libs/wxGTK-2.6.3.3 =app-editors/gedit-2.18.1-r1 =gnome-extra/gnome-games-2.18.2.1 =mail-client/mail-notification-4.0


se il fallimento di emerge è causato da /usr/lib64/libfontconfig.so che fa parte di media-libs/fontconfig, a questo punto mi viene da chiedermi se non è revdep-rebuild a calcolare male l'ordine di emersione dei pacchetti :?
_________________
[(.. watashi wa Urumi Kanzaki ga suki da ..)]
Back to top
View user's profile Send private message
lavish
Bodhisattva
Bodhisattva


Joined: 13 Sep 2004
Posts: 4296

PostPosted: Mon Aug 13, 2007 11:01 am    Post subject: Reply with quote

Puo' essere.. prova un
Code:
emerge -1 media-libs/fontconfig && revdep-rebuild -X

_________________
minimalblue.com | secgroup.github.io/
Back to top
View user's profile Send private message
Ic3M4n
Advocate
Advocate


Joined: 02 Nov 2004
Posts: 3489
Location: Bergamo.

PostPosted: Mon Aug 13, 2007 11:36 am    Post subject: Reply with quote

beh... effettivamente sono file di fontconfig a darti problemi, quindi potrebbe essere benissimo un problema di dipendenze di portage.
Back to top
View user's profile Send private message
Dun
Apprentice
Apprentice


Joined: 17 Apr 2004
Posts: 172
Location: Amsterdam (NL) / Venice (IT)

PostPosted: Mon Aug 13, 2007 11:46 am    Post subject: Reply with quote

Avuto problemi simili con tutt'altri pacchetti.

Il trucco sta nel fregarsene delle incoerenze e finire l'update per poi solo successivamente correggerle. (Qualche dubbio che lo switch -X di revdep-rebuild non funzioni tanto bene).

Code:

emerge -1v expat
revdep-rebuild -X
emerge -uDNv world (a questo punto revdep-rebuild mi segnalava molte incoerenze ma avrebbe emerso solo2 pacchetti)
revdep-rebuild
emerge -v --depclean
Back to top
View user's profile Send private message
MajinJoko
l33t
l33t


Joined: 20 Sep 2005
Posts: 639
Location: Bergamo / Verona

PostPosted: Mon Aug 13, 2007 11:50 am    Post subject: Reply with quote

In effetti, dopo l'emersione di fontconfig ha ripreso correttamente, è andato avanti un pò, ma è morto su x11-libs/gtk+-2.10.13:

Code:
x86_64-pc-linux-gnu-gcc -shared  .libs/imviqr.o  -Wl,--rpath -Wl,/var/tmp/portage/x11-libs/gtk+-2.10.13/work/gtk+-2.10.13/gdk-pixbuf/.libs -Wl,--rpath -Wl,/var/tmp/portage/x11-libs/gtk+-2.10.13/work/gtk+-2.10.13/gdk/.libs -Wl,--rpath -Wl,/var/tmp/portage/x11-libs/gtk+-2.10.13/work/gtk+-2.10.13/gtk/.libs -L/var/tmp/portage/x11-libs/gtk+-2.10.13/work/gtk+-2.10.13/gdk-pixbuf/.libs -L/var/tmp/portage/x11-libs/gtk+-2.10.13/work/gtk+-2.10.13/gdk/.libs ../../gdk-pixbuf/.libs/libgdk_pixbuf-2.0.so -L/usr/lib64 ../../gdk/.libs/libgdk-x11-2.0.so ../../gtk/.libs/libgtk-x11-2.0.so /usr/lib64/libpangocairo-1.0.so /usr/lib64/libpango-1.0.so /usr/lib64/libX11.so /usr/lib64/libXfixes.so /usr/lib64/libatk-1.0.so /usr/lib64/libgobject-2.0.so /usr/lib64/libgmodule-2.0.so -ldl /usr/lib64/libglib-2.0.so /usr/lib64/libcairo.so -lm  -march=athlon64 -Wl,-soname -Wl,im-viqr.so -o .libs/im-viqr.so
creating im-viqr.la
(cd .libs && rm -f im-ti-et.la && ln -s ../im-ti-et.la im-ti-et.la)
(cd .libs && rm -f im-viqr.la && ln -s ../im-viqr.la im-viqr.la)
../../gtk/gtk-query-immodules-2.0 im-xim.la  im-am-et.la im-cedilla.la im-cyrillic-translit.la im-inuktitut.la im-ipa.la im-thai.la im-ti-er.la im-ti-et.la im-viqr.la  > gtk.immodules
/var/tmp/portage/x11-libs/gtk+-2.10.13/work/gtk+-2.10.13/gtk/.libs/lt-gtk-query-immodules-2.0: error while loading shared libraries: libexpat.so.0: cannot open shared object file: No such file or directory
make[3]: *** [gtk.immodules] Error 127
make[3]: Leaving directory `/var/tmp/portage/x11-libs/gtk+-2.10.13/work/gtk+-2.10.13/modules/input'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/x11-libs/gtk+-2.10.13/work/gtk+-2.10.13/modules'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/x11-libs/gtk+-2.10.13/work/gtk+-2.10.13'
make: *** [all] Error 2

!!! ERROR: x11-libs/gtk+-2.10.13 failed.
Call stack:
  ebuild.sh, line 1632:   Called dyn_compile
  ebuild.sh, line 983:   Called qa_call 'src_compile'
  ebuild.sh, line 44:   Called src_compile
  gtk+-2.10.13.ebuild, line 108:   Called die

!!! compile failed



Ecco, adesso onestamente non so cosa fare.. prima almeno avevo una libreria su cui lavorare (quella di fontconfig, intendo).. ma ora?

Se creo un link simbolico al libexpat.so chiamato libexpat.so.0, è taaaanto male? Oppure come ovvio al problema sulle gtk+?
_________________
[(.. watashi wa Urumi Kanzaki ga suki da ..)]
Back to top
View user's profile Send private message
lavish
Bodhisattva
Bodhisattva


Joined: 13 Sep 2004
Posts: 4296

PostPosted: Mon Aug 13, 2007 11:58 am    Post subject: Reply with quote

https://bugs.gentoo.org/show_bug.cgi?id=188473
_________________
minimalblue.com | secgroup.github.io/
Back to top
View user's profile Send private message
lavish
Bodhisattva
Bodhisattva


Joined: 13 Sep 2004
Posts: 4296

PostPosted: Mon Aug 13, 2007 5:22 pm    Post subject: Reply with quote

MajinJoko wrote:
In effetti, dopo l'emersione di fontconfig ha ripreso correttamente, è andato avanti un pò, ma è morto su x11-libs/gtk+-2.10.13

prova:
Code:
emerge -1 pango gtk+ && revdep-rebuild -X

_________________
minimalblue.com | secgroup.github.io/
Back to top
View user's profile Send private message
MajinJoko
l33t
l33t


Joined: 20 Sep 2005
Posts: 639
Location: Bergamo / Verona

PostPosted: Tue Aug 14, 2007 12:38 am    Post subject: Reply with quote

ho portato a termine il revdep che si era bloccato sulle gtk con qualche "--resume --skipfirst" (ricordo che erano più di 60 pacchetti).

terminato questo, ho tentato di emergere le gtk, ma fallivano ancora. Allora ho emerso le gtk+-2.10.14 (mettendolo in package.keywords, su amd64 è in testing). Si è compilato senza problemi. Allora ho lanciato per l'ennesima volta il revdep-rebuild, che ha ricompilato una manciata di pacchetti (immagino quelli che si interrompevano prima, senza gtk+ installate correttamente).

Ora sono arrivato in fondo, il mio sistema è tornato stabile. Ma possibile che le gtk+-2.10.13 non digeriscano expat-2.0.1 ?


Vi ringrazio tantissimo per l'aiuto
_________________
[(.. watashi wa Urumi Kanzaki ga suki da ..)]
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4656
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Tue Aug 14, 2007 4:42 am    Post subject: Reply with quote

MajinJoko wrote:

Ora sono arrivato in fondo, il mio sistema è tornato stabile. Ma possibile che le gtk+-2.10.13 non digeriscano expat-2.0.1 ?

qui amd64. le gtk+-2.10.13 non hanno problemi. però io, i miei pallini con expat, li ho sputati per tempo l'estate scorsa.
Code:

s939 ~ # genlop -n expat
 * dev-libs/expat

     Sun Jul 30 21:32:56 2006 >>> dev-libs/expat-1.95.8
     Mon Jul 31 00:28:29 2006 >>> dev-libs/expat-2.0.0
...

probabilmente ti sei incartato in un problema di dipendenze, magari dovuto a un errore di portage nel definire la miglior sequenza di compilazione.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
MajinJoko
l33t
l33t


Joined: 20 Sep 2005
Posts: 639
Location: Bergamo / Verona

PostPosted: Tue Aug 14, 2007 10:02 am    Post subject: Reply with quote

cloc3 wrote:
MajinJoko wrote:

Ora sono arrivato in fondo, il mio sistema è tornato stabile. Ma possibile che le gtk+-2.10.13 non digeriscano expat-2.0.1 ?

qui amd64. le gtk+-2.10.13 non hanno problemi. però io, i miei pallini con expat, li ho sputati per tempo l'estate scorsa.
Code:

s939 ~ # genlop -n expat
 * dev-libs/expat

     Sun Jul 30 21:32:56 2006 >>> dev-libs/expat-1.95.8
     Mon Jul 31 00:28:29 2006 >>> dev-libs/expat-2.0.0
...

probabilmente ti sei incartato in un problema di dipendenze, magari dovuto a un errore di portage nel definire la miglior sequenza di compilazione.


Bene, allora ritiro la mia frecciatina alle gtk+-2.10.13, e prendo atto che forse era solamente un problema di ordine di emersione dei pacchetti.

Ciao!
_________________
[(.. watashi wa Urumi Kanzaki ga suki da ..)]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page 1, 2, 3, 4, 5, 6  Next
Page 1 of 6

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum