Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problemi durante l'upgrade di expat [risolto con pezza]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2, 3, 4, 5, 6  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4669
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Fri Aug 24, 2007 7:35 pm    Post subject: Reply with quote

:P

lavish wrote:
lucapost wrote:
Non è la prima: https://forums.gentoo.org/viewtopic-p-3219668-highlight-basta.html#3219668.

Quel post risale a quando expat-2 era passato in ~arch...


Lavish, sapevo che quella discussione ti avrebbe perseguitato ancora.
quando, all'epoca, mi sono imbattuto in expat quasi per caso per una dipendenza dei miei troppi pacchetti in tilde (nonostante tutto, ho deciso da tempo di usare istallazioni formalmente stabili) ho capito subito la dimensione del fenomeno expat e ho deciso di cavarmi il dente per tempo, anticipando l'inevitabile.

così, nelle pause di compilazione ho trovato il modo di inventare il flame su expat, baco di gentoo, con l'ambizione di rivendicarne la primogenitura.


    a conti fatti, tuttavia, mi sento di dire che la distribuzione ha saputo assorbire con eleganza questa difficoltà. da allora, infatti l'aggiornamento della versione stabile è stato evitato per più di un anno, è stato attentamente abbinato a quello, ugualmente importante, di gnome ed accompagnato da opportuna documentazione.

    quanto a revdep-rebuild, volendo anche ammettere qualche possibile passo falso in situazioni poco pulite, è uno strumento estremamente raffinato che risponde adeguatamente a questo tipo di problemi e che possiamo vantare da non più di un paio d'annetti. ai tempi dei tanto decantati fasti del 2004, ad esempio, non c'era proprio.

    tutto sommato ritengo che, sul piano della stabilità, gentoo si è difesa discretamente, anche in questi periodi di maretta, per cui un utente accorto può sentirsi soddisfatto dei propri sviluppatori.


al contrario, il fronte che probabilmente si sta progressivamente riducendo, in gentoo, è forse quello dello sviluppo. vero è che, fortunatamente, la nostra distribuzione è pensata bene abbastanza da permetterci di attingere abbondantemente ai laymann e agli ebuild di terze parti (cosa straordinaria: lasciar correre i propri utenti davanti allo stesso team di sviluppo) , ma sarebbe nelle corde proprie di una meta-distro l'anticipare gli altri nella proposizione di nuovi prodotti.

purtroppo la coperta è corta, e la complessità intrinseca del progetto assorbe risorse in eccesso, ma sono convinto che la struttura e le potenzialità sono tali che verrà trovato un equilibrio per una distribuzione più solida ed aggressiva.
_________________
vu vu vu
gentù
mi piaci tu


Last edited by cloc3 on Fri Aug 31, 2007 4:14 am; edited 1 time in total
Back to top
View user's profile Send private message
Chetto
Apprentice
Apprentice


Joined: 28 Nov 2006
Posts: 188
Location: Arco

PostPosted: Mon Aug 27, 2007 5:00 pm    Post subject: Reply with quote

Sono incappato anch'io nel fatidico problema di expat ma non riesco a risolvere in alcun modo nonostante abbia letto tutte le pagine della discussione.
Code:
revdep-rebuild
non arriva mai al termine, nemmeno con -X, si ferma durante l'emergione di ekiga. Qualche consiglio? Dovrei fare un downgrade di expat? Ho visto che qualcuno ha risolto così ma non mi piace risolvere "con pezze" ma se è l'unica soluzione perseguibile...
Back to top
View user's profile Send private message
lavish
Bodhisattva
Bodhisattva


Joined: 13 Sep 2004
Posts: 4296

PostPosted: Mon Aug 27, 2007 5:04 pm    Post subject: Reply with quote

se e' solo ekiga a non compilare, dai un
Code:
emerge --resume --skipfirst
e continua
_________________
minimalblue.com | secgroup.github.io/
Back to top
View user's profile Send private message
Chetto
Apprentice
Apprentice


Joined: 28 Nov 2006
Posts: 188
Location: Arco

PostPosted: Mon Aug 27, 2007 6:21 pm    Post subject: Reply with quote

Quote:
se e' solo ekiga a non compilare, dai un
Codice:
emerge --resume --skipfirst
e continua


scusa ma come faccio a darlo se il comando viene eseguito da revdep? E poi mi ricompila solo 2 pacchetti, il primo sembra andare a posto e il secondo è ekiga. Revdep mi segnala che ci sono molti link broken con expat e quindi il problema è quello...
Back to top
View user's profile Send private message
Chetto
Apprentice
Apprentice


Joined: 28 Nov 2006
Posts: 188
Location: Arco

PostPosted: Mon Aug 27, 2007 6:33 pm    Post subject: Reply with quote

Cambio di programma, ora revdep mi segnala solo un problema con il linking di libedataserver per quanto riguarda ekiga. Tuttavia il mio gnome continua ad andare a singhiozzo e mi ritrovo con un sistema inutilizzabile. :cry: Non posso fare altro che piangere, come posso fare per mettere a posto il mio sistema? (Non rimettere visto che a posto non lo è stato mia dato che ho installato da 1 mese). unmergere tutto gnome e poi riemergerlo risolverebbe forse? :cry: :cry: :cry: :cry: :cry:
Back to top
View user's profile Send private message
falko
Apprentice
Apprentice


Joined: 03 Dec 2004
Posts: 223
Location: Rovereto (TN) Italy

PostPosted: Mon Aug 27, 2007 6:55 pm    Post subject: Reply with quote

Ho aggiornato expat sabato scorso e come tutti (credo) ho avuto dei problemi, revdep-rebuild -X si bloccava quando tentava di riemergere gtk+ (perchè dipendevano da pango) e pango non riuscivo ad emergerlo.
Ho così guardato che pacchetti dovevano venir riemersi dal file .revdep-rebuild*ebuilds e ho riemerso a manina tutti gli ebuild di librerie (un po rozzo come modo di risolvere il problema ma sempre meglo che dare un emerge -e system && emerge -e world!)
comunque a mi è sembrato che dopo aver dato
Code:
emerge dev-perl/XML-Parser-2.34-r1

sia andato tutto a posto
_________________
Io non sarò mai nessuno ma... nessuno sarà mai come me. (Jim Morrison)

A ciacere no se sgonfa done

Gentoo on: Lenovo R500
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4669
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Mon Aug 27, 2007 6:59 pm    Post subject: Reply with quote

Chetto wrote:
Quote:
se e' solo ekiga a non compilare, dai un
Codice:
emerge --resume --skipfirst
e continua


scusa ma come faccio a darlo se il comando viene eseguito da revdep?

ma revdep lancia un emerge... :roll:

prova per controllo a dare emerge --resume -pv e dovresti avere una lunga lista comandata da ekiga.
(sempreché tu non abbia fatto altro nel frattempo)
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
Chetto
Apprentice
Apprentice


Joined: 28 Nov 2006
Posts: 188
Location: Arco

PostPosted: Mon Aug 27, 2007 10:26 pm    Post subject: Reply with quote

Quote:
prova per controllo a dare emerge --resume -pv e dovresti avere una lunga lista comandata da ekiga


Ehm.... Lunga non proprio, mi segnala solo ekiga, ed infatti è solo ekiga che viene emerso e mi segnala link rotti solo per ekiga ma qui non funziona nulla e non ottengo informazioni nemmeno lanciando le applicazioni dal terminale visto che si bloccano e non restituiscono nessun output, semplicemente non partono.
Back to top
View user's profile Send private message
lavish
Bodhisattva
Bodhisattva


Joined: 13 Sep 2004
Posts: 4296

PostPosted: Mon Aug 27, 2007 10:28 pm    Post subject: Reply with quote

hai dato un etc-update ?
_________________
minimalblue.com | secgroup.github.io/
Back to top
View user's profile Send private message
MeMyselfAndI
l33t
l33t


Joined: 15 Nov 2005
Posts: 784
Location: Between the monitor and the chair

PostPosted: Mon Aug 27, 2007 11:23 pm    Post subject: Reply with quote

Chetto wrote:
Quote:
prova per controllo a dare emerge --resume -pv e dovresti avere una lunga lista comandata da ekiga


Ehm.... Lunga non proprio, mi segnala solo ekiga, ed infatti è solo ekiga che viene emerso e mi segnala link rotti solo per ekiga ma qui non funziona nulla e non ottengo informazioni nemmeno lanciando le applicazioni dal terminale visto che si bloccano e non restituiscono nessun output, semplicemente non partono.


Potresti a questo punto elencare che versioni di gnome, expat e quant'altro hai installato ?
Back to top
View user's profile Send private message
flocchini
Veteran
Veteran


Joined: 17 May 2003
Posts: 1124
Location: Milano, Italy

PostPosted: Tue Aug 28, 2007 1:00 am    Post subject: Reply with quote

randomaze wrote:

Non proprio. I pacchetti compilati d'ora in poi dovrebbero usare gli header della nuova expat. Il problema é che i pacchetti che al momento sono problematici (subversion, ma anche pacchetti slotted come apr-util) userebbero la libreria 1.5.2 convinti di usare la .0 e questo potrebbe causare malfunzionamenti (o il crash dell'applicativo).


vero, ma per quanto mi riguarda per ora me lo tengo con il link e amen, se ne riparla con kde4 visto che di ricompilare tutto, kde in toto compreso, ora ho zero tempo e voglia... Tristezza e mestizia pero' :(
_________________
~~ Per amore della rosa si sopportano le spine... ~~
Back to top
View user's profile Send private message
Chetto
Apprentice
Apprentice


Joined: 28 Nov 2006
Posts: 188
Location: Arco

PostPosted: Tue Aug 28, 2007 9:57 am    Post subject: Reply with quote

Quote:
Potresti a questo punto elencare che versioni di gnome, expat e quant'altro hai installato ?


gnome 2.18-r1

Ma c'è un comando per vedere tutte le versioni dei programmi installati per caso?
Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1415
Location: <ud|me|ts> - Italy

PostPosted: Tue Aug 28, 2007 10:05 am    Post subject: Reply with quote

Chetto wrote:

Ma c'è un comando per vedere tutte le versioni dei programmi installati per caso?


Uno veloce è
Code:
eix -Ic

_________________
LP
Back to top
View user's profile Send private message
Chetto
Apprentice
Apprentice


Joined: 28 Nov 2006
Posts: 188
Location: Arco

PostPosted: Tue Aug 28, 2007 11:16 am    Post subject: Reply with quote

Quote:
Uno veloce è
Codice:
eix -Ic


Grazie, ma mi da 746 pacchetti, che faccio, posto? :? [/code]
Back to top
View user's profile Send private message
MeMyselfAndI
l33t
l33t


Joined: 15 Nov 2005
Posts: 784
Location: Between the monitor and the chair

PostPosted: Tue Aug 28, 2007 3:21 pm    Post subject: Reply with quote

c'e' sempre grep eh...
Back to top
View user's profile Send private message
u238
Guru
Guru


Joined: 04 Mar 2005
Posts: 373

PostPosted: Wed Aug 29, 2007 2:02 pm    Post subject: Reply with quote

Ciao a tutti,

Ho avuto anche io dei problemoni nell'upgrade di expat, e dopo mille tentativi invani di risolvere compilando ogni singolo pacchetto che dipendeva da expat (con qualche tentativo con revdep-rebuild in mezzo) ho deciso di provare con il symlink /usr/lib/libexpat.so.0 -> /usr/lib/libexpat.so.1.5.2. Lo so non è consigliabile, ho letto che potrebbero crashare le applicazioni ecc. ecc. ma a me serve il mio PC! :P

Ora la domanda è: posso tenere il symlink finchè piano piano faccio un emerge -e system completo? così almeno posso usare il PC nel frattempo! Poi quando ha finito cancello il link...o?
Back to top
View user's profile Send private message
lavish
Bodhisattva
Bodhisattva


Joined: 13 Sep 2004
Posts: 4296

PostPosted: Wed Aug 29, 2007 2:06 pm    Post subject: Reply with quote

Fare il symlink e' un'idiozia. Se proprio avete problemi nell'upgrade e vi serve subito il pc, rimanete ad expat-1 piuttosto.
_________________
minimalblue.com | secgroup.github.io/
Back to top
View user's profile Send private message
u238
Guru
Guru


Joined: 04 Mar 2005
Posts: 373

PostPosted: Wed Aug 29, 2007 2:26 pm    Post subject: Reply with quote

lavish wrote:
Fare il symlink e' un'idiozia. Se proprio avete problemi nell'upgrade e vi serve subito il pc, rimanete ad expat-1 piuttosto.


si ma prima o poi dovrò pur aggiornare..giusto? A me il PC serve tutti i giorni, sempre. ho solo questo (per il momento.....spero) ..come faccio ad aggiornarlo senza rimanere senza X 2 giorni o kissà quanto?
La mia domanda era.. se ricompilo system in questo stato teoricamente ricompila tutto usando i headers della nuova versione di expat..o sbaglio? quindi a fine ricompilazione se tolgo il symlink dovrebbe funzionare tutto.....?
Back to top
View user's profile Send private message
Chetto
Apprentice
Apprentice


Joined: 28 Nov 2006
Posts: 188
Location: Arco

PostPosted: Wed Aug 29, 2007 2:29 pm    Post subject: Reply with quote

Quote:
c'e' sempre grep eh...


sì ma non so che pacchetti intendi di preciso, posto tutto per ora: http://rafb.net/p/rACJNk48.html

//edit: tolta quella lista oscena di pacchetti e spostata su nopaste...
-- lavish
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Wed Aug 29, 2007 3:25 pm    Post subject: Reply with quote

Chetto wrote:
*

8O Aaarghhhh

Attento che c'è gente che potrebbe ucciderti per post come questo :roll: :wink: (non io, tranquillo 8) )

Le prossime volte che devi incollare cose così lunghe, meglio utilizzare servizi tipo http://www.pastebin.ca/ o simili.

Ma come mai tutti questi problemi con expat?

Lanciate SOLAMENTE
Code:

revdep-rebuild -pv


Cosa vi restituisce?
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
Chetto
Apprentice
Apprentice


Joined: 28 Nov 2006
Posts: 188
Location: Arco

PostPosted: Wed Aug 29, 2007 10:28 pm    Post subject: Reply with quote

Quote:
Attento che c'è gente che potrebbe ucciderti per post come questo :roll: :wink: (non io, tranquillo 8) )


Infatti, mi ero posto più di un problema prima di farlo ma la voglia di risolvere è forte! :?

Quote:
Lanciate SOLAMENTE
Codice:

revdep-rebuild -pv


Cosa vi restituisce?


Riemerge solo ekiga....
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Thu Aug 30, 2007 11:35 am    Post subject: Reply with quote

Chetto wrote:
Riemerge solo ekiga....

Ok, e da quanto ho capito ekiga non si ricompila.

A questo punto sarebbe utile se postassi:

  1. output COMPLETO di
    Code:

    revdep-rebuild -pv

  2. l'errore che ottieni in fase di compilazione

_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
Chetto
Apprentice
Apprentice


Joined: 28 Nov 2006
Posts: 188
Location: Arco

PostPosted: Fri Aug 31, 2007 5:58 pm    Post subject: Reply with quote

1-
Code:
localhost marco # revdep-rebuild -pv
Configuring search environment for revdep-rebuild

Checking reverse dependencies...

Packages containing binaries and libraries broken by a package update
will be emerged.

Collecting system binaries and libraries... done.
  (/root/.revdep-rebuild.1_files)

Collecting complete LD_LIBRARY_PATH... done.
  (/root/.revdep-rebuild.2_ldpath)

Checking dynamic linking consistency...
  broken /usr/bin/ekiga (requires  libedataserver-1.2.so.7)
 done.
  (/root/.revdep-rebuild.3_rebuild)

Assigning files to ebuilds... done.
  (/root/.revdep-rebuild.4_ebuilds)

Evaluating package order... done.
  (/root/.revdep-rebuild.5_order)

All prepared. Starting rebuild...
emerge --oneshot -pv =net-im/ekiga-2.0.7
..........

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] net-im/ekiga-2.0.7  USE="dbus gnome sdl* -avahi* -debug -doc" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB
Build finished correctly. Removing temporary files...
You can re-run revdep-rebuild to verify that all libraries and binaries
are fixed. If some inconsistency remains, it can be orphaned file, deep
dependency, binary package or specially evaluated library.


2-
Code:
checking for PWLib version... 1.10.5
checking for OpenLDAP support in PWLIB... no
configure: error: Sorry but the PWLib version you are using doesn't support LDAP

!!! Please attach the following file when filing a report to bugs.gentoo.org:
!!! /var/portage_tmp/portage/net-im/ekiga-2.0.7/work/ekiga-2.0.7/config.log

!!! ERROR: net-im/ekiga-2.0.7 failed.
Call stack:
  ebuild.sh, line 1638:   Called dyn_compile
  ebuild.sh, line 985:   Called qa_call 'src_compile'
  ebuild.sh, line 44:   Called src_compile
  ekiga-2.0.7.ebuild, line 65:   Called econf '--enable-dbus' '--enable-sdl' '--disable-avahi' '--disable-doc' '--enable-gnome'
  ebuild.sh, line 586:   Called die

!!! econf failed
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/portage_tmp/portage/net-im/ekiga-2.0.7/temp/build.log'.



Sono comunque abbastanza deciso a passare ad x86 anche se trovo sensibilmente più veloce amd64....
Back to top
View user's profile Send private message
lavish
Bodhisattva
Bodhisattva


Joined: 13 Sep 2004
Posts: 4296

PostPosted: Fri Aug 31, 2007 6:05 pm    Post subject: Reply with quote

Scusami ma l'errore e' chiaro...
Code:
configure: error: Sorry but the PWLib version you are using doesn't support LDAP


Devi aggiungere la USE ldap a dev-libs/pwlib e riemergere tale lib, tutto qua in teoria
_________________
minimalblue.com | secgroup.github.io/
Back to top
View user's profile Send private message
Chetto
Apprentice
Apprentice


Joined: 28 Nov 2006
Posts: 188
Location: Arco

PostPosted: Fri Aug 31, 2007 6:11 pm    Post subject: Reply with quote

Quote:
Devi aggiungere la USE ldap a dev-libs/pwlib e riemergere tale lib, tutto qua in teoria


Eh magari eh eh era una delle cose a cui ho pensato subito, salvo accorgermi che pwlib quella use ce l'ha già! Infatti....
Code:
localhost marco # emerge pwlib

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild   R   ] dev-libs/pwlib-1.10.5  USE="[b]alsa ipv6 ldap oss sdl ssl xml[/b] -debug -ieee1394 -sasl -v4l -v4l2" 0 kB
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6  Next
Page 4 of 6

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum