Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO]Problema installare Gnome
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
vdavi81
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jun 2006
Posts: 96
Location: Bonde

PostPosted: Tue Aug 07, 2007 12:49 pm    Post subject: [RISOLTO]Problema installare Gnome Reply with quote

Quando vado per emerge gnome. A circa 49 pacchetti dalla fine, mi viene dato il seguente errore:

Questo è il pachetto dev-perl/XML-Simple-2.16




* Using ExtUtils::MakeMaker
=============================================================================

Fatal error: Your default XML parser (XML::SAX::PurePerl) is broken.

There are known bugs in the PurePerl parser included with version 0.13
and 0.14 of XML::SAX. The XML::Simple tests will fail with this parser.

One way to avoid the problem is to install XML::SAX::Expat - it will
install itself as the system default XML parser and then you will be able
to install XML::Simple successfully. XML::SAX::Expat is also much faster
than XML::SAX::PurePerl so you probably want it anyway.

=============================================================================
Checking installed modules ...

!!! ERROR: dev-perl/XML-Simple-2.16 failed.
Call stack:
ebuild.sh, line 1621: Called dyn_compile
ebuild.sh, line 973: Called qa_call 'src_compile'
ebuild.sh, line 44: Called src_compile
ebuild.sh, line 1311: Called perl-module_src_compile
perl-module.eclass, line 136: Called perl-module_src_prep
perl-module.eclass, line 125: Called die

!!! Unable to build! (are you using USE="build"?)
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/dev-perl/XML-Simple-2.16/temp/build.log'.

daviputer ~ #
_________________
Gentoo the best of the best...


Last edited by vdavi81 on Thu Aug 16, 2007 4:35 pm; edited 1 time in total
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Tue Aug 07, 2007 6:29 pm    Post subject: Reply with quote

L'errore segnala una possibile fonte: hai abilitato la USE "build"?
Back to top
View user's profile Send private message
vdavi81
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jun 2006
Posts: 96
Location: Bonde

PostPosted: Tue Aug 07, 2007 9:58 pm    Post subject: Reply with quote

riverdragon wrote:
L'errore segnala una possibile fonte: hai abilitato la USE "build"?


Si lo avevo fatto ma sembra che non conti a nulla. Il problema lo da ugualmente.
Cosa potrà mai essere?
_________________
Gentoo the best of the best...
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Wed Aug 08, 2007 9:32 am    Post subject: Reply with quote

Quote:
There are known bugs in the PurePerl parser included with version 0.13
and 0.14 of XML::SAX. The XML::Simple tests will fail with this parser.

Prova ad aggiornare XML-SAX all'ultima versione stabile, dovrebbe essere la 0.15-r1, che non dovrebbe essere afflitta da questo problema.
Back to top
View user's profile Send private message
vdavi81
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jun 2006
Posts: 96
Location: Bonde

PostPosted: Wed Aug 08, 2007 12:05 pm    Post subject: Reply with quote

riverdragon wrote:
Quote:
There are known bugs in the PurePerl parser included with version 0.13
and 0.14 of XML::SAX. The XML::Simple tests will fail with this parser.

Prova ad aggiornare XML-SAX all'ultima versione stabile, dovrebbe essere la 0.15-r1, che non dovrebbe essere afflitta da questo problema.


Potresti essere piu preciso. Praticamente devo dire ad merge di instllare la versione sopraindicata?
_________________
Gentoo the best of the best...
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Wed Aug 08, 2007 12:16 pm    Post subject: Reply with quote

Dovrebbe essere sufficiente dare un emerge -1 XML-SAX, e poi riprendere con l'installazione di gnome.
Se è da molto che non sincronizzi portage, lancia un emerge --sync (o eix-sync se usi eix) prima di reinstallare XML-SAX.
Back to top
View user's profile Send private message
vdavi81
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jun 2006
Posts: 96
Location: Bonde

PostPosted: Wed Aug 08, 2007 2:45 pm    Post subject: Reply with quote

riverdragon wrote:
Dovrebbe essere sufficiente dare un emerge -1 XML-SAX, e poi riprendere con l'installazione di gnome.
Se è da molto che non sincronizzi portage, lancia un emerge --sync (o eix-sync se usi eix) prima di reinstallare XML-SAX.



Fatto questo guaio l'ho risolto.
Aesso compilo gnome e poi vi sapro dire cosa è venuto fuori .
_________________
Gentoo the best of the best...
Back to top
View user's profile Send private message
vdavi81
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jun 2006
Posts: 96
Location: Bonde

PostPosted: Wed Aug 08, 2007 5:20 pm    Post subject: Reply with quote

Come immaginavo adesso mi si pone un nuovo prblema

Ah ho fatto una scemenza. Ho comnpilato gnome (oh almeno fino dove sonoarrivato) senza cambiare le flag USE. Come faccio a mettere a posto tutti i pacchetti finora comilati. Ricompilandfo il tutto con le giuste flag USE

Tanto vi mostro il mio errore di compilazione

>>> Emerging (1 of 28) app-text/evince-0.6.1-r3 to /
* evince-0.6.1.tar.bz2 RMD160 ;-) ... [ ok ]
* evince-0.6.1.tar.bz2 SHA1 ;-) ... [ ok ]
* evince-0.6.1.tar.bz2 SHA256 ;-) ... [ ok ]
* evince-0.6.1.tar.bz2 size ;-) ... [ ok ]
* checking ebuild checksums ;-) ... [ ok ]
* checking auxfile checksums ;-) ... [ ok ]
* checking miscfile checksums ;-) ... [ ok ]
* checking evince-0.6.1.tar.bz2 ;-) ... [ ok ]
* Please re-emerge app-text/poppler-bindings with the gtk USE flag set

!!! ERROR: app-text/evince-0.6.1-r3 failed.
Call stack:
ebuild.sh, line 1637: Called dyn_setup
ebuild.sh, line 704: Called qa_call 'pkg_setup'
ebuild.sh, line 44: Called pkg_setup
evince-0.6.1-r3.ebuild, line 64: Called die

!!! poppler-bindings needs gtk flag set
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/app-text/evince-0.6.1-r3/temp/build.log'.
_________________
Gentoo the best of the best...
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Thu Aug 09, 2007 12:08 pm    Post subject: Reply with quote

Vdavi, credo che una bella letta al manuale non ti faccia male!

Aggiungi le USE gtk e gnome a make.conf, quindi lancia un emerge -avDN gnome (che corrisponde ad un emerge --ask --verbose --deep --newuse gnome).
Back to top
View user's profile Send private message
vdavi81
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jun 2006
Posts: 96
Location: Bonde

PostPosted: Fri Aug 10, 2007 2:05 pm    Post subject: Reply with quote

riverdragon wrote:
Vdavi, credo che una bella letta al manuale non ti faccia male!

Aggiungi le USE gtk e gnome a make.conf, quindi lancia un emerge -avDN gnome (che corrisponde ad un emerge --ask --verbose --deep --newuse gnome).


No bhe si lo sapevo. che dovevo aggiornare il make.conf e che dovevo fare newuse. Ma volevo sentire tutta l aprocedura.
Adesso ho un altro guaio:

-esd" 744 kB
[ebuild N ] net-print/gnome-cups-manager-0.31-r2 USE="-debug" 875 kB
[ebuild N ] app-editors/gedit-2.16.2-r1 USE="python -debug -doc -spell" 2,786 kB
[ebuild N ] gnome-base/gnome-2.16.3 USE="cdr cups hal -accessibility -dvdr -ldap" 0 kB
[blocks B ] perl-core/Test-Harness (is blocking dev-lang/perl-5.8.8-r2)

Total: 104 packages (33 upgrades, 33 new, 2 in new slots, 36 reinstalls, 1 block), Size of downloads: 183,261 kB

!!! Error: The above package list contains packages which cannot be installed
!!! at the same time on the same system.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

daviputer ~ #

un pachetto l'ho sbloccato. Ma questo non riesco perchè ci voglio entrambi e uno blocca l'altro. Come posso fare?... mantenendo un sistema in buono stato.
_________________
Gentoo the best of the best...
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Fri Aug 10, 2007 5:56 pm    Post subject: Reply with quote

quickpkg perl-core/Test-Harness && emerge -C perl-core/Test-Harness e riprendi ad installare gnome.
Back to top
View user's profile Send private message
vdavi81
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jun 2006
Posts: 96
Location: Bonde

PostPosted: Sat Aug 11, 2007 2:29 am    Post subject: Reply with quote

riverdragon wrote:
quickpkg perl-core/Test-Harness && emerge -C perl-core/Test-Harness e riprendi ad installare gnome.


Purtroppo avevo gia unmerso perl-core/Test-Harness . e adesso nn riesco piu a riemergerlo per fare il quickpkg... perchè quando lo vado a riemergere mi dice che c'è il problema che viene bloccato da dev-lan/perl... che ne è una dipendeza.

.....

[FORSE] Potrei unmergere perl è scaricare il tar.tgz e compilarlo con il make.

Si accettano soluzioni migliori.
_________________
Gentoo the best of the best...
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Sat Aug 11, 2007 9:18 am    Post subject: Reply with quote

Andando con attenzione prova a fare un quickpkg di perl e a rimuovere anche quello. Occhio che perl è parte di system. Se proprio qualcosa dovesse andare male fai emerge -1K perl per ripristinare l'installazione preesistente.

Prova a scrivere qui (dentro ai tag "code") il risultato di emerge -pvDN gnome
Back to top
View user's profile Send private message
vdavi81
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jun 2006
Posts: 96
Location: Bonde

PostPosted: Sat Aug 11, 2007 12:38 pm    Post subject: Reply with quote

Ecco:
daviputer ~ # emerge -pvDN gnome
!!! Invalid PORTDIR_OVERLAY (not a dir): '/usr/local/portage'
!!! Invalid PORTDIR_OVERLAY (not a dir): '/usr/portage/xeffects/trunk'

These are the packages that would be merged, in order:

Calculating dependencies... done!

[ebuild U ] sys-apps/portage-2.1.2.11 [2.1.2.9] USE="build* -doc -epydoc (-selinux)" LINGUAS="-pl" 327 kB
*** Portage will stop merging at this point and reload itself,
then resume the merge.
[ebuild R ] sys-apps/texinfo-4.8-r5 USE="build* nls -static" 1,487 kB
[ebuild N ] dev-util/unifdef-1.20 65 kB
[ebuild U ] net-dns/bind-tools-9.4.1_p1 [9.4.1-r1] USE="ipv6 -idn" 6,193 kB
[ebuild R ] sys-libs/ncurses-5.6-r1 USE="build* gpm unicode -bootstrap -debug -doc -minimal -nocxx -trace" 0 kB
[ebuild U ] sys-kernel/linux-headers-2.6.21 [2.6.17-r2] USE="(-gcc64%)" 4,287 kB
[ebuild R ] sys-apps/sed-4.1.5 USE="nls -static" 0 kB
[ebuild U ] app-shells/bash-3.2_p17 [3.2_p15-r1] USE="nls -afs -bashlogger -vanilla" 5 kB
[ebuild U ] sys-apps/findutils-4.3.8 [4.3.7] USE="nls (-selinux) -static" 1,766 kB
[ebuild R ] sys-apps/baselayout-1.12.9-r2 USE="build* unicode -bootstrap -static" 0 kB
[ebuild U ] dev-libs/libcdio-0.78.2 [0.77] USE="nls -cddb -minimal -nocxx" 1,977 kB
[ebuild N ] dev-lang/perl-5.8.8-r2 USE="berkdb build gdbm -debug -doc -ithreads -perlsuid" 0 kB
[ebuild U ] sys-libs/readline-5.2_p4 [5.1_p4] 1,996 kB
[ebuild U ] sys-fs/udev-104-r13 [104-r12] USE="(-selinux)" 0 kB
[ebuild U ] perl-core/libnet-1.21 [1.20-r1] USE="-sasl" 67 kB
[ebuild N ] perl-core/Test-Harness-2.64 0 kB
[ebuild NS ] sys-kernel/gentoo-sources-2.6.21-r4 USE="build -symlink" 43,180 kB
[ebuild U ] dev-perl/HTML-Parser-3.56 [3.55] USE="unicode" 85 kB
[ebuild R ] sys-fs/cryptsetup-luks-1.0.4-r3 USE="build* nls -dynamic (-selinux)" 0 kB
[ebuild U ] virtual/perl-libnet-1.21 [1.20] 0 kB
[ebuild U ] dev-perl/IO-Socket-SSL-1.07 [1.06] 46 kB
[ebuild R ] sys-apps/groff-1.19.2-r1 USE="X* -cjk" 2,836 kB
[ebuild N ] dev-perl/Digest-HMAC-1.01-r1 14 kB
[ebuild N ] dev-perl/Net-DNS-0.60 USE="ipv6" 144 kB
[ebuild N ] media-gfx/xloadimage-4.1-r4 USE="jpeg -png -tiff" 623 kB
[ebuild R ] sys-apps/dbus-1.0.2-r2 USE="X* -debug -doc (-selinux)" 0 kB
[ebuild R ] x11-apps/xdpyinfo-1.0.2 USE="dga* -debug -dmx -xinerama" 0 kB
[ebuild R ] media-libs/libmpeg2-0.4.1 USE="X* -sdl" 0 kB
[ebuild N ] x11-misc/xdg-utils-1.0.1 276 kB
[ebuild R ] dev-lang/python-2.4.4-r4 USE="berkdb build* gdbm ipv6 ncurses readline ssl -bootstrap -doc -examples -nocxx -nothreads -tk -ucs2" 0 kB
[ebuild R ] media-libs/freetype-2.3.4-r2 USE="X* zlib -bindist -debug -doc" 0 kB
[ebuild U ] dev-perl/Compress-Raw-Zlib-2.004-r1 [2.004] 0 kB
[ebuild U ] sys-apps/pciutils-2.2.4-r3 [2.2.3-r2] USE="hal%* zlib%* -network-cron%" 206 kB
[ebuild R ] media-gfx/imagemagick-6.3.4-r1 USE="X* jpeg* perl zlib -bzip2 -doc -fpx -graphviz -gs -hdri -jbig -jpeg2k -lcms -mpeg -nocxx -openexr -png -q32 -q8 -tiff -truetype -wmf -xml" 0 kB
[ebuild R ] media-libs/tiff-3.8.2-r2 USE="jpeg* zlib -jbig -nocxx" 0 kB
[ebuild U ] dev-python/pycrypto-2.0.1-r6 [2.0.1-r5] USE="-bindist -gmp -test" 151 kB
[ebuild U ] sys-apps/file-4.21-r1 [4.20-r1] USE="python" 538 kB
[ebuild U ] app-admin/eselect-1.0.10 [1.0.7] USE="-bash-completion -doc -vim-syntax%" 150 kB
[ebuild R ] app-text/poppler-0.5.4-r1 USE="jpeg* zlib -cjk" 0 kB
[ebuild R ] media-fonts/font-adobe-75dpi-1.0.0 USE="X* nls" 0 kB
[ebuild R ] media-fonts/font-misc-misc-1.0.0 USE="X* nls" 0 kB
[ebuild R ] media-fonts/font-cursor-misc-1.0.0 USE="X* nls" 0 kB
[ebuild U ] dev-perl/IO-Zlib-1.05 [1.04] 10 kB
[ebuild R ] x11-libs/cairo-1.4.10 USE="X opengl -debug -directfb -doc -glitz* -svg -xcb (-newspr%)" 0 kB
[ebuild R ] media-sound/esound-0.2.36-r2 USE="alsa* ipv6 tcpd -debug" 0 kB
[ebuild U ] net-misc/openssh-4.6_p1-r3 [4.5_p1-r1] USE="X* pam tcpd -X509 -chroot -hpn -kerberos -ldap -libedit (-selinux) -skey -smartcard -static" 945 kB
[ebuild U ] dev-perl/XML-LibXML-1.63 [1.62.001-r1] 256 kB
[ebuild U ] media-libs/mesa-6.5.3 [6.5.2-r1] USE="nptl -debug -doc (-hardened) -motif -xcb" VIDEO_CARDS="i810 via -mach64 -mga -none -r128 -radeon -s3virge -savage -sis (-sunffb) -tdfx -trident" 3,274 kB
[ebuild U ] dev-python/pycairo-1.4.0 [1.2.2] USE="-examples (-numeric%)" 469 kB
[ebuild N ] gnome-extra/gnome2-user-docs-2.16.1 USE="-debug" 3,912 kB
[ebuild R ] sys-devel/gcc-4.1.2 USE="build* fortran gtk* mudflap nls (-altivec) -bootstrap -d -doc -gcj (-hardened) -ip28 -ip32r10k (-multilib) -multislot (-n32) (-n64) -nocxx -objc -objc++ -objc-gc -test -vanilla" 0 kB
[ebuild R ] sys-libs/glibc-2.5-r4 USE="build* nls nptl nptlonly -debug -glibc-compat20 -glibc-omitfp (-hardened) (-multilib) -profile (-selinux)" 0 kB
[ebuild U ] dev-libs/glib-2.12.13 [2.12.11] USE="-debug -doc (-hardened)" 2,870 kB
[ebuild U ] dev-perl/Crypt-SSLeay-0.55 [0.51-r1] 119 kB
[ebuild R ] app-crypt/gnupg-1.9.21 USE="X* nls -gpg2-experimental -ldap (-selinux) -smartcard" 0 kB
[ebuild U ] x11-libs/pango-1.16.4 [1.14.10] USE="-debug -doc" 1,325 kB
[ebuild U ] dev-libs/atk-1.18.0 [1.12.4] USE="-debug -doc" 641 kB
[ebuild R ] gnome-base/libgtop-2.14.8 USE="X* gdbm -debug" 0 kB
[ebuild R ] net-print/cups-1.2.10-r1 USE="X* jpeg* nls pam ssl -dbus -ldap -php -png -ppds -samba -slp -tiff" 0 kB
[ebuild U ] dev-libs/liboil-0.3.12 [0.3.10-r1] USE="-doc" 792 kB
[ebuild U ] x11-libs/gtk+-2.10.14 [2.10.11] USE="X jpeg* -debug -doc -tiff -xinerama" 14,817 kB
[ebuild R ] media-libs/gst-plugins-base-0.10.11 USE="X* alsa* -debug -esd -oss -xv" 0 kB
[ebuild R ] dev-python/dbus-python-0.80.2 USE="-test%" 0 kB
[ebuild N ] mail-filter/spamassassin-3.2.1-r1 USE="berkdb ipv6 ssl -doc -ldap -mysql -postgres -qmail -sqlite -tools" 959 kB
[ebuild U ] gnome-base/gconf-2.18.0.1 [2.14.0] USE="-debug -doc" 1,317 kB
[ebuild U ] x11-libs/libwnck-2.18.3 [2.16.3] USE="-debug -doc" 471 kB
[ebuild R ] app-text/ghostscript-gpl-8.54 USE="X* cups gtk* -cjk -djvu -jpeg2k (-emacs%)" 0 kB
[ebuild NS ] media-plugins/gst-plugins-alsa-0.10.11 0 kB
[ebuild N ] media-plugins/gst-plugins-x-0.10.11 0 kB
[ebuild R ] gnome-base/libgnomecanvas-2.14.0 USE="X* -debug -doc" 0 kB
[ebuild U ] x11-misc/notification-daemon-0.3.7 [0.3.6-r1] USE="-debug" 403 kB
[ebuild R ] app-text/poppler-bindings-0.5.4 USE="gtk* -cairo -qt3* -qt4*" 0 kB
[ebuild N ] x11-themes/gnome-themes-2.16.3 USE="-accessibility -debug" 2,298 kB
[ebuild U ] x11-libs/libnotify-0.4.4 [0.4.3] USE="-doc" 387 kB
[ebuild R ] gnome-extra/libgsf-1.14.3 USE="gnome* python -bzip2 -debug -doc" 0 kB
[ebuild R ] gnome-base/librsvg-2.16.1-r1 USE="gnome* zlib -debug -doc" 0 kB
[ebuild N ] x11-misc/alacarte-0.10.2 USE="-debug" 197 kB
[ebuild R ] gnome-extra/gucharmap-1.8.0 USE="gnome* -cjk -debug" 0 kB
[ebuild U ] www-client/mozilla-firefox-2.0.0.6 [2.0.0.4] USE="gnome* ipv6 -bindist -debug -filepicker -java -mozdevelop -moznopango -restrict-javascript -xforms -xinerama -xprint" LINGUAS="fr it -af -ar -be -bg -ca -cs -da -de -el -en_GB -es -es_AR -es_ES -eu -fi -fy -fy_NL -ga -ga_IE -gu -gu_IN -he -hu -ja -ka -ko -ku -lt -mk -mn -nb -nb_NO -nl -nn -nn_NO -pa -pa_IN -pl -pt -pt_BR -pt_PT -ro -ru -sk -sl -sv -sv_SE -tr -zh -zh_CN -zh_TW" 36,828 kB
[ebuild N ] gnome-extra/gnome-keyring-manager-2.16.0-r1 USE="-debug -static" 444 kB
[ebuild N ] gnome-extra/gnome-games-2.16.3 USE="-artworkextra -debug -guile" 5,153 kB
[ebuild N ] gnome-extra/gnome-system-monitor-2.16.1 USE="-debug" 1,446 kB
[ebuild N ] gnome-extra/gcalctool-5.8.25-r1 USE="-debug" 1,120 kB
[ebuild N ] x11-terms/gnome-terminal-2.16.1 USE="-debug" 1,798 kB
[ebuild N ] gnome-extra/gnome-screensaver-2.16.2-r1 USE="opengl pam -debug -doc -xinerama" 1,988 kB
[ebuild N ] net-misc/vino-2.16.0-r1 USE="crypt jpeg zlib -avahi -debug -gnutls" 580 kB
[ebuild N ] mail-client/evolution-2.8.3-r2 USE="crypt hal ipv6 ssl -bogofilter -dbus -debug -doc -kerberos -krb4 -ldap -mono -nntp -pda -profile -spell" 12,629 kB
[ebuild N ] app-admin/pessulus-2.16.2 USE="-debug -doc" 142 kB
[ebuild N ] www-client/epiphany-2.16.3 USE="python -debug -doc" 4,133 kB
[ebuild N ] gnome-extra/yelp-2.16.2 USE="-beagle -debug" 839 kB
[ebuild N ] media-gfx/eog-2.16.3 USE="jpeg -debug -lcms" 1,047 kB
[ebuild R ] gnome-base/nautilus-2.16.3 USE="X gnome* -beagle -debug" 0 kB
[ebuild N ] net-analyzer/gnome-netstatus-2.12.1 USE="-debug" 489 kB
[ebuild N ] gnome-extra/gnome-utils-2.16.2-r2 USE="hal ipv6 -debug" 3,291 kB
[ebuild R ] gnome-base/gnome-mount-0.6 USE="gnome* -debug" 0 kB
[ebuild R ] media-video/totem-2.16.5 USE="dvd gnome* hal -a52 -dbus -debug -ffmpeg -firefox -flac -lirc -mad -mpeg -nsplugin -nvtv -ogg -theora -vorbis -xine -xv" 0 kB
[ebuild R ] x11-libs/gksu-2.0.0 USE="gnome* -debug -doc" 0 kB
[ebuild N ] app-text/evince-0.6.1-r3 USE="gnome -dbus -debug -djvu -doc -dvi -t1lib -tiff" 0 kB
[ebuild N ] app-arch/file-roller-2.16.3 USE="gnome -debug" 1,105 kB
[ebuild N ] net-analyzer/gnome-nettool-2.16.0 USE="-debug" 491 kB
[ebuild N ] gnome-base/gdm-2.16.7 USE="ipv6 pam tcpd -accessibility -debug (-selinux) -xinerama" 3,484 kB
[ebuild N ] gnome-base/gnome-session-2.16.3 USE="branding ipv6 tcpd -debug -esd" 744 kB
[ebuild N ] net-print/gnome-cups-manager-0.31-r2 USE="-debug" 875 kB
[ebuild N ] app-editors/gedit-2.16.2-r1 USE="python -debug -doc -spell" 2,786 kB
[ebuild N ] gnome-base/gnome-2.16.3 USE="cdr cups hal -accessibility -dvdr -ldap" 0 kB
[blocks B ] perl-core/Test-Harness (is blocking dev-lang/perl-5.8.8-r2)

Total: 105 packages (33 upgrades, 34 new, 2 in new slots, 36 reinstalls, 1 block), Size of downloads: 183,261 kB
daviputer ~ #

Ecco dopo aver fatto quickpkg e unmerso perl.

daviputer ~ # emerge -avt gnome
!!! Invalid PORTDIR_OVERLAY (not a dir): '/usr/local/portage'
!!! Invalid PORTDIR_OVERLAY (not a dir): '/usr/portage/xeffects/trunk'

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild N ] gnome-base/gnome-2.16.3 USE="cdr cups hal -accessibility -dvdr -ldap" 0 kB
[ebuild N ] net-print/gnome-cups-manager-0.31-r2 USE="-debug" 875 kB
[ebuild N ] media-gfx/eog-2.16.3 USE="jpeg -debug -lcms" 1,047 kB
[ebuild N ] net-misc/vino-2.16.0-r1 USE="crypt jpeg zlib -avahi -debug -gnutls" 580 kB
[ebuild N ] x11-themes/gnome-themes-2.16.3 USE="-accessibility -debug" 2,298 kB
[ebuild N ] gnome-extra/yelp-2.16.2 USE="-beagle -debug" 839 kB
[ebuild N ] gnome-extra/gnome-screensaver-2.16.2-r1 USE="opengl pam -debug -doc -xinerama" 1,988 kB
[ebuild N ] gnome-extra/gnome2-user-docs-2.16.1 USE="-debug" 3,912 kB
[ebuild N ] gnome-base/gnome-session-2.16.3 USE="branding ipv6 tcpd -debug -esd" 744 kB
[ebuild N ] www-client/epiphany-2.16.3 USE="python -debug -doc" 4,133 kB
[ebuild N ] gnome-extra/gnome-utils-2.16.2-r2 USE="hal ipv6 -debug" 3,291 kB
[ebuild N ] app-editors/gedit-2.16.2-r1 USE="python -debug -doc -spell" 2,786 kB
[ebuild N ] x11-terms/gnome-terminal-2.16.1 USE="-debug" 1,798 kB
[ebuild N ] gnome-base/gdm-2.16.7 USE="ipv6 pam tcpd -accessibility -debug (-selinux) -xinerama" 3,484 kB
[ebuild N ] net-analyzer/gnome-nettool-2.16.0 USE="-debug" 491 kB
[ebuild N ] gnome-extra/gcalctool-5.8.25-r1 USE="-debug" 1,120 kB
[ebuild N ] gnome-extra/gnome-system-monitor-2.16.1 USE="-debug" 1,446 kB
[ebuild N ] app-admin/pessulus-2.16.2 USE="-debug -doc" 142 kB
[ebuild N ] gnome-extra/gnome-games-2.16.3 USE="-artworkextra -debug -guile" 5,153 kB
[ebuild N ] mail-client/evolution-2.8.3-r2 USE="crypt hal ipv6 ssl -bogofilter -dbus -debug -doc -kerberos -krb4 -ldap -mono -nntp -pda -profile -spell" 12,629 kB
[ebuild N ] mail-filter/spamassassin-3.2.1-r1 USE="berkdb ipv6 ssl -doc -ldap -mysql -postgres -qmail -sqlite -tools" 959 kB
[ebuild N ] dev-perl/Net-DNS-0.60 USE="ipv6" 144 kB
[ebuild N ] dev-perl/Digest-HMAC-1.01-r1 14 kB
[ebuild N ] gnome-extra/gnome-keyring-manager-2.16.0-r1 USE="-debug -static" 444 kB
[ebuild N ] x11-misc/alacarte-0.10.2 USE="-debug" 197 kB
[ebuild N ] net-analyzer/gnome-netstatus-2.12.1 USE="-debug" 489 kB
[ebuild N ] app-arch/file-roller-2.16.3 USE="gnome -debug" 1,105 kB
[ebuild N ] app-text/evince-0.6.1-r3 USE="gnome -dbus -debug -djvu -doc -dvi -t1lib -tiff" 0 kB
[nomerge ] dev-perl/Net-DNS-0.60 USE="ipv6"
[ebuild N ] dev-lang/perl-5.8.8-r2 USE="berkdb build gdbm -debug -doc -ithreads -perlsuid" 0 kB

Total: 29 packages (29 new), Size of downloads: 52,095 kB

Would you like to merge these packages? [Yes/No] Yes
_________________
Gentoo the best of the best...
Back to top
View user's profile Send private message
vdavi81
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jun 2006
Posts: 96
Location: Bonde

PostPosted: Sat Aug 11, 2007 2:33 pm    Post subject: Reply with quote

Scusa ma era questo il vero outout .. prima avevo copiato un altra cosa:



These are the packages that would be merged, in order:

Calculating dependencies... done!

[ebuild U ] sys-apps/portage-2.1.2.11 [2.1.2.9] USE="build* -doc -epydoc (-selinux)" LINGUAS="-pl" 327 kB
*** Portage will stop merging at this point and reload itself,
then resume the merge.
[ebuild R ] sys-apps/texinfo-4.8-r5 USE="build* nls -static" 1,487 kB
[ebuild N ] dev-util/unifdef-1.20 65 kB
[ebuild U ] net-dns/bind-tools-9.4.1_p1 [9.4.1-r1] USE="ipv6 -idn" 6,193 kB
[ebuild R ] sys-libs/ncurses-5.6-r1 USE="build* gpm unicode -bootstrap -debug -doc -minimal -nocxx -trace" 0 kB
[ebuild U ] sys-kernel/linux-headers-2.6.21 [2.6.17-r2] USE="(-gcc64%)" 4,287 kB
[ebuild R ] sys-apps/sed-4.1.5 USE="nls -static" 0 kB
[ebuild U ] app-shells/bash-3.2_p17 [3.2_p15-r1] USE="nls -afs -bashlogger -vanilla" 5 kB
[ebuild U ] sys-apps/findutils-4.3.8 [4.3.7] USE="nls (-selinux) -static" 1,766 kB
[ebuild R ] sys-apps/baselayout-1.12.9-r2 USE="build* unicode -bootstrap -static" 0 kB
[ebuild U ] dev-libs/libcdio-0.78.2 [0.77] USE="nls -cddb -minimal -nocxx" 1,977 kB
[ebuild U ] sys-libs/readline-5.2_p4 [5.1_p4] 1,996 kB
[ebuild U ] sys-fs/udev-104-r13 [104-r12] USE="(-selinux)" 0 kB
[ebuild U ] perl-core/libnet-1.21 [1.20-r1] USE="-sasl" 67 kB
[ebuild N ] perl-core/Test-Harness-2.64 0 kB
[ebuild NS ] sys-kernel/gentoo-sources-2.6.21-r4 USE="build -symlink" 43,180 kB
[ebuild U ] dev-perl/HTML-Parser-3.56 [3.55] USE="unicode" 85 kB
[ebuild R ] sys-fs/cryptsetup-luks-1.0.4-r3 USE="build* nls -dynamic (-selinux)" 0 kB
[ebuild U ] virtual/perl-libnet-1.21 [1.20] 0 kB
[ebuild U ] dev-perl/IO-Socket-SSL-1.07 [1.06] 46 kB
[ebuild R ] sys-apps/groff-1.19.2-r1 USE="X* -cjk" 2,836 kB
[ebuild N ] dev-perl/Digest-HMAC-1.01-r1 14 kB
[ebuild N ] dev-perl/Net-DNS-0.60 USE="ipv6" 144 kB
[ebuild N ] media-gfx/xloadimage-4.1-r4 USE="jpeg -png -tiff" 623 kB
[ebuild R ] sys-apps/dbus-1.0.2-r2 USE="X* -debug -doc (-selinux)" 0 kB
[ebuild R ] x11-apps/xdpyinfo-1.0.2 USE="dga* -debug -dmx -xinerama" 0 kB
[ebuild R ] media-libs/libmpeg2-0.4.1 USE="X* -sdl" 0 kB
[ebuild N ] x11-misc/xdg-utils-1.0.1 276 kB
[ebuild R ] dev-lang/python-2.4.4-r4 USE="berkdb build* gdbm ipv6 ncurses readline ssl -bootstrap -doc -examples -nocxx -nothreads -tk -ucs2" 0 kB
[ebuild R ] media-libs/freetype-2.3.4-r2 USE="X* zlib -bindist -debug -doc" 0 kB
[ebuild U ] dev-perl/Compress-Raw-Zlib-2.004-r1 [2.004] 0 kB
[ebuild U ] sys-apps/pciutils-2.2.4-r3 [2.2.3-r2] USE="hal%* zlib%* -network-cron%" 206 kB
[ebuild R ] media-gfx/imagemagick-6.3.4-r1 USE="X* jpeg* perl zlib -bzip2 -doc -fpx -graphviz -gs -hdri -jbig -jpeg2k -lcms -mpeg -nocxx -openexr -png -q32 -q8 -tiff -truetype -wmf -xml" 0 kB
[ebuild R ] media-libs/tiff-3.8.2-r2 USE="jpeg* zlib -jbig -nocxx" 0 kB
[ebuild U ] dev-python/pycrypto-2.0.1-r6 [2.0.1-r5] USE="-bindist -gmp -test" 151 kB
[ebuild U ] sys-apps/file-4.21-r1 [4.20-r1] USE="python" 538 kB
[ebuild U ] app-admin/eselect-1.0.10 [1.0.7] USE="-bash-completion -doc -vim-syntax%" 150 kB
[ebuild R ] app-text/poppler-0.5.4-r1 USE="jpeg* zlib -cjk" 0 kB
[ebuild R ] media-fonts/font-adobe-75dpi-1.0.0 USE="X* nls" 0 kB
[ebuild R ] media-fonts/font-misc-misc-1.0.0 USE="X* nls" 0 kB
[ebuild R ] media-fonts/font-cursor-misc-1.0.0 USE="X* nls" 0 kB
[ebuild U ] dev-perl/IO-Zlib-1.05 [1.04] 10 kB
[ebuild R ] x11-libs/cairo-1.4.10 USE="X opengl -debug -directfb -doc -glitz* -svg -xcb (-newspr%)" 0 kB
[ebuild R ] media-sound/esound-0.2.36-r2 USE="alsa* ipv6 tcpd -debug" 0 kB
[ebuild U ] net-misc/openssh-4.6_p1-r3 [4.5_p1-r1] USE="X* pam tcpd -X509 -chroot -hpn -kerberos -ldap -libedit (-selinux) -skey -smartcard -static" 945 kB
[ebuild U ] dev-perl/XML-LibXML-1.63 [1.62.001-r1] 256 kB
[ebuild U ] media-libs/mesa-6.5.3 [6.5.2-r1] USE="nptl -debug -doc (-hardened) -motif -xcb" VIDEO_CARDS="i810 via -mach64 -mga -none -r128 -radeon -s3virge -savage -sis (-sunffb) -tdfx -trident" 3,274 kB
[ebuild U ] dev-python/pycairo-1.4.0 [1.2.2] USE="-examples (-numeric%)" 469 kB
[ebuild N ] gnome-extra/gnome2-user-docs-2.16.1 USE="-debug" 3,912 kB
[ebuild R ] sys-devel/gcc-4.1.2 USE="build* fortran gtk* mudflap nls (-altivec) -bootstrap -d -doc -gcj (-hardened) -ip28 -ip32r10k (-multilib) -multislot (-n32) (-n64) -nocxx -objc -objc++ -objc-gc -test -vanilla" 0 kB
[ebuild R ] sys-libs/glibc-2.5-r4 USE="build* nls nptl nptlonly -debug -glibc-compat20 -glibc-omitfp (-hardened) (-multilib) -profile (-selinux)" 0 kB
[ebuild U ] dev-libs/glib-2.12.13 [2.12.11] USE="-debug -doc (-hardened)" 2,870 kB
[ebuild U ] dev-perl/Crypt-SSLeay-0.55 [0.51-r1] 119 kB
[ebuild R ] app-crypt/gnupg-1.9.21 USE="X* nls -gpg2-experimental -ldap (-selinux) -smartcard" 0 kB
[ebuild U ] x11-libs/pango-1.16.4 [1.14.10] USE="-debug -doc" 1,325 kB
[ebuild U ] dev-libs/atk-1.18.0 [1.12.4] USE="-debug -doc" 641 kB
[ebuild R ] gnome-base/libgtop-2.14.8 USE="X* gdbm -debug" 0 kB
[ebuild R ] net-print/cups-1.2.10-r1 USE="X* jpeg* nls pam ssl -dbus -ldap -php -png -ppds -samba -slp -tiff" 0 kB
[ebuild U ] dev-libs/liboil-0.3.12 [0.3.10-r1] USE="-doc" 792 kB
[ebuild U ] x11-libs/gtk+-2.10.14 [2.10.11] USE="X jpeg* -debug -doc -tiff -xinerama" 14,817 kB
[ebuild R ] media-libs/gst-plugins-base-0.10.11 USE="X* alsa* -debug -esd -oss -xv" 0 kB
[ebuild R ] dev-python/dbus-python-0.80.2 USE="-test%" 0 kB
[ebuild N ] mail-filter/spamassassin-3.2.1-r1 USE="berkdb ipv6 ssl -doc -ldap -mysql -postgres -qmail -sqlite -tools" 959 kB
[ebuild U ] gnome-base/gconf-2.18.0.1 [2.14.0] USE="-debug -doc" 1,317 kB
[ebuild U ] x11-libs/libwnck-2.18.3 [2.16.3] USE="-debug -doc" 471 kB
[ebuild R ] app-text/ghostscript-gpl-8.54 USE="X* cups gtk* -cjk -djvu -jpeg2k (-emacs%)" 0 kB
[ebuild NS ] media-plugins/gst-plugins-alsa-0.10.11 0 kB
[ebuild N ] media-plugins/gst-plugins-x-0.10.11 0 kB
[ebuild R ] gnome-base/libgnomecanvas-2.14.0 USE="X* -debug -doc" 0 kB
[ebuild U ] x11-misc/notification-daemon-0.3.7 [0.3.6-r1] USE="-debug" 403 kB
[ebuild N ] x11-themes/gnome-themes-2.16.3 USE="-accessibility -debug" 2,298 kB
[ebuild U ] x11-libs/libnotify-0.4.4 [0.4.3] USE="-doc" 387 kB
[ebuild R ] gnome-extra/libgsf-1.14.3 USE="gnome* python -bzip2 -debug -doc" 0 kB
[ebuild R ] gnome-base/librsvg-2.16.1-r1 USE="gnome* zlib -debug -doc" 0 kB
[ebuild N ] x11-misc/alacarte-0.10.2 USE="-debug" 197 kB
[ebuild R ] gnome-extra/gucharmap-1.8.0 USE="gnome* -cjk -debug" 0 kB
[ebuild U ] www-client/mozilla-firefox-2.0.0.6 [2.0.0.4] USE="gnome* ipv6 -bindist -debug -filepicker -java -mozdevelop -moznopango -restrict-javascript -xforms -xinerama -xprint" LINGUAS="fr it -af -ar -be -bg -ca -cs -da -de -el -en_GB -es -es_AR -es_ES -eu -fi -fy -fy_NL -ga -ga_IE -gu -gu_IN -he -hu -ja -ka -ko -ku -lt -mk -mn -nb -nb_NO -nl -nn -nn_NO -pa -pa_IN -pl -pt -pt_BR -pt_PT -ro -ru -sk -sl -sv -sv_SE -tr -zh -zh_CN -zh_TW" 36,828 kB
[ebuild N ] gnome-extra/gnome-keyring-manager-2.16.0-r1 USE="-debug -static" 444 kB
[ebuild N ] gnome-extra/gnome-games-2.16.3 USE="-artworkextra -debug -guile" 5,153 kB
[ebuild N ] gnome-extra/gnome-system-monitor-2.16.1 USE="-debug" 1,446 kB
[ebuild N ] gnome-extra/gcalctool-5.8.25-r1 USE="-debug" 1,120 kB
[ebuild N ] x11-terms/gnome-terminal-2.16.1 USE="-debug" 1,798 kB
[ebuild N ] gnome-extra/gnome-screensaver-2.16.2-r1 USE="opengl pam -debug -doc -xinerama" 1,988 kB
[ebuild N ] net-misc/vino-2.16.0-r1 USE="crypt jpeg zlib -avahi -debug -gnutls" 580 kB
[ebuild N ] mail-client/evolution-2.8.3-r2 USE="crypt hal ipv6 ssl -bogofilter -dbus -debug -doc -kerberos -krb4 -ldap -mono -nntp -pda -profile -spell" 12,629 kB
[ebuild N ] app-admin/pessulus-2.16.2 USE="-debug -doc" 142 kB
[ebuild N ] www-client/epiphany-2.16.3 USE="python -debug -doc" 4,133 kB
[ebuild N ] gnome-extra/yelp-2.16.2 USE="-beagle -debug" 839 kB
[ebuild N ] media-gfx/eog-2.16.3 USE="jpeg -debug -lcms" 1,047 kB
[ebuild R ] gnome-base/nautilus-2.16.3 USE="X gnome* -beagle -debug" 0 kB
[ebuild N ] net-analyzer/gnome-netstatus-2.12.1 USE="-debug" 489 kB
[ebuild N ] gnome-extra/gnome-utils-2.16.2-r2 USE="hal ipv6 -debug" 3,291 kB
[ebuild R ] gnome-base/gnome-mount-0.6 USE="gnome* -debug" 0 kB
[ebuild R ] media-video/totem-2.16.5 USE="dvd gnome* hal -a52 -dbus -debug -ffmpeg -firefox -flac -lirc -mad -mpeg -nsplugin -nvtv -ogg -theora -vorbis -xine -xv" 0 kB
[ebuild R ] x11-libs/gksu-2.0.0 USE="gnome* -debug -doc" 0 kB
[ebuild N ] app-text/evince-0.6.1-r3 USE="gnome -dbus -debug -djvu -doc -dvi -t1lib -tiff" 0 kB
[ebuild N ] app-arch/file-roller-2.16.3 USE="gnome -debug" 1,105 kB
[ebuild N ] net-analyzer/gnome-nettool-2.16.0 USE="-debug" 491 kB
[ebuild N ] gnome-base/gdm-2.16.7 USE="ipv6 pam tcpd -accessibility -debug (-selinux) -xinerama" 3,484 kB
[ebuild N ] gnome-base/gnome-session-2.16.3 USE="branding ipv6 tcpd -debug -esd" 744 kB
[ebuild N ] net-print/gnome-cups-manager-0.31-r2 USE="-debug" 875 kB
[ebuild N ] app-editors/gedit-2.16.2-r1 USE="python -debug -doc -spell" 2,786 kB
[ebuild N ] gnome-base/gnome-2.16.3 USE="cdr cups hal -accessibility -dvdr -ldap" 0 kB
[blocks B ] perl-core/Test-Harness (is blocking dev-lang/perl-5.8.8-r2)

Total: 103 packages (33 upgrades, 33 new, 2 in new slots, 35 reinstalls, 1 block), Size of downloads: 183,261 kB

!!! Error: The above package list contains packages which cannot be installed
!!! at the same time on the same system.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
_________________
Gentoo the best of the best...
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Sat Aug 11, 2007 6:14 pm    Post subject: Reply with quote

Non ho capito, nel tuo ultimo messaggio l'aggiornamento è bloccato, ma nel secondo del penultimo (dopo aver rimosso perl) risulta fattibile, qual'è quello in cui ti ritrovi ora?

Se proprio risultasse ancora bloccato, visto che vedo numerosi pacchetti che nulla hanno a che fare con gnome, aggiorna l'intero sistema (emerge -uDavN world) e poi installa gnome.
Back to top
View user's profile Send private message
vdavi81
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jun 2006
Posts: 96
Location: Bonde

PostPosted: Sun Aug 12, 2007 4:17 am    Post subject: Reply with quote

riverdragon wrote:
Non ho capito, nel tuo ultimo messaggio l'aggiornamento è bloccato, ma nel secondo del penultimo (dopo aver rimosso perl) risulta fattibile, qual'è quello in cui ti ritrovi ora?

Se proprio risultasse ancora bloccato, visto che vedo numerosi pacchetti che nulla hanno a che fare con gnome, aggiorna l'intero sistema (emerge -uDavN world) e poi installa gnome.


Per adesso mi trovo nell'ultimo.
Non sono nelle condizioni di fare un emerge world. Poichè ho un pc celeron mobile a 1,3 GHz. Quindi impiegherei una cifra. il mio intento era quello di avere sia gnome che kde naturalemnete de è gia installato. Se faccio un emerge ec.. world con i flag modificati rischio di compromettere il funzionamento di kde a cui tengo di più che gnome.

Il proble di avere fatto una mezza installazione di gnome è che molti programmi che usano le gtk sno ora compromessi.....In pratica con la mia genialata mi sono sputtanato il sistema.
_________________
Gentoo the best of the best...
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sun Aug 12, 2007 5:34 am    Post subject: Reply with quote

vdavi81 wrote:
riverdragon wrote:
L'errore segnala una possibile fonte: hai abilitato la USE "build"?


Si lo avevo fatto ma sembra che non conti a nulla. Il problema lo da ugualmente.
Cosa potrà mai essere?

ma attualemente, hai tolto definitivamente quella USE?

inoltre, hai compilato così tutto il sistema? i problemi potrebbero venire proprio da lì:
Code:

s939 ~ # euse -i build
global use flags (searching: build)
************************************************************
[-    ] build - !!internal use only!! DO NOT SET THIS FLAG YOURSELF!, used for creating build images and the first half of bootstrapping [make stage1]

local use flags (searching: build)
************************************************************
no matching entries found

come che sia, a questo punto lascierei perdere l'aggiornamento di gnome fino ad avere reintegrato l'installazione.
esiste il comando perl-cleaner. usa l'opzione --help per la sintassi e porta pazienza, perché ne avrai bisogno.

se non basta, lancia un `emerge -e system`.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Sun Aug 12, 2007 10:07 am    Post subject: Reply with quote

Concordo con quanto dice cloc3, a giudicare da questa riga
Code:
[ebuild R ] sys-apps/texinfo-4.8-r5 USE="build* nls -static" 1,487 kB
direi che hai ancora la USE build attiva. Toglila e riprova.
Back to top
View user's profile Send private message
vdavi81
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jun 2006
Posts: 96
Location: Bonde

PostPosted: Sun Aug 12, 2007 11:51 am    Post subject: Reply with quote

riverdragon wrote:
Concordo con quanto dice cloc3, a giudicare da questa riga
Code:
[ebuild R ] sys-apps/texinfo-4.8-r5 USE="build* nls -static" 1,487 kB
direi che hai ancora la USE build attiva. Toglila e riprova.


Si adesso ho tolto la flag USE...

Il problema è il seguente: Questo pacchetto

perl-core/Test-Harness (is blocking dev-lang/perl-5.8.8-r2) (1)

è mascherato da perl-core/Test-Harness (is blocking dev-lang/perl-5.8.8-r2)(2)

Prima era installato (1), ma io per smascherare (2). L'ho disinstallato. Solo che se io installo (2) senza (1), nessuno problema.... Però non vale l viceversa
perchè (2) è una dpendenza di (1). Immagino che non ci cairete nulla, ma non è facile spiegare.

Quindi ho n sistema che va tutto aggiustato, perch tra installazioni aggiornamente e cambi di flagari mi sonosputtanato il sistema.. E voi sapete bene cosa significa formattare tutto e rienstalare il sistema, quando si ha a che fare con gentoo.

Quindi se io non fossi stato tantomongoloide da cancellare (1), ma avessi fatto realmente quickpkg (1) && emerge -C (1). Come consiglato (Solo che quando ho letto il forum lo avevo gia fatto), probabilmente adesso andrebbe tutto . Come faccio con questi 2 pacchetti per avere gnome devno essere
entrambi presenti .


Help me. Probabilmente faro anche un emerge world del sistema. Ma quasto lo discuteremo in altro thread, dove parleremo della compilazione distribuita.
_________________
Gentoo the best of the best...
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Sun Aug 12, 2007 4:28 pm    Post subject: Reply with quote

Questo è quanto scritto nell'ebuild:
Code:
RDEPEND="~sys-devel/libperl-${PV}
        berkdb? ( sys-libs/db )
        gdbm? ( >=sys-libs/gdbm-1.8.3 )
        build? ( !perl-core/Test-Harness )"
ovvero: perl compilato con la use build NON vuole test-harness. Rimuovi test-harness, poi prova a ricompilare perl senza la use build (emerge -1N perl) e quindi riprendi. Ricordati, quando installi, di specificare l'opzione --newuse (o -N) perché devi ricompilare tutti i pacchetti che hanno erroneamente la use build impostata.
Back to top
View user's profile Send private message
vdavi81
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jun 2006
Posts: 96
Location: Bonde

PostPosted: Sun Aug 12, 2007 11:06 pm    Post subject: Reply with quote

Sembra che stia compilndo. Quindi abbiamo risolto il problema.


Ultima domanda. Quando faro l'emergeworld come devono essere settate le flag USE per far si che sia gnome che KDE possano convibere nello stesso sistema?

Perchè qui mi sembra una coperta corta ho setti per uno o setti per l'altro
_________________
Gentoo the best of the best...
Back to top
View user's profile Send private message
riverdragon
Veteran
Veteran


Joined: 14 Sep 2006
Posts: 1269
Location: Verona

PostPosted: Mon Aug 13, 2007 12:05 am    Post subject: Reply with quote

vdavi81 wrote:
Perchè qui mi sembra una coperta corta ho setti per uno o setti per l'altro
Assolutamente no, le use gnome, gtk aggiungono il supporto per gnome, le use kde, qt3, qt4 aggiungono il supporto per kde. Non sono alternative le une alle altre.
Back to top
View user's profile Send private message
vdavi81
Tux's lil' helper
Tux's lil' helper


Joined: 06 Jun 2006
Posts: 96
Location: Bonde

PostPosted: Tue Aug 14, 2007 12:58 am    Post subject: Reply with quote

Bene questo guaio lo messo a posto. Ho fatto l'errore di togliere i flag per kde. Per adesso considero risolto il Thread. Quando faro l'emerge world. Magari proverò con la compilazione distribuita, prima intanto provo il sstema, per vedere cosa è venuto fuori. Per adesso vi saluto.
_________________
Gentoo the best of the best...
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Tue Aug 14, 2007 4:05 am    Post subject: Reply with quote

vdavi81 wrote:
Magari proverò con la compilazione distribuita.

parti da qui.
assicurati che tutti gli host facciano uso della stessa versione di gcc.

comincia da configurazioni semplificate, per non cercare complicazioni impreviste in cui rischieresti di perdere l'orientamento.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum