Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
E' possibile?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
mokusei
n00b
n00b


Joined: 13 Jan 2007
Posts: 7

PostPosted: Mon Aug 06, 2007 4:32 pm    Post subject: E' possibile? Reply with quote

Salve a tutti,
sapete se c'e' un indirizzo da cui emergere vecchi pacchetti? Mi servirebbe, per un portatile non piu' giovanissimo (933 MHZ), installare gentoo con l'ultimo xfree al posto di xorg e con le glibc precedenti alla versione 2.1. Se no, avete soluzioni alternative? Grazie per avermi letto,

Marco
Back to top
View user's profile Send private message
.:deadhead:.
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 2963
Location: Milano, Italy

PostPosted: Mon Aug 06, 2007 5:06 pm    Post subject: Reply with quote

li puoi recuperare dal CVS [online qui http://sources.gentoo.org/]

Scegliere però pacchetti vecchi non ti espone a bachi e a codice meno pulito?

Se vuoi un server grafico leggero prova kdrive (attivi la use sotto xorg-server) et voilà.

PS: hai poi risolto questo? https://forums.gentoo.org/viewtopic-p-3844789.html#3844789
_________________
Proudly member of the Gentoo Documentation Project: the Italian Conspiracy ! ;)
Back to top
View user's profile Send private message
mokusei
n00b
n00b


Joined: 13 Jan 2007
Posts: 7

PostPosted: Mon Aug 06, 2007 7:19 pm    Post subject: Reply with quote

.:deadhead:., grazie per avermi risposto. Ricordo che, quando avevo debian, il portatile andava bene con xfree e con xorg un po' soffriva (anche se poco). Adesso sullo stesso ho xorg e, tutto sommato, va bene. Quindi pensavo che, se con gentoo ho xorg e firefox 1.5 e ho, piu' o meno, le stesse prestazioni di quando avevo debian con xfree e firefox 1.0.qualcosa, potevo aumentare le prestazioni con l'accoppiata gentoo e xfree (nonostante il rischio del codice meno pulito). Per quanto riguarda le glibc, io ho le 2.3.6-r5 e, sembra che il Mathematica for students 3.0.1 non le digerisca (va in seg. fault). Da cio' che ho letto nel loro sito questo capitava con la versione 2.1 delle glibc (ma a quanto pare anche con le versioni successive), ecco perche' cercavo i pacchetti vecchi. Il problema di qingy purtroppo non l'ho risolto, eppure lo ho disinstallato e riemerso piu' volte, cancellando anche i file di configurazione, ma nulla. Adesso sono passato a Slim ma mi sono tenuto qingy in un terminale perche' "deve funzionare" e appena ho un po' di tempo indago meglio (specialmente adesso che ho qualche conoscenza in piu' su come si gestisce gentoo, anche se devo ancora imparare molto :wink: ).
Ciao e grazie ancora.

Marco
P.S. KDrive non lo conoscevo adesso mi informo.
Back to top
View user's profile Send private message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 832
Location: Italy

PostPosted: Mon Aug 06, 2007 9:38 pm    Post subject: Reply with quote

kdrive è un server molto leggero. Non ha il supporto per la rotellina del mouse e altre "piccolezze" ma è un buon server grafico ;)

(ma come mai è messo come flag use di xorg? Io ho sempre saputo che fosse un server grafico "a parte")
Back to top
View user's profile Send private message
.:deadhead:.
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 2963
Location: Milano, Italy

PostPosted: Tue Aug 07, 2007 10:19 am    Post subject: Reply with quote

@mokusei
E' un bel problema... oramai le versioni del sw che tu citi sono leggermente antidiluviane... passare ad una nuove release di mathematica probabilmente risolverebbe il problema, non credi? Cmq tutto è fattibile se trovi e scarichi un ebuild in /usr/local/portage (il tuo repository personale) dovresti farcela. Certo è che bugs e compatibilità con sw così datati non viene garantita...


lordalbert wrote:
(ma come mai è messo come flag use di xorg? Io ho sempre saputo che fosse un server grafico "a parte")

Il server kdrive che trovi singolarmente si appoggia ad xfree ed è una vecchia versione. Mediante la USE kdrive applicata al pacchetto xorg tu avrai il vantaggio di avere i pacchetti necessari modulari e d avere versioni aggiornate di tutti i sw.
_________________
Proudly member of the Gentoo Documentation Project: the Italian Conspiracy ! ;)
Back to top
View user's profile Send private message
mokusei
n00b
n00b


Joined: 13 Jan 2007
Posts: 7

PostPosted: Wed Aug 08, 2007 3:17 pm    Post subject: Reply with quote

Grazie a tutti e due per i consigli. Solo una'ultima curiosita': kdrive con la flag use in xorg mi eredita i file di configurazione di xorg, vero? Cioe' gli do' un bel USE="kdrive" emerge xorg-server e poi e' tutto a posto.

Marco
Back to top
View user's profile Send private message
.:deadhead:.
Advocate
Advocate


Joined: 25 Nov 2003
Posts: 2963
Location: Milano, Italy

PostPosted: Thu Aug 09, 2007 8:55 am    Post subject: Reply with quote

mokusei wrote:
Grazie a tutti e due per i consigli. Solo una'ultima curiosita': kdrive con la flag use in xorg mi eredita i file di configurazione di xorg, vero? Cioe' gli do' un bel USE="kdrive" emerge xorg-server e poi e' tutto a posto.

ti consiglio di leggere la doc sul sito, dove vengono spiegate anche le differenze tra i sw: ad es, kdrive non ha configurazione ma le varie opzioni sono specificate in fase di compilazione.
_________________
Proudly member of the Gentoo Documentation Project: the Italian Conspiracy ! ;)
Back to top
View user's profile Send private message
mokusei
n00b
n00b


Joined: 13 Jan 2007
Posts: 7

PostPosted: Fri Aug 10, 2007 4:08 pm    Post subject: Reply with quote

Aggiornamento: ho compilato stamattina xorg-server (e dipendene relative) con USE="kdrive" emerge xorg-server. Ha aggiornato i pacchetti:
[ebuild U ] x11-libs/libdrm-2.3.0 [2.0.2]
[ebuild U ] x11-libs/libXfont-1.2.7-r1 [1.2.2]
[ebuild U ] media-libs/mesa-6.5.3 [6.5.1-r1] USE="-xcb%" VIDEO_CARDS="-i810* -mga* -s3virge* -savage* -tdfx* -trident* -via*"
[ebuild U ] x11-base/xorg-server-1.2.0-r3 [1.1.1-r1] USE="kdrive*" INPUT_DEVICES="-evdev* -mouse*" VIDEO_CARDS="-apm* -ark* -chips* -cirrus* -cyrix* -dummy* -fbdev* -glint* -i128* -i740* -i810* -imstt* -mga* -neomagic* -nsc* -nv* -rendition* -s3* -s3virge* -savage* -siliconmotion* -sisusb* -tdfx* -tga* -trident* -tseng* -v4l* -vesa* -vga* -via* -vmware* -voodoo*"
nel make conf ho le seuenti variabili:
INPUT_DEVICES="ps2mouse keyboard"
VIDEO_CARDS="sis"
La compilazione e' andata bene, pero' in /usr/bin non c'e' Xsis530 (avendo una sis630 e avendo specificato il parametro sis nel make.conf mi aspettavo di trovarlo), pero' ci sono Xfbdev e Xvesa. Qualcuno ha una spiegazione? Ho scordato qualche useflag? Se vi e' di aiuto, la prossima volta, vi posto la variabile USE del make.conf. Ciao.

Marco
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum