Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
frozen-bubble in segmentation fault
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 832
Location: Italy

PostPosted: Thu Aug 02, 2007 11:41 pm    Post subject: frozen-bubble in segmentation fault Reply with quote

Ciao. Ho installato frozen-bubble che però non parte...

in shell quando lo lancio mi da segmentation fault

Code:

[SDL Init] Segmentation fault


ho provato a ricompilare sdl-perl ma nulla, il problema persiste.
Come posso risolverlo?

tnx
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Fri Aug 03, 2007 6:22 am    Post subject: Re: frozen-bubble in segmentation fault Reply with quote

lordalbert wrote:

ho provato a ricompilare sdl-perl ma nulla, il problema persiste.

la dipendenze dai pacchetti sdl sembra più ampia:
Code:

s939 ~ # emerge -pv frozen-bubble

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] media-libs/sdl-gfx-2.0.13-r1  USE="(-mmx)" 585 kB
[ebuild  N    ] media-libs/sdl-ttf-2.0.8  USE="X" 2,400 kB
[ebuild  N    ] media-libs/sdl-net-1.2.6  364 kB
[ebuild  N    ] media-libs/sdl-image-1.2.5-r1  USE="gif jpeg png tiff" 1,290 kB
[ebuild  N    ] media-libs/sdl-pango-0.1.2  400 kB
[ebuild  N    ] dev-perl/sdl-perl-2.1.3-r2  USE="mpeg truetype" 765 kB
[ebuild  N    ] games-arcade/frozen-bubble-2.1.0  19,421 kB

prova a ricompilarli tutti che magari giova.
non bastasse, lancia il programma con strace e leggi l'output, per avere maggiori informazioni:
Code:

# strace -f frozen-bubble > out.txt 2>&1


EDIT: 8)
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 832
Location: Italy

PostPosted: Fri Aug 03, 2007 10:06 am    Post subject: Reply with quote

eheh ok grazie! :)
Back to top
View user's profile Send private message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 832
Location: Italy

PostPosted: Fri Aug 03, 2007 5:16 pm    Post subject: Reply with quote

ho provato a ricompilare ma nulla...

L'output di strace è qua
http://pastebin.com/m76795887

l'ho messo li per non appesantire il forum visto che è molto lungo...
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Fri Aug 03, 2007 7:04 pm    Post subject: Reply with quote

lordalbert wrote:

L'output di strace è qua
http://pastebin.com/m76795887

non sono un esperto di output di strace e non conosco frozen-bubble, però il tuo output sembra molto simile a quello del post che ti ho indicato.

il vero esperto commenta così.
prova se le soluzioni suggerite funzionano anche per te.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 832
Location: Italy

PostPosted: Fri Aug 03, 2007 7:41 pm    Post subject: Reply with quote

grazie, non avevo visto il link postato prima :) adesso leggo

EDIT: quel post consiglia di installare 2 pacchetti... il secondo ce l'ho, il primo invece è solo per sistemi a 64bit. Io ho un p4...
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sat Aug 04, 2007 6:20 am    Post subject: Reply with quote

lordalbert wrote:

EDIT: quel post consiglia di installare 2 pacchetti... il secondo ce l'ho

ricompilalo.
a parte l'architettura, i vostri strace sembrano copie gemelle, che si stoppano dopo il secondo accesso a libpng.so.3.
alla fine, l'autore del topic dice di aver risolto ricompilando una manciata di pacchetti. non si capisce bene quali, ma:
OnlyTux wrote:

I tried re-emerging it with the -D --newuse options.

It emerged other 5 packets

_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 832
Location: Italy

PostPosted: Sat Aug 04, 2007 10:55 am    Post subject: Reply with quote

cloc3 wrote:
lordalbert wrote:

EDIT: quel post consiglia di installare 2 pacchetti... il secondo ce l'ho

ricompilalo.
a parte l'architettura, i vostri strace sembrano copie gemelle, che si stoppano dopo il secondo accesso a libpng.so.3.
alla fine, l'autore del topic dice di aver risolto ricompilando una manciata di pacchetti. non si capisce bene quali, ma:
OnlyTux wrote:

I tried re-emerging it with the -D --newuse options.

It emerged other 5 packets


si quello l'ho letto anche io, e non ho ben capito...
Ma si riferisce ad altri problemi, anche qtorrent non gli partiva, anche se si compilava con successo....

edit: anche ricompilando libpng non cambia niente.
Magari provo a scrivere in seguito a quel post...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum