Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Xorg] Pas d'accès aux terminaux <ctrl>+<alt>+<F1,F2..>
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
zefiloux
n00b
n00b


Joined: 23 Jul 2007
Posts: 35

PostPosted: Thu Jul 26, 2007 7:01 pm    Post subject: [Xorg] Pas d'accès aux terminaux <ctrl>+<alt>+& Reply with quote

Bonjour tout le monde.

J'ai depuis peu réussi à configurer Xorg pour que X marche... Etant donné que je n'arrivais pas à le configurer depuis gentoo, j'ai collé le xorg.conf configuré avec debian il y a quelques semaines.. J'arrive donc à lancer X mais l'écran "hésite" à son démarrage. Comme si il se figeait 2à3 secondes (c'est un fait certain pas une impression..). Le bouton d'allumage de l'écran s'éteind lui-même puis se rallume. Le vrai problème est que je n'arrive plus à voir les terminaux auxquels on accède avec <ctr><alt><Fnombre>... L'écran devient alors noir et affiche lui-même (et non gentoo) le message : impossible d'afficher... (quelquechose du genre..)

Cela est surement dû à xorg.conf mais je ne sais pas quelle section... Je possède une ATI radeon 9800 pro X350 et voici le xorg.conf :

Quote:

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/X11R6/lib/X11/fonts/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "ch"
Option "XkbVariant" "fr"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
EndSection

Section "Device"
Identifier "ATI Technologies Inc Radeon R350 [Radeon 9800 Pro]"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "DELL E172FP"
Option "DPMS"
HorizSync 31-80
VertRefresh 56-75
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies Inc Radeon R350 [Radeon 9800 Pro]"
Monitor "DELL E172FP"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "DRI"
Mode 0666
EndSection



Merci beaucoup à ceux qui essaient de m'aider !


Last edited by zefiloux on Thu Jul 26, 2007 7:59 pm; edited 1 time in total
Back to top
View user's profile Send private message
loopx
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2787
Location: Belgium / Liège

PostPosted: Thu Jul 26, 2007 7:46 pm    Post subject: Reply with quote

uh, je sais pas trop ce qu'il faut régler, mais cette commande (dans le X) fonctionne généralement bien ^^


Code:

setxkbmap -model pc105 -layout be -variant basic



à adapter, je suis belge :p


nan sérieux, dans le xorg.conf, y a un truc...

Code:

Section "InputDevice"
        Identifier  "Keyboard1"
        Driver      "kbd"
        Option      "AutoRepeat" "500 30"
        Option      "XkbLayout" "be"
EndSection


:lol:


bon, je suis de bonne today

dans la section "server layout", il te faut ceci pour le clavier:

Code:

InputDevice    "Keyboard1" "CoreKeyboard"



je pense que ca devrais le faire
_________________
Mon MediaWiki perso : http://pix-mania.dyndns.org
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Thu Jul 26, 2007 7:53 pm    Post subject: Reply with quote

Je suppose que tu parles des touches F1 F2 et pas 1 2 ... sinon c'est normal que ça ne marche pas
Qu'est ce que ça donne si tu utilises un autre pilote que flgrx ?
Back to top
View user's profile Send private message
zefiloux
n00b
n00b


Joined: 23 Jul 2007
Posts: 35

PostPosted: Thu Jul 26, 2007 8:03 pm    Post subject: Reply with quote

Loopx j'ai rien compris à ton post !! lol enfait peut-être le fait que j'ai écris <ctrl><alt><nombre> et pas <ctrl><alt><Fnombre> t'as fais penser que le problème venait du clavier... Je ne pense pas qu'il y ait un rapport, mon clavier se porte bien :) Mais merci pour ta bonne humeure ^^


kopp wrote:
Je suppose que tu parles des touches F1 F2 et pas 1 2


Heu oui bien sur désolé ^^. J'ai édité le premier post et le titre. Pourquoi c'est normal ? A cause du driver et de gentoo ?

Je veux bien essayer avec un autre mais lequel ? L'autre = radeon ? J'avais essayé et j'ai pas réussi je sais pas si ça marche avec la x350...
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Thu Jul 26, 2007 8:25 pm    Post subject: Reply with quote

Je voulais dire que si tu utilisais les chiffres et pas les F1, F2 c'était normal que ça marche pas ;)
Euh, le driver vesa par exemple, je suppose qu'il doit marcher.
Back to top
View user's profile Send private message
zefiloux
n00b
n00b


Joined: 23 Jul 2007
Posts: 35

PostPosted: Thu Jul 26, 2007 8:56 pm    Post subject: Reply with quote

kopp wrote:
Euh, le driver vesa par exemple


Oui mais l'accélération 3D ne marche pas avec vesa ou bien ??
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Thu Jul 26, 2007 9:40 pm    Post subject: Reply with quote

Certainement pas, mais c'est pour essayer de déterminer les causes du plantage. Et vu que les pilotes ATI ne sont pas réputés pour leur stabilité...
Back to top
View user's profile Send private message
loopx
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2787
Location: Belgium / Liège

PostPosted: Fri Jul 27, 2007 7:54 pm    Post subject: Reply with quote

ah oki, je comprend mieux ^^


Regarde du coté du kernel comme on l'a dit plus haut, n'utilise PAS le framebuffer ATI ... Utilise soit "aucun" :D soit celui de vesa-tng (si je me trompe pas :roll: )

recompile le kernel, boot dessus et test :o
_________________
Mon MediaWiki perso : http://pix-mania.dyndns.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum