Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[risolto] Nuovo hard disk - rallentamento sistema
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
!equilibrium
Bodhisattva
Bodhisattva


Joined: 06 Jun 2004
Posts: 2109
Location: MI/BG/LC

PostPosted: Wed Jul 25, 2007 2:40 pm    Post subject: Reply with quote

pingoo wrote:
Beh, in realtà non ne ho l'assoluta certezza ma credo di aver formattato e attivato correttamente lo swap quando ho fatto il passaggio al nuovo hd. Poi ho cambiato kernel in favore dei suspend2 ed ho fatto alcune prove di ibernazione (solo in swap) e infine ho aggiunto l'opzione resume2


a ecco, ora quadra la cosa. se hai usato suspend2 sulla tua partizione di swap, questa quando fai il boot non può più essere vista come swap fino a riavvio avvenuto (almeno era così quando provai suspend2 parecchio tempo fa) e poi devi riformattarla/riattivarla (non ricordo più quale delle due azioni) manualmente; in genere in questi casi o si usa una seconda partizione di swap dedicata al solo suspend, oppure si usa un file immagine al posto dello SWAP (che è il default se non hanno cambiato).

resta comunque indiscusso che il tuo problema della RAM rimane dovuto all'assenza dello swap, infatti (come avevo già riportato prima), tu stesso hai incollato questi valori da meminfo:

Quote:
cat /proc/meminfo
SwapTotal: 0 kB
SwapFree: 0 kB


lo SwapTotal impostato a 0 indica che lo swap non è attivo, altrimenti riporterebbe la dimensione totale della tua partizione di swap.
senza swap e con solo 512Mb di RAM è facile saturare tutta la memoria con firefox e qualche altro applicativo :wink:
_________________
Arch Tester for Gentoo/FreeBSD
Equilibrium's Universe

all my contents are released under the Creative Commons Licence by-nc-nd 2.5
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Wed Jul 25, 2007 2:53 pm    Post subject: Reply with quote

!equilibrium wrote:
pingoo wrote:
Beh, in realtà non ne ho l'assoluta certezza ma credo di aver formattato e attivato correttamente lo swap quando ho fatto il passaggio al nuovo hd. Poi ho cambiato kernel in favore dei suspend2 ed ho fatto alcune prove di ibernazione (solo in swap) e infine ho aggiunto l'opzione resume2


a ecco, ora quadra la cosa. se hai usato suspend2 sulla tua partizione di swap, questa quando fai il boot non può più essere vista come swap fino a riavvio avvenuto (almeno era così quando provai suspend2 parecchio tempo fa) e poi devi riformattarla/riattivarla (non ricordo più quale delle due azioni) manualmente; in genere in questi casi o si usa una seconda partizione di swap dedicata al solo suspend, oppure si usa un file immagine al posto dello SWAP (che è il default se non hanno cambiato).

Questo lo escluderei, poco più di un anno fa usavo tranquillamente suspand2 e non ho mai avuto problemi con la mia unica partizione di swap...
_________________
Le tre grandi virtù di un programmatore: pigrizia, impazienza e arroganza. (Larry Wall).
Prima di postare un file togli i commenti con
Code:
grep -vE '(^[[:space:]]*($|(#|!|;|//)))'
Back to top
View user's profile Send private message
!equilibrium
Bodhisattva
Bodhisattva


Joined: 06 Jun 2004
Posts: 2109
Location: MI/BG/LC

PostPosted: Wed Jul 25, 2007 4:22 pm    Post subject: Reply with quote

Kernel78 wrote:
Questo lo escluderei, poco più di un anno fa usavo tranquillamente suspand2 e non ho mai avuto problemi con la mia unica partizione di swap...


ah ecco, infatti io l'ho usato parecchio tempo fa, quando ancora non era nemmeno in portage ed era solo una patch del kernel.
quindi suspend2 non c'entra nulla.
_________________
Arch Tester for Gentoo/FreeBSD
Equilibrium's Universe

all my contents are released under the Creative Commons Licence by-nc-nd 2.5
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum