Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Is glibc 2.6 stable in Gentoo? What's new in it?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
robbyjo
Guru
Guru


Joined: 06 Apr 2003
Posts: 462

PostPosted: Mon Jul 16, 2007 10:18 pm    Post subject: Is glibc 2.6 stable in Gentoo? What's new in it? Reply with quote

Hi all,

Have any one tried glibc 2.6? Is it stable in Gentoo? What's new in it? Thank you.
Back to top
View user's profile Send private message
Paapaa
l33t
l33t


Joined: 14 Aug 2005
Posts: 955
Location: Finland

PostPosted: Mon Jul 16, 2007 10:39 pm    Post subject: Re: Is glibc 2.6 stable in Gentoo? What's new in it? Reply with quote

robbyjo wrote:
Have any one tried glibc 2.6? Is it stable in Gentoo?


You can check it out here:

http://packages.gentoo.org/packages/?category=sys-libs;name=glibc
_________________
Paludis, the way packages are meant to be managed.
Back to top
View user's profile Send private message
dalu
Guru
Guru


Joined: 20 Jan 2003
Posts: 407

PostPosted: Mon Jul 16, 2007 10:42 pm    Post subject: Reply with quote

good that you're asking because i was just wondering the same
also emerge -p glibc-2.6 (more less) outputs this:

[ebuild U ] sys-libs/glibc-2.6 [2.5-r4] USE="nls -build -debug -glibc-compat20 -glibc-omitfp -hardened (-multilib) -profile (-selinux) (-nptl%*) (-nptlonly%*)" 15,878 kB

what happened to the nptl and nptlonly USE flags and why are they not active?

also , well i don't want to start a new thread on it, but if i have to i will
i noticed some ebuilds were light green, some dark green, whats the reason?
Back to top
View user's profile Send private message
AllenJB
Veteran
Veteran


Joined: 02 Sep 2005
Posts: 1283
Location: Ashford, Kent

PostPosted: Tue Jul 17, 2007 5:41 am    Post subject: Reply with quote

dalu wrote:
good that you're asking because i was just wondering the same
also emerge -p glibc-2.6 (more less) outputs this:

[ebuild U ] sys-libs/glibc-2.6 [2.5-r4] USE="nls -build -debug -glibc-compat20 -glibc-omitfp -hardened (-multilib) -profile (-selinux) (-nptl%*) (-nptlonly%*)" 15,878 kB

what happened to the nptl and nptlonly USE flags and why are they not active?

also , well i don't want to start a new thread on it, but if i have to i will
i noticed some ebuilds were light green, some dark green, whats the reason?

It looks to me like they're being removed. I suspect it means those features are forced on in the latest glibc. But I could be wrong.

See also The GLIBC 2.6 thread
_________________
http://gentoo-wiki.com :: http://lug.org.uk :: http://www.linux.org/groups/ :: User Blogs
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Tue Jul 17, 2007 8:24 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads.

See thread AllenJB linked to.
_________________
www.gentoo.org.au || #gentoo-au
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum