Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Symbolic link changed for no apparent reason (FORGET)
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message

Joined: 27 Apr 2006
Posts: 218
Location: São José dos Campos, São Paulo, Brasil

PostPosted: Wed Aug 22, 2007 4:00 am    Post subject: Symbolic link changed for no apparent reason (FORGET) Reply with quote

Hi. When I tried to load eix, I was told that it couldn't find
So I issued locate, and saw that it resides in /usr/lib/gcc/i686-pc-linux-gnu/4.1.2.
Entering that directory, I saw that was a broken symbolic link to WEIRD, where WEIRD was a weird combination of seemingly random characters. Also, revdep-rebuild was running in another terminal, and when I looked at the output of revdep-rebuild, it wanted to re-emerge a lot of packages because of the lack of

I rebooted the computer, and things are working again. eix works fine. The symbolic link is OK.

jorge@jorge /usr/lib/gcc/i686-pc-linux-gnu/4.1.2 $ file symbolic link to `'

So, what can have changed the symlink and how was it restored without my intervention? Other than a hardware bug that made the kernel go crazy and report wrong contents for the symlink, which was solved when I rebooted the computer, I can't think of any other explanation. This computer has showed a bit of hardware problems (hard lockups) in the past, and it is not impossible that this was a hardware problem. I just would like to know if any gentooer knows of any other possibility.

My emerge --info :

Portage (default-linux/x86/2007.0/desktop, gcc-4.1.2, glibc-2.5-r4, 2.6.22-gentoo-r3 i686)
System uname: 2.6.22-gentoo-r3 i686 AMD Athlon(tm) XP 2600+
Gentoo Base System release 1.12.9
Timestamp of tree: Tue, 21 Aug 2007 06:20:01 +0000
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
CFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=athlon-xp -pipe -fomit-frame-pointer"
FEATURES="distlocks metadata-transfer sandbox sfperms strict"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTDIR_OVERLAY="/usr/local/jorgeportage /usr/portage/local/layman/enlightenment /usr/portage/local/layman/initng"
USE="3dnow 3dnowext 7zip X aac aalib acpi alsa aotuv bash-completion bogofilter branding bzip2 cairo cdr cracklib divx dri emacs emacs-w3 encode evo fam ffmpeg firefox fortran gcj gcl gif glibc-omitfp gmedia gnuplot gpm gstreamer gtk2 gzip-el iconv ipv6 jpeg kdeenablefinal kdehiddenvisibility lesstif libcaca lirc logrotate mad matroska midi mikmod mmx mmxext mng moznopango mp2 mp3 mpeg mplayer mudflap ncurses network-cron nptl nptlonly nsplugin nvidia offensive ogg opengl openmp pam pch pcre pdf png pppd psyco python qt3support quicktime readline realmedia rtc sdl session sox spell sse ssl svg symlink tcltk tcpd theora tiff tk toolkit-scroll-bars truetype truetype-fonts type1-fonts unicode usb v4l v4l2 vorbis wmp x86 xml xorg xosd xv zlib" ALSA_CARDS="cmipci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INITNG_PLUGINS="also bash_launcher chdir chroot conflict cpout critical ctrlaltdel daemon_clean debug_commands envparser find fmon fstat history idleprobe initctl interactive iparser last limit lockfile logfile netdev netprobe ngc4 ngcs nge pause provide reload renice rlparser simple_launcher stcmd stdout suid syncron syslog sysreq unneeded usplash" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIRC_DEVICES="inputlirc" USERLAND="GNU" VIDEO_CARDS="nv nvidia"

Last edited by jorgepeixoto on Wed Aug 22, 2007 8:19 am; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 27 Apr 2006
Posts: 218
Location: São José dos Campos, São Paulo, Brasil

PostPosted: Wed Aug 22, 2007 8:19 am    Post subject: Reply with quote

It seems I do have hardware problems. It seems they are related to my TV capture card (the computer behaves badly when I capture video with mencoder). These problems seem to happen with different versions of mencoder, different kernel versions... Since the computer worked fine some days ago (in fact, it worked even while slightly overclocked; today it has problems even while underclocked), I have no idea of what could cause this... perhaps something damaged my TV card?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum