Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[risolto] Gnome non carica icone temi e impostazioni
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
^Stefano^
Guru
Guru


Joined: 20 Nov 2005
Posts: 394
Location: Ferrara

PostPosted: Thu Jul 12, 2007 3:51 pm    Post subject: [risolto] Gnome non carica icone temi e impostazioni Reply with quote

Oggi riavviando gnome mi trovo davanti a questo messaggio:
Code:
Si è verificato un errore durante l'avvio del demome delle impostazioni di GNOME.

Alcuni aspetti come temi, suoni o impostazioni dello sfondo potrebbero non funzionare correttamente.

L'ultimo messaggio di errore è stato:

Failed to execute dbus-launch to autolaunch D-Bus session

GNOME tenterà di riavviare il demone delle impostazioni al prossimo login.


e difatti i temi e le icone non si vedono. ho provato
Code:
slocate gnome-setting

ed ho ottenuto qualche risultato interessante
Code:
/usr/libexec/gnome-settings-daemon
/usr/include/gnome-settings-daemon-2.0
/usr/include/gnome-settings-daemon-2.0/gnome-settings-daemon
/usr/include/gnome-settings-daemon-2.0/gnome-settings-daemon/gnome-settings-client.h
/usr/lib64/pkgconfig/gnome-settings-daemon.pc

di questi l'unico comando che fa qualcosa è il primo che mi riporta questi errori:
Code:
stefano@blueyes ~ $ /usr/libexec/gnome-settings-daemon

(gnome-settings-daemon:17910): GSwitchIt-WARNING **: Unable to connect to dbus: Failed to execute dbus-launch to autolaunch D-Bus session

** (gnome-settings-daemon:17910): WARNING **: No introspection data registered for object class "KeyboardConfigRegistry"

** (gnome-settings-daemon:17910): CRITICAL **: dbus_g_proxy_new_for_name: assertion `connection != NULL' failed

** (gnome-settings-daemon:17910): CRITICAL **: dbus_g_proxy_call: assertion `DBUS_IS_G_PROXY (proxy)' failed

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Aiuto

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Applica tema

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Applicazioni preferite

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Apri cartella

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Audio

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Barre menu e strumenti

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Browser dei componenti Bonobo

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Calcolatrice

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Cartella Home

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Cattura schermata

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Cerca file...

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Computer

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Editor di testo

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Epiphany - Browser web

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Esplorazione file

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Evolution

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Finestre

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Formattazione floppy

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Gestione dei file

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Gestore portachiavi

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Informazioni su GNOME

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Lockdown Editor

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Modifica menù

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Monitor di sistema

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Mouse

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Plugin di Indicatore tastiera

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Preferenze delle tecnologie assistive

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Proxy di rete

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Registro di sistema

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Salvaschermo

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Scorciatoie da tastiera

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Sessioni

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Sfondo della scrivania

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Tastiera

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Tema

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Tipi di carattere

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Unità e supporti rimovibili

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Visualizzatore di caratteri di GNOME

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Visualizzatore di immagini

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Mostra scrivania

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Volume

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Montadischi

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Condizioni meteo

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Monitor di sistema

** (bug-buddy:17914): WARNING **: Impossibile caricare l'icona per Cestino

mentre il quarto ed il quinto mi danno permission denied. Ho già provato a ricompilare gnome-control-center dbus hal dbus-glib ma non hanno dato un buon risultato. Anche vari revdep-rebuild non hanno dato nessun risultato. uso compiz-fusion ma tutto sto casino accade anche senza che lo stesso sia in esecuzione.
qualcuno può aiutarmi?

EDIT: per adesso ho risolto ricompilando dbus con la USEFLAG X attiva. Prima era disattivata perchè non mi ricordo quale programma la richiedeva così. la cosa che non capisco è come mai abbia sempre funzionato senza.
_________________
8-09 V-Day con una raccolta firme. Vi aspettiamo
Raccolta Firme
Progetto tRicicloPC con Linux
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum