Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] /bin/bb: can't access tty; job control turned off
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
kknull
n00b
n00b


Joined: 06 Jul 2007
Posts: 14

PostPosted: Wed Jul 11, 2007 9:06 pm    Post subject: [solved] /bin/bb: can't access tty; job control turned off Reply with quote

Hi,
I have installed succesfully gentoo from an ubuntu system (using stage3 and portage packages and chrooting in the system)
When I try to boot the system, I get this message:

Code:
/bin/bb: can't access tty; job control turned off


Searching in the forum, I found that the problem can be fstab configuration, but I don't think this is my case.
However, this is my fstab:

Code:
/dev/hda8      /      ext3      noatime      0 1
/dev/hda5      /home      ext3      noatime      0 2
/dev/hda6      none      swap      sw      0 0
/dev/hdb      /mnt/cdrom   auto      noauto,ro   0 0
proc          /proc      proc      nodev,nosuid,noexec       0 0
shm         /dev/shm   tmpfs      nodev,nosuid,noexec   0 0


Thanks. KKnull


Last edited by kknull on Fri Jul 13, 2007 8:20 am; edited 1 time in total
Back to top
View user's profile Send private message
didymos
Advocate
Advocate


Joined: 10 Oct 2005
Posts: 4798
Location: California

PostPosted: Wed Jul 11, 2007 10:01 pm    Post subject: Reply with quote

The forum search function kind of sucks. Found this on Google:
/bin/bb: can't access tty...
_________________
Thomas S. Howard
Back to top
View user's profile Send private message
c4
Guru
Guru


Joined: 21 Feb 2004
Posts: 312
Location: Sweden

PostPosted: Wed Jul 11, 2007 10:05 pm    Post subject: Reply with quote

Did a quick Google search and came up with a page in the Gentoo handbook that had /bin/bb mentioned in grub.conf

Quote:


Code Listing 3: grub.conf for non-genkernel users

# Which listing to boot as default. 0 is the first, 1 the second etc.
default 0
# How many seconds to wait before the default listing is booted.
timeout 30
# Nice, fat splash-image to spice things up :)
# Comment out if you don't have a graphics card installed
splashimage=(hd0,0)/boot/grub/splash.xpm.gz

title=Gentoo Linux 2.6.19-r5
# Partition where the kernel image (or operating system) is located
root (hd0,0)
kernel /boot/kernel-2.6.19-gentoo-r5 root=/dev/hda3

title=Gentoo Linux 2.6.19-r5 (rescue)
# Partition where the kernel image (or operating system) is located
root (hd0,0)
kernel /boot/kernel-2.6.19-gentoo-r5 root=/dev/hda3 init=/bin/bb

# The next four lines are only if you dualboot with a Windows system.
# In this case, Windows is hosted on /dev/hda6.
title=Windows XP
rootnoverify (hd0,5)
makeactive
chainloader +1


Do you have such a line there in your grub.conf?
A person described the same problem in this thread

As for your fstab it looks ok as far as I can tell
_________________
AMD64 Gentoo Hardened server
AMD64 Xubuntu Desktop
X86 Dreamlinux Vaio laptop
Back to top
View user's profile Send private message
kknull
n00b
n00b


Joined: 06 Jul 2007
Posts: 14

PostPosted: Wed Jul 11, 2007 10:59 pm    Post subject: Reply with quote

c4 wrote:
Did a quick Google search and came up with a page in the Gentoo handbook that had /bin/bb mentioned in grub.conf

Quote:


Code Listing 3: grub.conf for non-genkernel users

# Which listing to boot as default. 0 is the first, 1 the second etc.
default 0
# How many seconds to wait before the default listing is booted.
timeout 30
# Nice, fat splash-image to spice things up :)
# Comment out if you don't have a graphics card installed
splashimage=(hd0,0)/boot/grub/splash.xpm.gz

title=Gentoo Linux 2.6.19-r5
# Partition where the kernel image (or operating system) is located
root (hd0,0)
kernel /boot/kernel-2.6.19-gentoo-r5 root=/dev/hda3

title=Gentoo Linux 2.6.19-r5 (rescue)
# Partition where the kernel image (or operating system) is located
root (hd0,0)
kernel /boot/kernel-2.6.19-gentoo-r5 root=/dev/hda3 init=/bin/bb

# The next four lines are only if you dualboot with a Windows system.
# In this case, Windows is hosted on /dev/hda6.
title=Windows XP
rootnoverify (hd0,5)
makeactive
chainloader +1


Do you have such a line there in your grub.conf?
A person described the same problem in this thread

As for your fstab it looks ok as far as I can tell


I have checked my menu.conf and I found that I had init=/bin/bb option enable at default, so gentoo was running in safe mode! Now all work properly.

Thanks. KKnull
Back to top
View user's profile Send private message
OmSai
l33t
l33t


Joined: 30 Sep 2007
Posts: 605
Location: Manchester, CT, USA

PostPosted: Fri Sep 25, 2009 12:13 am    Post subject: Reply with quote

I had used the default ext3 as my root fs in fstab instead of ext4 which I had intended to use :P
_________________
Gentoo is the stick-shift of Linux.
You work it manually, it has somewhat better performance, but it's really for the fun of it.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum