Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] emerging PAM
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
ashlar
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jun 2006
Posts: 140

PostPosted: Mon Jul 09, 2007 2:31 pm    Post subject: [RISOLTO] emerging PAM Reply with quote

Ho aggiornato il sistema, mi ha compilato tutto correttamente eccetto "PAM", l'errore che mi da è il seguente:
Quote:

*
* Your current setup is using the pam_stack module.
* This module is deprecated and no more supported, and since version
* 0.99 is no more installed, nor provided by any other package.
* The package will be built (to allow binary package builds), but will
* not be installed.
* Please replace pam_stack usage with proper include directive usage,
* following the PAM Upgrade guide at the following URL
* http://www.gentoo.org/proj/en/base/pam/upgrade-0.99.xml
*


Sono andato a vedere la pagina che dice contenere le spiegazioni ma non ho capito quale file devo editare e in quale modo, qualcuno di voi lo ha già fatto? Mi potete spiegare passo passo quali file devo ritoccare?


Last edited by ashlar on Mon Jul 09, 2007 7:03 pm; edited 3 times in total
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Mon Jul 09, 2007 2:41 pm    Post subject: Reply with quote

Devi controllare tutti i file dentro a /etc/pam.d, ed applicare eventualmente la modifica mostrata nel "Code listing 1.1" del documento.
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
ashlar
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jun 2006
Posts: 140

PostPosted: Mon Jul 09, 2007 3:22 pm    Post subject: Reply with quote

Scen wrote:
Devi controllare tutti i file dentro a /etc/pam.d, ed applicare eventualmente la modifica mostrata nel "Code listing 1.1" del documento.

Dopo un iniziale illusione mi ha dato lo stesso errore :
Quote:

*
* Your current setup is using the pam_stack module.
* This module is deprecated and no more supported, and since version
* 0.99 is no more installed, nor provided by any other package.
* The package will be built (to allow binary package builds), but will
* not be installed.
* Please replace pam_stack usage with proper include directive usage,
* following the PAM Upgrade guide at the following URL
* http://www.gentoo.org/proj/en/base/pam/upgrade-0.99.xml
*
Note: The repository at /usr/local/portage does not have a profiles/repo_name entry.
This can reduce the functionality of the repository in some cases.
*
* ERROR: sys-libs/pam-0.99.8.0 failed.
* Call stack:
* ebuild.sh, line 1663: Called dyn_preinst
* ebuild.sh, line 1100: Called pkg_preinst
* pam-0.99.8.0.ebuild, line 167: Called die
*
* deprecated PAM modules still used
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/sys-libs/pam-0.99.8.0/temp/build.log'.
*
!!! FAILED preinst: 1

* Messages for package sys-libs/pam-0.99.8.0:

*
* Your current setup is using the pam_stack module.
* This module is deprecated and no more supported, and since version
* 0.99 is no more installed, nor provided by any other package.
* The package will be built (to allow binary package builds), but will
* not be installed.
* Please replace pam_stack usage with proper include directive usage,
* following the PAM Upgrade guide at the following URL
* http://www.gentoo.org/proj/en/base/pam/upgrade-0.99.xml
*
*
* ERROR: sys-libs/pam-0.99.8.0 failed.
* Call stack:
* ebuild.sh, line 1663: Called dyn_preinst
* ebuild.sh, line 1100: Called pkg_preinst
* pam-0.99.8.0.ebuild, line 167: Called die
*
* deprecated PAM modules still used
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/sys-libs/pam-0.99.8.0/temp/build.log'.
*


L'unico file che conteneva pam_stack era il file xdm... che altro posso fare?
Back to top
View user's profile Send private message
Flameeyes
Retired Dev
Retired Dev


Joined: 30 Mar 2005
Posts: 187
Location: Dublin, Ireland

PostPosted: Mon Jul 09, 2007 3:36 pm    Post subject: Reply with quote

Se l'ebuild muore significa che qualcosa ancora ha un pam_stack non commentato. Cosa ritorna il comando

Code:

fgrep pam_stack /etc/pam.d -r


?

Assicurati di aver cancellato eventuali file di backup creati da vim (*~) perché non sono ignorati dal controllo.
_________________
You want to know what I'm working on right now? Just follow my blog.
Back to top
View user's profile Send private message
ashlar
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jun 2006
Posts: 140

PostPosted: Mon Jul 09, 2007 7:03 pm    Post subject: Reply with quote

finalmente risolto come suggeritomi da flame... ho cancellato tutti i file con ~ all'interno della cartella pam.d e cambiato nel seguente modo il file "xdm" che conteneva le diciture _stack:
Quote:

#%PAM-1.0
auth include system-auth
auth required pam_nologin.so
account include system-auth
password include system-auth
session include system-auth
session optional pam_console.so
/etc/pam.d/xdm lines 1-7/7 (END)
Back to top
View user's profile Send private message
TwoMinds
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jul 2004
Posts: 146
Location: Italy

PostPosted: Tue Jul 10, 2007 11:30 am    Post subject: Reply with quote

...il Code Listing 1.2 dice anche che va riordinato: i "required" prima degli "include":
Code:

#%PAM-1.0
auth include system-auth
auth required pam_nologin.so
account include system-auth
password include system-auth
session include system-auth
session optional pam_console.so

andrebbe
Code:

#%PAM-1.0
auth required pam_nologin.so
auth include system-auth
account include system-auth
password include system-auth
session include system-auth
session optional pam_console.so

...correggetemi se sbaglio...
Back to top
View user's profile Send private message
Flameeyes
Retired Dev
Retired Dev


Joined: 30 Mar 2005
Posts: 187
Location: Dublin, Ireland

PostPosted: Tue Jul 10, 2007 12:33 pm    Post subject: Reply with quote

Anche session optional va prima di session include, per il resto è giusto.
_________________
You want to know what I'm working on right now? Just follow my blog.
Back to top
View user's profile Send private message
macca75
n00b
n00b


Joined: 28 Dec 2005
Posts: 59

PostPosted: Sun Nov 18, 2007 10:57 am    Post subject: pam upgrade Reply with quote

Ciao...............
Code:
dickdastardly pam.d # emerge  pam   
Calculating dependencies... done!
>>> Verifying ebuild Manifests...

>>> Emerging (1 of 1) sys-libs/pam-0.99.8.1-r1 to /
 * Linux-PAM-0.99.8.1.tar.bz2 RMD160 SHA1 SHA256 size ;-) ...             [ ok ]
 * Linux-PAM-0.99.8.1-ldflags-to-libadd.patch.bz2 RMD160 SHA1 SHA256 size ;-) ...         [ ok ]
 * checking ebuild checksums ;-) ...                                      [ ok ]
 * checking auxfile checksums ;-) ...                                     [ ok ]
 * checking miscfile checksums ;-) ...                                    [ ok ]
 * checking Linux-PAM-0.99.8.1.tar.bz2 ;-) ...                            [ ok ]
 * checking Linux-PAM-0.99.8.1-ldflags-to-libadd.patch.bz2 ;-) ...        [ ok ]
 *
 * Your current setup is using one or more of the following modules,
 * that are not built or supported anymore:
 * pam_pwdb, pam_radius, pam_timestamp
 * If you are in real need for these modules, please contact the maintainers
 * of PAM through http://bugs.gentoo.org/ providing information about its
 * use cases.


Code:
qfile -o /etc/pam.d/*
/etc/pam.d/sshd


Ho rimosso /etc/pam.d/sshd

Code:
emerge pam


l'intsallazione e' andata a buon fine, naturalmente grazie alle vostre spiegazioni.
Ciao a tutti
Back to top
View user's profile Send private message
MeMyselfAndI
l33t
l33t


Joined: 15 Nov 2005
Posts: 784
Location: Between the monitor and the chair

PostPosted: Sun Nov 18, 2007 2:55 pm    Post subject: Reply with quote

Spero non ti interessi usare il demone ssd in un futuro prossimo..
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum