Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Installation] Probleme avec Grub ~ Resolu
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Nah
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2006
Posts: 107
Location: Lille,France

PostPosted: Fri Jul 06, 2007 2:49 pm    Post subject: [Installation] Probleme avec Grub ~ Resolu Reply with quote

Bonjour,
je suis en train de terminer un installation de Gentoo, mais grub pose probleme. Lorsque je lance la commande pour qu'il s'installe sur le mbr, j'obtient cette erreur:
Code:
Could not find device for /boot: Not found or not a block device.

:roll:

Voici mon grub.conf:
Code:
default 0
timeout 30

title=Gentoo Linux 2.6.20-r8
root (hd0,0)
kernel /boot/kernel-2.6.20-r8 root=/dev/sda1 quiet vga=0x31B video=vesafb:mtrr:3,ywrap

Je n'ai pas fait de partition separe pour /boot, c,a viendrai de l`a ??
Merci d'avance pour votre aide ! :P


Last edited by Nah on Fri Jul 06, 2007 10:49 pm; edited 1 time in total
Back to top
View user's profile Send private message
Ezka
Guru
Guru


Joined: 17 Feb 2005
Posts: 352
Location: par là, mais vraiment ...

PostPosted: Fri Jul 06, 2007 3:51 pm    Post subject: Reply with quote

Vérifie que ta partition soit bootable, et qu'il existe bien /boot.

Lorsque tu installes grub tu tappes quoi exactement ?

EDIT : je viens de re-trouver ça : Résolution des erreurs de GRUB sous Gentoo
_________________
Ez.
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3584
Location: Belgium

PostPosted: Fri Jul 06, 2007 4:05 pm    Post subject: Reply with quote

Ezka wrote:
Vérifie que ta partition soit bootable

Sous Linux, ce flag n'a strictement aucune importance.
Il est destiné à winchose et à chépukelautreos
Back to top
View user's profile Send private message
Nah
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2006
Posts: 107
Location: Lille,France

PostPosted: Fri Jul 06, 2007 4:10 pm    Post subject: Reply with quote

Je suis tout simplement le handbook amd64, j'execute donc ses commandes :
Code:
emerge grub
nano -w /boot/grub/grub.conf
grep -v rootfs /proc/mounts > /etc/mtab
grub-install --no-floppy /dev/hda

J'ai regarder aussi du coté du lien que tu as poster, en fesant un :
Code:
cp /proc/mounts /etc/mtab
ça ma fait une autre erreur (que je n'ai pas noter :(), là ça compile, qd ce sera fini, je vais essayer de faire l'installation manuel.
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3584
Location: Belgium

PostPosted: Fri Jul 06, 2007 4:16 pm    Post subject: Reply with quote

Nah wrote:
grub-install --no-floppy /dev/hda

Ce ne serait pas plutôt /dev/sda ?
Back to top
View user's profile Send private message
acolin
n00b
n00b


Joined: 16 Feb 2006
Posts: 42
Location: Presles - Belgique

PostPosted: Fri Jul 06, 2007 5:55 pm    Post subject: Reply with quote

A quoi ressemble ton /boot/grub/device.map ?
Back to top
View user's profile Send private message
bivittatus
l33t
l33t


Joined: 31 Jan 2006
Posts: 687
Location: Roissy-en-Brie (France)

PostPosted: Fri Jul 06, 2007 8:23 pm    Post subject: Reply with quote

ghoti wrote:
Nah wrote:
grub-install --no-floppy /dev/hda

Ce ne serait pas plutôt /dev/sda ?


+1 le root est déclaré en /dev/sda1 dans le grub.conf! :wink:

Code:
kernel /boot/kernel-2.6.20-r8 root=/dev/sda1 quiet vga=0x31B video=vesafb:mtrr:3,ywrap

_________________
Linus TORVALDS: "Je ne suis pas là pour détruire Microsoft. Ce sera juste un effet secondaire tout à fait involontaire."
Back to top
View user's profile Send private message
Nah
Tux's lil' helper
Tux's lil' helper


Joined: 01 May 2006
Posts: 107
Location: Lille,France

PostPosted: Fri Jul 06, 2007 10:47 pm    Post subject: Reply with quote

Nope, j'ai oublier de changer lors du copier/coller du guide. ;)

J'ai essayer tout ce que j'ai trouver mais en vain, je suis donc passer par l'installation est la pas de probleme !?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum