Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[libXfont] libXfont.so: undef reference ft_isdigit (resolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
apocryphe
n00b
n00b


Joined: 03 Jul 2005
Posts: 59
Location: 78 - Pres de Saint Germain

PostPosted: Thu Jul 05, 2007 1:52 pm    Post subject: [libXfont] libXfont.so: undef reference ft_isdigit (resolu) Reply with quote

Bonjour,

je suis entrain de faire une install fraiche d une gentoo avec gcc4.2, et j'ai un souci avec les paquet X ( JE NE peux donc pas compiler xorg... ce qui est un peu balo ) qui ont besoin de :

/usr/lib/gcc/i686-pc-linux-gnu/4.2.0/../../../libXfont.so: undefined reference to `ft_isdigit'


voila le paste:
Quote:


sed -e 's|__vendorversion__|"bdftopcf 1.0.0" "X Version 11"|' -e 's|__xorgversion__|"bdftopcf 1.0.0" "X Version 11"|' -e 's|__xservername__|Xorg|g' -e 's|__xconfigfile__|xorg.conf|g' -e 's|__projectroot__|/usr|g' -e 's|__apploaddir__||' -e 's|__appmansuffix__|1x|g' -e 's|__libmansuffix__|3x|g' -e 's|__adminmansuffix__|8|g' -e 's|__miscmansuffix__|7|g' -e 's|__filemansuffix__|5x|g' < bdftopcf.man > bdftopcf.1x
i686-pc-linux-gnu-gcc -O2 -march=k8 -pipe -o bdftopcf bdftopcf-bdftopcf.o -lXfont
/usr/lib/gcc/i686-pc-linux-gnu/4.2.0/../../../libXfont.so: undefined reference to `ft_isdigit'
collect2: ld returned 1 exit status
make[1]: *** [bdftopcf] Error 1
make[1]: Leaving directory `/mnt/hdc9/gentoo/var/tmp/portage/x11-apps/bdftopcf-1.0.0/work/bdftopcf-1.0.0'
make: *** [all] Error 2
*
* ERROR: x11-apps/bdftopcf-1.0.0 failed.
* Call stack:
* ebuild.sh, line 1642: Called dyn_compile
* ebuild.sh, line 988: Called qa_call 'src_compile'
* ebuild.sh, line 44: Called src_compile
* ebuild.sh, line 1327: Called x-modular_src_compile
* x-modular.eclass, line 337: Called x-modular_src_make
* x-modular.eclass, line 332: Called die
*
* emake failed
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/mnt/hdc9/gentoo/var/tmp/portage/x11-apps/bdftopcf-1.0.0/temp/build.log'.
*



pour info j ai fais un fix lib tool.sh gcc4.2 et un revdep... mais rien n y fait


-----> J ai reussi a localiser le pb : a la compile de libXfont.so il y a une generation de ft_isdigit qui ne devrai pas avoir lieu car deprercate ! je ne sais pas pourquoi ca me cré cet obj car les autres ne l'ont pas !

RESOLU:
la maj libXfont 1.3 corrige le pb


merci
_________________
Laptop Dell Inspiron 1520
Intel Core2Duo T7250 - GM965 - 4 Go 667MHz DDR2 - Nvidia 8400 GS (256MiB) - BCM4401- iwlwifi3945 - SD R5C822
~amd64 - GCC 4.4.1 - XFS ahci officiel 2.6.30.4 - Xorg 1.6.2 - kde 4.3 - Nvidia 190.18 - WSXGA+ (1680x1050)


Last edited by apocryphe on Sat Jul 07, 2007 1:40 pm; edited 6 times in total
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Thu Jul 05, 2007 2:29 pm    Post subject: Reply with quote

T'as pas l'air de réagir sur IRC, donc je te le redis là : met ton titre en conformité stp ;)
Back to top
View user's profile Send private message
apocryphe
n00b
n00b


Joined: 03 Jul 2005
Posts: 59
Location: 78 - Pres de Saint Germain

PostPosted: Thu Jul 05, 2007 2:41 pm    Post subject: Reply with quote

Bon geekounet est telement un mec humble, modeste, sans pretention qu'il a prefere que j'enleve mon poste Oooooo combien elogieux envers sa personne, donc je propose a celui qui passe par la de deposer un pti message d'amour pour geekounet !
_________________
Laptop Dell Inspiron 1520
Intel Core2Duo T7250 - GM965 - 4 Go 667MHz DDR2 - Nvidia 8400 GS (256MiB) - BCM4401- iwlwifi3945 - SD R5C822
~amd64 - GCC 4.4.1 - XFS ahci officiel 2.6.30.4 - Xorg 1.6.2 - kde 4.3 - Nvidia 190.18 - WSXGA+ (1680x1050)
Back to top
View user's profile Send private message
apocryphe
n00b
n00b


Joined: 03 Jul 2005
Posts: 59
Location: 78 - Pres de Saint Germain

PostPosted: Thu Jul 05, 2007 3:27 pm    Post subject: Reply with quote

d'apres le changelog j'ai matte ca, je ne sais pas si ca a un lien avec mon souci actuel :

Quote:


commit 2a7109894f4dcfaba70135e19fb6d595332522c7
Author: Egbert Eich <eich@suse.de>
Date: Wed May 5 17:24:40 2004 +0000

BugZilla #601: fixed missing symbols in Xserver freetype module due to
using isdigit instead of ft_isdigit, missing or faulty defines for
digit and string functions in ftstdlib.h (now myftstdlib.h). Reverted
freetype2 to upstream version, fixed CHAR_BIT in myftstdlib.h and made
the use of a copy of ftconfig.h in lib/font/FreeType obsolete (Egbert
Eich).



_________________
Laptop Dell Inspiron 1520
Intel Core2Duo T7250 - GM965 - 4 Go 667MHz DDR2 - Nvidia 8400 GS (256MiB) - BCM4401- iwlwifi3945 - SD R5C822
~amd64 - GCC 4.4.1 - XFS ahci officiel 2.6.30.4 - Xorg 1.6.2 - kde 4.3 - Nvidia 190.18 - WSXGA+ (1680x1050)
Back to top
View user's profile Send private message
Desintegr
l33t
l33t


Joined: 25 Mar 2004
Posts: 863
Location: France - Orléans

PostPosted: Thu Jul 05, 2007 3:49 pm    Post subject: Reply with quote

Essaye de reemerger dans l'ordre freetype, libXfont et bdftopcf.
_________________
Gentoo ~AMD64
Hoc Volo, Sic Jubeo !
Mon wiki : http://desintegr.free.fr
Back to top
View user's profile Send private message
apocryphe
n00b
n00b


Joined: 03 Jul 2005
Posts: 59
Location: 78 - Pres de Saint Germain

PostPosted: Thu Jul 05, 2007 3:51 pm    Post subject: Reply with quote

Desintegr

merci de me repondre


j'ai deja tout re-emerge, j ai meme downgradee libXfont, mais rien n'y fait !

je precise que xorg-server ne compil pas non plus donc c est vraiment embetant...
_________________
Laptop Dell Inspiron 1520
Intel Core2Duo T7250 - GM965 - 4 Go 667MHz DDR2 - Nvidia 8400 GS (256MiB) - BCM4401- iwlwifi3945 - SD R5C822
~amd64 - GCC 4.4.1 - XFS ahci officiel 2.6.30.4 - Xorg 1.6.2 - kde 4.3 - Nvidia 190.18 - WSXGA+ (1680x1050)
Back to top
View user's profile Send private message
apocryphe
n00b
n00b


Joined: 03 Jul 2005
Posts: 59
Location: 78 - Pres de Saint Germain

PostPosted: Thu Jul 05, 2007 3:58 pm    Post subject: Reply with quote

Quote:

laptop lib # objdump -T libXfont.so | grep digit
00000000 D *UND* 00000000 ft_isdigit
0005de40 g DO .data 00000100 Base digit_value

_________________
Laptop Dell Inspiron 1520
Intel Core2Duo T7250 - GM965 - 4 Go 667MHz DDR2 - Nvidia 8400 GS (256MiB) - BCM4401- iwlwifi3945 - SD R5C822
~amd64 - GCC 4.4.1 - XFS ahci officiel 2.6.30.4 - Xorg 1.6.2 - kde 4.3 - Nvidia 190.18 - WSXGA+ (1680x1050)
Back to top
View user's profile Send private message
apocryphe
n00b
n00b


Joined: 03 Jul 2005
Posts: 59
Location: 78 - Pres de Saint Germain

PostPosted: Thu Jul 05, 2007 11:26 pm    Post subject: Reply with quote

J'avance.... !!!


Visiblement les autres n'ont pas cet obj sur leur .so, je ne sais pas pq moi il me le cré !

le pb vient de la

si quelqu un sait comment suprimmer cet obj jsuis preneur !

merci et bonne soirée
_________________
Laptop Dell Inspiron 1520
Intel Core2Duo T7250 - GM965 - 4 Go 667MHz DDR2 - Nvidia 8400 GS (256MiB) - BCM4401- iwlwifi3945 - SD R5C822
~amd64 - GCC 4.4.1 - XFS ahci officiel 2.6.30.4 - Xorg 1.6.2 - kde 4.3 - Nvidia 190.18 - WSXGA+ (1680x1050)
Back to top
View user's profile Send private message
samymore
n00b
n00b


Joined: 06 Jul 2007
Posts: 1
Location: Dijon

PostPosted: Fri Jul 06, 2007 12:28 pm    Post subject: Reply with quote

bonjour,

Nouvel utilisateur de gentoo, (c'est ma primo install), j'ai exactement le même problème.
bdftopcf refuse de se compiler et renvoi l'erreur : lib64/libXfont.so: undefined referance to 'ft_isdigit' ...

J'ai un peu fouillé sur les forums et j'ai trouvé ceci :

[https://forums.gentoo.org/viewtopic-t-568821-highlight-bdftopcf.html]

Il semblerait qu'il y ai un problème au niveau de libXfont ! D'après ce que j'ai lu, le passage à la version 1.3.0 résout le problème.
Apparemment, une mise à jour devrait être disponible rapidement.
Je n'ai pas encore pu essayer ...
Je testerais çà ce week-end, en espérant que tout rentre dans l'ordre :)
Back to top
View user's profile Send private message
apocryphe
n00b
n00b


Joined: 03 Jul 2005
Posts: 59
Location: 78 - Pres de Saint Germain

PostPosted: Fri Jul 06, 2007 7:24 pm    Post subject: Reply with quote

samymore tu peux prendre la meme lib et la remplacer... et ca resout le pb

parc contre c est un peu crade mais bon en attendant...
_________________
Laptop Dell Inspiron 1520
Intel Core2Duo T7250 - GM965 - 4 Go 667MHz DDR2 - Nvidia 8400 GS (256MiB) - BCM4401- iwlwifi3945 - SD R5C822
~amd64 - GCC 4.4.1 - XFS ahci officiel 2.6.30.4 - Xorg 1.6.2 - kde 4.3 - Nvidia 190.18 - WSXGA+ (1680x1050)
Back to top
View user's profile Send private message
Tom_
Guru
Guru


Joined: 20 May 2004
Posts: 395
Location: France

PostPosted: Fri Jul 06, 2007 7:55 pm    Post subject: Reply with quote

Avec gcc-4.2, Il faut utiliser libXfont depuis l'overlay Palgene il me semble. Jettes un oeil dans la partie "unsupported software" du forum. ;)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum