Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[FIXED] emerge vlc wants to install old version of gcc
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
pwaring
Tux's lil' helper
Tux's lil' helper


Joined: 28 Aug 2003
Posts: 99

PostPosted: Sat Jun 30, 2007 12:33 pm    Post subject: [FIXED] emerge vlc wants to install old version of gcc Reply with quote

I'm trying to install vlc so that I play media files and watch DVDs, but when I run 'emerge vlc -p' this appears in the output:

[ebuild NS ] sys-devel/gcc-3.3.6-r1 USE="fortran nls (-altivec) -bootstrap -
boundschecking -build -doc -gcj -gtk (-hardened) (-ip28) (-ip32r10k) (-multilib)
-multislot (-n32) (-n64) -nocxx -nopie -nossp -objc -test -vanilla"

I've already got gcc 4.1.2 installed, and I really don't want gcc 3.3.6 because it's a much older version and gcc takes forever to compile. Is there a good reason why vlc is trying to install 3.3.6, or have I configured something incorrectly? (it's a fairly new install, the only things I've done so far is to install X, fluxbox and gdm and their dependancies). This`is on a Pentium Centrino laptop and my make.conf looks like this:

Code:

# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /etc/make.conf.example for a more detailed example.
CFLAGS="-O2 -march=i686 -pipe"
CXXFLAGS="${CFLAGS}"
# This should not be changed unless you know exactly what you are doing.  You
# should probably be using a different stage, instead.
CHOST="i686-pc-linux-gnu"

GENTOO_MIRRORS="ftp://gentoo.virginmedia.com/sites/gentoo ftp://ftp.mirrorservic
e.org/sites/www.ibiblio.org/gentoo/ "

SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="bash-completion X cairo a52 alsa dts dvd ffmpeg mp3 mpeg win32codecs ncurse
s opengl sdl skins truetype wxwindows xv quicktime real ogg vorbis xvid xml png
svg"

FEATURES="parallel-fetch"
INPUT_DEVICES="keyboard mouse"
VIDEO_CARDS="nv"


Thanks in advance.


Last edited by pwaring on Sat Jun 30, 2007 2:04 pm; edited 1 time in total
Back to top
View user's profile Send private message
didymos
Advocate
Advocate


Joined: 10 Oct 2005
Posts: 4798
Location: California

PostPosted: Sat Jun 30, 2007 12:43 pm    Post subject: Reply with quote

It actually wants libstdc++-v3, and that's part of gcc. Portage defaults to building the whole compiler, when it should default to building just the c++ library. It behaves properly on my machine, and I can't figure out why it keeps doing this to other people. Anyway, emerge sys-libs/libstdc++-v3, then vlc. It might not even be vlc, seeing as virtual/libstdc++ isn't in it's dependencies. It's either something it's pulling in that requires that lib, or some package you already have requires it.
_________________
Thomas S. Howard
Back to top
View user's profile Send private message
pwaring
Tux's lil' helper
Tux's lil' helper


Joined: 28 Aug 2003
Posts: 99

PostPosted: Sat Jun 30, 2007 2:04 pm    Post subject: Reply with quote

Cheers, that did the trick, although it would be better if portage didn't try to build the entire compiler, especially when a later version of gcc is already installed. I'll see if I can play around with that later and narrow the problem down sufficiently to file a bug report.
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7820

PostPosted: Wed Sep 19, 2007 6:52 am    Post subject: Reply with quote

Moved from Multimedia to Duplicate Threads, refer to topic "Portage wants me to merge gcc 3?!".
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum