Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[risolto]login all'avvio
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
betamatteo
n00b
n00b


Joined: 30 May 2007
Posts: 42

PostPosted: Sat Jun 30, 2007 7:34 am    Post subject: [risolto]login all'avvio Reply with quote

ciao,
al termine del boot mi viene chiesto
Code:
localhost login:

e poi la password,
ma il login è incorrect.
provo a mettergli root ma non va bene.
in fase d'installazione non ho dato alcun login e nessun utente, ho solo creato una password di root.

betamatteo


Last edited by betamatteo on Sat Jun 30, 2007 3:36 pm; edited 1 time in total
Back to top
View user's profile Send private message
crisandbea
Veteran
Veteran


Joined: 03 Jul 2005
Posts: 1778
Location: BOSCO (SA) ... ma domiciliato a Bologna....

PostPosted: Sat Jun 30, 2007 7:54 am    Post subject: Re: login all'avvio Reply with quote

betamatteo wrote:
ciao,
al termine del boot mi viene chiesto
Code:
localhost login:

e poi la password,
ma il login è incorrect.
provo a mettergli root ma non va bene.
in fase d'installazione non ho dato alcun login e nessun utente, ho solo creato una password di root.

betamatteo


fai login come utente root,

ovvero nome_utente=root passward=tuapasswordroot,

fatto cio crei il tuo utente:
Code:
useradd nome_utente_che_vuoi -m -G users,wheel,audio -s /bin/bash

Code:
passwd  nome_utente_che_vuoi


ciao
Back to top
View user's profile Send private message
betamatteo
n00b
n00b


Joined: 30 May 2007
Posts: 42

PostPosted: Sat Jun 30, 2007 9:02 am    Post subject: Reply with quote

non accetta il login root
Code:
localhost login:root
passwd:..............
loginn incorrect ecc....

ho provato con su, sudo -su, sudo -root, su root ecc....
credo di aver saltato un passaggio in fase d'installazione, nella prima parte la guida diceva di cambiare la password di root e opzionale la creazione di un utente, io ho solo cambiato la password di root.
poi però in fase di "configurazione del sistema", allavoce "informazioni sul sistema" ho saltato l'impostazione della password di root.
però quello che succede è che non riconosce il login "root", non la password,
Back to top
View user's profile Send private message
Sw0rdmast3r
n00b
n00b


Joined: 16 Jun 2007
Posts: 46

PostPosted: Sat Jun 30, 2007 9:26 am    Post subject: Reply with quote

Prova a passare la riga init=/bin/bash a grub, devi fare cosi:
1 Premi "e" dove c'è la riga del sistema che vuoi avviare
2 Spostati sulla riga che inizia con Kernel
3 Aggiungi "init=/bin/bash" e premi invio e poi "b"
4 Aggiungi l'utente root e un utente normale
_________________
EnTeR ThE MaTrIx
Back to top
View user's profile Send private message
betamatteo
n00b
n00b


Joined: 30 May 2007
Posts: 42

PostPosted: Sat Jun 30, 2007 9:34 am    Post subject: Reply with quote

tanto per non sbagliare ti posto grub.conf
Code:
default 0
timeout 30
splashimage=(hd0,4)/boot/grub/splash.xpm.gz

title=Gentoo Linux 2.6.20-r8
root (hd0,4)
kernel /boot/kernel-genkernel-x86-2.6.20-gentoo-r8 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=/dev/hda7 udev
initrd /boot/initramfs-genkernel-x86-2.6.20-gentoo-r8

title=Windows XP
rootnoverify (hd0,0)
makeactive
chainloader +1


hd0,4 > hda5 /boot
hda7 è la partizione /
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sat Jun 30, 2007 11:22 am    Post subject: Reply with quote

betamatteo wrote:
non accetta il login root

non devi modificare grub.conf, ma usare la modalità di editor propria di grub (nei 30 secondi di timeout).
se lo trovi troppo complicato, accedi da livecd al file /etc/passwd con un qualunque editor di testo (nano?) e togli la x dalla prima riga, che dovrebbe apparire così:
Code:

 cloc3@s939 ~ $ head -n1 /etc/passwd
root:x:0:0:root:/root:/bin/bash


p.s.: `man 5 passwd`
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
betamatteo
n00b
n00b


Joined: 30 May 2007
Posts: 42

PostPosted: Sat Jun 30, 2007 2:44 pm    Post subject: Reply with quote

non ne vengo fuori
sono riuscito ad entrare nell'editor di grub, ma la soluzione di Sw0rdmast3r era la modifica di grub.conf
rispetto a /etc/passwd non c'è alcuna prima riga da togliere la x
questo è il mio /etc/passwd,
Code:
root:x:0:0:root:/root:/bin/bash
bin:x:1:1:bin:/bin:/bin/false
daemon:x:2:2:daemon:/sbin:/bin/false
adm:x:3:4:adm:/var/adm:/bin/false
lp:x:4:7:lp:/var/spool/lpd:/bin/false
sync:x:5:0:sync:/sbin:/bin/sync
shutdown:x:6:0:shutdown:/sbin:/sbin/shutdown
halt:x:7:0:halt:/sbin:/sbin/halt
mail:x:8:12:mail:/var/spool/mail:/bin/false
news:x:9:13:news:/usr/lib/news:/bin/false
uucp:x:10:14:uucp:/var/spool/uucppublic:/bin/false
operator:x:11:0:operator:/root:/bin/bash
man:x:13:15:man:/usr/share/man:/bin/false
postmaster:x:14:12:postmaster:/var/spool/mail:/bin/false
smmsp:x:209:209:smmsp:/var/spool/mqueue:/bin/false
portage:x:250:250:portage:/var/tmp/portage:/bin/false
nobody:x:65534:65534:nobody:/:/bin/false
ldap:x:439:439::/usr/lib/openldap:/dev/null
sshd:x:22:22:added by portage for openssh:/var/empty:/sbin/nologin

non c'e niente che somiglia a
Code:
cloc3@s939 ~ $ head -n1 /etc/passwd


betamatteo
Back to top
View user's profile Send private message
Deus Ex
Guru
Guru


Joined: 16 Nov 2005
Posts: 489
Location: Patavium

PostPosted: Sat Jun 30, 2007 3:08 pm    Post subject: Reply with quote

man head wrote:

NAME
head - output the first part of files

SYNOPSIS
head [OPTION]... [FILE]...

DESCRIPTION
Print the first 10 lines of each FILE to standard output. With more
than one FILE, precede each with a header giving the file name. With
no FILE, or when FILE is -, read standard input.

Mandatory arguments to long options are mandatory for short options
too.

-c, --bytes=[-]N
print the first N bytes of each file; with the leading `-',
print all but the last N bytes of each file

-n, --lines=[-]N
print the first N lines instead of the first 10; with the lead-
ing `-', print all but the last N lines of each file



cloc3 ti ha suggerito di entrare in /etc/passwd e cancellare la "x" che c'è in mezzo tra "root:" e ":0" della riga "root:x:0:0:root:/root:/bin/bash"
_________________
Deus Ex
--
L’inflazione che caccia nelle mani dell’individuo, in un gesto solo, miliardi di marchi, lasciandolo più miserabile di prima, dimostra punto per punto che il denaro è un’allucinazione collettiva.
Back to top
View user's profile Send private message
betamatteo
n00b
n00b


Joined: 30 May 2007
Posts: 42

PostPosted: Sat Jun 30, 2007 3:35 pm    Post subject: Reply with quote

grazie, era quella la soluzione
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sat Jun 30, 2007 4:00 pm    Post subject: Reply with quote

betamatteo wrote:
grazie, era quella la soluzione

anche quella di crisandbea. dacci un occhio, perché è proprio carina.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
betamatteo
n00b
n00b


Joined: 30 May 2007
Posts: 42

PostPosted: Sat Jun 30, 2007 5:24 pm    Post subject: Reply with quote

scusami, cloc3
ma non capisco
crisandbea scrive
Code:
ai login come utente root,

ovvero nome_utente=root passward=tuapasswordroot,

fatto cio crei il tuo utente:
Codice:
useradd nome_utente_che_vuoi -m -G users,wheel,audio -s /bin/bash

Codice:
passwd  nome_utente_che_vuoi

ma il mio problema era che non mi faceva accedere a niente, mi chiedeva continuamente il login
quando ho eliminato la x da /etc/passwd allora ho potuto impostare passwd di root e utente

ciao e grazie per tutto :)
Back to top
View user's profile Send private message
crisandbea
Veteran
Veteran


Joined: 03 Jul 2005
Posts: 1778
Location: BOSCO (SA) ... ma domiciliato a Bologna....

PostPosted: Sat Jun 30, 2007 5:32 pm    Post subject: Reply with quote

@betamatteo

quello che ho scritto io era giusto, nel momento in cui tu potevi loggarti almeno come root, dato che dal tuo primo topic, non si capiva se ci riuscivi o meno a loggarti come utente root.
tutto qui.

ciao
Back to top
View user's profile Send private message
betamatteo
n00b
n00b


Joined: 30 May 2007
Posts: 42

PostPosted: Sat Jun 30, 2007 5:57 pm    Post subject: Reply with quote

@crisandbea
scusami, ultimamente sono in conflitto con le parole, a questo si aggiunge la scoperta che quel poco che avevo imparato su linux, è davvero poco.
quando sono riuscito a loggarmi come root, ho fatto come hai detto tu.
ciao
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sun Jul 01, 2007 5:36 am    Post subject: Reply with quote

betamatteo wrote:
scusami, cloc3
ma non capisco
crisandbea scrive

in effetti ho sbagliato nick.
il metodo astuto, che è bene imparare per altre evenienze, è quello di Sw0rdmast3r: cioè l'editor in linea di grub.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
betamatteo
n00b
n00b


Joined: 30 May 2007
Posts: 42

PostPosted: Sun Jul 01, 2007 7:34 am    Post subject: Reply with quote

ho provato ad usare l'editor di grub ma forse mi manca qualche passaggio
ho editato la riga col kernel, ho aggiunto init=/bin/bash, invio e poi "b"
al riavvio non risultava alcuna modifica, ho verificato rientrando nell'editor di grub e aprendo grub.conf

ciao
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Mon Jul 02, 2007 7:30 am    Post subject: Reply with quote

betamatteo wrote:
forse mi manca qualche passaggio ...
al riavvio non risultava alcuna modifica

non devi editare grub.conf.
la fase di boot è gestita da tre sistemi operativi diversi:
boot-->grub-->SO (linux).
tra grub e linux ci sta un timeout di 30 secondi. è lì che devi schiacciare il tasto e.
le modifiche avvengono in ram, dunque funzionano solo per il login attuale, mentre al successivo si riparte con quelle standard (a meno che tu non abbia editato e reinstallato grub.conf - coda sbagliata).

`info grub`
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
betamatteo
n00b
n00b


Joined: 30 May 2007
Posts: 42

PostPosted: Mon Jul 02, 2007 9:04 am    Post subject: Reply with quote

sono seriamente preoccupato, nonostante l'mpegno a ponderare bene le parole, queste poi sfuggono dalla tastiera e si assemblano secondo una loro logica. :?

in quei trenta secondi ho premuto "e" e sono comparse le tre righe una delle quali comincia con kernel ecc...
ho premuto ancora "e" ed ho aggiunto in quella riga init=/bin/bash, poi invio, poi "b".
al termine del boot mi sono ritrovato con il problema del login, ero bloccato, allora sono uscito da gentoo e ho controllato con l'altra distro, ho aperto /boot/grub/grub.conf ed ho visto che le righe contenute in questo file erano le stesse che ho trovato nella procedura precedente, ma non figurava il cambiamento con l'aggiunta di init ecc......
per questo ho pensato che forse mi mancava un passaggio per salvare le modifiche fatte, adesso invece so che le modifiche funzionano solo per quella sessione e alla successiva si imposta tutto come prima.

sempre tra quei 30 secondi, procedura a cui non so dare un nome, ho provato a premere "c" e poi help, mi esce una lista di comandi da poter usare, quali cat, nano, find ecc...., però poi non mi funzionano.
domanda:
posso intervenire su gentoo con quei comandi?
e le modifiche valgono solo per quella sessione?

betamatteo
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Mon Jul 02, 2007 12:46 pm    Post subject: Reply with quote

betamatteo wrote:
sono seriamente preoccupato, nonostante l'mpegno a ponderare bene le parole, queste poi sfuggono dalla tastiera e si assemblano secondo una loro logica. :?

:P niente paura. stai imparando molte cose nuove tutte in un colpo, ed è normale attraversare qualche momento di crisi. all'inizio leggere e capire è molto faticoso e si commettono facilmente ingenuità..
betamatteo wrote:

ho premuto ancora "e" ed ho aggiunto in quella riga init=/bin/bash

ho visto che usi l'initrd di genkernel. siccome non conosco quegli script non ti posso aiutare.
in linea di principio, però dovrebbero rispettare gli standard del kernel.
il parametro init definisce il nome del primo programma che il kernel avvia dopo essere stato caricato.
di solito quale programma si chiama init. fa un sacco di cose, e l'ultima di esse è il login manager (grafico o meno).
nei casi di emergenza, può essere comodo avviare piuttosto il programma /bin/bash che è una semplice shell, ovviamente senza login. è una cosa bella da sapere, perchè aiuta a capire il funzionamento di un sistema linux.

mi chiedo se hai anche cancellato la stringa init=/linuxrc che deve essere rimossa per evitare una doppia definizione, con esiti non prevedibili. se neanche questo basta, puoi rimuovere la riga initrd da grub (credo si usi la lettera d).
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum