Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
error emerging gcc-3.3.6-r1
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
kukuriza
n00b
n00b


Joined: 26 Mar 2007
Posts: 9

PostPosted: Fri Jun 29, 2007 7:11 am    Post subject: error emerging gcc-3.3.6-r1 Reply with quote

Hello forum.
I'm trying to emerge --update --deep --newuse world.
The output of this is:
These are the packages that would be merged, in order:

Calculating world dependencies... done!
[ebuild NS ] sys-devel/gcc-3.3.6-r1 USE="fortran nls (-altivec) -bootstrap -boundschecking -build -doc -gcj -gtk (-hardened) (-ip28) (-ip32r10k) (-multilib) -multislot (-n32) (-n64) -nocxx -nopie -nossp -objc -test -vanilla"
[ebuild N ] virtual/libstdc++-3.3
[ebuild R ] media-libs/win32codecs-20061022-r1 USE="quicktime* real*"
[ebuild U ] dev-java/java-config-2.0.33-r1 [2.0.32]
[ebuild U ] dev-java/xml-commons-resolver-1.2 [1.1-r1]
[ebuild U ] media-video/mplayer-1.0.20070622-r1 [1.0.20070321] USE="-amrnb% -amrwb% -ssse3%"
[ebuild UD] dev-lang/ruby-1.8.5_p2-r1 [1.8.6-r1] USE="-cjk%"
[ebuild U ] app-text/djvu-3.5.19 [3.5.17] USE="-doc%"
=====================================================
The emerge of gcc is failed, attached the build log:
c1: error: bad value (pentium-m) for -march= switch
cc1: error: bad value (pentium-m) for -mcpu= switch
make[2]: *** [gengenrtl.o] Error 1
make[2]: Leaving directory `/var/tmp/portage/sys-devel/gcc-3.3.6-r1/work/build/gcc'
make[1]: *** [stage2_build] Error 2
make[1]: *** Waiting for unfinished jobs....
echo timestamp > clean_s1
make[1]: Leaving directory `/var/tmp/portage/sys-devel/gcc-3.3.6-r1/work/build/gcc'
make: *** [bootstrap-lean] Error 2

!!! ERROR: sys-devel/gcc-3.3.6-r1 failed.
3556 Call stack:
3557 ebuild.sh, line 1615: Called dyn_compile
3558 ebuild.sh, line 972: Called qa_call 'src_compile'
3559 ebuild.sh, line 44: Called src_compile
3560 ebuild.sh, line 1305: Called toolchain_src_compile
3561 toolchain.eclass, line 26: Called gcc_src_compile
3562 toolchain.eclass, line 1541: Called gcc_do_make
3563 toolchain.eclass, line 1415: Called die
3564
3565 !!! emake failed with bootstrap-lean
3566 !!! If you need support, post the topmost build error, and the call stack if relevant.
3567 !!! A complete build log is located at '/var/tmp/portage/sys-devel/gcc-3.3.6-r1/temp/build.l og'.

Thanx in advance
Back to top
View user's profile Send private message
erikm
l33t
l33t


Joined: 08 Feb 2005
Posts: 631

PostPosted: Fri Jun 29, 2007 7:14 am    Post subject: Reply with quote

The march=pentium-m flag is not supported by your compiler. Switch compiler, or change the flag to a similar, supported one (e.g. march=pentium3, or failing that, march=i686).

EDIT: I see now that gcc fails in stage 2; hence, the failure is due to gcc-3.3 itself not supporting the pentium-m architecture. Try
Code:
~# CFLAGS="-O2 -march=i686" emerge =sys-devel/gcc-3.3.6-r1


Last edited by erikm on Fri Jun 29, 2007 7:27 am; edited 2 times in total
Back to top
View user's profile Send private message
didymos
Advocate
Advocate


Joined: 10 Oct 2005
Posts: 4798
Location: California

PostPosted: Fri Jun 29, 2007 7:15 am    Post subject: Reply with quote

You don't need gcc-3.3.6. What you do need is libstdc++-v3, so just do this:
Code:

emerge sys-libs/libstdc++-v3


then do the world emerge.
_________________
Thomas S. Howard
Back to top
View user's profile Send private message
kukuriza
n00b
n00b


Joined: 26 Mar 2007
Posts: 9

PostPosted: Fri Jun 29, 2007 8:00 am    Post subject: error emerging gcc-3.3.6-r1 - Solved Reply with quote

Tnanks a lot for advice.
I emerged the
Code:

       sys-libs/libstdc++-v3

then i did the world merge.
No errors.
The only question i have is what was the indication that i nee only the libstdc++-v3 ???
:lol:
Back to top
View user's profile Send private message
didymos
Advocate
Advocate


Joined: 10 Oct 2005
Posts: 4798
Location: California

PostPosted: Fri Jun 29, 2007 9:10 am    Post subject: Reply with quote

Code:

[ebuild NS ] sys-devel/gcc-3.3.6-r1 USE="fortran nls (-altivec) -bootstrap -boundschecking -build -doc -gcj -gtk (-hardened) (-ip28) (-ip32r10k) (-multilib) -multislot (-n32) (-n64) -nocxx -nopie -nossp -objc -test -vanilla"
[ebuild N ] virtual/libstdc++-3.3


Besides that, this happens a lot. Not that particular error, necessarily, but all of sudden someone "needs" gcc-3*, and it won't emerge. Usually, it's libstdc++ that's required. It's part of the compiler, and portage defaults to installing the full compiler instead of just the c++ library. I don't know why it does. It shouldn't, either in the ideal world sense or in the real world sense. I just got into a discussion about this the other day. On my system, it defaults to just the library, and I can't figure out why it won't for other people. It's here, if you care:
Problem emerge mplayer-bin
_________________
Thomas S. Howard
Back to top
View user's profile Send private message
kukuriza
n00b
n00b


Joined: 26 Mar 2007
Posts: 9

PostPosted: Sat Jun 30, 2007 6:07 am    Post subject: Reply with quote

thanx for the answer
Back to top
View user's profile Send private message
Arfrever
Bodhisattva
Bodhisattva


Joined: 29 Apr 2006
Posts: 2460
Location: Polska / Lenkija

PostPosted: Sat Jun 30, 2007 9:58 pm    Post subject: Reply with quote

didymos wrote:
Usually, it's libstdc++ that's required. It's part of the compiler, and portage defaults to installing the full compiler instead of just the c++ library. I don't know why it does.

Bug 161953, Comment 3.

Perduodu linkėjimus
Arfrever
Back to top
View user's profile Send private message
didymos
Advocate
Advocate


Joined: 10 Oct 2005
Posts: 4798
Location: California

PostPosted: Sat Jun 30, 2007 10:32 pm    Post subject: Reply with quote

Ah, thank you. That was annoying the hell out of me.
_________________
Thomas S. Howard
Back to top
View user's profile Send private message
cd_rom
n00b
n00b


Joined: 03 May 2006
Posts: 23

PostPosted: Sun Jul 15, 2007 6:14 pm    Post subject: Reply with quote

thanks, i tripped into this problem when i tried to "emerge jdk"!
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 8114

PostPosted: Wed Sep 19, 2007 6:53 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads, refer to topic "Portage wants me to merge gcc 3?!".
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum