Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
f-spot (mono) on sparc (ultra5)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
shimitar
Apprentice
Apprentice


Joined: 23 Nov 2003
Posts: 162
Location: Italy, Torino

PostPosted: Fri Jul 06, 2007 6:02 am    Post subject: f-spot (mono) on sparc (ultra5) Reply with quote

Ciao!

i did some unmasking of the mono stuff because i wanted to try out f-spot for photo organizing. Since i read that mono shuold be working, i saidm hey kets give it a try.

This is my results:
Code:

ultra5 ~ # vi /home/willy/error
Stacktrace:

  at (wrapper managed-to-native) NDesk.GLib.IO.g_io_add_watch (NDesk.GLib.IOChannel,NDesk.GLib.IOCondition,NDesk.GLib.IOFunc,intptr) <0x00008>
  at (wrapper managed-to-native) NDesk.GLib.IO.g_io_add_watch (NDesk.GLib.IOChannel,NDesk.GLib.IOCondition,NDesk.GLib.IOFunc,intptr) <0xffffffff>
  at NDesk.GLib.IO.AddWatch (NDesk.GLib.IOChannel,NDesk.GLib.IOCondition,NDesk.GLib.IOFunc) <0x0004c>
  at NDesk.DBus.BusG.Init (NDesk.DBus.Connection,NDesk.GLib.IOFunc) <0x00044>
  at NDesk.DBus.BusG.Init (NDesk.DBus.Connection) <0x00080>
  at NDesk.DBus.BusG.Init () <0x0002c>
  at FSpot.Driver.Main (string[]) <0x00278>
  at (wrapper runtime-invoke) System.Object.runtime_invoke_void_string[] (object,intptr,intptr,intptr) <0xffffffff>

Native stacktrace:


Debug info from gdb:

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -134957664 (LWP 24267)]
[New Thread -150209632 (LWP 24269)]
[New Thread -135103584 (LWP 24268)]
0xf7c3e12c in fork () from /lib/libc.so.6
  3 Thread -135103584 (LWP 24268)  0xf7ddf6b0 in ?? ()
   from /lib/libpthread.so.0
  2 Thread -150209632 (LWP 24269)  0xf7ddb5f4 in pthread_cond_wait@@GLIBC_2.3.2
    () from /lib/libpthread.so.0
  1 Thread -134957664 (LWP 24267)  0xf7c3e12c in fork () from /lib/libc.so.6

Thread 3 (Thread -135103584 (LWP 24268)):
#0  0xf7ddf6b0 in ?? () from /lib/libpthread.so.0
#1  0x000e5520 in collection_thread (unused=0xf7f272f8) at collection.c:34
#2  0xf7dd57a0 in start_thread () from /lib/libpthread.so.0
#3  0xf7c73178 in ?? () from /lib/libc.so.6
#4  0xf7c73178 in ?? () from /lib/libc.so.6
Backtrace stopped: previous frame identical to this frame (corrupt stack?)

Thread 2 (Thread -150209632 (LWP 24269)):
#0  0xf7ddb5f4 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/libpthread.so.0
#1  0x000e9288 in timedwait_signal_poll_cond (cond=0xf76221f0,
    mutex=0xf76221d4, timeout=0x0, alertable=0) at handles.c:1413
#2  0x000ec1f4 in _wapi_handle_timedwait_signal_handle (
    handle=<value optimized out>, timeout=0xf76221d4, alertable=
dwarf2-frame.c:1084: internal-error: Unknown register rule.
A problem internal to GDB has been detected,
further debugging may prove unreliable.
Quit this debugging session? (y or n) [answered Y; input not from terminal]
dwarf2-frame.c:1084: internal-error: Unknown register rule.
A problem internal to GDB has been detected,
further debugging may prove unreliable.
Create a core file of GDB? (y or n) [answered Y; input not from terminal]


=================================================================
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
=================================================================


Which does NOT looks good...

Any suggestions? thank you.
_________________
Willy Gardiol
willy@gardiol.org
Back to top
View user's profile Send private message
Sodki
Guru
Guru


Joined: 11 Aug 2003
Posts: 418
Location: London, U.K. & Lisbon, Portugal

PostPosted: Mon Jul 09, 2007 3:47 pm    Post subject: Reply with quote

I get the same error when I try to launch F-Spot or Banshee (both use mono) on PPC. Maybe it's an endian issue with mono?
Back to top
View user's profile Send private message
Sodki
Guru
Guru


Joined: 11 Aug 2003
Posts: 418
Location: London, U.K. & Lisbon, Portugal

PostPosted: Mon Jul 09, 2007 7:44 pm    Post subject: Reply with quote

I've solved my problem by downgrading to mono-1.2.3.1. Can you please do the same and see if it works? Thank you.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum