Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
MTU is resetting [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
Stonic
n00b
n00b


Joined: 03 Jun 2007
Posts: 47

PostPosted: Wed Jun 27, 2007 12:38 am    Post subject: MTU is resetting [SOLVED] Reply with quote

Hey, I've been having some issues with the MTU setting on my network card with my gentoo router.

The x-box live that is connected to my box needs an MTU value of at least 1300. The value on the interface that is open the the internet (eth0) is set at 576 MTU

Quote:
UP BROADCAST RUNNING MULTICAST MTU:576 Metric:1


When I set it to 1500 using:
Code:
ifconfig eth0 mtu 1500
it is set, and shows the value.
-The xbox can connect, and everything is working..
-However, it seems as if 24 hours or so goes by and the setting is reset to it's original value. (The box has not been restarted yet)
I have to re-set the value, and it's all good again..

I think I have a shitty network card, and need to upgrade, I am currently using a d-link (forgot model number.)
Is there a way to force the value to stay? or is it being reset due to a low-traffic card?


Last edited by Stonic on Wed Jun 27, 2007 5:40 am; edited 1 time in total
Back to top
View user's profile Send private message
syntax4head
n00b
n00b


Joined: 28 Feb 2004
Posts: 21

PostPosted: Wed Jun 27, 2007 1:43 am    Post subject: Reply with quote

I just saw this issue when I went to upgrade kernels from 2.6.15 to 2.6.20. It took me forever to figure out why my DNAT box was broken. After a couple hours of googling I find that my MTU on eth0 is set to 576. I adjusted this to 1500. I don't know how it got set like that to begin with. I'm going to investigate further.
-----
Okay, here's a follow up. See this thread: https://forums.gentoo.org/viewtopic-t-554063-start-0-postdays-0-postorder-asc-highlight-faulty+mtu.html
Apparently this MTU of 576 is a dhcpcd issue. It turns out that dhcpcd now obeys the MTU request of the dhcp server, when obtaining an IP. Some ISP's set the MTU to 576, which is typically what a PPP or modem connection would use. The short of it is that it breaks stuff. Either passing the -M option to dhcpcd to ignore MTU or setting the MTU manually to 1500 should fix the problem.

Set the following in /etc/conf.d/net for whatever device is causing the problem:
Code:
mtu_eth0="1500"

This may be your permanent fix :wink:
Back to top
View user's profile Send private message
Stonic
n00b
n00b


Joined: 03 Jun 2007
Posts: 47

PostPosted: Wed Jun 27, 2007 3:44 am    Post subject: Reply with quote

Great find, thanks!!!

Very helpful. The next thing is, as I am a complete noob with linux, how would you set the -M option for dhcp? I don't remember how i set it up or what dirrectory.. is there a config file i have to modify?
Back to top
View user's profile Send private message
Stonic
n00b
n00b


Joined: 03 Jun 2007
Posts: 47

PostPosted: Wed Jun 27, 2007 5:39 am    Post subject: Reply with quote

Nevermind, excuse me.. I figured out the eth0_mtu="1500" bit, and it's working just dandy now, thanks a lot for the research and information, I apreciate it :)
Back to top
View user's profile Send private message
think4urs11
Administrator
Administrator


Joined: 25 Jun 2003
Posts: 6659
Location: above the cloud

PostPosted: Wed Jun 27, 2007 6:32 am    Post subject: Reply with quote

Moved from Networking & Security to Duplicate Threads as DUP for [Resolved] Faulty MTU with Intel e1000 card
_________________
Nothing is secure / Security is always a trade-off with usability / Do not assume anything / Trust no-one, nothing / Paranoia is your friend / Think for yourself
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum