Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Eclipse] Version de Java
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Neuromancien
l33t
l33t


Joined: 03 Dec 2003
Posts: 867

PostPosted: Mon Jun 25, 2007 8:42 pm    Post subject: [Eclipse] Version de Java Reply with quote

Bonsoir,

J'aimerais installer Eclipse mais il veut m'installer dev-java/sun-jdk-1.4.2 comme dépendance alors que j'ai déjà installé la version 1.5.0. Que faire ?
_________________
emerge --info
dmesg
lspci
.config
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Mon Jun 25, 2007 9:42 pm    Post subject: Reply with quote

La JDK 1.4 est nécessaire pour la compilation de certains paquets java en dépendance d'eclipse, donc tu ne peux pas y couper. Mais ça s'installe très bien à côté des JDK 1.5 et 1.6, les slots sont fait pour ça, et t'es pas obligé de l'utiliser en JVM principale, ça sert juste à compiler.

EDIT : et fait un peu de recherche avant de poster, le sujet est déjà apparu ya pas longtemps (premier résultat après ton post pour une simple recherche sur eclipse dans le forum français, alors va pas me dire que t'as cherché avant).
Back to top
View user's profile Send private message
Neuromancien
l33t
l33t


Joined: 03 Dec 2003
Posts: 867

PostPosted: Tue Jun 26, 2007 8:13 pm    Post subject: Reply with quote

En même temps, le paquet sun-jdk-1.4.2 est marqué comme unsatisfied.
_________________
emerge --info
dmesg
lspci
.config
Back to top
View user's profile Send private message
kopp
Advocate
Advocate


Joined: 09 Apr 2004
Posts: 2885
Location: Grenoble, France

PostPosted: Tue Jun 26, 2007 11:22 pm    Post subject: Reply with quote

Comment ça unsatisfied ? ce serait pas parce que tu dois télécharger le binaire à la fin ? Genre fetch-restricted à cause de la licence ?
Back to top
View user's profile Send private message
Zazbar
Apprentice
Apprentice


Joined: 26 Jul 2005
Posts: 279
Location: Paris Time

PostPosted: Wed Jun 27, 2007 8:39 am    Post subject: Reply with quote

kopp wrote:
Comment ça unsatisfied ? ce serait pas parce que tu dois télécharger le binaire à la fin ? Genre fetch-restricted à cause de la licence ?


Probablement, et c'est peut etre pour ca qu'il installe le blackdown par défaut (qui est opensource, lui ^^)
_________________
Mieux vaut fermer sa gueule et passer pour un con que l'ouvrir et montrer qu'on l'est. -- P. Dac - Pensées
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Wed Jun 27, 2007 9:09 am    Post subject: Reply with quote

Zazbar wrote:
kopp wrote:
Comment ça unsatisfied ? ce serait pas parce que tu dois télécharger le binaire à la fin ? Genre fetch-restricted à cause de la licence ?


Probablement, et c'est peut etre pour ca qu'il installe le blackdown par défaut (qui est opensource, lui ^^)

Non, il est pas opensource, c'est un port de la machine Java de Sun pour Linux, créé à l'époque où Sun ne distribuait pas encore de version Linux. La raison pour laquelle c'est le choix par défaut sous Gentoo, c'est parce que sa redistribution est autorisée. (cf. Wikipedia)
Note : Sun autorise la redistribution de sa JVM depuis la version 1.5, et la JVM Sun 1.7 est bien libre elle par contre :)
Back to top
View user's profile Send private message
Zazbar
Apprentice
Apprentice


Joined: 26 Jul 2005
Posts: 279
Location: Paris Time

PostPosted: Wed Jun 27, 2007 12:01 pm    Post subject: Reply with quote

geekounet wrote:
Zazbar wrote:
kopp wrote:
Comment ça unsatisfied ? ce serait pas parce que tu dois télécharger le binaire à la fin ? Genre fetch-restricted à cause de la licence ?


Probablement, et c'est peut etre pour ca qu'il installe le blackdown par défaut (qui est opensource, lui ^^)

Non, il est pas opensource, c'est un port de la machine Java de Sun pour Linux, créé à l'époque où Sun ne distribuait pas encore de version Linux. La raison pour laquelle c'est le choix par défaut sous Gentoo, c'est parce que sa redistribution est autorisée. (cf. Wikipedia)
Note : Sun autorise la redistribution de sa JVM depuis la version 1.5, et la JVM Sun 1.7 est bien libre elle par contre :)


Merci pour ses précisions, je pensais que c'etait un projet 'totalement' séparé mais apparement non :)
_________________
Mieux vaut fermer sa gueule et passer pour un con que l'ouvrir et montrer qu'on l'est. -- P. Dac - Pensées
Back to top
View user's profile Send private message
Neuromancien
l33t
l33t


Joined: 03 Dec 2003
Posts: 867

PostPosted: Fri Jun 29, 2007 8:15 pm    Post subject: Reply with quote

kopp wrote:
Comment ça unsatisfied ? ce serait pas parce que tu dois télécharger le binaire à la fin ? Genre fetch-restricted à cause de la licence ?

Oui, c'est le cas. J'installe le binaire téléchargé ? Cela ne risque pas de poser des problèmes sachant que j'ai déjà installé le JDK 1.5 ?
_________________
emerge --info
dmesg
lspci
.config
Back to top
View user's profile Send private message
blasserre
Veteran
Veteran


Joined: 10 Feb 2004
Posts: 1362
Location: Lille, Vlaanderen

PostPosted: Fri Jun 29, 2007 9:22 pm    Post subject: Reply with quote

Neuromancien wrote:
kopp wrote:
Comment ça unsatisfied ? ce serait pas parce que tu dois télécharger le binaire à la fin ? Genre fetch-restricted à cause de la licence ?

Oui, c'est le cas. J'installe le binaire téléchargé ? Cela ne risque pas de poser des problèmes sachant que j'ai déjà installé le JDK 1.5 ?
geekounet wrote:

La JDK 1.4 est nécessaire pour la compilation de certains paquets java en dépendance d'eclipse, donc tu ne peux pas y couper. Mais ça s'installe très bien à côté des JDK 1.5 et 1.6, les slots sont fait pour ça, et t'es pas obligé de l'utiliser en JVM principale, ça sert juste à compiler.

_________________
benj

technicien professionnel, ascendant winner
Back to top
View user's profile Send private message
Neuromancien
l33t
l33t


Joined: 03 Dec 2003
Posts: 867

PostPosted: Fri Jun 29, 2007 9:42 pm    Post subject: Reply with quote

Une question : Comme la JDK 1.4 ne sert que pour la compilation d'Eclipse, peut-on la supprimer ensuite ?
_________________
emerge --info
dmesg
lspci
.config
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum