Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
registrazione suoni: mi registra un semitorno sotto c.a.!
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
darkmanPPT
Veteran
Veteran


Joined: 13 Apr 2006
Posts: 1069
Location: vi/bo

PostPosted: Sun Jun 24, 2007 10:37 pm    Post subject: registrazione suoni: mi registra un semitorno sotto c.a.! Reply with quote

ebbene si....
non so perchè.. ma quando provo a registrare qualcosa di audio (sia che sia la chitarra attaccata via jack che la voce)... ho sempre lo stesso risultato:
quando faccio il "play" mi ritrovo sempre il pezzo "come se" fosse stato registrato circa un semitono sotto rispetto a quello che ho suonato.
allora.. per la cronaca:
io ho attivato jack seguendo correttamente la guida.
per registrare ho provato:
audacity
mhwaveedit

sia usando ALSA che usando JACK (facendolo partire con il comando jack -d alsa)

:cry: :cry:
nessuno ha delle idee su come risolvere questa cosa???

altre informazioni:
TALVOLTA se provo a registrare con ALSA... si registra un bel beeeeeep al posto di quello che dovrei aver registrato. la cosa divertente è che audacity mi disegna correttamente il grafico temporale delle frequenze (non so come chiamarlo in modo migliore :-D).
ho provato anche ad usare OSS.... no comment.. uno schifo assurdo.

non ho problemi di uscita audio.. i suoni mi si sentono bene. la mia scheda è pienamente supportata da ALSA. (ho una Intel ICH6)

una volta mi andava (credo che sia passato più di un anno da quando ho provato... e da allora sono cambiati tante versioni)


....e per finire... sotto windows va.... cacchio.... non voglio usare windows.... :cry: :cry:
_________________
Darkman
Back to top
View user's profile Send private message
fikiz
Apprentice
Apprentice


Joined: 07 Mar 2005
Posts: 282
Location: Italy

PostPosted: Mon Jun 25, 2007 6:58 am    Post subject: Reply with quote

ho avuto lo stesso problema, ma purtroppo non ho una soluzione da suggerirti. Mi sono liberato di questa noia solo quando ho cambiato la scheda madre.
La scheda audio (integrata) che mi dava questo problema e', se non sbaglio, una AC97. In passato funzionava perfettamente, ad un certo punto ha cominciato a registrare un semitono sotto (circa) ma, siccome la usavo qualche volta solo come accordatore, non mi sono reso conto di quale aggiornamento software ha causato questo comportamento; a memoria mi pare che fino al kernel 2.6.17 o 2.6.18 avevo un funzionamento corretto.

Non ho approfondito molto la questione, ho fatto prima a tornare ad utilizzare l'accordatore classico. comunque ho riscontrato il problema con tutte le applicazioni che leggono dalla scheda audio.

Se puoi prova con qualche downgrade di kernel oppure di alsa. jack non l'ho mai usato, quindi lo escuderei.
Back to top
View user's profile Send private message
randomaze
Bodhisattva
Bodhisattva


Joined: 21 Oct 2003
Posts: 9985

PostPosted: Mon Jun 25, 2007 7:40 am    Post subject: Reply with quote

Sono indeciso se spostarvi nel forum di discussione....
Se la scheda audio funziona male in teoria é un problema di supporto, ma "suona mezzo tono sotto" mi sembra parecchio specifica... (un pò come configurare paranoicamente un firewall, per intenderci).
Si accettano pareri via pm.
_________________
Ciao da me!
Back to top
View user's profile Send private message
darkmanPPT
Veteran
Veteran


Joined: 13 Apr 2006
Posts: 1069
Location: vi/bo

PostPosted: Mon Jun 25, 2007 8:58 am    Post subject: Reply with quote

eh, boh....
cmq... sapete quale è la cosa strana?

che ho appena provato con ardour a registrare... (non so perche si rifiuti di registrare tramite il jack del microfono... ma vabbè.. funzia solo il jack "line in")
ebbene.. registra giusto......
allora il problema è.......
perchè TUTTI gli altri programmi registrano in modo sbagliato?

cioè... vabbè che ardour funziona... però non è nemmeno il massimo della "estetica" come programma... non capisco perchè non mi vadano gli altri... boh!
eppure o provato con tutti tramite jack..... 8O 8O
boh...
idee?
_________________
Darkman
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Wed Jun 27, 2007 6:36 am    Post subject: Reply with quote

Salve a tutti (ciao darkman, son qua anche io), ci ho pensato su e fornisco la mia opinione: se si registra un qualsiasi segnale a 44,100 khz e poi lo si riascolta a 48 khz chiaramente la tonalità cambia perchè i dati vengono letti con una frequenza differente da quella di campionamento, adesso io non so dove si debbano settare nei vari programmi audio linux tutti sti parametri.

Penso quindi che anche il tempo probabilmente cambi un po' (non saprei quanto, da verificare questo...), e ipotizzo anche che non sia mezzo tono esatto, fra l'altro esistono programmi audio che cambiano tonalità con non poche difficoltà e non sempre con buoni risultati.

Altre cose:
- secondo me ardour sembra più completa come programma per DAW da quel che ho visto anche se esteticamente è una ciofeca, sembra che esista ardour 2 che è concepito parecchio in "pro tools style" ma non avendolo provato non saprei dare un parere oltre quel che ho scritto... poi non so dove siano i plugins aggiuntivi etc..., fra l'altro le mie schede non son supportate...
- magari prima di provare con windows prova con la nuova release di ubuntu studio (almeno a scopo statistico per avere qualche numero in più per capire)
- hai provato a registrare con audacity e riascoltare con ardour? Fai qualche "prova incrociata" :D
do noi y do noi y do so sinh tron goi quan ao ban buon quan ao ban buon quan lot rbi do boi dep xe day doi ao so mi nu thoi trang cong so chup anh studio

Non ho alte robe per il momento..... spero sia di aiuto, saludos :D


Last edited by lsegalla on Fri May 03, 2013 2:47 pm; edited 1 time in total
Back to top
View user's profile Send private message
fikiz
Apprentice
Apprentice


Joined: 07 Mar 2005
Posts: 282
Location: Italy

PostPosted: Wed Jun 27, 2007 9:08 am    Post subject: Reply with quote

Si', ragionando sul discorso 44.1 Khz - 48 Khz, un LA a 440 Hz campionato a 48 Khz e riprodotto a 44.1 Khz suona a 404.25 Hz, che sarebbe una nota a meta' strada tra un SOL e un SOL#. Potrebbe proprio venire da qui quel semitono che "ci manca".
Se il ragionamento e' giusto, sembra che l'audacity che usa darkmanPPT o l'accordatore che usavo io (kguituner, mi pare) chiedono alla scheda di campionare a 44.1 Khz e quella di nascosto lavora a 48.
Magari Ardour chiede 48 Khz e ottiene effettivamente 48 Khz, e quindi registra correttamente... e' un'ipotesi.

Purtoppo non dispongo piu' della macchina che mi dava questo problema, e quindi non posso approfondire.
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Wed Jun 27, 2007 11:51 am    Post subject: Reply with quote

Oppure semplicemente ardour lavora tranquillamente sempre alla stessa freq. di campionamento, che poi sia 44,1 khz o 48 khz poco importante è...
do lot vera ao lot nam sieu mong tui ngu cho be thoi trang cong so nu ao so mi cong so do boi dep quan ao thoi trang dep chan goi so sinh vay cong so vay cong so chup anh da ngoai
E comunque usando la 48 khz si ottiene gran poco di più, niente di udibile senz'altro... anzi: nel caso di una ipotetica riconversione del segnale a un 44,100 il sistema dovrebbe fare un bel po' di calcoli ma... sono OT


Last edited by lsegalla on Fri May 03, 2013 2:48 pm; edited 1 time in total
Back to top
View user's profile Send private message
darkmanPPT
Veteran
Veteran


Joined: 13 Apr 2006
Posts: 1069
Location: vi/bo

PostPosted: Wed Jun 27, 2007 1:07 pm    Post subject: Reply with quote

ardour funziona a 48000
perchè jack funziona a tale rate.... :wink:
uhmm... si spiegherebbero un bel po' di cose.... però una volta non me lo faceva... come mai allora?
_________________
Darkman
Back to top
View user's profile Send private message
lsegalla
l33t
l33t


Joined: 27 Jun 2007
Posts: 796

PostPosted: Wed Jun 27, 2007 1:47 pm    Post subject: Reply with quote

darkmanPPT wrote:
ardour funziona a 48000
perchè jack funziona a tale rate.... :wink:
uhmm... si spiegherebbero un bel po' di cose.... però una volta non me lo faceva... come mai allora?


Questo non lo so... sono pur sempre un niubbo no? ahaha....
Ma suppongo che a un certo punto qualcuno o qualcosa abbia cambiato quel parametro, comunque ti consiglio di impostare dappertutto 44,1 khz e poi dicci se hai risolto. Non vorrei che tu registrassi a 48 khz e poi magari per la riproduzione viene usata non so che applicazione che funzia per default a 44,100.
ao nguc vera ao lot nam goi cam tui ngu cao cap cho be vest cong so nu ao so mi nu shop thoi trang quan ao thoi trang han quoc quan ao so sinh cho be vest cong so vest cong so chup anh cuoi o ha noi
Facci sapere se hai risolto......


Last edited by lsegalla on Fri May 03, 2013 2:48 pm; edited 1 time in total
Back to top
View user's profile Send private message
GiRa
l33t
l33t


Joined: 07 Apr 2005
Posts: 717

PostPosted: Wed Jun 27, 2007 2:44 pm    Post subject: Reply with quote

Non ho letto tutto il thread e spero di non dire cose già dette:
- gioca con i rate di Frames/Period e Periods/Buffer se li abbassi troppo la scheda integrata non ce la fa e quindi hai millemila sfighe
- Controlla i timer nel kernel (metti tutto a low latency desktop)
- Ardour si basa su jack e quindi non stona
- Non usare Audacity che, al momento, registra in emulazione OSS dandoti vari problemi (tra l'altro devi settare a mano il rate di registrazione)
- Ardour è brutto ma fatto molto bene, è già da un po' che sto pensando di installarmi l'overlay pro-audio per avere la versione 2
Back to top
View user's profile Send private message
darkmanPPT
Veteran
Veteran


Joined: 13 Apr 2006
Posts: 1069
Location: vi/bo

PostPosted: Wed Jun 27, 2007 6:38 pm    Post subject: Reply with quote

mo me la installo la versione 2
_________________
Darkman
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum