Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Installare hamachi [RISOLTO]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Karhot87
Tux's lil' helper
Tux's lil' helper


Joined: 26 Apr 2007
Posts: 137
Location: Poggio Murella (GR) ma studio a Roma

PostPosted: Sun Jun 24, 2007 12:17 pm    Post subject: Installare hamachi [RISOLTO] Reply with quote

Salve voglio installare hamachi,ma quando lo emergo mi da questo errore:

* Found sources for kernel version:
* 2.6.20-gentoo-r8
* Checking for suitable kernel configuration options...
* CONFIG_TUN: is not set when it should be.
* Please check to make sure these options are set correctly.
* Failure to do so may cause unexpected problems.
* Once you have satisfied these options, please try merging
* this package again.

!!! ERROR: net-misc/hamachi-0.9.9.9_p20-r2 failed.
Call stack:
ebuild.sh, line 1631: Called dyn_setup
ebuild.sh, line 703: Called qa_call 'pkg_setup'
ebuild.sh, line 44: Called pkg_setup
hamachi-0.9.9.9_p20-r2.ebuild, line 39: Called check_extra_config
linux-info.eclass, line 471: Called die

!!! Incorrect kernel configuration options
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/net-misc/hamachi-0.9.9.9_p20-r2/temp/build.log'.

e nn capisco cosa devo abilitare nel kernel. Sapete aiutarmi?


Last edited by Karhot87 on Mon Jun 25, 2007 5:42 pm; edited 1 time in total
Back to top
View user's profile Send private message
made
l33t
l33t


Joined: 19 Mar 2005
Posts: 608
Location: veneto

PostPosted: Sun Jun 24, 2007 12:25 pm    Post subject: Reply with quote

Quote:
CONFIG_TUN: is not set when it should be.


c'è scritto cerca nel file .config la riga CONFIG_TUN

poi salva e riprova

Code:
nano /usr/src/linux/.config


poi cerca la config_tun

e metti nel file
Code:

CONFIG_TUN=y


ricompila il kernel
_________________
My system: cpu AMD Athlon(tm) 64 Processor 3800+,kernel 2.6.25-r1-gentoo
Back to top
View user's profile Send private message
Karhot87
Tux's lil' helper
Tux's lil' helper


Joined: 26 Apr 2007
Posts: 137
Location: Poggio Murella (GR) ma studio a Roma

PostPosted: Sun Jun 24, 2007 12:46 pm    Post subject: Reply with quote

Ok, grazie, sono riuscito ad installarlo, ma nn funziona...
Back to top
View user's profile Send private message
made
l33t
l33t


Joined: 19 Mar 2005
Posts: 608
Location: veneto

PostPosted: Sun Jun 24, 2007 3:04 pm    Post subject: Reply with quote

riesci a compilare ma non funziona....... cioè non parte l'eseguibile

fallo partire da shell e poi posta l'errore che vediamo
_________________
My system: cpu AMD Athlon(tm) 64 Processor 3800+,kernel 2.6.25-r1-gentoo
Back to top
View user's profile Send private message
Karhot87
Tux's lil' helper
Tux's lil' helper


Joined: 26 Apr 2007
Posts: 137
Location: Poggio Murella (GR) ma studio a Roma

PostPosted: Sun Jun 24, 2007 3:52 pm    Post subject: Reply with quote

Allora, se lancio:
"hamaci start"
l'errore è il seguente:

"25 17:49:22.120 [ 0] [24238] tap: connect() failed 2 (No such file or directory)"

se invece avvio la gui con il comando "ghamachi" esce fuori una finestra con scritto:

"TAP/TUN not found"
Back to top
View user's profile Send private message
wilma_dammi_la_clava
n00b
n00b


Joined: 07 Jul 2006
Posts: 64

PostPosted: Mon Jun 25, 2007 8:29 am    Post subject: Reply with quote

devi prima lanciare
modprobe tun--> tuncfg-->hamachi -l XXXX <--crei le chiavi
poi
hamachi start--> hamachi login

ovviamente devi avere il kernel compilato con il modulo tun/tap o compilato staticamente
sennò non funziona.
_________________
errare è umano ....ma per fare veramente casino ci vuole la password di ROOT!!!!!!!!
Back to top
View user's profile Send private message
Karhot87
Tux's lil' helper
Tux's lil' helper


Joined: 26 Apr 2007
Posts: 137
Location: Poggio Murella (GR) ma studio a Roma

PostPosted: Mon Jun 25, 2007 5:42 pm    Post subject: Reply with quote

Grazie wilma_dammi_la_clava, nn ho capito bene il comando

hamachi -l XXXX

ma cmq adesso hamachi funge.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum