Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Weird network problem: ping, dns ok, no internet[SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
robiss
n00b
n00b


Joined: 23 Jun 2007
Posts: 5

PostPosted: Sat Jun 23, 2007 10:46 pm    Post subject: Weird network problem: ping, dns ok, no internet[SOLVED] Reply with quote

i have a strange problem with network. i can ping, arping, dns is working, but i cant browse, cant open ftp, ... my internet works fine on windows and linvecd, ifconfig and route looks the same as on live cd. Then i try to open website in links i just see "request sent", in opera its just blank page, and and on conquer i see "connection to x.x.x.x broken". I can even open my routers web admin, i can see and even login to it, but no page is opened after i login to it. Maybe somenone could give me at least some clue what could be wrong, iam trying to resolve this stupid problem for 3d day already, and searched on internet, tryed lots of diferent things and nothing helps.

Last edited by robiss on Sun Jun 24, 2007 4:08 pm; edited 1 time in total
Back to top
View user's profile Send private message
robiss
n00b
n00b


Joined: 23 Jun 2007
Posts: 5

PostPosted: Sun Jun 24, 2007 8:44 am    Post subject: Reply with quote

Please anyone, give me at least some clue what could possibly be wrong :(
Back to top
View user's profile Send private message
gsoe
Apprentice
Apprentice


Joined: 10 Dec 2006
Posts: 289
Location: Denmark

PostPosted: Sun Jun 24, 2007 10:05 am    Post subject: Reply with quote

What's the actual output of
Code:
ifconfig
route
And what's the content of
Code:
/etc/resolv.conf
/etc/conf.d/net
Also, what ping commands work? ping URL or ping IP-address? Do you have any kind of iptables rules on your system?
Back to top
View user's profile Send private message
robiss
n00b
n00b


Joined: 23 Jun 2007
Posts: 5

PostPosted: Sun Jun 24, 2007 12:52 pm    Post subject: Reply with quote

I think this should be enought information:

And btw ftp work fine






robiss ~ # route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 * 255.255.255.0 U 0 0 0 eth0
loopback * 255.0.0.0 U 0 0 0 lo
default 192.168.1.1 0.0.0.0 UG 0 0 0 eth0



robiss ~ # ifconfig
eth0 Link encap:Ethernet HWaddr 00:16:36:5F:00:1C
inet addr:192.168.1.2 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::216:36ff:fe5f:1c/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1320 Metric:1
RX packets:227 errors:59 dropped:0 overruns:0 frame:59
TX packets:2824 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:29417 (28.7 Kb) TX bytes:196122 (191.5 Kb)
Interrupt:18

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:6 errors:0 dropped:0 overruns:0 frame:0
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:300 (300.0 b) TX bytes:300 (300.0 b)




robiss ~ # lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS/940GML and 945GT Express Memory Controller Hub (rev 03)
00:01.0 PCI bridge: Intel Corporation Mobile 945GM/PM/GMS/940GML and 945GT Express PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
00:1c.2 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 3 (rev 02)
00:1c.3 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 4 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) Serial ATA Storage Controller IDE (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc M56P [Radeon Mobility X1600]
03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
04:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5789 Gigabit Ethernet PCI Express (rev 21)
0a:09.0 CardBus bridge: Texas Instruments Unknown device 8039
0a:09.1 FireWire (IEEE 1394): Texas Instruments Unknown device 803a
0a:09.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD)



robiss ~ # ping www.google.lt
PING www.l.google.com (209.85.135.103) 56(84) bytes of data.
64 bytes from mu-in-f103.google.com (209.85.135.103): icmp_seq=1 ttl=245 time=55.7 ms
64 bytes from mu-in-f103.google.com (209.85.135.103): icmp_seq=2 ttl=245 time=55.9 ms



robiss ~ # arping www.google.lt
ARPING 209.85.135.103 from 192.168.1.2 eth0
Sent 4 probes (4 broadcast(s))
Received 0 response(s)


robiss ~ # iptables --list
Chain INPUT (policy ACCEPT)
target prot opt source destination
Chain FORWARD (policy ACCEPT)
target prot opt source destination
Chain OUTPUT (policy ACCEPT)
target prot opt source destination



robiss ~ # lsmod
Module Size Used by
nls_iso8859_1 4224 1
nls_cp437 5888 1
vfat 9472 1
fat 39964 1 vfat
usb_storage 59456 1
usbmouse 4224 0
snd_usb_audio 69760 0
snd_usb_lib 12928 1 snd_usb_audio
snd_rawmidi 17408 1 snd_usb_lib
genrtc 6988 0
snd_hwdep 6660 1 snd_usb_audio
usbhid 18912 0
yenta_socket 21388 0
rsrc_nonstatic 8576 1 yenta_socket
pcmcia_core 30104 2 yenta_socket,rsrc_nonstatic
serio_raw 5124 0
pcspkr 2688 0
i2c_i801 7312 0
uhci_hcd 18700 0
intel_agp 19740 1
agpgart 23756 1 intel_agp
sg 27292 0
ehci_hcd 25484 0
usbcore 100616 8 usb_storage,usbmouse,snd_usb_audio,snd_usb_lib,usbhid,uhci_hcd,ehci_hcd
evdev 7296 1



robiss ~ # nmap -v www.google.lt
Starting Nmap 4.20 ( http://insecure.org ) at 2007-06-24 15:32 Local time zone must be set--see zic manual page
Warning: Hostname www.google.lt resolves to 4 IPs. Using 209.85.135.104.
Initiating Parallel DNS resolution of 1 host. at 15:32
Completed Parallel DNS resolution of 1 host. at 15:32, 0.13s elapsed
Initiating SYN Stealth Scan at 15:32
Scanning mu-in-f104.google.com (209.85.135.104) [1697 ports]
Discovered open port 443/tcp on 209.85.135.104
Discovered open port 80/tcp on 209.85.135.104
Stats: 0:00:02 elapsed; 0 hosts completed (1 up), 1 undergoing SYN Stealth Scan
SYN Stealth Scan Timing: About 2.47% done; ETC: 15:33 (0:01:15 remaining)



robiss ~ # wget www.google.lt
--15:33:20-- http://www.google.lt/
=> `index.html'
Resolving www.google.lt... 209.85.135.104, 209.85.135.147, 209.85.135.99, ...
Connecting to www.google.lt|209.85.135.104|:80... connected.
HTTP request sent, awaiting response...


robiss ~ # emerge nano
Calculating dependencies... done!

>>> Emerging (1 of 1) app-editors/nano-2.0.4 to /
>>> Downloading 'http://distfiles.gentoo.org/distfiles/nano-2.0.4.tar.gz'
--15:33:55-- http://distfiles.gentoo.org/distfiles/nano-2.0.4.tar.gz
=> `/usr/portage/distfiles/nano-2.0.4.tar.gz'
Resolving distfiles.gentoo.org... 216.165.129.135, 156.56.247.195, 64.50.236.52, ...
Connecting to distfiles.gentoo.org|216.165.129.135|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1,313,903 (1.3M) [application/x-gzip]

0% [ ] 0 --.--K/s ^


robiss ~ # nano -w /etc/resolv.conf
# Generated by dhcpcd for interface eth0
nameserver 192.168.1.1



robiss ~ # rc-status
Runlevel: default
cpufreqd [ stopped ]
net.eth0 [ started ]
netmount [ started ]




robiss ~ # echo $http_proxy

robiss ~ #
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7466

PostPosted: Sun Jun 24, 2007 2:16 pm    Post subject: Reply with quote

robiss wrote:
ifconfig
eth0 Link encap:Ethernet HWaddr 00:16:36:5F:00:1C
inet addr:192.168.1.2 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::216:36ff:fe5f:1c/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1320 Metric:1
RX packets:227 errors:59 dropped:0 overruns:0 frame:59
TX packets:2824 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:29417 (28.7 Kb) TX bytes:196122 (191.5 Kb)
Interrupt:18


dig that, your problem comes from there i think
Back to top
View user's profile Send private message
robiss
n00b
n00b


Joined: 23 Jun 2007
Posts: 5

PostPosted: Sun Jun 24, 2007 3:27 pm    Post subject: Reply with quote

MTU is not a problem , i chaged it experimening with diffent setting, i switched back to 1500, that not helps.
And biggest clue to my is why ftp works, then http not, and from what iam seeing iam getting responses from servers(200 ok), but thats it, nothing else goes anywhere further. :cry:

But thanks anyway.
Back to top
View user's profile Send private message
robiss
n00b
n00b


Joined: 23 Jun 2007
Posts: 5

PostPosted: Sun Jun 24, 2007 4:07 pm    Post subject: Reply with quote

so it apears mtu was a problem, i set it with ifconfig eth0 mtu 1500 and everthing started to work, i seams it hadn´t read config file before since in there was written 1500.
Big big thanks krinn :D :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum