Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Зависает x-сервер
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
kaminari
n00b
n00b


Joined: 21 Jun 2007
Posts: 6

PostPosted: Thu Jun 21, 2007 1:40 pm    Post subject: Зависает x-сервер Reply with quote

Есть система Gentoo 2007.0 на Athlon64 X2 3800, память 1 ГБ, Видюха Nvidia GeForce 7600 256MB

Система периодически виснет при работающем X-сервере независимо от нагрузки и запущенных приложений. Установлен Beryl, но система может зависнуть и без него. Зависание может произойти как через 15 мин, так и через несколько часов. В консоли может работать неделями. Раньше на этом компе такая же фигня была в Убунту. После зависания не движется мышь, не работают никакие "волшебные" кнопки.

Настройки xorg.conf:

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "Files"
RgbPath "/usr/share/X11/rgb"
ModulePath "/usr/lib64/xorg/modules"
FontPath "/usr/share/fonts/misc/"
FontPath "/usr/share/fonts/cyrillic/"
FontPath "/usr/share/fonts/100dpi/:unscaled"
FontPath "/usr/share/fonts/75dpi/:unscaled"
FontPath "/usr/share/fonts/corefonts/"
FontPath "/usr/share/fonts/100dpi"
FontPath "/usr/share/fonts/75dpi/"
FontPath "/usr/share/fonts/ttf/"
FontPath "/usr/share/fonts/terminus/"
EndSection

Section "Module"
Load "GLcore"
Load "wfb"
Load "dbe"
Load "extmod"
Load "freetype"
Load "glx"
Load "xtrap"
Load "type1"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us,ru"
Option "XkbOptions" "grp:ctrl_shift_toggle,grp_led:scroll"
Option "XkbVariant" ",winkeys"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "false"
EndSection

Section "Monitor"
Identifier "Samsung 970p"
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 75.0
Option "DPMS"
EndSection

Section "Device"
Identifier "nVidia Corporation G70 [GeForce 7600 GT]"
Driver "nvidia"
Option "AddARGBGLXVisuals" "true"
Option "UseEvents" "false"
Option "RenderAccel" "true"
Option "HWcursor" "on"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation G70 [GeForce 7600 GT]"
Monitor "Samsung 970p"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Заранее благодарю!


Last edited by kaminari on Sat Jun 23, 2007 10:51 am; edited 2 times in total
Back to top
View user's profile Send private message
fank
l33t
l33t


Joined: 16 Oct 2004
Posts: 794
Location: Minsk, Belarus

PostPosted: Thu Jun 21, 2007 2:46 pm    Post subject: Reply with quote

смотрим сюда
http://gentoo-wiki.com/Compiz
видим, что
Code:
 Load "GLcore"
 Load "vbe"

должно быть выключено

и так далее по руководству нужно все проверить...

потом нужно запостить
Code:
emerge xorg-server -pv


и лог тоже было бы неплохо увидеть...
Back to top
View user's profile Send private message
Laitr Keiows
Moderator
Moderator


Joined: 04 Jul 2005
Posts: 891
Location: Kobe, Japan

PostPosted: Sat Jun 23, 2007 2:58 am    Post subject: Reply with quote

Память проверить рекомендую.
Back to top
View user's profile Send private message
kaminari
n00b
n00b


Joined: 21 Jun 2007
Posts: 6

PostPosted: Sat Jun 23, 2007 10:14 am    Post subject: Reply with quote

Спасибо fank-у!
Действительно собака порылась в
Code:
Load "GLcore"

Просто в других гидах (howto xgl, howto nvidia-gl, howto beryl) об этом ничего не сказано.
В итоге привел свой /etc/X11/xorg.conf к следующему виду:

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen" 0 0
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
EndSection

Section "Files"
RgbPath "/usr/share/X11/rgb"
ModulePath "/usr/lib64/xorg/modules"
FontPath "/usr/share/fonts/misc/"
FontPath "/usr/share/fonts/cyrillic/"
FontPath "/usr/share/fonts/100dpi/:unscaled"
FontPath "/usr/share/fonts/75dpi/:unscaled"
FontPath "/usr/share/fonts/corefonts/"
FontPath "/usr/share/fonts/100dpi"
FontPath "/usr/share/fonts/75dpi/"
FontPath "/usr/share/fonts/ttf/"
FontPath "/usr/share/fonts/terminus/"
EndSection

Section "Module"
Load "glx"
Load "dbe"
Load "extmod"
Load "xtrap"
Load "wfb"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us,ru"
Option "XkbOptions" "grp:ctrl_shift_toggle,grp_led:scroll"
Option "XkbVariant" ",winkeys"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "false"
EndSection

Section "Monitor"
Identifier "Samsung 970p"
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 75.0
Option "DPMS"
EndSection

Section "Device"
Identifier "nVidia Corporation G70 [GeForce 7600 GT]"
Driver "nvidia"
Option "UseEvents" "false"
Option "RenderAccel" "true"
Option "HWcursor" "on"
Option "DRI" "true"
Option "XAANoOffscreenPixmaps" "true"
EndSection

Section "Dri"
Group 0
Mode 0666
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation G70 [GeForce 7600 GT]"
Monitor "Samsung 970p"
Option "AddARGBGLXVisuals" "true"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection


Уже 2 дня - полет нормальный!

Вот вывод $ emerge -pv xorg-server
(Может нужен кому)
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] x11-base/xorg-server-1.2.0-r3 USE="dri nptl xorg xprint (-3dfx) -debug -dmx -ipv6 -kdrive -minimal -sdl" INPUT_DEVICES="evdev keyboard mouse -acecad -aiptek -calcomp -citron -digitaledge -dmc -dynapro -elo2300 -elographics -fpit -hyperpen -jamstudio -joystick -magellan -microtouch -mutouch -palmax -penmount -spaceorb -summa -synaptics -tek4957 -ur98 -vmmouse -void -wacom" VIDEO_CARDS="nvidia -apm -ark -chips -cirrus -cyrix -dummy -epson -fbdev -fglrx -glint -i128 (-i740) -i810 (-impact) (-imstt) -mach64 -mga -neomagic (-newport) (-nsc) -nv -r128 -radeon -rendition -s3 -s3virge -savage -siliconmotion -sis -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v4l -vesa -vga -via -vmware -voodoo" 0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB
Back to top
View user's profile Send private message
kaminari
n00b
n00b


Joined: 21 Jun 2007
Posts: 6

PostPosted: Sat Jun 23, 2007 10:53 am    Post subject: Reply with quote

Ага, только запостил, что все зашибись, а она опять зависла :cry: :x :?

Laitr Keiows wrote:
Память проверить рекомендую.

Гонял Memtest86 5 раз - ни одной ошибки.

Может кто знает где можно прочитать про эти модули и за что каждый из них отвечает?
Back to top
View user's profile Send private message
kaminari
n00b
n00b


Joined: 21 Jun 2007
Posts: 6

PostPosted: Fri Jul 06, 2007 10:02 am    Post subject: Reply with quote

Разобрался наконец!
:twisted:
Тупо пересобрал xorg-server с CFLAGS= -O2 вместо -O3
Пока работает (стук-тук)
Back to top
View user's profile Send private message
gelog
n00b
n00b


Joined: 01 Oct 2007
Posts: 24

PostPosted: Mon Oct 01, 2007 11:37 pm    Post subject: Reply with quote

у меня тож самое было на ubuntu, зависал берил, но вот компиз работает норм ) + у firefoxa и nvidia утечка памяти, так вообше кошмар !! :twisted:

PS сейчас пробую gentoo, так как мне bsd системы вообще по душе :). да вот ток ядро новое не собирается :/
Back to top
View user's profile Send private message
bobdva
Apprentice
Apprentice


Joined: 25 Nov 2003
Posts: 207
Location: Moscow

PostPosted: Wed Oct 03, 2007 10:58 am    Post subject: Reply with quote

kaminari wrote:
Разобрался наконец!
:twisted:
Тупо пересобрал xorg-server с CFLAGS= -O2 вместо -O3
Пока работает (стук-тук)


не помогло - так же виснет. Откатился уже до 1.3 - который раньше работал без нареканий и с -O3
Back to top
View user's profile Send private message
bobdva
Apprentice
Apprentice


Joined: 25 Nov 2003
Posts: 207
Location: Moscow

PostPosted: Wed Oct 03, 2007 11:50 am    Post subject: Reply with quote

По теме: X.org Lockups
Back to top
View user's profile Send private message
but4er
n00b
n00b


Joined: 22 Sep 2006
Posts: 18

PostPosted: Mon Oct 15, 2007 11:19 am    Post subject: Reply with quote

была похожая проблемма, дело оказалось в (памяти + chipset), память была полностью рабочая, memtest никаких ошибок не выдавал, но вот в связке они работать не хотели.
Back to top
View user's profile Send private message
Cleus
Apprentice
Apprentice


Joined: 21 Aug 2004
Posts: 157

PostPosted: Fri Nov 02, 2007 6:00 am    Post subject: Reply with quote

А у меня тоже проблема, причем устойчивая, недавно появилась - играет mplayer и в определенный момент висет, намертво завешивая Х-ы. Второго компа нет, проверить, зависла вся система или нет не могу, но по крайней мере кнопка выключения компа (acpid) не реагирует, видимо таки виснет тоже. Убить Х не могу, клава и мышь не реагируют. Можно только перезагрузиться. Ужасно.
Сперва грешил на mkv с h.264, но на обычной xvid авишке случилось то же самое.
Все самое последнее - xorg, ядро.
Память еще не проверял, но до этого поменял gcc профиль на новый, может это от него такое случилось?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum