Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[E17][MPD] Emphasis: Not Connected To Mpd (Résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Thesalan
n00b
n00b


Joined: 16 Nov 2006
Posts: 69

PostPosted: Thu Jun 21, 2007 11:50 am    Post subject: [E17][MPD] Emphasis: Not Connected To Mpd (Résolu) Reply with quote

Bonjour,

Je ne sais pas si il y a des personnes qui utilisent emphasis ici (lecteur audio pour e17 basé sur mpd), mais j'ai un petit souci avec:
Comme l'indique le titre, emphasis me dit qu'il n'est pas connecté a mpd alors que je l'ai bien lancé.
J'ai installé la version 0.13 de mpd, et j'ai bien fait un --create-db.
Au niveau de /etc/mpd.conf j'ai tout laissé par défaut (j'ai fait un lien vers mes mp3 dans /var/lib/mpd/music)

Donc la, je sèche....


Last edited by Thesalan on Thu Jun 21, 2007 5:12 pm; edited 1 time in total
Back to top
View user's profile Send private message
Bapt
Veteran
Veteran


Joined: 14 Apr 2003
Posts: 1152
Location: Paris

PostPosted: Thu Jun 21, 2007 2:51 pm    Post subject: Reply with quote

Ton mpd écoute sur quel port ?
Emphasis est il bien configurer pour se connecter sur le bon port ?

parce que emphasis+mpd : chezmoiçamarche parfaitement :)
Pour configurer emphasis, si je me souviens bien c'est clique droit préférence ou un truc du genre (je pourrais te dire ce soir.)
pour tester que ton mpd fonctionne bien, essayer avec mpc (client en libre de commande).
Back to top
View user's profile Send private message
Thesalan
n00b
n00b


Joined: 16 Nov 2006
Posts: 69

PostPosted: Thu Jun 21, 2007 5:00 pm    Post subject: Reply with quote

Ils sont tous les deux sur le port 6600 (par défaut)

Je vais essayer avec mpc...

EDIT: ca ne marche pas:
Quote:
# mpc
MPD_HOST and/or MPD_PORT environment variables are not set
error: problems getting a response from "localhost" on port 6600 : Connection refused


J'ai donc fais un export MPD_HOST="localhost" et MPD_PORT="6600" et voila:
Quote:
error: problems getting a response from "localhost" on port 6600 : Connection refused


Voici mon /etc/mpd.conf si ca peut aider: (j'ai pas tout mis, le reste est commenté)

Quote:
# A default Gentoo configuration file for MPD
# See the mpd.conf man page for a more detailed description of each parameter.

######################## REQUIRED PATHS ########################
music_directory "/var/lib/mpd/music"
playlist_directory "/var/lib/mpd/playlists"
db_file "/var/lib/mpd/database"
log_file "/var/log/mpd/mpd.log"
error_file "/var/log/mpd/mpd.error.log"
################################################################


######################## OPTIONAL PATHS ########################
#
# If you wish to use mpd --kill to stop MPD, then you must
# specify a file here in which to store MPD's process ID.
#
pid_file "/var/run/mpd/mpd.pid"
#
# If specified, MPD will save its current state (playlist,
# current song, playing/paused, etc.) at exit. This will be
# used to restore the session the next time it is run.
#
state_file "/var/lib/mpd/state"
#
################################################################


######################## DAEMON OPTIONS ########################
#
# If started as root, MPD will drop root privileges and run as
# this user instead. Otherwise, MPD will run as the user it was
# started by. If left unspecified, MPD will not drop root
# privileges at all (not recommended).
#
user "mpd"
#
# The address and port to listen on.
#
bind_to_address "localhost"
port "6600"
#
# Controls the amount of information that is logged. Can be
# "default", "secure", or "verbose".
#
#log_level "default"
#
# If Zeroconf is configured, the service name to publish. This
# should be unique on your local network, but name collisions
# will be taken care of for you.
#
#zeroconf_name "Music Player"
#
################################################################


Last edited by Thesalan on Thu Jun 21, 2007 5:10 pm; edited 1 time in total
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4954

PostPosted: Thu Jun 21, 2007 5:03 pm    Post subject: Reply with quote

J'ai eu le même soucis avec gmpc. En fait il a fallu changer localhost en 127.0.0.1
Oui je sais c'est gros, mais ça m'a fait ça 2 fois de suite (sur 2 machines différentes)
_________________
membre officieux du SAV Ati GEntoo
Back to top
View user's profile Send private message
Thesalan
n00b
n00b


Joined: 16 Nov 2006
Posts: 69

PostPosted: Thu Jun 21, 2007 5:12 pm    Post subject: Reply with quote

Lol en effet c'est bien ca!!! Merci!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum