Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Bind9] Refuse le caractère "_" (Résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
X-Guardian
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jan 2005
Posts: 133
Location: Templeuve, Nord de la France

PostPosted: Thu Jun 14, 2007 9:45 am    Post subject: [Bind9] Refuse le caractère "_" (Résolu) Reply with quote

Salut,

J'ai un petit problème avec Bind9.

Apparement il refuse tout type de nom de serveur avec un "_" dedans.
Ex : Serv_Test

Il me retourne dans mes logs :
dns_rdata_fromtext: pri/mondomaine.fr.inv:2: near 'Serv_Test.mondomaine.fr.': bad name (check-names)

Je vire les "_" des fichiers de conf, et plus de messages d'erreur.

Cela m'embête un peu, puisque samba et LDAP sont fonctionnels, et tout est configuré comme cela avec les noms des serveurs.

Est-ce irrémédiable ? Dois-je changer toute la config en amont ? (le nom des serveurs dans toutes les applis ?)

@+,
Guile.


Last edited by X-Guardian on Thu Jun 14, 2007 2:26 pm; edited 1 time in total
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Thu Jun 14, 2007 10:10 am    Post subject: Reply with quote

L'underscore peut apparaitre dans un nom de domaine, mais pas dans le hostname, c'est un caractère invalide :)
Back to top
View user's profile Send private message
X-Guardian
Tux's lil' helper
Tux's lil' helper


Joined: 25 Jan 2005
Posts: 133
Location: Templeuve, Nord de la France

PostPosted: Thu Jun 14, 2007 11:34 am    Post subject: Reply with quote

Re,

Ce qui m'étonnes, ce qu'il n'y ait que Bind9 qui ait eu à me le rappeler.

L'underscore est valable dans un nom de domaine ? Je ne le savais pas du tout :)

Bon, plus qu'à refaire tout mes certificats SSL et les serveurs seront remis en état (Bind marche maintenant ;) )

Me reste plus qu'à résoudre encore certains problèmes avec la redirection du fai, de dyndns, ...

Lorsque je fais un dig, tout me renvois vers mondomaine.dyndns.org ou sur mon IP dynamique. (et pas en local).

Vivement qu'on ait notre IP fixe ... enfin qu'Orange décide à faire passer ses techniciens pour régler nos problèmes de lignes (3 Mois 1/2 maintenant ... pour du service pro ...)

@+,
Guile.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum