Joined: 12 May 2004
|Posted: Mon Jun 11, 2007 10:26 pm Post subject: [ GLSA 200706-04 ] MadWifi: Multiple vulnerabilities
|Gentoo Linux Security Advisory
Title: MadWifi: Multiple vulnerabilities (GLSA 200706-04)
Date: June 11, 2007
Multiple vulnerabilities have been discovered in MadWifi, possibly allowing for the execution of arbitrary code or a Denial of Service.
The MadWifi driver provides support for Atheros based IEEE 802.11 Wireless Lan cards.
Vulnerable: < 0.9.3.1
Unaffected: >= 0.9.3.1
Architectures: All supported architectures
Md Sohail Ahmad from AirTight Networks has discovered a divison by zero in the ath_beacon_config() function (CVE-2007-2830). The vendor has corrected an input validation error in the ieee80211_ioctl_getwmmparams() and ieee80211_ioctl_getwmmparams() functions(CVE-207-2831), and an input sanitization error when parsing nested 802.3 Ethernet frame lengths (CVE-2007-2829).
An attacker could send specially crafted packets to a vulnerable host to exploit one of these vulnerabilities, possibly resulting in the execution of arbitrary code with root privileges, or a Denial of Service.
There is no known workaround at this time.
All MadWifi users should upgrade to the latest version:
|# emerge --sync
# emerge --ask --oneshot --verbose ">=net-wireless/madwifi-ng-0.9.3.1"