Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Novità su festival in italiano
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
mrfree
Veteran
Veteran


Joined: 15 Mar 2003
Posts: 1303
Location: Europe.Italy.Sulmona

PostPosted: Wed Jun 29, 2005 11:37 am    Post subject: Novità su festival in italiano Reply with quote

Per facilitare l'installazione delle voci in italiano ho creato un ebuild, lo trovate qui (bugs.gentoo.org)

Basta emergere il pacchetto e, volendo, aggiungere la voce in italiano come default (come fare è illustrato nel messaggio post-installazione nell'ebuild stessa); cmq brevemente pc_mbrola è la voce maschile ed lp_mbrola quella femminile (anche se lei pare un'inglese che parla italiano).

Provare per credere
Code:
echo "sa sa, prova prova 1 2 3 prova, sa sa" | festival --tts

oppure, per chi usa dmix
Code:
echo "sa sa, prova prova 1 2 3 prova, sa sa" | aoss festival --tts

:D

Finalmente potrò configuare gaim per la lettura automatica dei messaggi :)

A proposito... qualcuno ha utilizzato con successo festival-gaim???
Io sto provando ma in pratica mi comunica vocalmente gli eventi del tipo "tizio è online" "caio è offline" ma non mi legge i messaggi


03-07-2005: Per festival-gaim con aoss https://bugs.gentoo.org/show_bug.cgi?id=97836
_________________
Please EU, pimp my country!

ICE: /etc/init.d/iptables panic


Last edited by mrfree on Sun Jul 03, 2005 5:18 pm; edited 2 times in total
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Wed Jun 29, 2005 11:48 am    Post subject: Reply with quote

Ti hanno già aggiunto un commento riguardo header e licenza invalidi.
Back to top
View user's profile Send private message
CarloJekko
Veteran
Veteran


Joined: 31 Mar 2005
Posts: 1315
Location: Baia Domizia :-)

PostPosted: Wed Jun 29, 2005 11:57 am    Post subject: Reply with quote

io mi sono dovuto registrare al cnr per avere quei file ma tu come hai fatto?
_________________
C.
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Wed Jun 29, 2005 12:03 pm    Post subject: Reply with quote

È da un po' di tempo che hanno cambiato la licenza di distribuzione della voce italiana per festival rendendo quindi possibile distribuirla liberamente.
Back to top
View user's profile Send private message
CarloJekko
Veteran
Veteran


Joined: 31 Mar 2005
Posts: 1315
Location: Baia Domizia :-)

PostPosted: Wed Jun 29, 2005 12:05 pm    Post subject: Reply with quote

Perfetto... era ora :-)
cmq dove devomettere l'ebuild?
_________________
C.
Back to top
View user's profile Send private message
mrfree
Veteran
Veteran


Joined: 15 Mar 2003
Posts: 1303
Location: Europe.Italy.Sulmona

PostPosted: Wed Jun 29, 2005 12:54 pm    Post subject: Reply with quote

Kernel78 wrote:
Ti hanno già aggiunto un commento riguardo header e licenza invalidi.

Grazie per la segnalazione...
_________________
Please EU, pimp my country!

ICE: /etc/init.d/iptables panic
Back to top
View user's profile Send private message
mrfree
Veteran
Veteran


Joined: 15 Mar 2003
Posts: 1303
Location: Europe.Italy.Sulmona

PostPosted: Wed Jun 29, 2005 12:57 pm    Post subject: Reply with quote

CarloJekko wrote:
Perfetto... era ora :-)
cmq dove devomettere l'ebuild?

Penso che questo ti tornerà utile ;)
_________________
Please EU, pimp my country!

ICE: /etc/init.d/iptables panic
Back to top
View user's profile Send private message
CarloJekko
Veteran
Veteran


Joined: 31 Mar 2005
Posts: 1315
Location: Baia Domizia :-)

PostPosted: Wed Jun 29, 2005 1:01 pm    Post subject: Reply with quote

Grande và... stupendo... prima mi andava solo la ragazza... (provatela a farle dire cose sporche è uno spasso :lol: )
L'ho integratoin kde con ksyait...
STUPENDO... quante risate!!!! SUPER :lol:
grazie mrfree
_________________
C.
Back to top
View user's profile Send private message
xchris
Advocate
Advocate


Joined: 10 Jul 2003
Posts: 2824

PostPosted: Wed Jun 29, 2005 1:39 pm    Post subject: Reply with quote

io ho usato gaim-festival ma molto tempo fa...
l'ho tolto perche' rompeva le palle :D
_________________
while True:Gentoo()
Back to top
View user's profile Send private message
z3n0
Apprentice
Apprentice


Joined: 17 Mar 2005
Posts: 229
Location: Caserta

PostPosted: Wed Jun 29, 2005 1:41 pm    Post subject: Reply with quote

non sapevo dell'esistenza di sta utility...
cmq a me dice :

saytime
The time is now, a little after ten past 3, in the afternoon.
Linux: can't open /dev/dsp

:(
_________________
AMD Athlon 64 Winchester 939 3200+, Thermaltake Venus 12,Asus a8v Deluxe, 2*512 A-Data Vitesta Ddr 500 PC4000, Western Digital Raptor 36.7GB 10000rpm SATA 8mb, Maxtor 160gb SATA 8mb, Nvidia GeForce 4 MX440 64mb..
Back to top
View user's profile Send private message
mrfree
Veteran
Veteran


Joined: 15 Mar 2003
Posts: 1303
Location: Europe.Italy.Sulmona

PostPosted: Wed Jun 29, 2005 2:11 pm    Post subject: Reply with quote

CarloJekko wrote:
grazie mrfree

Figurati, è un piacere ;)
_________________
Please EU, pimp my country!

ICE: /etc/init.d/iptables panic
Back to top
View user's profile Send private message
mrfree
Veteran
Veteran


Joined: 15 Mar 2003
Posts: 1303
Location: Europe.Italy.Sulmona

PostPosted: Wed Jun 29, 2005 2:23 pm    Post subject: Reply with quote

@z3n0
Non saprei... a me funziona
Code:
$ saytime
The time is now, a little after five past 4, in the afternoon.
Warning: w-_ unkown, replaced with _-_

il warning deve essere legato al fatto che nella lingua italiana non è prevista la lettera w :)
_________________
Please EU, pimp my country!

ICE: /etc/init.d/iptables panic
Back to top
View user's profile Send private message
CarloJekko
Veteran
Veteran


Joined: 31 Mar 2005
Posts: 1315
Location: Baia Domizia :-)

PostPosted: Wed Jun 29, 2005 3:55 pm    Post subject: Reply with quote

mrfree gaim festival in ita è una figata.. cmq per far parlare i messaggi devi deselezionare
announce event
prepend buddy name
e replace www.....
_________________
C.
Back to top
View user's profile Send private message
mrfree
Veteran
Veteran


Joined: 15 Mar 2003
Posts: 1303
Location: Europe.Italy.Sulmona

PostPosted: Wed Jun 29, 2005 3:58 pm    Post subject: Reply with quote

CarloJekko wrote:
mrfree gaim festival in ita è una figata.. cmq per far parlare i messaggi devi deselezionare
announce event
prepend buddy name
e replace www.....

Infatti stavo facendo qualche prova e adesso sono arrivato ad ottenere la lettura del primo messaggio che mi inviano :)
Probabilmente il problema riguarda però il fatto che uso dmix quindi probabilmente quanto prova ad accedere alla periferica audio direttamente va in errore e non riproduce niente, a tal proposito ho inviato una email agli sviluppatori di festival-gaim chiedendo di aggiungere una qualche opzione che permetta l'uso di dmix (come avviene ad esempio per i suoni di gaim), stiamo a vedere...
_________________
Please EU, pimp my country!

ICE: /etc/init.d/iptables panic
Back to top
View user's profile Send private message
mrfree
Veteran
Veteran


Joined: 15 Mar 2003
Posts: 1303
Location: Europe.Italy.Sulmona

PostPosted: Wed Jun 29, 2005 4:31 pm    Post subject: Reply with quote

Comunque il problema di festival-gaim è proprio legato al device audio utilizzato, in pratica si instaura una race-condition all'interno dello stesso gaim tra il gestore dei suoni e il plugin festival; disabilitando il suono per i messaggi ricevuti il plugin funziona egregiamente... questa è ovviamente una soluzione temporanea, infatti se sto ascoltando della musica il problema rimane :)
_________________
Please EU, pimp my country!

ICE: /etc/init.d/iptables panic
Back to top
View user's profile Send private message
magowiz
Veteran
Veteran


Joined: 17 Feb 2005
Posts: 1029
Location: Italy/Milan/Bresso

PostPosted: Wed Jun 29, 2005 5:12 pm    Post subject: voce femminile : non funzionante Reply with quote

ciao, ho provato a fare esattamente come scritto nelle istruzioni in fondo all'emerge ma non riesco a far funzionare la voce femminile :


se metto come prima voce lc_mbrola e come seconda pc_mbrola la prima viene ignorata, mi sono accorto poi che non esiste nemmeno una cartella lc_mbrola dentro /usr/share/festival/voices/italian mentre esiste una chiamata lp_mbrola così ho provato a mettere quella come prima, però mi da il seguente errore :

Code:
echo "ciao" | festival --tts
FATAL ERROR : cannot find file /usr/share/festival/voices/italian/lp_mbrola/it4/it4 !
Cannot open file /tmp/est_27970_00000.au as tokenstream
Wave load: can't open file "/tmp/est_27970_00000.au"
Cannot load wavefile: /tmp/est_27970_00000.au


dove sbaglio?
Back to top
View user's profile Send private message
CarloJekko
Veteran
Veteran


Joined: 31 Mar 2005
Posts: 1315
Location: Baia Domizia :-)

PostPosted: Wed Jun 29, 2005 5:21 pm    Post subject: Reply with quote

hmm... dmix non lo uso... Peccato è troppo forte (un mio amico è disperato perchè non può usarlo su winzozz.. finalmente m'invidia qlcuno con windoze )
_________________
C.
Back to top
View user's profile Send private message
Sparker
l33t
l33t


Joined: 28 Aug 2003
Posts: 992

PostPosted: Wed Jun 29, 2005 5:38 pm    Post subject: Re: voce femminile : non funzionante Reply with quote

magowiz wrote:
ciao, ho provato a fare esattamente come scritto nelle istruzioni in fondo all'emerge ma non riesco a far funzionare la voce femminile :
dove sbaglio?

basta copiare it4 dalla cartella di pc_mbrola in quella di lc_mbrola
Back to top
View user's profile Send private message
magowiz
Veteran
Veteran


Joined: 17 Feb 2005
Posts: 1029
Location: Italy/Milan/Bresso

PostPosted: Wed Jun 29, 2005 5:50 pm    Post subject: Reply with quote

grazie, ha funzionato!
a parte il fatto che ho copiato in lp_mbrola e non in lc_mbrola (che non esisteva)
Back to top
View user's profile Send private message
z3n0
Apprentice
Apprentice


Joined: 17 Mar 2005
Posts: 229
Location: Caserta

PostPosted: Wed Jun 29, 2005 8:01 pm    Post subject: Reply with quote

qualcuno sa aiutarmi?
mi dite le vostre configurazioni? io uso alsa-driver con -oss nel make.conf e nel kernel open sound system è disabilitato..
abilitandono non risolvo e nemmeno compilando alsa-driver con la flag oss..

help ;)
_________________
AMD Athlon 64 Winchester 939 3200+, Thermaltake Venus 12,Asus a8v Deluxe, 2*512 A-Data Vitesta Ddr 500 PC4000, Western Digital Raptor 36.7GB 10000rpm SATA 8mb, Maxtor 160gb SATA 8mb, Nvidia GeForce 4 MX440 64mb..
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Wed Jun 29, 2005 9:15 pm    Post subject: Reply with quote

Qualcuno sa, almeno in linea di massima, quanto tempo deve passare prima che questo ebuild sia aggiunto al portage ?
Back to top
View user's profile Send private message
otaku
Guru
Guru


Joined: 16 Dec 2004
Posts: 428
Location: Rho (MI)

PostPosted: Wed Jun 29, 2005 9:24 pm    Post subject: Reply with quote

Kernel78 wrote:
Qualcuno sa, almeno in linea di massima, quanto tempo deve passare prima che questo ebuild sia aggiunto al portage ?

dipende... tmw me l'hanno incluso dopo pochi giorni... altri miei ebuild sono ancora li nel bugzilla in attesa che qualcuno ci dia un occhiata :)
_________________
Ventiquattr'ore al giorno in preda a una follia contorta...
Back to top
View user's profile Send private message
mrfree
Veteran
Veteran


Joined: 15 Mar 2003
Posts: 1303
Location: Europe.Italy.Sulmona

PostPosted: Thu Jun 30, 2005 6:50 am    Post subject: Reply with quote

Grazie magowiz per la segnalazione.

Ho corretto l'ebuild in bugzilla, la it-festival-1.0.0-r2.ebuild sembra funzionare correttamente

PS: dalla versione it-festival-1.0.0-r2 è richiesto che la versione di festival sia >=app-accessibility/festival-1.4.3-r3 essenzialmente per una questione legata ai path utilizzati, in quest'ultima release (richiesta anche da festival-gaim-1.1) la directory utilizzata è /usr/share/festival piuttosto che /usr/lib/festival; il file di configurazione ora è /usr/share/festival/voices.scm
_________________
Please EU, pimp my country!

ICE: /etc/init.d/iptables panic
Back to top
View user's profile Send private message
Kernel78
Moderator
Moderator


Joined: 24 Jun 2005
Posts: 3652

PostPosted: Thu Jun 30, 2005 7:04 am    Post subject: Reply with quote

@mrfree
ti odio, mi stai tentando fortemente ad inserire nella mia macchina qualcosa che non si trova nel portage :lol:
Mi ero riproposto di non mettere nemmeno un pacchetto mascherato e adesso sto prendendo in considerazione l'idea di aggiungere il tuo ebuild :wink:
Back to top
View user's profile Send private message
Lestaat
Guru
Guru


Joined: 13 Jan 2005
Posts: 412
Location: Perugia

PostPosted: Thu Jun 30, 2005 7:40 am    Post subject: Reply with quote

ehm....
qualcuno mi aiuta che non riesco a far digerire l'ebuild al sistema?
Code:

!!! aux_get(): ebuild path for 'portage/it-festival-1.0.0-r1' not specified:
!!!            None
!!! aux_get(): ebuild path for 'portage/it-festival-1.0.0-r1' not specified:
!!!            None
doebuild(): aux_get() error reading portage/it-festival-1.0.0-r1; aborting.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum