Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
pata_via e niente dvdrom / masterizzatore [RISOLTO]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
^Stefano^
Guru
Guru


Joined: 20 Nov 2005
Posts: 394
Location: Ferrara

PostPosted: Wed May 30, 2007 10:13 pm    Post subject: pata_via e niente dvdrom / masterizzatore [RISOLTO] Reply with quote

Salve a tutti, ho appena installato i gentoo-sources-2.6.21-r2 su amd64 per provare il nuovo supporto pata_via
quello che ho fatto è stato disabilitare l'intera sezione ATA/ATAPI/MFM/RLL support che sta nella categoria Device Driver ed abilitare tutto l'occorrente nella sezione Serial ATA (prod) and Parallel ATA (experimental) drivers. Per tutto l'occorrente indendo
<*> ATA device support
<*> VIA SATA support
<*> Generic ATA support
<*> VIA PATA support
il mio chipset è
Code:
00:0f.0 RAID bus controller: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)

ho impostato grub, /etc/fstab e riavviato. Il pc boota bene, l'hard disk viene riconosciuto come /dev/sda (hard disk IDE non SATA) con le sue 3 partizioni sda1 sda2 sda3. dvd e masterizzatore vengono visti così
Code:
sd 2:0:0:0: Attached scsi generic sg0 type 0
scsi 3:0:0:0: CD-ROM            HL-DT-ST DVD-ROM GDR8163B 0L23 PQ: 0 ANSI: 5
scsi 3:0:0:0: Attached scsi generic sg1 type 5
scsi 3:0:1:0: CD-ROM            PIONEER  DVD-RW  DVR-111D 1.06 PQ: 0 ANSI: 5
scsi 3:0:1:0: Attached scsi generic sg2 type 5

quindi in fstab ho inserito /dev/sg1 e /dev/sg2 ma quando vado a montare ricevo questo messaggio
Code:
blueyes linux # mount /dev/sg1 /mnt/cdrom
mount: /dev/sg1 non è un dispositivo di blocchi
blueyes linux #

Cosa ho sbagliato? La configurazione del kernel dovrebbe essere giusta, nel senso che i cdrom i dvdrom e i masterizzatori vengono visti anche loro con il driver pata_via giusto?
Ho provato a fare una ricerca, in genere ho letto che vengono visti come /dev/sr0 /dev/sr1 e funzionano... :?
Grazie a tutti in anticipo.

EDIT: non avevo abilitato il supporto ai cdrom nella sezione scsi. ora anche a me vengono visti come sr0 ed sr1 :oops:
_________________
8-09 V-Day con una raccolta firme. Vi aspettiamo
Raccolta Firme
Progetto tRicicloPC con Linux
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Fri Jun 01, 2007 12:01 pm    Post subject: Reply with quote

edit: fortunato che hai sbagliato ad usare i device (erano sga e sgb per inciso, scsi generico usa le stesse regole di hd ed sd per attribuire i nomi)
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
^Stefano^
Guru
Guru


Joined: 20 Nov 2005
Posts: 394
Location: Ferrara

PostPosted: Fri Jun 01, 2007 12:05 pm    Post subject: Reply with quote

se scsi usa sga ed sgb, perchè in dmesg mi appariva sg1 ed sg2? neanche con un ls /dev |grep sg mi apparivano sga ed sgb, ma solo sg1 ed sg2.
adesso ho abilitato il supporto scsi ai cdrom e disabilitato il supporto scsi generico, così da avere solo sr0 ed sr1 e funziona tutto bene. sia con kernel 2.6.20-r8 stabile su amd64 sia con kernel 2.6.21-r2 in testing su amd64.
_________________
8-09 V-Day con una raccolta firme. Vi aspettiamo
Raccolta Firme
Progetto tRicicloPC con Linux
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum